Fast Track to Google SketchUp

By Team Digit
Credits

The People Behind This Book

EDITORIAL
Robert Sovereign-Smith Assistant Editor
Nash David Copy Editor
Nimish Chandiramani Writer, Copy Editor
Mohamed Rameez Writer
Rasagy Sharma Writer
Madhusudan Mukerjee Writer
Suyash Sambhare Writer

DESIGN AND LAYOUT
Vijay Padaya, Ravindranathan U Layout Designers
Rohit Chandwaskar Cover Design
Harsho Mohan Chatteraj Illustrator

© Nine dot Nine Interactive Pvt. Ltd.
Published by Nine dot Nine Interactive
No part of this book may be reproduced, stored in a retrieval system or transmitted in any form or by any means without the prior written permission of the publisher.

May 2008
Free with Digit. Not to be sold separately. If you have paid separately for this book, please e-mail the editor at editor@thinkdigit.com along with details of location of purchase, for appropriate action.
Oh, Build Me A Home...

If you’re an expert with 3D design and architectural drawing tools, go away—this Fast Track isn’t for you, and neither is SketchUp. You’ll be happier with tools like AutoCAD and 3ds Max.

Really now, shoo.

If you must stay, however, know this—while SketchUp isn’t as evolved as the aforementioned tools, it’s far from a beginner’s toy. It combines shocking levels of usability with even more shocking levels of functionality, and has, in fact, been designed so that even eighth-graders have no trouble with it (so if you’re still not comfortable with it after this Fast Track, shame on you).

So if SketchUp’s so simple and user-friendly, why this Fast Track? Couldn’t you just install the software, fire it up and get going? In truth, yes. SketchUp even gives first timers a helpful guide the first time you run it. What we’re doing here, however, is showing you what SketchUp’s really capable of—functionality that you won’t see if you’re just playing around.

We’ve approached this book in the way that many of you might—with no prior knowledge of SketchUp or 3D modelling concepts in general. There are no assumptions on expertise (besides that you’re handy with a keyboard and mouse), so if you find us getting too basic, this is deliberate, and we’ll forgive you for skipping ahead.

Every 3D modelling tool has its forte—some are great for organic models, some for special effects, and so on. So what do you do with SketchUp? If you take a trip through the online 3D Warehouse, you’ll see that a majority of the community is making buildings—we’ve assumed that you’ll be doing so too, and that’s how things will progress in this book.

Google has designed SketchUp primarily to help even ordinary people model buildings with varying complexity (not that you can’t do other stuff, mind you). These buildings can then be put into Google Earth, and hopefully, we’ll see all the world’s cities in 3D some day. It’s a massive crowdsourcing operation by the big G—some might even call it a huge Matrix-like human farm—but heck, we’re all doing it anyway. Enough
Chapter 1  The Basics  7
1.1 You and Google SketchUp  8
1.2 A Tour Of SketchUp's Interface  10
1.3 Viewing A 3D Model  21
1.4 Conclusion  23

Chapter 2  Beginning Modelling  24
2.1 The Drawing Axes  25
2.2 Drawing Preferences  27
2.3 Drawing Lines And 2D Shapes  28
2.3 Inferences In SketchUp  39
2.4 Using The Value Control Box (VCB)  43
2.5 Modelling With The Push Tool  48
2.6 Modelling With The Move And Rotate Tools  56
2.7 The Tape Measure Tool  63
2.8 Creating Components  65

Chapter 3  Your First Real Model  68
3.1 Making Your First Real Model  69
3.2 Painting Your Model  75
3.3 Viewing Your Model In Style  80
3.3 Working With Shadows And Fog  83
3.4 Organising Your Model Using Layers  84
3.5 Conclusion  85

Chapter 4  The Architect In You  86
4.1 Creating Your First Floor Plan  87
4.2 Stair-ing Up At The Sky  93
4.3 Roof On Our Heads  98
Chapter 5  Playing In The Sandbox  101
5.1  Sandbox Tools  102
5.2  System Requirements  104
5.3  Sandbox From Contours  105
5.4  Sandbox From Scratch  106
5.5  The Smoove Tool  107
5.6  Stamp Tool  110
5.7  The Drape Tool  112
5.8  The Add Detail and Flip Edge Tools  114
5.9  Workshop  118

Chapter 6  More Fun With Models  123
6.1  The Follow Me Tool  124
6.2  Making Buildings With Photo Match  131

Chapter 7  Presenting Your Model  135
7.1  Section Planes  136
7.2  Looking Around  137
7.3  Welcome To The Scene  139

Chapter 8  Share  144
8.1  Export Quality  145
8.2  A Mark On The Earth  146
8.3  In The Warehouse  149

Chapter 9  Tips And Tricks  152
9.1  Modelling Tips  153
9.2  Presentation Tips  158
For all those of you who wanted to get into 3D modelling, but had till now been discouraged by the steep learning curves of the modelling software out there, the solution appears to be Google SketchUp. Built to provide the best features of its big brother Google SketchUp Pro in a small, easy to use freeware package, Google
SketchUp revolutionises the translation of imagination into real 3D structures by making the process as intuitive as possible.

Most of the powerful 3D modelling software available in the market are extremely daunting at first glance (as we soon realised on trial). They also end up exacting a heavy toll on your wallet, something the beginner, or the casual user would obviously wish to avoid. Being both simplistic and most importantly, freeware, Google SketchUp overcomes both these hindrances. The quickly learnable, small yet versatile and powerful toolset allows the user to strike the right balance between sophistication and simplicity.

The workspace and the tools have been designed to be as intuitive to the user as possible. The intelligent interface ensures that even users with no prior experience in 3D modelling can quickly familiarise themselves with the Google SketchUp interface. The tools allow you to exercise simple, uninhibited freehand creativity, while the dimensions box, the measuring tape, etc. allow you to enforce strict dimensional accuracy.

With its emphasis on versatility and flexibility, Google SketchUp is the solution for the low-end 3D professional. For the architect, Google SketchUp offers features such as walkthroughs and projections. For the product designer and the engineer, views are easily available in orthographic and isometric modes. For the hobbyist, Google SketchUp provides the Google toolbar, his chance at showcasing his designs to the global community of Google Earth and Google Warehouse users.

But as they say, good things come in small packages. Despite its admirable arsenal of abilities, Google SketchUp comes in a small, freely downloadable freeware package of 31.7 MB. It is easy on your system resources, avoiding major headaches for the average user. You can download Google Sketchup from http://SketchUp.google.com/download.html or get it off this month’s DVD.

1.1 You and Google SketchUp

So, let’s get you introduced to the world of 3D modelling through Google SketchUp. You already know how useful Google SketchUp can be. It allows you to make sophisticated 3D models such as
System Requirements

Windows (Current version: 6.4.112)

- Microsoft Windows 2000, XP, or Vista
- Google SketchUp will run on 64bit versions of Windows, but it will run as a 32bit application.
- .NET 1.1 framework is required.
- Video card that is 100 per cent OpenGL compliant. Please ensure you have the latest driver for your card by visiting the vendor’s website.
- Windows compatible pointing device
- Microsoft Internet Explorer 6.0 or higher
- Windows Media Player or QuickTime 5.0 and web browser for multimedia tutorial

Recommended Configuration

- 2 GHz Pentium 4 processor or higher
- 2 GB RAM
- 500 MB of available hard-disk space, 15GB for Vista.
- 3D class Video Card with 512 MB of dedicated memory
- 3 button, scroll-wheel mouse

Minimum Hardware Requirements with Microsoft Windows 2000, XP Home or Professional Editions:

- 600 MHz Pentium III processor
- 128 MB RAM
- 128 MB of available hard-disk space

Minimum Hardware Requirements with Microsoft Windows Vista:

- 800 MHz processor for Vista Home Basic. 1 GHz processor on other Vista versions.
- 512 MB RAM for Vista Home Basic. 1 GB RAM on other Vista versions
- 15 GB of available hard-disk space

Mac (Current version: 6.4.120)

- Mac OS X 10.4.1+ and 10.5+.
- QuickTime 5.0 and web browser for multimedia tutorials
- Video card that is 100 per cent OpenGL 1.5+ compliant. Please ensure you have the latest driver for your card.
- Safari
- Neither Boot Camp nor Parallels are supported environments.

Recommended Configuration

- 2.1+ GHz G5/Intel processor.
- 2 GB RAM
- 400 MB of available hard-disk space
- Graphics card that is OpenGL compliant with 512 MB video memory.
- 3 button, scroll-wheel mouse

Minimum Hardware Requirements

- 1 GHz PowerPC G4
- 512 MB RAM
- 160 MB of available hard-disk space
architectural designs and product blueprints. By the end of this chapter, you’ll be well equipped to begin using Google SketchUp. We’ll start by introducing you to the interface, the tools, and how to basically get acquainted with the software. To begin, you’d obviously need the software installed. Before you begin, ensure that your system has at least the basic configurations listed on the previous page.

Other considerations to note:
- A Linux version of Google SketchUp isn’t available at this time.
- Google SketchUp will run on multiple-processor machines, but will only use one thread on one processor. Google SketchUp doesn’t support hyperthreading or multithreading at this time.

1.2 A Tour Of SketchUp’s Interface

After installing Google SketchUp on your computer, double-click the appropriate icon (on your desktop or via Start > Programs > Google SketchUp) to start the program.

The first view you get on opening Google SketchUp for the first time is that of a dialog box asking you to choose your default settings for usage. You have a choice of view and system of units.
For the time being, for all conventional purposes, choose Perspective View (the other option being Top View) and choose metric centimetres as the preferred System of Units. Since we are just getting acquainted with the interface, these settings don’t really affect us much now. They can be modified later on to suit your preferences by going to the Menu Bar and choosing Window > Preferences > Template.

Starting with an inspiring “You can learn Google SketchUp”, the Learning Centre is a very handy beginner’s guide, which opens up every time you start Google SketchUp (unless disabled, of course). From basic introductory suggestions as on how to use Google SketchUp to handy tips and tricks (along with a bit of good old-fashioned advice—on how one should NOT run around with scissors), the Learning Centre is an ideal introduction to Google SketchUp. It also contains a clickable step-by-step interactive model which you can practice on. This Fast Track to Google SketchUp is, of course, the better option, since it contains a more detailed explanation for beginners.

The first time you begin Google SketchUp, the Instructor (which can also be activated on later usage by clicking on Window > Instructor on the Menu Bar) which is basically a demonstrative guide on the usage of the tool selected, will also be present.

Upon closing both windows, do not be startled if you encounter an individual (called Bryce) who offends both your sense of dressing and 3D logic (you’ll realise what we mean later). His pitiful existence is merely to provide you with a good perspective view of the models you create.

You will initially notice three mutually perpendicular lines in bright primary colours (red, blue, and green) serving as the three axes. Any point in three-dimensional space can be uniquely identified with respect to its perpendicular distance from the three axes. This forms the fundamental of all 3D geometry. 3D space is divided into 8 octants. To visualise this easier, take a sphere (or a cube) and make three mutually perpendicular cuts passing through its centre. It will be divided into eight identical parts. Each of these pieces is referred to as octants. You may choose to draw your structures in a combination of any of the eight octants.
Upon entering Google SketchUp, you are presented with the familiar Windows toolbar organisation. Also present is a toolbar filled with icons, for quick access to common tools (called the Getting Started toolbar). At the bottom right is a field box, which will be your primary guide to dimensional accuracy while modelling. On the same line, to the left, there’s text which helps you with the usage of the selected tool. On clicking a tool, it tells you the ideal next step on the tool’s usage.

1.2.1 The Menu Bar
The Google SketchUp interface follows the pattern of the regular Windows Menu Bar with the following submenus and options:

- **File**: Apart from standard file options such as New, Open, Save, Save As and Exit, the File Menu also offers Import and Export options. These allow you to acquire files designed using other software and use Google SketchUp files in other programs, respectively.

  **Import**: The import option allows you to accept not just standard image formats (JPEG, BMP, GIF, PNG, etc.) but also files created in other 3D modelling software like AutoCAD and 3DsMAX.

  **Export**: Contains a variety of options to produce two and three dimensional images from your Google SketchUp graphic for use in external programs.
Edit: As any designer would tell you, perhaps the most useful tool in any Edit Menu is the Undo button. Other standard options include Redo, the famous trinity of Cut, Copy and Paste, a Paste Variation (paste in place) and Delete. The Hide option, as the name suggests, allows you to conceal objects with Unhide to complement it. Other editing options are the Lock Object, Group Object, and Intersect with model, the detailed usage of which will be explained at a later stage. This play with objects is possibly one of the most interesting aspects of Google SketchUp.

View: The Ability to enable or disable the view of basic structural outlines like axes, grids, guidelines and sectional cuts and planes, can be toggled via this menu. Other options like the visual effects and styles of edges and surfaces can also be modified. There are options for animation and for visual effects such as shadow and fog. Through this menu, you can select the toolbars you wish to view and customise the workspace to your personal preferences.

1.2.2 The Toolbars
The tools available in Google SketchUp are grouped as per their functionality into a set of toolbars for your easy access and use.
The basic toolbar (Getting Started) can be expanded to provide a larger toolset (View > Toolbars > Large Tool Set). However, the Getting Started toolbar lives up to its name and is quite sufficient for most of our present requirements. The other toolbars are:

1. **Camera Toolbar**: The Camera tools are used for adjusting the view to suit your tastes. The basic functions of zooming, panning (moving around the workspace) and orbiting (rotating camera view) will, in future form a major part of your modelling activity in Google SketchUp. Further on, a section is included on how to do the same.

2. **Construction Toolbar**: The Construction toolbar contains options for dimensional measurement and accuracy while simultaneously providing options to input 2D and 3D text. It also has a handy tool called axes which allows you to reorient your axes to your convenience.

3. **Drawing Toolbar**: As the name suggests, this allows you to construct elementary two dimensional shapes like circles, rectangles and polygons. Lines can be constructed using the line tool and / or the freehand tool. These basic two dimensional shapes can later on be extended into three dimensions using the Push / Pull tool (an exercise you will encounter later).

4. **Face Style Toolbar**: The Face Style toolbar allows you to choose between various surface styles for your models such as wireframe, monochrome, etc. The X-Ray option makes the object semitransparent allowing you to view surfaces that are otherwise not visible.

5. **Google Toolbar**: This toolbar is your chance at showcasing your models created in Google SketchUp as 3D objects on the globe using Google Earth. You need Google earth running to use these options. One of the tools allows you to access the Google 3D Warehouse which, in turn, allows you to share your models while granting you access to thousands of models uploaded by other Google SketchUp users worldwide.

6. **Modification Toolbar**: These contain the primary tools for three dimensional modelling. From the simple push / pull tool that allows you to extrapolate two-dimensional figures into one more, to the Move / Copy tool that allows you to move either
entire objects or just sides and faces to construct your required graphic, this toolbar is your gateway to freehand 3D drawings. The toolbar also features the Follow Me tool, which allows you to make complex curved surfaces with relative ease. The Scale tool, another integral part of the toolbar allows you to resize your object to your desired scale.

7. **Layer Toolbar**: Most graphic designing software employ the concept of layers, which allows you to separate your objects from each other. Google SketchUp is no different.

8. **Principal Toolbar**: This contains tools for selecting, erasing and colouring. Colouring, of course, has several other options like defining a texture for the surface (wood, asphalt, etc.). The Make Component option allows you to integrate requisite parts of your structure into one whole component, which can be modified as per your requirements.

9. **Sections Toolbar**: The toolbar allows you to find sections in your design. Various tools include the provision to view / hide the section plane, to view / hide the cut portions and to create a new section plane.

10. **Shadows Toolbar**: As you might have inferred, this toolbar has options with which you can add shadow effects to your objects. Lots of detail like the position of the light, the intensity and the length of the shadow can be tweaked.

11. **Standard Toolbar**: The concept of the Standard toolbar is common to most software containing essential options like New, Open, Save, Cut, Copy, Paste and Undo, among others.

12. **Views Toolbar**: This allows you to access two-dimensional perspective views of your three dimensional drawing. This basically means that you can see how your drawing looks like from the top view, the side view and the front view.

13. **Walkthrough Toolbar**: Designers or architects often need to gauge how their creation might look if one was walking towards it, away from it or from any other perspective. This toolbar possesses the combination of the right set of tools for this purpose. Positioning the camera, the Walk option and the Look Around Option are the tools included in this toolbar. These toolbars enable easy access to all tools, which otherwise
might have to be accessed from their respective options in the Menu Bar (which, as we all will agree, is way more tedious). As you get more comfortable with the interface while using Google SketchUp, you can customise and formulate your own toolbar layout for the right feel that works for you.

- **Camera**: This submenu has options for modifying camera angles and views. The Camera Toolbar incorporates a majority of its essential features. You can change back and forth between pre-decided views apart from choosing from a standard set (as in the Views Toolbar). Various styles of perspective can be obtained by selecting the required option. For example, a two-dimensional perspective, which does not allow you to pan along the third dimension can be switched to from a three-dimensional one. As opposed to the Camera toolbar, the Camera submenu incorporates more variations to zooming, like Zoom Window and Zoom Extents. Surprisingly, an option to change the background image has also been included (Photo Match Option). The contents of the Walkthrough toolbar are also part of this submenu.

- **Draw**: This includes all features of the Drawing toolbar (already mentioned earlier). It has the same commands (Line, Arc, Freehand, Rectangle, Circle and Polygon).

- **Tools**: The tools submenu is a coagulation of the most useful tools. The useful tools from other toolbars are incorporated into this. The Modification Toolbar, the Construction Toolbar, the Principal Toolbar, the Sections Toolbar all contribute their tools to form this menu.

- **Window**: The Window submenu allows you access to the various dialog boxes available in Google SketchUp. It is also the menu through which you can edit your preferences or open the Instructor (introduced earlier). The Ruby console allows you to script in the Ruby scripting interface to define specific aspects of the behaviour of objects. This is beyond the scope of this Fast Track.

- **Help**: The last submenu (phew!) in Google SketchUp is the one which requires least explanation. Though Google SketchUp doesn’t come with an inbuilt Help Library, it has an extensive online Help Database, with articles on almost every subject possible. The Google SketchUp community also has forums for solving specific queries of individuals. The Help submenu has links
to the Google SketchUp Online Help Centre. The Learning Centre dialog mentioned earlier can be opened from here. Other options include Licensing, links to the Google SketchUp community, Updating facilities, a Bouquets and Brickbats facility for those possessing strong opinions and links where one can have access to online tutorials on specific subjects. More Plug-ins can be downloaded from the Google SketchUp website via an option in the submenu. One of the most useful tools present here is the Quick Reference Guide. On opening, a PDF file opens which contains a single page description (with options) on the most frequently used tools and options in Google SketchUp. This provides an excellent start-up for people already familiar with 3D modelling.

1.2.2 The Dialogs
The Dialog Boxes can be accessed from the Window submenu. These include:

1. **The Materials Dialog:** The Materials Dialog box allows you to choose the texture, colour and other aesthetics of your model. It is synonymous with the dialog that opens on selecting the Paint Bucket option under the Tools submenu.

2. **The Components Dialog:** The Components dialog allows easy control and manipulation of the various parts of your structure you have organised into components. It also allows the importing of predefined component templates.

3. **The Styles Dialog:** The styles dialog is your key to presenting your model well. It allows for fine surface details, textures, background images etc. It also allows the modification of the aspects of your model such as transparency (among others)

4. **The Layers Dialog:** All 2D and 3D modelling tools today incorporate the notion of layers. The concept of layers is based on the fact that we may often want to edit one aspect of our drawing without causing changes to the other. This is done by drawing individual portions in different layers. Google SketchUp incorporates this facility and allows easy editing. Through the layers dialog, you can create new layers and organize your drawing and its various components among the layers.

5. **The Outliner Dialog:** The Outliner dialog allows the user to provide outlines to the various structures in his drawing.
Specifications such as size, clearance etc. are available in this dialog box.

6. **The Scenes Dialog**: Here you can classify your complex drawing into various scenes for easy reference. This feature also allows for animated views of your 3D models.

7. **The Shadows Dialog**: A touch of reality and romance to your model. The shadows dialog box allows the user to produce 3 dimensional shadow effects in his drawings. The detail is fine tuneable with this dialog box allowing the choice of such details as the position and intensity of light, the time of the year, etc.

8. **The Fog Dialog**: Add a sense of mystery or gloom to your 3D model using this simple and easy to use dialog box. Fog effects with options such as distance, colour and intensity of the fog provide a good incentive to unbridled creativity.

9. **The Photo Match Dialog**: The photo match dialog provides elementary tools for managing external 2D images in Google SketchUp. You may import an elementary external 2D drawing and use the tools provided to create an automatic 3D drawing. Other features such as background image etc. are also available in this dialog.

10. **The Soften Edges Dialog**: The soften edges dialog allows you to replace the sharp edges of his model with gentle curves.
1.2.3 Moving around

Now let’s get around to trying out Google SketchUp. The interface is actually incredibly easy to get used to and by the end of this section, you’ll probably ponder the reason for the existence of this tutorial.

Panning: Go to the Getting Started toolbar, click on the pan tool (it’s in the shape of a palm) and click on it. Click and drag anywhere on the workspace to move the workspace along. Using this tool, later on in the course of your modelling, you will be able to pan to different areas of your designs when they prove to be larger than your workspace in your preferred zoom. For getting better views, you may choose between the perspective, two point perspective and parallel projection options within the Camera submenu in the Menu bar. You may notice that the perspective view allows a slight angle of rotation to the camera (your view) so that it always stays focussed on the object, whereas the other two modes allow free translation of the camera. The Pan tool can be quickly accessed by pressing [H] on your keyboard, but the method you should use most often is to hold down [Shift], middle-click and drag.

Zooming: Click on the Zoom tool, once again from the Getting Started toolbar (it has a picture of a hand lens on it). Click on a point you wish to zoom to in the workspace and drag the mouse pointer upwards in order to zoom in. You can zoom out by clicking and dragging the mouse pointer downwards. You may more conveniently use the Scroll button on your mouse and scroll up and down (for zooming in and out, respectively). This can be done even when the zoom tool is not selected and hence is a quick way to zoom in and out while you are modelling. Alternatively, you may use [Z] on your keyboard for selecting the zoom tool. The Zoom Extents (hand lens with arrows around it) is a special tool that instantaneously gives you the largest view in which your whole model fits in the screen. Go ahead, click on the Zoom Extents tool and watch the man at the centre fill the screen.

Orbiting: Now that your knowledge of Google SketchUp has grown massive enough, you can start orbiting. Click on the Orbit button from the Getting Started toolbar (two crossed curved arrows), click
on the workspace and drag left, right, up or down. Go ahead and get a feel of it. Align yourself with the three axes and get views for practice. The image of the man at the centre is 2D and hence you cannot orbit about it. During the course of drawing in Google SketchUp, you can quickly use the orbit button by clicking the middle mouse button (the scroll wheel). The [O] key on the keyboard is also an option.

The Camera Submenu and Tools

Other less often used tools for adjusting your view include the Field of View tool, the position camera tool, etc.
- The Field of View tool, available from the Camera Submenu, is a tool with which you can adjust your field of view while the camera moves in or out to maintain the view on your screen. With the tool selected, click on desired point in the workspace and drag down to increase field of view. Drag up to decrease field of view.
- The Position Camera tool can be used to quickly change your view. Click on the Position Camera Tool from the Camera Submenu, and click on any portion of the workspace to position the camera at that height.
- The Zoom Window Tool from the Camera Submenu can be used to zoom to a specific rectangular field of view. Select the tool, click and drag along the diagonal of a rectangle around your object to notice the effect.
- The Walk Tool can be used to get the effect of gradually walking
towards or away from your model. Select it from the Camera Submenu and click and drag upwards to walk towards and downwards to walk away from you point.

- The Look around tool can be used to pivot your camera from the current position. Choose the tool from the Camera Submenu, click and drag up and down to tilt, left and right to pan.

1.3 Viewing A 3D Model

Now that you are familiar with the Google SketchUp Camera interface, let’s practice. Go to the Components Dialogue within the Window Submenu, select the select tab, and in the drop down menu, choose architecture. Scroll down in the window till you see the model of a laptop, click on it and drag it into the workspace.

Close the Components Dialog, Select the Zoom (Getting Started Toolbar, Mouse Scroll Wheel, Camera Submenu or [Z] on the keyboard) tool and zoom into the laptop. Zoom until the laptop fills a decent portion of your screen as shown in the screenshot. Use the orbit tool to obtain top, front and side views. Get an isometric side view by orbiting to an angle. Try walking towards and away from it using the Walk Tool. Use the Look Around Tool to adjust your view. Use the place camera option from the Camera Submenu, and click above the laptop to obtain a downward view on the laptop. Use the
Pan tool to centre the laptop in your field of View.

Try obtaining the exact views to gauge your skill with the camera tools. If you have Google Earth running, you can use the Snapshot tool from the Google Toolbar to obtain a snapshot.
1.4 Conclusion

Through the length of this chapter, we have managed to learn from scratch, the basic aspects of Google SketchUp. By tinkering and experimenting with the Camera and View options, we have got well acquainted with the whole workspace that the software offers. Soon, you shall learn exactly how to use the many tools described in this valuable tool, to good effect. The later chapters in this Fast-track to Google SketchUp provide you detailed workshops on how to draw and manipulate 3D objects. Slowly, as you get acquainted with the exact know-how about the various tools, my sincere suggestion is that you start tinkering around with them. Apart from the instructions in the workshops, (though they will be quite descriptive and thorough) trying stuff out on your own is the best way to get better at using Google SketchUp. So get creative, get wacky, monkey around with the tools in Google SketchUp and you’ll understand that unleashing your creativity with Google SketchUp feels awesome!
So now that you know what SketchUp is basically all about, the time has come to move ahead and start modelling. Don’t start walking the ramp already—we’re talking about designing figures and objects, remember?
What Is A Model?

Architects and designers for example, make prototypes of the buildings they design to preview how they would look once finished. Typically, a model is a small-scale version of the real thing. Such a representation could either be physical (like a miniature building made with glass and board) or virtual (a computer generated 3D image using tools such as CADD—Computer Aided Design and Drafting).

SketchUp is a really flexible, simple and easy-to-use tool that any layman—with a bit of practice—can use to make 3-Dimensional models. With SketchUp, now everyone can make a model without the technical hurdles and learning-related delays involved in getting the hang of other tools in the market, like AutoCAD, 3ds Max, etc.

2.1 The Drawing Axes

As soon as you open SketchUp, what you see is the drawing area, which is basically a space provided to you to create your model.

If you’re really bright and didn’t bunk classes, you’ll remember coordinate geometry in school. A coordinate system is basically a method of locating points or positions by assigning numbers to them. A three dimensional coordinate system—like the one in SketchUp—has 3 axes and is used to locate a point or object in space. This helps to represent objects in 3D (length, breadth and depth/height) on a 2D surface (a flat screen or a sheet of paper).

SketchUp provides three drawing axes: X, Y and Z. Each axis represents a particular dimension and these three axes help to identify the 3D space of the drawing area.

X-axis: The X axis is represented by a solid red line, with the minus X part of the axis represented by a dotted red line.

Y-axis: The Y axis is the green line (solid for plus and dotted for minus)

Z-axis: The Z axis is the blue line you see. Plus or minus Z (above and below the ground plane) are represented by solid blue and dotted blue lines, respectively.

The point of intersection is called the origin. This is represented by a black circle in SketchUp. Each axis has its negative coordinates
(−1, −2, −3, etc.) on one side of the point of origin and the positive coordinates (1, 2, 3 etc.) on the other.

2.1.1 Moving The Axes
The drawing axes are by no means fixed and can be moved whenever necessary. Moving is easy:
● Right-click on the drawing axes (“context clicking” in SketchUp lingo) and choose Place.
● Move the floating axes with the mouse to the point you want to set up as the new coordinate origin of your model. Click to accept the new origin.
● Move the cursor away from this point to fix the red axis, using the inference tips to align it exactly the way you want. Click again, and bingo, you’ve got your new X-axis.
● Move the mouse again to align the green axis similarly. Click and you have the Y-axis. The Z-axis will set itself accordingly.

The best way to move the axes to a particular point relative to the current axes position is to use the Move Sketching Context dialog box. If you context click on the axes and choose Move, the Move Sketching Context dialog box pops up.

You can now specify the values of the X, Y and Z axes to identify the point in the present coordinate system you’d like to make the point of origin of the new axes. For example, putting the value “10” for each of the axes would shift them marginally. Once you’re
done, just click on the "OK" button and the axes will move to the exact point you have specified.

2.1.2 Re-aligning The Axes
If you want to align SketchUp’s point of view with the current view, right-click on the drawing axes and select “Align View” in the menu that appears.

2.1.3 Axing The Axes
When you open a new file, SketchUp, by default, displays the three axes for your convenience. However, if you find them bugging you, you could quite easily hide them. To hide the drawing axes, simply choose View > Axes.

We’ll soon get to drawing lines and stuff, but before all the fun starts, it would be a little prudent to check the Drawing Preferences settings so as to ensure a hassle-free drawing experience.

2.2 Drawing Preferences
To get to the Drawing Preferences, choose Window > Preferences > Drawing.

2.2.1 Click Style
This option lets you choose how your input device reacts to clicks

- Click-drag-release: Ticking this box will enable you to draw a line, for example, by holding the mouse button to define the starting point of the line, dragging the mouse to lengthen it and release the mouse to end it.
Auto-detect: Choosing this one would let you use the “Click-drag-release” or “Click-move-click” as and when you need, automatically sensing which one you require according to the movement and use of the mouse. This is SketchUp’s default.

Click-move-click: Clicking this button would ensure that the Line Tool will draw by establishing the stating point of a line with a click. The desired length is achieved by moving the mouse and end point with another click. This would determine the end point of the line and the line you wish to draw will promptly appear.

Continue Line Drawing: Clicking on this checkbox will force the Line Tool to automatically use the end point of a line as the start point of a new line.

2.2.2 Miscellaneous
There’s just one option given here—the Display Crosshairs one.

Display Crosshairs: Ticking this checkbox provides you with a really neat view of the three axes that move around with the mouse cursor while you’re drawing. The crosshairs assist in expediting drawing according to, or relative to, the three primary axes.

2.3 Drawing Lines And 2D Shapes
In SketchUp, shapes—and things that you draw are called entities. Before you get around to making even the most basic of shapes, you’ll need to know how to draw “Line entities”.

2.3.1 The Line Tool
The Line Tool is certainly the most indispensable and basic aspect of our modelling project.

It can be used to draw Line Entities or edges, which can then be used to create two-dimensional shapes.

2.3.2 Activating the Line Tool
Just click on the button with a pencil on it in the Drawing Toolbar above, in order to select the Line Tool. If you can’t see the Drawing Toolbar above, choose View > Toolbars > Getting Started, or, alternatively, View > Toolbars > Drawing.
2.2.2 Drawing a Line

- Select the Line Tool. The cursor will turn into a pencil.
- Click on the point from which you want to start your line. You may hold the mouse button down or release it. Either way, since you’ve set the preference to Auto-detect, SketchUp will follow the movement of the cursor and draw your line as you plot it.
- Now move the mouse cursor to the end point of the line you wish to draw. Click again. Voila, there’s your single line.
- This ending point then functions as a possible starting point for another line and you can continue to draw as many connected lines as you please in this manner. You can even specify the exact length of the line you wish to draw by using the VCB—the Value Control Box (but you’ll have to wait a few pages to understand that one).

![All lined up](image)

2.2.3 Drawing A Line Along An Axis

The easiest lines to draw are along the X, Y or Z axes.

Click on any of the axes and as you move the mouse cursor along that particular axis, it will form a line that stretches out in the same colour as the axis you’re working on. However, if you deviate, the line will change to black.

![This ToolTip tells you you’re on the Z-axis](image)

![This ToolTip tells you you’re on the Y-axis](image)

![This ToolTip tells you you’re on the X-axis](image)
As you’re doing this, if you let the cursor stay on the axis for a second, SketchUp will tell you which axis you’re on.

2.2.4 Locking Lines On Axes
When you’re drawing a line on an axis, there’s always the risk that, while you’re dragging the mouse along it, you may deviate off that particular axis. To ensure that this does not happen, SketchUp allows you to lock the direction on that axis.

Locking is as easy as turning a key. Only, in this case, you hold down the shift button. The process is explained below:
• Select the line tool.
• Click on the spot on the axis along which you want the line.
• Hold down [Shift]. Instantly you will find that the line which you draw gets thicker, while maintaining the same colour as the axis on which you are drawing.

Now if you drag the mouse around the drawing area, you’ll see a dotted line that connects the cursor, constantly, (as long as you’re holding down [Shift]), and the ToolTip which says Constrained on Line. In short, the line is now locked on to the axis you have chosen and irrespective of where your mouse roams, the line will only form on that very axis.
• Drag the cursor till the point which you want the line to extend and click again. The line will be formed.

Holding down [Shift] keeps the line constrained in a particular direction

2.2.5 Fiddling with Line Entities
Once you’ve drawn a line, you can play around with it, make changes, edit, split, or divide it into equal line segments, if you so please.
Editing a line
After drawing a line, you can edit its length using the Move tool. The Move tool is a part of the Getting Started toolbar.

In case you’re confused and disoriented, the button will signify itself as you move the mouse over it, by showing you its label, which says Move / Copy.

To edit the line:
- Select the Move Tool. Once you select it you’ll know because the mouse pointer will become a four-pointed arrow.
- Hover the mouse over the Line entity you want to shorten or lengthen until it reaches one end. The endpoint must now be used to extend or shorten the line.
- Click (left-click, obviously) and hold the cursor down on the endpoint of the Line.
- Drag the cursor back and forth to change the length of the line.
- Alternatively, adjust the length of the line with the help of the Line entity’s Entity info dialog box by typing in the exact values. You can access the Entity Info dialog by context clicking on the line (right-click) and choosing Entity Info from the menu that appears.

Dividing a line into equal segments
You can divide a line segment into any number of equal line segments. The process is easy:
- Right click on a line you have already drawn and choose Divide
- An array of points will appear on the line at equal intervals, to show exactly where the line will be divided. Drag the cursor back and forth to change the length of the line.

Get the facts about your drawings with the Entity Info dialog box
sor over the line and SketchUp will tip you with a tag that shows you exactly how many segments it would be divided into if you click there, and what the length of each individual segment would be.

- Click on the line when you see the required number of divisions. The line will be divided into equal, joined line segments.

The tooltips that tell you whether you’re on midpoints, endpoints, edge, etc. are thanks to the unique “inferencing” system in SketchUp. To understand that, turn to, *Inferences in SketchUp* later in this chapter.

**2.2.6 Drawing 2D Shapes**

The next step after you’ve figured out how to draw lines, is to figure how to draw figures with lines.

**Making Faces**

In SketchUp, 2D shapes are called *Face Entities*. It is essential to be able to draw faces first, because every 3-Dimensional model is actually constituted by several different 2D faces.

You can draw faces with the Line Tool, Arc Tool, Freehand Tool, Rectangle Tool, Circle tool or Polygon Tool.

2D shapes can be created in 3D perspective but if you wish to make things look really flat, like paper, when you’re drawing, you can shift to a Top camera view by choosing *Camera > Standard Views > Top*. Also choose *Camera > Parallel Projection* to ensure that your view isn’t distorted by the default Perspective view.

**Using the Line Tool to create a face**

Just as we go about creating shapes on paper, the elementary way to create faces in SketchUp is to use the basic element—the line.

Let us try and create a triangle using the Line Tool.
Drawing a Triangle (the hard way)

- Activate the Line Tool (you could do this simply by using the keyboard shortcut [L]). The cursor will turn into a pencil.
- Click on any point to set the starting point of your first line. This time we’ll steer clear of the axes and make our lines elsewhere, so try and click on a point in the drawing axes which does not lie on any of the axes.
- Drag the mouse and form a line. You could draw the line in any direction you please. In the image, you’ll see that we’ve drawn our line parallel to the green axis. You now have the first side of the triangle ready.
- SketchUp now perceives the endpoint of this line as the starting point as you next line. Drag the cursor away and click randomly elsewhere to create the second side of the triangle. As you can see in the image, the second line is parallel to the red axis.
- To create the final line of the triangle, simply drag the mouse to the starting point of the first line you had drawn and click on it (SketchUp tells you you’re at the right place, with the inference tag “Endpoint”).
- As soon as the triangle is created and its area is fully enclosed, the face is created and SketchUp, by default, displays the bounded area in a shaded grey.

The good thing about making a triangle is that once the endpoints of the lines are joined together, they are inevitably coplanar.
Congratulations! You’ve made your first 2D shape in SketchUp. Orbit around and take a proud look at your handiwork.

Squares and Rectangles
In the same way in which we formed the triangle, you could make other 2 Dimensional shapes like squares and rectangles, simply by drawing the fourth line. However, unlike while forming the triangle, it is imperative that the four lines that you draw are coplanar.

Drawing a Rectangle
There are two ways of drawing squares or rectangles:

The hard way
This is the same as a triangle, only instead of drawing three edges, you draw four—taking care that they’re coplanar.

The Easy way:
SketchUp has provided the “Rectangle” tool, which, when chosen, quickly enables you to make a rectangle or square as you please. The tool looks like a square and can be found in the Drawing Toolbar or the Getting Started Toolbar—View > Toolbars > Getting Started or View > Toolbars > Drawing. Another way would be to click on the Rectangle option in the Draw drop down menu above. Alternatively, you could use the keyboard shortcut, [R].
• A single click will set the first corner point of the rectangle.
• Now move the mouse in a diagonal fashion till you reach the
point you feel is the opposite corner of the rectangle you want to draw.

- Click again. This will define the second corner point of the rectangle. The rectangle will appear and fix itself at the spots you have defined.

**Drawing a Square**
Since SketchUp has so kindly given us the Rectangle tool, this time we’ll avoid the bother of making every individual line and simply use it to make a square.

- Select the Rectangle tool.
- Click once to establish the first corner point
- Drag the cursor to the opposite corner. As you do so, a dotted, diagonal line will appear. SketchUp will also provide you with a tooltip telling you that you are in a position that will create a square.

![This flat panel is your rectangle in 3D](image)

**Squaring things up**

You can specify the specific values of each line in the VCB that is at the bottom right corner.

**Arcs**
SketchUp has the Arc tool which helps you to draw half-circles, and curved lines (or arcs). Working with the Arc tool is easy and can be chosen from the Drawing toolbar or the Arc option in the Drawing menu above. Alternatively, you could just use `[A]`. 
**Drawing an Arc**

- Activate the Arc Tool in any of the ways specified above. The cursor will instantly change into a pencil with an arc.
- Click in the drawing area. This will be the starting point of the arc.
- Move the mouse to the point you’d like to end the arc. Click to place the ending point of the arc. Strangely, you’ll see a straight line appear, instead of an arc. This straight line is the chord.
- To stretch this line into an arc you’ll have to move the mouse in a perpendicular direction from the straight line. As you do this, you’ll see the line being curved into an arc.
- Simultaneously, another straight line extends at a right angle from this straight line. This is the “bulge” of your arc. Click once more to set the bulge distance. There, you’ve got your arc.

**Circles**

SketchUp has thought of everything and has thrown in the indispensible “Circle” tool which makes drawing a circle easy as pie—pun intended.

**Drawing a Circle**

The keyboard shortcut `[C]` is enough to activate the Circle tool. The cursor will change into a circle with a pencil attached to its centre. When you click now, you’ll be choosing the centre point of the circle you are going to draw.
- Click to fix the centre of the circle. The next step is to define the radius of the circle.

As you move the cursor, a line will extend out from the centre to show you the radius of your circle.

You can see the radius value (the length of the radius of your circle) being displayed.

![Making circles “radiate” outwards](image-url)
dynamically in the value control box as you move the mouse around. To set exact specifications, simply type in the length value of the radius and hit [Enter].

- When you think the circle you are trying to make is large enough, click, to finish the circle.
- You can even lock a circle to its current orientation by holding down [Shift] before you begin drawing the circle.

Polygons
What is a polygon anyway? A polygon is nothing but a closed plane (flat, two-dimensional) figure bounded by straight lines; rectangles, squares, pentagons etc. are all examples of polygons. You can wake up the Polygon Tool from the Drawing Toolbar (the button with a hexagon on it).

Drawing a Polygon
- Select the Polygon tool in any of the ways above. The cursor will instantly change into a pencil with a polygon hovering with it.
- Click on the spot which you’d like to make the centre of your polygon in the drawing area.
- Now move the cursor away from the centre point to determine the radius of the polygon. The radius value is constantly being displayed in the VCB below. You could type the exact radius in the VCB.
and press [Enter] to have the polygon take shape accordingly. You can even specify the number of sides of the polygon in the VCB.

- Click again to complete the polygon.
- You can lock the polygon to an orientation (as you did with the circle) by pressing and holding down [Shift] before starting the process of drawing the polygons.

For all of these shapes—including the line—to be drawn with complete accuracy would need a better understanding of the Inference engine that SketchUp has so kindly provided for our assistance.

**Hands Free**

Suppose you don’t want a particular shape and want to escape the fixity of geometrical shapes, you can draw about anything you like with the mouse if you choose the Freehand Tool.

You can use the Freehand tool to draw irregular shapes, which SketchUp calls “Curve entities”. These are nothing but several line segments connected together that behave as a single line.

Alternatively, you could activate the Freehand Tool from the Drawing toolbar.

Using the Freehand Tool is easy:

**Drawing a random curve**

- Select the Freehand tool (Draw > Freehand). You’ll know you’ve done that when you see the cursor transforming into a pencil with a curve hanging in the air.

Fishy drawings are feasible too
Click and hold down the mouse button to begin drawing.
Drag the mouse and draw the shape you desire.
To end your drawing, release the mouse button.

2.3 Inferences In SketchUp

One of the most terrific things about SketchUp is this predictive ability called the “Inference Engine”. Once you’ve mastered using this, you can start drawing really quickly for almost everything you draw in SketchUp can be made using the Inference Engine.

The Inference Engine
The Inference Engine is a geometric analysis mechanism that infers points (relative to other points) and gives you smart tips and visual cues as you draw. It locates (“infers” in SketchUp lingo) points from other points in your model, flashing cues like “Endpoint”, “Midpoint” and so on to keep you on track and in touch with what exactly you’re drawing. This enables a hassle-free drawing experience, and eliminates the potential pitfalls of attempting to work in a 3D space while actually using a 2D screen. These cues are what they call tooltips.

Cute Cues
As you work on your model, SketchUp’s Inference Engine automatically displays ToolTip cues to help you identify any significant points or relevant geometry. This helps you draw better and more accurately. Besides, specific colours are used by the inference engine to show the type of inference it displays. (In short, ToolTips + Coloured Lines = Inference Engine).

Types of Inferences
SketchUp expedites the modelling process with three main types of inferences:
1. Point Inferences
2. Linear Inferences
3. Planar Inferences
Sometimes, two or more of these could combine together to form a complex inference.
2.3.1 Point Inferences

While you draw the inference engine detects at which point the pencil (mouse cursor) has been situated and instantly gives you a ToolTip telling you exactly which point it is, with reference to other points and aspects of your model. For example, if you hover the cursor on the corner of one of the polygons you created earlier, the inference engine will inform you that you’re on an endpoint.

The different kinds of inferences, their colours and what they indicate are listed in the table below for your quick reference:

<table>
<thead>
<tr>
<th>Point Inference</th>
<th>Colour</th>
<th>What it indicates</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Endpoint</td>
<td>Green</td>
<td>The end of a Line entity or Arc entity</td>
</tr>
<tr>
<td>2 Midpoint</td>
<td>Cyan</td>
<td>The middle point of a line or ‘edge’</td>
</tr>
<tr>
<td>3 Intersection</td>
<td>Black</td>
<td>The exact point where a line intersects another line or face</td>
</tr>
<tr>
<td>4 On Face</td>
<td>Blue</td>
<td>The point lies on a “Face Entity” (basically, the point you have chosen lies on the side of a 3D model or shape you have already drawn or set up)</td>
</tr>
<tr>
<td>5 On Edge</td>
<td>Red</td>
<td>The point lies on a line or “edge”</td>
</tr>
<tr>
<td>6 Equi-Distant on Edge</td>
<td>Magenta</td>
<td>A chamfer (an equidistant point between two connected edges)</td>
</tr>
</tbody>
</table>
7 Half Circle Blue While drawing an arc, this indicates that the clicking on the point at which the cursor is will create a semi-circle

2.3.2 Linear Inferences

When the line you’re drawing is along a particular axis, another line or a specific direction in space, the SketchUp Inference Engine snaps in place, showing you a ToolTip and sometimes a dotted line that stays with your cursor till you move it away from the particular position. In short, Linear Inference = ToolTip + Dotted Line.

The following table would help to understand Linear Inferences better:

<table>
<thead>
<tr>
<th>Linear Inference</th>
<th>Colour</th>
<th>What it indicates</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 On Axis</td>
<td>Solid line</td>
<td>Shows that the line you’re drawing is aligned to any axis (red, green or blue). The ToolTip, therefore, would be, not just “On Axis” but “On Red Axis”, “On Green Axis” or “On Blue Axis”. The colour of the line becomes the same as the colour of the corresponding axis.</td>
</tr>
<tr>
<td>2 From Point</td>
<td>Dotted Line</td>
<td>Indicates linear alignment from a particular point along the directions of the Drawing Axes. This dotted line is drawn in the colour of the corresponding axis.</td>
</tr>
<tr>
<td>3 Perpendicular</td>
<td>Magenta</td>
<td>Shows that your cursor is now in position to draw a line that is perpendicular to an edge.</td>
</tr>
<tr>
<td>4 Parallel</td>
<td>Magenta</td>
<td>Shows you that the line you intend to draw is parallel to an edge.</td>
</tr>
<tr>
<td>5 Tangent at Vertex</td>
<td></td>
<td>When drawing from the endpoint of an Arc Entity, using an Arc Tool</td>
</tr>
</tbody>
</table>
It's great to familiarise yourself with these inferences but you'll only really know how important they are once you start making models.

2.3.3 Planar Inferences
The inference engine also tells you where you are by snapping to a plane in 3D space.

In Your Face
Every time the cursor alights on a particular surface (or “face”), a blue On Face inference identifies it. This is a point inference.

2.3.4 Encouraging An Inference
The really cool part about the Inference engine is that even if an inference doesn’t immediately pop up, SketchUp can be coerced a little by simply pausing the mouse cursor over the particular point
that you’d like an inference from. The tooltip will appear and then SketchUp temporarily gives priority to that alignment.

2.3.5 Locking Inferences
In case you’re finding it difficult to draw correctly and finding that you’re not able to infer points as well as you could, it would really help to use the Inference Lock.

To lock an inference, simply hold down the [Shift] key whenever SketchUp infers the desired alignment. Instantly the line of inference will become thicker (bold).

This inference will now stay locked and you may wave the cursor around but the drawing will continue in the locked direction, while telling you apologetically that the drawing is “Constrained on Line”.

Inferences may be locked along an axis direction, along an edge direction, on a face, from a point, parallel or perpendicular to an edge, etc.

2.4. Using The Value Control Box (VCB)

Another of the terrific facilities in SketchUp is the Value Control Box (VCB), which you can see as an empty box at the bottom-right of your screen, as a part of the Status Bar. What the VCB does, is show you the dimensions of the entity you are drawing while you are in the process of doing so (length of the line you’re drawing, length and breadth of the rectangle / square you’re drawing, radius of the circle you’re drawing, etc.). If you keep your eye on the VCB while drawing, you can ensure that your creation has the measurements you want.

The VCB ensures a sound value system

However, you could also enter the exact value into the VCB so that the selected entity is of precisely the dimensions you wish.

The following tips will help you use the VCB better:

- You don’t need to click in the box before you enter a value. Just start typing the numerals and they will appear in the Value Control Box.
- Make sure you type in a value before—or just after—you’ve finished creating the entity. If you start a new operation and then try to modify the value of the entity you’ve already made, it won’t happen. So, for example, if you wish to draw a line of say, 15 feet, click to set the starting point and then type 15’. Hit [Enter] to see your line form itself as per the measurement you’ve entered.
- If you don’t like what you see, you could experiment by typing in different values as many times as you wish till the entity looks okay. As long as you don’t draw something else, the entity will continue to alter itself as per the measurements you fill in.
- Once you exit a tool, you can’t use the VCB to change the values of the entity you have made.
- You can type the value in any unit system, and SketchUp will immediately convert it to the default unit system and proceed to modify your entity accordingly.
  SketchUp basically gives you four formatting options for the units displayed for measurements, dimensions and within the VCB:
  1. Architectural units (feet and inches)
  2. Decimal units (in decimal units which include feet, millimetres, centimetres and metres)
  3. Engineering units (feet and decimal units of feet)
  4. Fractional units (fractional inches)

### 2.4.1 Using The VCB To Make 2D Shapes
We’ll try and guide you quickly through the ways in which you could specify precise values while creating different shapes in this section.

**Using the VCB for Lines**
- When you’re drawing a line, once you set its starting point (by clicking once in the drawing area), you’ll notice the label “Length” just outside the Value Control Box. Whatever numerals you type in now will be accepted by SketchUp as the desired length of the line you’re drawing.
- Simply type in the length of the line you’re drawing after you set the starting point.
- Press [Enter]. If you don’t specify inches (") or meters (m), etc., SketchUp automatically uses the current unit system being used.
Now let’s say you already have started drawing a line and want it to end at an exact coordinate in the 3D drawing area—and you even know the exact coordinates of the endpoint. Simply type in the coordinates enclosed in square brackets and the line will stretch out till the endpoint you have specified. Please note that these coordinates are absolute—in the sense that they must be according to the points on the three axes.

Occasionally, you know where you’d like the line to end, but don’t know the exact three-dimensional coordinates. Just feed into the VCB the x, y and z values—that is the relative distances from the starting point of the line you are drawing. Note that these coordinates have nothing to do with the units and points on the three axes, but are relative units of distance from the start point of the line to the end point of the line.

Relative coordinates (relative to the starting point of the line) must always be typed in the VCB enclosed by angle brackets.

Using the VCB for Arcs

When drawing an arc, the value you see in the VCB is the chord length of the arc. Again, this is only displayed once you have set the starting point of the arc.

Once you set the ending point of the arc, the value you see in the VCB is the bulged distance.

You can specify exact lengths for chords, bulges, radius and number of segments.

- **Chord Length:** You could specify exactly how large your arc should be by specifying the chord length. By default, any value you type into the VCB after placing the starting point of an arc will be accepted as the chord length of the arc. You’ll see the VCB label “Length” on the status bar below (right) to indicate that you can now fill in the length of your chord.

- **Negative Chord lengths:** If you want SketchUp to draw the arc in a direction opposite to the current drawing direction, you’ll have to type in a negative value.

- **Controlling the Bulge:** Once you’ve placed the starting and the ending point of your arc, the VCB will accept any value as the bulge (amount of curvature of the arc). To ensure that you
remember this, SketchUp changes the label of the VCB from “Length” to “Bulge”. Type in the extent of bulge you want and press [Enter].

- **Radius**: You can specify the radius of the arc you desire in the VCB by typing in the exact value followed by the alphabet “r”. This can be done while you’re creating the arc. Don’t forget to press [Enter]. Alternatively, you could just type in the value without the letter “r” because SketchUp figures you’re filling in a value for the radius anyway.

Feeding it in...

...and the resultant bulge

- **Segmentation**: if you type in a value followed by the letter “s”, and then press “Enter”, SketchUp divides the arc into the number of segments you have specified. As usual, you’ll have to specify this either while drawing or immediately after creating the arc.
Using the VCB for Rectangles
Soon as you begin drawing a rectangle using the Rectangle tool, you’ll see the dimensions of the rectangle dynamically being displayed in the Value Control Box (the label “Dimensions” will also be visible just outside the VCB).

- You can draw an entire rectangle and fill in the length and breadth values as per your requirement (before you begin any other operation). Simply typing two numerals separated by a comma—and then pressing [Enter]—will do this for you.
- Alternatively, you can simply set the first corner of your rectangle by clicking once and then putting the values of length and breadth in the VCB.
- Uniquely, you could even type in a single dimension at a time (just the length or just the breadth). This will change only the dimension you have mentioned and the other two sides of the rectangle will remain of the same length as before. Thus, entering a value followed by a comma in the VCB, (for example, 33”,) then the new value will only be applied to the first dimension and the length will change to 33 inches. Similarly, typing in the value after a comma (for example, , 33”) will change only the second dimension.
- Negative values will change the direction in which your rectangle is being drawn. Any further values will now be understood to now refer to this new direction.

Using the VCB for Circles
Every time you draw a circle, the VCB shows you the value of the radius from the centre point. You can specify the exact length of the radius by typing the numeral in the VCB while drawing a circle (or immediately after you’ve drawn one). For your convenience, the “Radius” label will appear outside the VCB on the status bar below. The process is easy:
- Choose the circle tool. The cursor will change to a pencil with a floating circle.
- Click on a point in the drawing area to choose the centre point of the circle.
- Type the value of the radius of the circle. Press [Enter].
- Simply typing in the value is enough. However, you can specify the
exact measurements, for example, 4’ 6” or 6m. The image below shows how a value of 15 feet was filled in the VCB as radius, and the resultant circle.

You could even specify the number of sides.
- As soon as you activate the circle tool, you’ll see the “sides” label of the VCB, indicating that you can type in a number to specify how many sides you want your circle to have.
- Type in the number of sides and press [Enter] before you click to set the centre of your circle.
- In case you’ve already drawn your circle but now want to change the number of sides, simply type in the number of sides in the VCB followed by the letter “s” and press [Enter]. This value will now be applied to all circles you draw in future.

Using the VCB for Polygons
Once you set the centre point of a polygon you can use the VCB to set the exact measurements of the radius and the number of segments in a manner similar to a circle as explained above.

2.5 Modelling With The Push Tool

We now enter the realm of 3D—and this is where the real fun starts. Finally, someone had the bright idea of providing the layman with handy point-and-click software to create three-dimensional shapes on the computer.

Jostling For Space
SketchUp holds a patent on its Push/Pull technology which is a system and method for three-dimensional modelling. You can use the Push/Pull tool to catch hold of a two-dimensional surface and literally pull or push it into three dimensions. Simple non-curved face entities can be extruded towards a starting point. What you’re
do, in other words, is creating volume out of a face.

**Activating the Push/Pull tool**
The easiest way to activate the Push tool is to use the Keyboard Shortcut [P]. You could also select the tool from the Getting Started or the Modification toolbar. Just click on the icon which looks like a rubber stamp (a block of wood with a red vertical arrow emerging from its upper surface). Or click your way through Tools > Push/Pull.

**Extruding 2D shapes**
Once you’ve created a 2-dimensional surface in the drawing area, it can be extruded into 3D. This applies for all the shapes we’ve seen till now—the square, the rectangle, the circle, the polygon, etc.

- Activate the Push/Pull tool in any of the above ways. You’ll know it’s activated when you see the cursor become a block with an upward pointing arrow.
- Select the face you want to extrude by clicking on it. (Note: You cannot extrude a curved surface, such as the outer, curved edge of a cylinder or a sphere. In order to push or pull a surface, it must be flat)
- As you move the cursor over a surface, it will become a shaded blue/purple in order to show that you can now extrude this face. Remember that to select a face, it is the up arrow that must be on the face and not just the 3D rectangle that hovers with your mouse cursor.
- Click on the face.
- Move the cursor to extrude the face in either direction. In this image, you see the Push / Pull tool extruding a circle into a cylinder in the positive direction of the blue axis.
Click again to finish.

You'll have noticed that once you select a face to push around, it only extends within its own parameters and even though you may randomly move the mouse around, it will not break the rules of geometry to make twisted, random shapes.

Hole-in-one
If you wish to create a void in the face of a 3D model, all you need to do is draw a shape on it and use the Push/Pull tool to push it through the volume of the model to the other side. This will create a hole in the face in the same shape as the shape you had drawn on it.

2.5.1. Workshops: Creating Basic 3D Models
Let's now try and make a few 3-dimensional things on our own.

Creating a Box
We'll start by the basic building block—that is, the block (or box) shape.

In this workshop we intend to

a. Create a rectangle on the ground plane (flat and aligned with the X and Y axes).
b. Use the Push/Pull tool to turn it into a box (a cuboid).

Follow the following steps to make a box:

- Select the Rectangle Tool (an easy way to do that is to use the keyboard shortcut \[ R \]). The cursor will turn into a pencil with a rectangle tagging along behind it.
- Click on a point on positive side (non-dotted part) of the red axis.
- Drag the cursor to the left and click on a point on the positive side of the green axis. A shaded rectangle will be created.
- Select the Push/Pull tool from the toolbar above.
- Hover the mouse cursor on the rectangle you’ve created till you see it change colour and become full of dots.
- Click on the face and drag the mouse upwards. You’ll find that as the mouse goes up, the rectangle now becomes a box, filling up in volume along the blue axis.
Congratulations! You’ve successfully made your first three dimensional model.
You can also make cubes using squares as your base.

**Full Cylinders**
In this workshop we plan to do the following:

- Create a circle on the ground plane (flat and aligned with the X and Y axes).
- Use the Push/Pull tool to turn it into a cylinder

To stretch a circle into a canister, do the following:

- Select the Circle Tool (an easy way to do that is to use the keyboard shortcut “C”). The cursor will turn into a pencil with a circle attached to it.
- This time too, we’ll make our shape on the ground plane. Click on the point of origin (point of intersection of all the three axes) to select it as the centre of your circle.
- Drag the cursor outwards and type in the value of the radius in the VCB. In this case, we’ll type the value 10” (ten inches). Hit the [Enter] button. The circle will appear—shaded—on the ground plane.
- The circle will appear—shaded—on the ground plane.
- Select the Push/Pull tool from the toolbar along the top of your screen (or along the side of the screen).
- Hover the mouse cursor on the circle you’ve created till you see it change colour and become full of dots as in the image.
- Click on the face and drag the mouse upwards. You’ll find that as the mouse goes up, the circle now becomes a cylinder, filling up in volume along the blue axis. Click again.
**Prisms and Polyhedra**

Now let’s see how you can create a prism (a 3D triangle) or a polyhedron by...

a. Drawing a triangle or a polygon on the ground plane.

b. Using the Push / Pull tool to extrude it into a polyhedron.

- Select the Polygon Tool. The cursor will turn into a pencil with a polygon attached to it. Specify the number of sides. By default, SketchUp allows you to draw a six-sided figure (hexagon) but you can create a triangle by specifying the number of sides (three) in the Value Control Box.

- Click on the point of origin (point of intersection of all the three axes) to select it as the centre of your polygon.

- Drag the cursor outwards and type in the value of the radius (let’s try 10 inches again) in the VCB. Hit the [Enter] button.

- The triangle / polygon will appear on the ground plane.

- Select the Push / Pull tool

- Click on the face and drag the mouse upwards. Your triangle / polygon will fill up into a prism / polyhedron. Click again when you feel it’s of the height you desire.

**3D Layering**

We’re now going to give you a practical on how you can push or pull new faces to create layers on a particular face of a model.
• Create a 3D figure. For example, a box.
• Select the Push / Pull tool and Push / Pull a face.
• Press and release [Ctrl]. A plus sign will appear next to the cursor.
• Push / Pull again. The top most face will now remain the standing point for a new push / pull action.

Contrarily, if you don’t press the [Ctrl] key, each time you attempt to make layers on a face, the same face will continue to extrude, instead of several layers being formed.

2.5.1. Workshop: Creating Complex Models

You’re now ready to proceed to creating more complicated shapes and objects. In this section we’ll figure out how to go beyond the plain and ordinary.

Drawing on Faces
If you want to draw shapes on one or more of the faces of one of the 3D models you’ve made so far, the following steps will take you there:
• Choose the “Rectangle” tool. (The Circle or Polygon or line tool would do as well).
• Drag the mouse till the pointer rests on the surface of the 3D shape on which you wish to draw a shape. SketchUp will display a blue dot and give you the ToolTip “On Face”.
• Click and drag on the surface. You can create any of the shapes as we’ve discussed earlier. However, in this case, we’re making a rectangle.
Click again to finish drawing the rectangle.
You’ll notice that the shape you draw will appear as if it has been drawn exactly on the surface and is in complete alignment with the other edges of the surface.

Pushing parts of faces
Once you’ve created a shape on a surface (as shown above), you can select and push or pull that part of the face, as if it’s a separate entity.
Select the Push / Pull tool.
Drag the cursor onto the rectangle you’ve drawn on the face of the box. You’ll see the inner portion of the rectangle shaded, indicating that it is now ripe for pulling and pushing.
Click on it and drag the mouse. If you drag the mouse outwards (in a direction away from the surface, the rectangular section will extrude as if it is being pulled out. If you drag the mouse towards the inside of the box, the
rectangular section will subside, as if creating a window in the surface of the box.

- You can do the same with circles or other shapes (even freehand ones drawn on the surface) by using the Push / Pull tool to make the shapes project out or sink in.

**Holey Walls**
You just witnessed how Push / pull implodes any shape on a face into the volume and towards the back face of the volume when you use the tool to drag it inwards. SketchUp subtracts the shape and creates a void if the shape is pushed completely out of the back of the volume. This is a great way of making windows if you’re making walls or buildings with SketchUp. However, it is imperative that the front face and the back face are parallel to each other for the void to happen.

- Create a box with the Push/pull tool
- Draw a rectangle on one of its faces
- Use the Push/pull tool to push the rectangle inwards towards the opposite face of the box.
- As soon as it reaches the face on the opposite side—that is, you’ve pushed the area of the rectangle completely out of the face at the back of the box, release the mouse. The section will void, creating a window right through the box.
2.6 Modelling With The Move And Rotate Tools

The Move Tool is visible in the Modification toolbar (View > Toolbars > Modification) or the Getting Started toolbar (View > Toolbars > Getting Started). You could also activate the Move Tool by using the Keyboard Shortcut [ M ].

2.6.1 Moving
You could move most anything simply by following the steps below:

- Activate the Move tool. You’ll know it’s selected when the cursor turns into a four-pointed arrow.
- Click on the entity you want to move.
- Move the mouse away and the selected entity will follow.
- Click when you reach the point to which you want to move the entity.

You can lock the direction of the movement by holding down [ Shift ] when you begin the movement.

If you want to align the movement in the direction parallel to the axes, you’ll have to hold down one of the arrow keys to keep the movement locked.

Making A Long Face
When a point or edge of a face entity is moved, it extends but stays connected to the model and pulls along adjoining parts of it, making modifications to the shape where necessary.

Sticky Movements
Geometry in SketchUp is sticky, in the sense that if you move a particular entity, all the entities connected to it will stretch and move.
as if stuck to the one you are moving. You can thus, move faces, lines or points in such a way that the rest of your model is dragged along behind with them. In the example below, we select a line that splits a face across the middle and move it upwards, along the blue axis, making a kind of sloping roof for a house.

**Autofold**
SketchUp automatically folds faces when you move a face in such a manner that the resultant face is non-planar.

Sometimes Autofold doesn't happen because SketchUp tends to keep a face planar. This can be solved by pressing the [Alt] key once before moving an entity.

**Copy that**
You can also use the Move tool to copy entities (after all, the tool is called Move / Copy, isn’t it?).

- Click on the select tool, the button with a single arrow in the toolbar above.
- Select the entity to be copied.
- Activate the Move tool.
- Press and let go of the [Ctrl] key. The Move cursor (four pointed) will now have a “+” sign hovering around it.
- Click on the entity you have selected to copy. Move the mouse and the copy of the entity will follow.
- Click wherever you want a copy of the entity to be situated. A copy of the original entity will appear there.

You can specify exact length or extent of displacement in the VCB when you're moving an entity.

You could even move several entities together, by selecting them before you select the Move tool and begin the operation.

The movement of an entity can be locked in a particular direction by holding down the [Shift] key while it is being moved.
Else you could lock the line of movement to a specific axis using the up, left or right arrow keys during the operation.

2.6.2 Rotating

Another SketchUp brainwave is the “Rotate” tool, which you can locate in either the toolbar above or the Tools menu. You could otherwise, simply use the keyboard shortcut “Q” instead. You’ll know it’s active when the cursor changes into a couple of circular arrows and drag along with it a protractor.

Here are the basics of using the rotate tool:

- Activate the Rotate tool as above. The cursor will now become a protractor with a circular arrow.
- As the mouse hovers over an entity, the protractor automatically orients itself to the surface. The process now involves three clicks of the mouse: (1) A click to select an entity for rotation (2) a click to set a “rotation arm” with the help of which you can rotate the entity and (3) a click to finish the rotation operation.
- Click on an entity to select it for rotation. The point you click on will also be the centre of rotation and you can use the Inferences to choose the right point.
Drag the mouse outwards to establish a lever or rotation hand to rotate the entity with. In the image below, the upper face of a box has been chosen to be rotated.

- Click to set the starting point of the rotation operation.
- Drag the mouse till the endpoint of the rotation.
- Click to complete the operation.

As we rotate the upper face of the box, you’ll find the rest of the faces of the box also turning and twisting accordingly.

**Rotating Copies**
The “Rotate” tool even allows you to make copies which you can then rotate. To use the “Rotate” tool to copy an entity, do the following:

- Select the Rotate Tool.
- Click on an entity to select it for rotation.
- Hit and let go of the [Ctrl] key. A plus sign will attach itself to the protractor icon cursor.
- Move the mouse in a circle and click to set the starting point of the rotation.
- Drag the mouse to the endpoint of the rotation. You’ll see a copy of the entity appear and rotate with the movement of the mouse.
- Click to finish.

**Folding an entity with the Rotate tool**
If you set the protractor icon along an edge, SketchUp will figure out that you want to fold geometry on that particular line.
Folding an edge with the Rotate Tool
- Draw a rectangle using the Rectangle tool.
- Use the Line tool to split the face of the plane. In this case, we’ll draw a line to segregate one of the corners of the rectangle. This is now our fold line.
- Select this corner using the select tool.
- Activate the “Rotate” tool.
- Click and hold down the mouse button on one end of the fold line.
- Pull the icon along the fold line, to orient the protractor in the right direction and release the mouse button.
- Move the mouse to set the direction of rotation. Click the mouse button, to set the stating point of the rotation.
- Drag the mouse. The triangular portion of the model will now fold in the direction you move.
- Click to finish.

2.6.3 Cottage
Now, we’ll attempt to make what looks like a typical cottage using most of the tools we’ve seen above.
1. Select the Rectangle Tool. Click and drag to form the bottom of the cottage on the ground plane
2. Activate the Push / Pull tool. Select the rectangle you’ve drawn. Push it to make it extrude upwards, along the blue axis till you feel the cottage is high enough.
3. Split the face of the roof of your cottage by drawing a line (with the Line tool)
4. Activate the Move / Copy tool.
5. Select the line that splits the face by clicking on it. Use the mouse cursor to move the edge upwards. This will form a gable—a sloping roof. Move it upwards along the blue axis (the Inference will cue you on it) till it reaches the height you require. Alternatively, you could specify the value of the movement in the VCB. You now have made the basic faces of a cottage with a sloping roof.

6. Select the rectangle tool again. Create a window on one of the walls of the cottage.

7. Activate the Move / Copy Tool again and press the [Ctrl] button on your keyboard. The cursor will allow you to set an identical window wherever else you please. You can repeat the motion several times to put two windows each on two of the parallel walls of the cottage. We’ll put a few windows on the other walls too.

8. Use the Rectangle tool to make a door.

9. Activate the Push / Pull tool. Select each window and the door, one by one and gently push them inwards a little to make them look like really real windows. You can ensure
that each of these sink in to the same degree by specifying the same value (positive for one face and negative for the opposite face) when pushing each entity inwards and then pressing [Enter].

10. Now use the Push / Pull tool to push in the walls (fill in the same measurements for both the opposite walls in the VCB) to create a uniform protrusion all around the cottage—a sort of pent roof.

11. Switch to the Top view (Camera > Standard Views > Top) and use the rectangle tool to draw a large rectangle around the cottage on the ground plane. Use the paint bucket tool to colour this green. Great, now you’ve got a garden patch.

12. Now let’s try and make some garden stools for the green patch outside the cottage. Select the Polygon tool. Use the VCB to specify the number of sides. Set the number of sides to 15.

13. Click—drag—click to make a polygon on the ground plane, on the garden patch next to your cottage.

14. Use the Push / Pull tool to extrude the polygon upwards in the direction of the blue axis. Pull it to the height of a typical chair (relative to the cottage you’ve drawn).

15. Select the Rotate tool. Choose the upper face of the stool we just made and rotate it as described in 2.6.2 above.
16. Click again when the cursor has come full circle. The vertical lines of the stool will auto fold.
17. Select the stool and use the Move/Copy tool (and the [Ctrl] key) to copy the entity.
18. Move the cursor and place the copy of the stool on the other side of the door (you could put several more around too).
   Home, sweet home! Orbit around and take a look. Don’t forget to save it for future reference.

2.7 The Tape Measure Tool

Pulling Out The Measuring Tape
Use the Keyboard Shortcut [T] or click on Tape Measure in the Tools menu above. You’ll also find the Tape Measure icon in the Construction Toolbar.

The tape measure tool does, well, what tape measures do—and a little more. You can use the Tape Measure Tool for the following:

Measuring Distances Between Two Points.
To see how far a point is from another point, simply do the following:
- Activate the Tape Measure Tool. The mouse pointer will turn into a Measuring tape.
- Click on the starting point of the entity you want to measure.
- Move the cursor in the desired direction. You’ll see the measuring tape line stretch out with it.
- Click at the end point. The distance between the two points will be displayed dynamically as a tag with your cursor, or in the VCB.
- You could also use the click-drag-release way with the same results.

Creating Construction Line Entities
These are infinite dashed lines that you temporarily set up to make your drawing actions more accurate, while Construction Points Entities are finite dashed lines that you could provisionally make for more precise drawings.
To make “Construction Line” or “Construction Point” entities,

- Activate the TMT (Tape Measure Tool).
- Click on the line that is parallel to the construction line. This point will be the starting point of the measurement.
- Start from one of the “On Edge” inference cue points and move across a face to make a construction line entity. To create a finite construction line, start from an “Endpoint”.
- Hit the [Ctrl] key and let it go.
- Shift the mouse in the direction of measurement. A measuring tape line will appear and the construction line (dashed, infinite) will spring out both ways from the starting point.
- Click to set the point where you desire a construction line. The distance will be visible in the VCB.

Scaling Or Rescaling A Model

Once you’re done drawing a model, you may feel that you’ve made it too small or too big. In short, you may realize that the scale needs to be changed. This is where the TMT comes to the rescue. The tool can be used to specify precise dimensions between two points, using what SketchUp calls “Reference Lines”.

2.7.1 Resizing Models Using The Tape Measure

Let’s take the model of the cottage we made earlier in this chapter to check how we can resize things using the TMT.

- Re-open the model of the cottage that you have made.
- Activate the Tape Measure Tool.
- Choose a line segment that is a part of the model (for example, on edge of the roof). Click one end of the line segment to set the starting point.
- Drag the cursor to the other end of the line.
- Click again on the endpoint of the line seg-
2.8 Creating Components

Several entities come together to form a “Group” or “Component”. Components are nothing but pre-built mini-models or parts of models—reusable models which can be placed in other models. SketchUp has very kindly provided a large number of components, the break-up of which is given below:

<table>
<thead>
<tr>
<th>Component Type</th>
<th>Number of Components pre-set in SketchUp</th>
</tr>
</thead>
<tbody>
<tr>
<td>Architecture</td>
<td>27</td>
</tr>
<tr>
<td>Construction</td>
<td>20</td>
</tr>
<tr>
<td>Film and Stage</td>
<td>21</td>
</tr>
<tr>
<td>Landscape</td>
<td>27</td>
</tr>
<tr>
<td>Mechanical</td>
<td>12</td>
</tr>
<tr>
<td>People</td>
<td>18</td>
</tr>
<tr>
<td>Shapes</td>
<td>22</td>
</tr>
<tr>
<td>Transportation</td>
<td>12</td>
</tr>
</tbody>
</table>

These components can be accessed by activating the “Component Browser” from the Window menu.

You can click on any of the several ready components provided therein and then drag the mouse cursor and click again to insert the component in your model.

Each individual component is called a “Component Instance” and can be used as many times as you wish.
However, if you’ve created something cool and you feel you could use it in several different models—or use it again for another model in future, you can give your model the status of a component by adding it to the component library. For this, however, you’ll first have to understand how to go about creating components.

How To Create A Component

- Activate the “Select” Tool.
- Click and hold down the mouse button and drag to select the entity in its entirety.
- Let go of the mouse button when you see that all the elements of the entity you have selected are included in the selection space.
- Click on the Edit button above and select the Make Component option from the drop-down menu that appears. Else, simply right click on the model you have selected and choose Make Component in the menu which appears (or just use the Keyboard Shortcut [G])
- Either way, the Create Component dialog box should appear.
- Fill in the necessary details in the dialog box. Don’t forget to specify the types of faces (horizontal, vertical, etc)
- Click on Create
- In the component browser, you’ll now see your model become a part of the components in the In Model category.
- Select the category you’d like to keep it as a part of in the drop down menu in the lower half of the “Components” dialog.
Click on your model from the upper “in model” section and drag it to the lower section.
Release the mouse button.
Your model will now become one of the components in the “Model Component Library”.

In the images given below, you’ll see us creating a smiley and inserting it as a component in the “Shapes” category of the Components’ resources.

Here’s an image of a Smiley we created.
Select the smiley and use the keyboard shortcut “G” to activate the “Create Component” window.
Fill in the details as Name: Smiley Ball, Description: Two eyes and a smile on a yellow ball, etc.

We now click on Create. Now when we access the “Components” dialog box from the “Windows” menu, we find that our smiley is present in the “In Models” inventory of components.
Use the drop down menu in the lower half of the window to reveal the “Shapes” components.
Click and drag the smiley from the upper half of the window (in model) to the lower half (shapes).
The smiley will now be visible as one of the shapes and be reusable whenever we open SketchUp, in any other model we please.

Conclusion
With this chapter, you now pretty much know how to make a lot of basic (and some complex) models. In the next one, we’ll guide you through the motions of creating your first “real” model.
Your First Real Model

Now that you have got a fair idea about how each tool can be used, let’s start doing some actual work—making an actual model. You can model anything you like, from a simple chair to a complex building.
3.1 Making your First Real Model

So let’s get started. We’ll try and make a simple house, with triangular roofs and an L-Shaped body as shown.

First, we need two rectangles for making the base of the house. Select the Rectangle Tool to make a rectangle of dimensions 10’ x 30’ by using the VBT to enter the exact dimensions. Next, we need another rectangle of 20’ x 10’ placed perpendicular to the first one. To do this, first take your cursor to one corner of the rectangle and then slowly move perpendicular to it. You will find the corner turning first green and then grey while a dotted red line appears. Press [Shift] to lock the particular direction and make the rectangle spaced a bit away from the first one.

Now use the Push/Pull tool to make two cuboids. Enter the height as 8’. To make the other cuboid of the same height, either enter the value as 8’ or drag the cursor to the top of the first
Using Push/Pull Tool to make two cuboids of the same height

cuboid. You will see a blue dot and a tooltip that says “On Face”. Finally you’ll get two cuboids as shown.

Now that the basic structure is done, let’s make the roof.

For this, we need a line parallel to the longer side for the centreline of the roof. Choose Line Tool and place your cursor around the mid-point of the smaller edge till it turns Cyan. Then, drag it to the opposite edge to form a line dividing the top in two equal parts. Do the same for the other cuboid, so that these lines are along the longer edge of each cuboid.

Now use the Move Tool to drag the line up to a height of 4’ and 3’ for the two cuboids. At times, Google SketchUp can’t understand which way you would like to move the line since we are working in a 2-D workspace. So if you find some difficulty here, just press the Up key. This will restrict the line to move only in the vertical direction. A dotted Blue line appears when you move your line along the Blue axis (Vertically).

Using the Move Tool to make triangular roofs
We are done with making the typical house like we used to draw when we were kids—with a square base with a triangular roof. But in real life, roofs aren’t so simple in shape. So to make them look more real, let’s make them cover more area than just the base. To do this, choose the Push / Pull Tool. Now drag the longer wall inside to a depth of 1.5’ (or 1’6”). Do this with all four walls. You will have to use the Orbit Tool to push the walls that are not visible in the current view.

The basic model of the house is done. But wait, you won’t like a house divided in two parts, will you? So let’s join the two blocks by joining the smaller cuboid to the larger one and then merge the roofs.

First use Line Tool to divide the face towards the larger cuboid in two parts—a rectangle and a large triangle. Then use the Push / Pull Tool to join the rectangular part with the opposite wall by
placing the cursor on the Face or the Edge. You might want to use the Orbit Tool so that you are able to view both the smaller and the larger face at one time. Or just move your cursor to the edge and it'll join automatically.

Now comes the more interesting part—Merging the Roofs. All you have to do is use the Push/Pull Tool again, to pull the smaller triangular face completely inside the larger roof. No need to get the exact intersection as we'll take care of that later. Then select all four triangular roof-tops by using the Select Tool (Hold Shift for selecting multiple items). Then navigate to the Edit > Intersect > Intersect Selected Only. This forms a line on the intersection of the two roofs.

No house is complete without doors and windows, right? So let's first make a door for each end. Use Rectangle Tool to make a rectangle of the dimensions 2'6" x 5' on each of the two faces.

Now it's time for the windows. Let's make a window of dimensions 1'6" x 1'6" on each face. To make sure the windows are properly aligned, choose the Rectangle tool. Now align one edge of the rectangle with reference to the top of the door, the same way as we did to align the bases in the starting. Press the mouse button to choose the first point in line with the top edge of the door and then use VBT to enter the dimensions. Make a similar window for the other face.

To give a better look to the doors and windows, let's give them a little depth. Use the Push / Pull Tool to move the door inwards, say 6". Do the same with the windows (or drag the cursor on the
So we are ready with the basic shape of our house having doors and windows. Before we wrap up, let’s add a covering roof in front of each entrance. To do so, complete the triangle in each face to divide the face into a triangle and a rectangle (as you did for merging the roof-tops). Now use the Push/Pull Tool to bring the roof 5’ outside so it will cover the entrance area.
Now, time to add some pillars to support the covering roof. Use Rectangle Tool to make two rectangles on the end of the roof of dimensions 1’x 1’, as shown.

Use the Push/Pull Tool to drag the pillar-base to the ground. Either use the VBT to enter a dimension of 8’, or just take your cursor to any edge of the base. Do the same for the other side.

So this completes our very first model—A simple house. But wait! Before we move ahead to improve its looks, we must do one more task—Removing extra lines that are not needed for the model.

Often while doing tasks like merging, we leave unnecessary lines. Though they might not be visible at first, changing the view shows an altogether different picture. Navigate to View > Face Style > X-Ray. You may also choose Wireframe in the same options list to view your model without any shading for each face.

We need to remove the extra lines that were left behind while merging the smaller roof with the larger one. Choose the Select Tool and select the lines that lie behind the larger roof, invisible in the normal view. Press [Del] to erase them.
This finally completes our model. Feel free to experiment with the design. You could look up for different types of house structures on the Net. You can also use the Arc Tool and the Circle Tool, which we didn’t use for this model, to get different shapes.

3.2 Painting Your Model

Though Google SketchUp automatically shades the model based on various aspects like distance from view, or inclination with each axes, etc, still our house looks more like a model than a real house. What is lacking are Textures for the surfaces, which differentiate a rectangle from a wall made of bricks or even a wooden door.

First, we need the Materials Dialog. To view the Materials Dialog, navigate to Window > Materials. You could alternatively choose the Paint Bucket Tool, which will show the Materials Dialog on its own.

Now in the Materials Dialog, you can see:
1. The Preview Screen: This shows the current selection. Clicking on the preview screen paints the selected objects with the particular texture.
2. Toggle Secondary Pane Display: This allows you to open another materials tab so that you can see two different textures at one time. Though optional in the beginning, it allows one to compare and choose the better one amongst any two textures more conveniently.

3. Create Material: This allows you to make custom materials. We’ll be discussing this in detail shortly.

4. Set Paint to Default: This allows you to restore the original paint which is set by default in Google SketchUp.

5. Sample Paint: This option works like the Pick Color Tool in most applications. It allows you to use a material already used in the model by just clicking on it. It’s useful when working with complex models which need to be painted in a symmetrical pattern.

6. Material Category: This drop-down list allows you to view materials used in the model or choose from the wide range of predefined materials in Google SketchUp.

7. Select and Edit Tabs: Select Tab allows you to view different materials of one category, say different metals from the Metal Category. The Edit Tab then allows you to change some features of the material to suit your need. More on this later.

8. Materials in a Category: This allows you to see a preview of all the materials in a particular category. Hover your cursor on one of these to see the label for each material.

9. Details: This allows you to view additional Libraries, change the thumbnail size, etc.

Let us first play around with simple colours. Choose Colors named from the Material Category Drop-down menu. Then scroll down and choose “0043_SaddleBrown” (With orange and gold colours). Now select the Paint Bucket Tool (if you haven’t already) and click on each wall of the house to paint it with that colour.
Choose “0021_DarkRed” and paint the roofs. Use the Orbit tool whenever you need so that you don’t miss out on the surfaces that are not visible in your normal view. Choose “0135_DarkGray” for the doors and the window.

Notice that when you try and paint the pillar, it paints the whole face. Google SketchUp differentiates between two surfaces by seeing their boundary. Since the pillars are not bounded on their top edge, you can’t colour the pillars and the top face of the roof with a different colour. To set a boundary for the pillars, use the line tool to close the top edge of each pillar. Remember that the pillar has four faces, at least two of which are not visible in a particular view. Then choose “0047_Khaki” for the pillars and “0021_DarkRed” for the triangular roof surface. Feel free to experiment with the colours you feel seem the best!

Colours aren’t all that Google SketchUp offers. Now let’s try some real textures. Select Brick_Rough_Tan from “Brick and Cladding” Category. Use this to paint all the walls. Use Brick_Tumbled for the pillars. Choose Roofing_Type_Spanish from “Roofing” Category for the roof. Use Metal_Brass_Ceiling for the ceiling.
from the Metal Category for the window sill and Metal_Embossed for the doors and the windows. Looks better right?

Though the Material Library offers a wide range of textures, sometimes they are just not enough. In such a case you can always make a texture by using a picture, say a jpeg file. There are loads of textures available on the net for free.

So download a texture, say for the walls of the house. Now click Create Material to open the Create Material Dialog.

In the Create Material dialog you will find the preview screen on the top-left. Choose a name for your texture and enter it in the text box. First, click the button in the Texture area next to the text field. Browse to select the texture file. The Opacity bar allows you to make your textures semi-transparent or opaque. The Color section allows you to change the colour of your texture using one of the four colour pickers: RGB (Red-Green-Blue), HSL (Hue-Saturation-Lightness), HSB (Hue-Saturation-Brightness) and Color Wheel colour pickers. Experiment with different colours to see how the material retains its texture but the colour changes. To restore the original image, Press the Reset Color button below the Colorize checkbox. Press OK when you are done.

Apply the texture on the walls. Notice how the picture is tiled on the surface to give it a uniform texture look. Also notice the dimensions given while creating a new texture. By default, Google SketchUp resizes the texture image to 4” x 4”. A smaller size may make the texture look like tiny dots when zoomed out. A larger size may make the picture being tiled apparent. Experiment with these dimensions to see which one suits your model the best. But how can you change the dimensions after you have applied the texture? Surely creating another material again isn’t the most practical option. For this, we have the Edit Tab.

Choose the Edit Tab to see properties of the material currently selected. Notice that most of the options are same as the ones available when you were creating a new texture, which means you can always edit the properties after trying them out on your model. Now try changing the dimensions of the texture. See the difference in having a dimension smaller (left wall) and larger (right wall) than the default dimensions.
Two options that weren’t available before are for matching the colour with one already existing in the model. Though you can always use the colour pickers to manually add a colour to the texture, it’s easier to pick a colour from the model itself. Thus, this allows you to use a particular texture with similar colour for all the surfaces, like this:

Textures add a realistic touch to your model. Try adding more objects and giving them a suitable texture to make your house look more real. For example, we decided to add a small park in the empty space with a pond and a gravel path around it, using the Circle Tool and the Push / Pull Tool. And yes, feel free to experiment more!
3.3 Viewing Your Model In Style

So far we have used Google SketchUp to make a 3D model using basic shapes, changed their colour and added textures. But you must be wondering why call it SketchUp? Why not call it just another 3D Modelling Software? Well, the answer lies in the Styles Dialog.

The Styles dialog allows you to view the model in different predefined styles such as in the form of a blue-print, a rough sketch or a model made on a whiteboard. Thus, it mainly allows you to present the model in different ways, depending upon the need. To view the Styles Dialog, go to Window > Styles.

Here you can see:

1. Preview Screen: Similar to that in Material’s Dialog. Shows the preview of the Style
2. Name & Description: In some cases, this gives a complete detail about the effect of the style on each entity in the model
3. Toggle Secondary Selection Pane: Same as that in Material’s dialog.
4. Create new Style: Allows you to make user-defined styles.
5. Update Style: Changes made to the Style are saved for later use.
6. Select / Edit / Mix Tab: Allows you to select from the library of Styles already available, or edit a particular style or mix attributes from different styles to make a custom style.
7. Style Select Drop down list: Allows you to select Styles In Model, or navigate through the library category wise.
8. Style Thumbnail: Small Preview of each style. Hover mouse on a thumbnail to see the name of the Style.
9. Details Menu: Same as Materials dialog. Allows you to add / change library, edit thumbnail size, etc.

Now let us experiment with what the library has. We can view the model in one of the Assorted Style, Color / Watermark / Sketchy Styles or just view with the default styles. The Assorted Style
Category has the most contrasting combination of styles, containing nearly every style you would like to use.

From the Drop down list, choose Assorted Style and select Blueprint. You’ll notice a drastic change in the view. The whole model looks exactly the way one sketches in a Blueprint. Try experimenting with other styles, like Standard CAD, Sketchy Pen Sepia, Straight Line 01 pix, etc.

But well, the library is also limited to a certain number of styles. You might want to make one on your own! For that, choose a style similar to what you want to make and click the Create Style Button. This will add a copy of the style in the In Model Category. Now for some editing!

Click Edit to view the Edit Tab. The buttons on the top are for the Edge, Face, Background, Watermark & Modeling Settings. Let’s check out each one-by-one.

### 3.3.1 Edit Settings

In the Edge Settings, you can toggle viewing edges, viewing profile view, depth cue etc. Extension will allow you to specify how much each edge will extend from its endpoint. It’s useful when you need to show intersection points of different edges. Halo does something opposite to extension, allowing some edges to fade away before the reach their endpoints. Drag the slider below to increase/decrease the level of detail and choose from three options for colour: All Same, By Material and By Axis. Experiment with the settings to see the results.
3.3.2 Face Settings
In the Face Settings, you can choose from a wide range of styles to view the faces, like Wireframe, Shaded, X-Ray Mode, etc. Background Settings allow you to change the background attributes and also choose the colours you would like to set for the Background, sky & ground (if checkbox is not selected, they are set to the background colour).

The Watermark Settings allow you to make a background / overlay for your model. Press the [+] Button to select an image file. Then choose between using it as a Background (behind the model) or as an Overlay (in front of the model). Drag the Slider in the next screen to blend the image with the background and toggle masking for the image. Next, select if you would like to stretch the image, or tile it or position it. Use scale to change the size of the image. And you are done! Don’t forget you can always edit Watermarks later by clicking on the “Cogwheel” button.

3.3.3 Modelling Settings
The Modelling Settings allow you to change attributes while working with your model like viewing Model Axes, changing colours for Selected / Locked Objects, etc.

The Mix Tab allows you to take each of the above settings from a style. So you can take the edge settings from one style, background settings from another and so on. Just drag the style in the respective Settings bar to apply the settings as they are in the style.

Here’s what we made by using a combination of various Styles. Try your own mix!

Using different styles for individual settings
3.4 Working With Shadows And Fog

Now time to give our model a more realistic look by adding Shadows and Fog.

First navigate to Window > Shadow. This opens the Shadow Settings dialog. Now check the Display Shadows checkbox if it is unchecked. You will see two options: Time & Date. Drag the slider around to choose your preferred shadow settings. Notice that changing Time changes the inclination of the shadow with the vertical axis, whereas changing the Date changes the length of the shadow.

That's not all! Click on View more Details to see advanced options. Now you can specify the Light and Dark settings. Notice that changing the value of Light doesn’t affect the shadows, whereas changing the value of Dark affects the whole model. You can also choose where to show the shadows, apart from using the sun to shade your model.

Now time to add some fog. Navigate to Window and select Fog. This opens the Fog dialog. First enable Display Fog if it isn’t so already. Next, we have the Distance option. Notice that this has two sliders. The first one is used to specify the distance from which fog begins to appear. The second one determines from where fog is very dense, thus controlling the depth of fog. Change the colour of the fog for some, err... unrealistic effects! Also notice that fog changes according to the camera movement, that is, if you orbit around the model, fog will vary accordingly in real time.
3.5 Organising Your Model Using Layers

Now that you have got used to most of the tools needed to make a 3D model, you are all equipped to make the most complex models you ever thought of! The problem which many face after a while is organising their models, as it becomes a tedious task to handle lots of different sized surfaces. Making changes after such a model is complete is one of the most difficult tasks and to solve this problem, we have the Layer Manager.

As always, navigate to Window > Layers. This opens a Layer Dialog which initially shows only Layer0 (and Layer1 generally). Each layer has a visibility option (Checked by default) and a box specifying the colour for that layer. So in the beginning, by default, all your work is saved in one main layer (Generally layer0). Dividing your model into smaller layers, helps view one particular layer at one time, thus making editing layers a simpler task.

So, we begin by selecting similar objects, say the roof. Choose the Select Tool and hold Shift as you select all the roof-tops. You can also right-click one of the roof-tops and choose Select > All with same material. Of course, this works only when you already have applied different texture to each type of surfaces. Again right-click on the selected surface(s) and choose Entity Info. This opens the Entity Info dialog.

The Entity dialog shows the objects selected and the layers they are contained in, apart from other options like Total Area covered by the selected surface and setting shadow and visibility settings for them. So let’s make a new layer for the roof-tops. Go back to the Layers dialog and press the [+] button to add another layer in the list of layers. Enter the name as Roof. Now in the Entity Info dialog, choose the layer as Roof from the drop down list.
Follow the same procedure to make more layers, say for Pillars, Doors, Walls, Windows, Base, etc. Now click on the Details button and choose Color by layer. This option will hide all textures and colours set by you and instead set the colour of each surface according to the layer they belong to. Now choose different colours for each colour according to your choice. Also, see that the Visible option allows you to view / hide individual layers (you can’t hide layer0—the default layer).

If you feel that you have too many layers, you can always remove layers. Select a layer and press the [-] Button to remove the layer. This also allows you to choose if you would like to move the objects in the layer to the default layer or the current layer (the layer that has a radio button checked on the left to its name). This can be used to merge layers easily. The last option also allows you to remove the objects. This could be used for removing a temporary layer after the model is complete.

Using layers to organise your data better

3.6 Conclusion

This completes most of the information you must know before making your first real model. Now the stage is yours! Let the creativity flow! Experiment to your heart’s content!
Okay, so you’re not really an architect, or even an architecture student. With SketchUp, however, you can pretend. When you’re redecorating the house, you can now do it in style—create a bunch of options in SketchUp, and decide which one works best for you. We’ll start with 2D floor plans, and then proceed into the third dimension. We’re assuming that you’ve read the previous chap-
ters. If terms like VCB and Component don’t make sense to you right now, we’d suggest you take a step back and read Chapter 2 again.

4.1 Creating Your First Floor Plan

Let us assume, for the rest of this chapter, that you’re building yourself a shiny new home. In the previous chapter, we went through the process of building a house, but there was one catch—that house was, but an empty shell. The walls had no thickness, no rooms, storeys or anything that may be considered part of the house’s interiors. This time round, we won’t ignore that bit.

4.1.1 Setting Up

We’ll be using the Value Control Box (VCB) a lot here, so the first thing we need to do is set up the default units of measurement. You don’t really need to do this—just type in 12 m no matter what your default unit, and SketchUp recognises it as 12 metres. However, if you just type 12 and your default unit is inches, SketchUp will recognise it as inches. Typing 12 is undoubtedly the more preferable option (if you’re using the metric system), which is why we’re going to Window > Preferences > Template and choosing Metric—Meters—3D under Drawing Template.

If you haven’t done it already, enable the Large Tool Set—this will give you better access to tools you’re going to use often.

If you have a paper drawing of the floor plan you’re going to design, that helps plenty. And if you are indeed familiar with architecture, you can import your floor plan from software like AutoCAD and skip this step altogether.

Finally, we start working in the Top view—choose Camera > Standard Views > Top. Also choose Camera > Parallel projection—using Perspective won’t give you the “technical drawing” experience we’re looking for. While you’re in this view, resist the temptation to use the Orbit tool. Naturally, you’ve just used it—go back to Camera > Standard Views > Top to get back to the top view. What you really need to use here are the Zoom (scroll wheel) and Pan ([ Shift] + Middle-click + Drag) tools.
4.1.2 Getting With The Plan

Let's look at this logically—every good floor plan needs walls, so this is what we first set out to do. Use the line tool to draw a basic floor plan in the top view—it need not be like ours, and especially so, because we’re not using it for anything serious.

Now go back to the normal 3D view—Camera > Standard Views > Iso, and choose Camera > Perspective. To turn this floor plan into 3D, our approach is simple—use the Push tool ([ P ]) to extrude the plan upwards, and then delete the top plane using the Select tool [ Space ] and hitting [ Delete ]. But something’s not right...

Real walls have a thickness associated with them, so, this approach, although ultra-convenient, is dreadfully wrong. Use undo ([ Ctrl ] + [ Z ]) to get back to the plan in its 2D form, and get back to the top view.
Adding thickness to walls is simple—use the Offset tool (F) to offset the edges of your plan, only remember that you should take the offset outside your plan. When you take measurements of your house, you’re measuring the inside—creating the offset outside ensures that your measurements remain intact. Now go back to the Perspective view, and use the Push tool to extrude the area between the two offset edges. Voila! A wall!

The current result is much better, but we still need to build interior walls to mark off rooms. Your instincts are most likely going to tell you to start drawing rectangles on walls and start extruding them using Push. However, the second you complete the rectangle, a surface fills up the top of your model, preventing further access to the inside. We’re not sure if this is a bug or is supposed to happen, but it’s mightily irritating—and we understand that. To get around it, simply delete this plane—your rectangle will still be there, and you can start extruding it.

This may work if you have only one or two interior walls to build, or if you have infinite patience, but there’s a much better approach. Go back to your plan in 2D in the top view again—we’ll start drawing our walls here itself, using the Line tool (L). Use the Tape Measure to create guides, so you know where to start drawing. In the screenshot, we’ve measured 2 m from the wall on the left. Use [Ctrl] to toggle whether the Tape creates a guide (a “+” appears next to the cursor). Now, start drawing the wall along...
this guide. Once you’ve completed it, delete the unnecessary edge between the exterior wall and this one using the Eraser tool (\[E\]).

Repeat this for all the interior walls you want to create. Don’t worry about leaving blank spaces for doorways and windows right now—we’ll take care of those later. Since this is the final approach we’ll be taking, it’s better to start your plan from scratch, with accurate measurements and everything.

Now that the house has rooms, it’s time to start adding fixtures, say doors.

4.1.3 Openings
There are two approaches you can take to creating doors and windows for your house—either punch them in yourself, or use preset components in their place. First, however, you need to create guide points for all the doors. The typical doorway is about a metre wide, and a couple high.

We’ll start with punching in our own doors. The procedure here is quite simple, now that you’ve got those guides. For each door, draw a rectangle that’s 2 m x 1 m. Use
the Push tool to push it backwards till it meets the other side of the wall—you’ll know you’ve done it right when you see a hole where your rectangle once was. Repeat this for all your doorways.

This approach, while time-consuming, is better if you want to create walkthroughs for your design (more on walkthroughs in Chapter 7). The second approach is to use a pre-constructed door component. Go to Window > Components and in the drop-down, choose Architecture. The second door (Door3-0x6-8RHRev) is exactly 2 m x 1 m, so you don’t need to make any adjustments to your guides. If it weren’t, however, you could easily resize it proportionately using the Tape Measure.

Click on the door you want, and in the model, use the cursor to align the bottom-left corner of the door to the spot where you want it—it ought to snap to the bottom edge of the wall and the guides you created. To copy this door, use the Move tool ([M])—hit ([Ctrl]) and click on a reference point on the door (corners work best) and position the copied door where you need it. If you’re up to it, you could do both—punch holes for doors, and use the component.

It’s the same with windows, except you can’t get away by just placing the window—you’ll have to create holes in your wall.
4.1.4 More Fun

We’re still not done having our way with this house yet. If you go back to our first 3D view, you’ll see that we’ve earmarked a space for the balcony, but we still haven’t made it. The method is simple—draw new edges where you want the balcony’s walls to end, and use the Push tool to push it down.

This house could also be an apartment in a multi-storey building. Once you’re done with it, you can turn this house into a component—select the entire model and hit [G]. Call it Apartment. Now use the Move tool and [Ctrl] to create copies stacked on top of each other. Leave one copy outside this stack so you can make changes to it—every change you make will be reflected in the rest, so this’ll save you a lot of time.

We’ve created a four-storey building now. Rather crude, but rather nice too, yes? We’ve even added a sketchy style for effect.
4.2 Stair-ing Up At The Sky

Unless you’re designing buildings for supremely lazy people, you’ll want to build stairs some time or the other. There are three methods you could use, each with its own benefits and compromises—it’s either easy and inflexible, or a little challenging and incredibly tweak-able.

But First, Some Stair-talk

Rise And Run: The rise of your staircase is its total height—in other words, the total vertical distance it travels. The run is the total horizontal distance it travels.

Tread: Each step is called a tread.

Riser: This is, well, the part that rises and connects one step to another. Stairs need not always have risers—we’re sure you’ve seen stairs with gaps between them.

Landing: These are areas where the stairs flatten out—between storeys, for example.

4.2.1 The Subdivided Rectangle Method

This is the easiest in terms of the skill you require, but it’s still quite tedious. The idea is to split a rectangle into a number of segments—one for each step, and then raise each segment in ascending order to create the entire flight. Start with a rectangle—the width should be what you want for your stairs, and the length should be the run length. Select one of the long edges of the rectangle, right-click and choose Divide. Use the VCB to enter the number of segments you want to divide the edge into.

If your rectangle is along one of the axes, you can start segmenting right away—using the

Starting with segmenting
Line tool and starting from the endpoint of each segment, draw a line along the axis to meet the other edge. Repeat this for all segments.

Now, perpendicular to the rectangle’s surface, draw a single line, and divide it into the number of steps you want. We’ll use this as a reference point for the steps’ height. Use the Push tool and start extruding the first segment—use the segments on the vertical line to infer the height. Go on like this for all segments, decreasing (we recommend starting with the highest step) the height with each step.

You’ll notice that on each side, an edge has appeared every time you raised a segment. These aren’t necessary now, so use the Eraser tool (E) and remove them all. You don’t even need the extra edges on the landing, so get rid of those too.

### 4.2.2 The Draw-and-cut Method

The title is self-explanatory—we’ll be drawing the profile (or elevation, or side view, depending on what you choose to call it) of the stairway on a flat face, and then using that profile to “carve” out stairs in the model. Start by drawing the profile of a single step on the side of a box.
Select the two edges of the profile using the Select tool (Space) and holding down [Shift]. Now use the Move tool and hit [Ctrl] to copy the step to create another step. Make sure that the bottom corner of the copy coincides with the top corner of the original. To make many such copies, just type “nx” in the VCB, where n is the number of copies you want—a handy trick to remember.

You’ll notice that the profile still shows with thick lines—this means that it’s not a part of the face yet. If you try to use the Push tool now, it’ll ignore this profile. To get around this, you need to close the surface—use the Line tool at the top of the stairs and draw a line to the opposite edge of the rectangle—you’ll be creating a landing, not to mention making this profile part of the rectangle’s face (the profile’s lines become thin). When you’ve done this, you can use the Push tool to do one of two things:

1. You could extrude the stairway, leaving the rest of the rectangle intact, or
2. Push the top section of the rectangle till it meets its opposite face, and deletes itself

But wait! There’s more fun to be had with this method, using the Follow Me tool (read more about it in chapter 6). Instead of a simple box, let’s use a more complicated surface.

Using the method described above, draw the profile of your stairway, but don’t extrude it. Choose Tools > Follow Me, select
the upper section (the part you want to do away with) and drag your cursor along the top edge of the surface. If you’re doing this right, you ought to end up with a rather interesting result.

Finally, we come to the most important, most flexible, and comparatively more challenging method.

### 4.2.3 The Component Method

In this method, we’ll work on a single step, and then duplicate that step several times. This may sound iffy, but thanks to one wonderful feature of components, is quite handy. When you create duplicates of a component, any change you make to one automatically gets reflected in all the duplicates. What this means is that you can work on just one step and give it as much detail as you’d like—even after you’ve created the stairway.

Start with one single box. Use the Select tool (Space) and triple-click on it to select all the faces and edges. Right-click and choose Make Component. Call it Step. Now, using the same method as the Drag-and-cut method, make several duplicates of this box to form a stairway.

Nothing remarkable yet, but it gets better. We want to create a little bulge (called a nosing) at the top-front of each step now, so let’s get started. Double-click a step to go into Edit Component mode. Draw a line a little below the front edge, and use the Push tool to make that face jut out a bit.
Use the Arc tool to draw a half-circle here, and push the unwanted area all the way to the other end to delete it. You now have a perfectly good nosing at the top of each step. Think of the possibilities—you can design a step in intricate detail, and have it reflect along the stairway.

You can also create stringers along your steps—these are the diagonal structures that support your steps—usually the case with wooden steps without risers. Creating one sounds simple enough, but can get tricky. First, you’ll need to go back to the stage before we started constructing the nosing. Use the Push tool to reduce your steps’ height—this gives you a set of riser-less wooden steps.

To get the angle of the stringer right, we’ll use the Protractor (Tools > Protractor) to create an angular guide. Click to position the protractor at the midpoint of the bottom edge of the bulge. Notice that the changes are being made to the other steps as well.
the step you’re editing. You’ll now have to choose a reference line—click on the bottom edge to select it as a reference line. Now click on the midpoint of the bottom edge of the step above to create the guide. If the guide didn’t appear, you’ll need to use [Ctrl] to toggle guides and repeat.

Once you have this guide in place, you’ll need to create one that’s perpendicular to it. Use the same reference point, and choose the first guide as your reference line. Make sure you move the new guide away from the midpoint of the edge when you’re done. Enter 90 in the VCB and hit [Enter]. It helps to use the Left or Right view with Parallel Projection turned on here. Create enough guides to aid you in drawing a rectangle using the Line tool.

Move the new rectangle away from the step just a little bit, and then use the Push tool to turn it into a box. You can get rid of the guides (Edit > Delete Guides) if you want. Now use the Push tool to increase the length of the box, such that the boxes from each component touch each other. Move this box up a bit, and your stringer’s done!

As you can see, while the Component method requires a lot of work, it’s always worth it.

4.3 Roof On Our Heads

Every house needs a roof, and these structures come in various shapes and sizes. You can have the typical sloping roof you’ve drawn in so many nursery drawings (called a gabled roof), go the pointy gothic way, or stick with the simple flat roof with a parapet.
### 4.3.1 Keeping It Simple

Right now, let’s start with the flat roof. First, select your entire house and make a component out of it. This way, we can trace the outline of its roof without those lines becoming part of the house. Use the Line tool to trace the roof; once you’re done, you’ll see that a surface has formed. You can still see the edges of the underlying walls, though, so use the Push tool to increase the thickness slightly. Now use the Offset tool to create the outline for the parapet, and use the Push tool to extrude it—just like you did for your first floor plan.

Of course, flat roofs are no fun at all. Any roof that isn’t flat is called a *pitched* roof, and pitched roofs require *eaves*—overhangs that jut out above your house.

### 4.3.2 Eaves And Gables

To create the overhang, we’re going to trace our roof like before, and then use the offset tool. This’ll look like your floor plan with walls again, but in this case, we don’t want the walls. Double-click on the inner face to select it and all the edges attached to it, and hit [Delete]. This should leave you with a single face that overhangs your house. Now use the Push tool to raise it a bit.
Now to create a gabled roof on this house—we’ll start with the largest face in the front. Start with a vertical guide at the midpoint of the top edge of the roof. If you know what angle the roof needs to be at, use the Protractor to create an angular guide at one of the corners. From the intersection of these two guides, use the Line tool to draw lines to both corners of the roof. Finally, use the Push tool and extrude this roof along the length of the house.

Repeat this for the rest of the house. Your roofs will doubtless cross each other; let them. There’ll be a noticeable lack of edges where the roofs intersect. To remedy this, right-click on the offending faces and choose Intersect > Intersect With Model.

Offset the roof outline, delete the inner face, and raise the roof.

Create the face using guides. Then Push!

The face on the right has been intersected with the model, but the face on the left hasn’t. Notice the defined edge with the intersected face.
A sandpit or a sandbox is basically an enclosed space that children can play in. It's usually full of sand and allows the kids to build things like sandcastles or other structures without having to go find a beach.

SketchUp's sandbox is a virtual sandpit and helps you to generate and manipulate complicated surfaces. Floor plans and roofs are usually easier (considering that you've meticulously followed
the last few chapters) but when it comes to organic, hand-crafted entities, terrains and shapes with more random patterns such as swimming pools or faces, it’s Sandbox to the rescue.

5.1 Sandbox Tools

Sandbox tools are provided with SketchUp to enable the creation and modification of complicated and irregular surfaces.

It’s typical of 3D-modelling software packages, including CAD, to facilitate terrain designing by dividing the surface you create into a mesh of triangles—small and big—which is, in terrain modelling lingo, called a TIN (Triangulated Irregular Network). The TIN is infinitely convenient as it helps you work on minute aspects of the terrain you’re creating, by further sub-dividing the triangles into smaller triangles. These triangulated faces, however, when smoothened out, appear like a single smooth surface.

If you find the triangles a bit too square, you could import or create a polygon mesh using other SketchUp tools and then proceed to work on it as you would with a TIN, although, manually creating them would be a bit tedious. However, SketchUp only creates triangular meshes with Sandbox.

5.1.1. Angling Triangles

When you take a look at the hidden geometry of a terrain you’ve created, you’ll find that the triangles are oriented in different directions—sometimes horizontal and sometimes vertical. This orientation is called ‘triangulation’. This triangulation can be modified. But before we enter that, let’s figure out how a TIN can be created.

5.1.2. Hammering out TINs

You could create a triangulated surface by any of the following ways:

1. Using the “Sandbox From Contours Tool”
2. Using the “Sandbox From Scratch Tool”

3. Importing an image of a contour map, tracing its contours with the Freehand Tool and then elevating the contours from the surface (using the ‘Move’ tool) and then clicking on the ‘Sandbox From Contours’ button.


5.1.3. Opening the Toolbox

When you open SketchUp, the Sandbox tools are not visible by default. If you want to see them hanging around with the other tools, you’ll have to activate it by clicking View > Toolbars > Sandbox.

It’s possible that the Sandbox toolbar has not been enabled at all. To rectify that, you’ll have to click Window > Preferences > Extensions and check the Sandbox Tools option.

The following tools have been provided in the Sandbox Toolbar:
1. Sandbox From Contours Tool
2. Sandbox From Scratch Tool
3. Smoove Tool
4. Stamp Tool
5. Add Detail Tool
6. Flip Edge Tool

Evidently, the above list probably seems to be in Greek for you! We’ll give you the low-down on all of the above in a minute. First, however, you’ll need to understand what basic systemic conditions are necessary to ensure you don’t slip while playing in the Sandbox.
5.2. System Requirements

The thing with using Sandbox tools is that the computer gets pushed into doing a lot of mathematical calculations at once, and this can slow down the process greatly on slower machines with little RAM and extinct chips. Lots and lots of RAM, an excellent video graphics card (which is updated for Vista—if you’re using Vista) and a hard disk that is not already filled, are some of the essential pre-conditions for a smooth and slick Sandbox experience.

Often the triangulation is so complex that if you want to “Add detail” or “Drape” over a TIN, the computer takes a long, long time to process the action—sometimes giving you the impression that it’s hung.

To simplify a terrain, download the Simplify Contours script from Downloads > Ruby Script at http://www.sketchup.com/, and restart SketchUp. You can then select the TIN you want to make simpler, click on the Plugins button in the menu above and click Simplify Contours.

Also, try to reduce the overall area of the terrain you’re working on (either by creating or selecting small portions of terrain), because endpoints of contours are more significant and will affect the performance of the Sandbox tools.

The system requirements for a trouble-free experience of the use of the Sandbox tools are the same as the requirements for the smooth functioning of SketchUp itself, as recommended below:

Hardware
● A 2-GHz Pentium 4 processor (or higher)
● 2 GB RAM (and you really thought 512 MB would be enough?)
● A Video card that is Open GL compliant (OpenGL is a method for rendering 3d images. GL stands for Graphics Language. OpenGL is the “open source” version of GL) with 512 MB Video memory, or one which is OpenGL 1.5+ compliant in case you’re working on a Mac.
● 15 GB of available hard disk space (160 MB for Macs)

You’re ready to enter the Sandbox now.
5.3. Sandbox From Contours

The Sandbox From Contours tool does just exactly what it says, that is, helps you to create a sandbox (a TIN) from contours. So how exactly would you manage to make contours? You could do any one of the following:

a) Create contour lines by using the Freehand Tool. You can activate the Freehand tool either by clicking Draw > Freehand in the drop down menu above, or clicking on the Freehand button (which looks like a shapeless squiggle) in the Drawing toolbar.

b) Import contour lines from another file.

Whatever you choose to do, there’s one thing you have no choice about—the lines must be offset in height (vertically displaced) from the ground plane.

5.3.1 Creating Contoured Boxes

It’s a piece of cake to use contour lines to create a sandbox.

Draw contour lines (as many as you like)—lines which are irregular and randomly scribbled would do for the present. Just make sure that the lines are offset from the ground plane.

Use the select tool and select all the lines you’ve drawn (the line’s will turn blue once selected).

Click Draw > Sandbox > From
Contours or just click on the “From Contours” button in the Sandbox toolbar. SketchUp instantly creates a terrain by using the contour lines you’ve drawn as guides and filling in the spaces in between (or, if it’s a complex set of contours, may take a few seconds for calculations before creating a TIN out of them).

5.4. Sandbox From Scratch

If you’re mouse-happy fingers are a bit sad and you’re not itching to scribble, SketchUp let’s you scratch up a Sandbox without much labour. Use it to make flat TINs along the ground plane. You can activate the Sandbox from Scratch Tool from the Draw menu (Draw > Sandbox > Scratch) or just the click on the button that shows you a flat grid in the Sandbox toolbar.

What the Sandbox from Scratch basically does, is help you make a flat Triangulated Irregular Network—in this case, a quadrilateral—by allowing you to create a bounded space made up of 10 feet square grids. You could enter a value in the VCB to change the grid size before you complete the action of creating the Sandbox. You could even change the size of every individual square in the grid using the VCB.

5.4.1. Scratching the Surface

Let us, quite literally, start from scratch. To create a TIN using the “Sandbox from Scratch” tool, just do this:

● Activate the Sandbox From Scratch Tool (as delineated above).
  The cursor now turns into a pencil with a grid floating about.
● Click once, to start the TIN and drag the mouse to establish the length of the surface. You could ensure the exact length of the line by specifying the length of the line in the VCB.
● Click (or press [Enter] if you’re using the VCB). The length of one edge of your TIN is...
now fixed (and by default, the opposite, parallel edge of the surface you’re going to create.)

- Pull the mouse around and you’ll find that as the cursor moves perpendicular to the line you’ve created, a grid of little grids stretches out along with it.

- Click again. This sets the breadth of your TIN and basically creates the entire grid the way you want. Just as you could specify the exact length of your TIN using the VCB, you could enter an exact value to determine the width you desire.

5.5. The Smoove Tool

So now you have a TIN and you think it’s a bit flat. You’d like to jazz it up a little and stretch parts of it—make mountains and valleys in the plains. For that, you need to use the “Smoove” Tool. The Smoove Tool allows you to vertically extrude points, edges or faces—and the points in their vicinity, creating a slick protrusion in the triangulated plane. You can activate the Smoove Tool by using the Tools menu (Tools>Sandbox>Smoove) or from the Sandbox toolbar.

5.5.1 Smoove Operator

Building a Mountain

Make one of those flat TINs using the Sandbox From Scratch Tool (as described above). We display one such terrain for your reference.

- Activate the Smoove Tool as mentioned above. You’ll now see the cursor become an arrow

OR

- Select a section of the TIN with the Select Tool and then activate the Smoove Tool. If the selection is not happening then read on.
You may, for example, find that every time you wish to select a certain section of the terrain, the entire TIN gets selected. This means that you need to "ungroup" the terrain. How to "ungroup" the terrain? We’ll tell you.

a) Right click on the terrain. It’ll turn blue with selection.
b) Click on the "Explode" option in the menu that appears.
c) The grid will now appear as one with diagonally parallel (dashed) lines running across through the vertices of every individual square. You’ve now ungrouped the terrain into individual sections.
d) Now you can activate the Smoove Tool.

Click anywhere on the TIN to help SketchUp identify the region you want to sculpt. The points and vertices which you intend to move (or smoove)—including the points that will move along with—will be highlighted.

Now click on the selected region, hold down the mouse button and drag the mouse upwards or downwards along the
blue axis. The selected region of the TIN will rise or compress along with the movement of the mouse. If you’d like the region to offset an exact measure, you could type the value in the VCB.

● Click to end the process.
● You can select the Smooved region and context click to soften it.

This will un-triangulate the surface, making the smooved area more coplanar.

Isn’t this so easy? And you thought this one would be a cliff-hanger!
5.6. Stamp Tool

Your models could get more impressive if you put impressions on them. This could be done by using the Stamp Tool. Stamping can be done by pushing the duplicate of the base of a piece of geometry onto a terrain.

You can activate the Stamp Tool by clicking Tools > Sandbox > Stamp or just clicking on the Stamp button in the Sandbox Toolbar.

5.6.1. Using the Stamp Tool

So you’ve got a house ready, but you want to put it down on a different kind of terrain. For that, you could first stamp an impression of the base of the house on the terrain using the “Stamp Tool” in the following manner:

Stamping the base of a house on to a TIN

- Make a TIN on which you would like the house to be. You’ll see the house ready in the wings in our image.

Prior to stamping, you’ll need (a) a TIN and (b) a Stamp

- Create the face you want to be used as the stamp. You could use the bottom face of the house, a set of faces, a group, a component, or an entire model—in this case, the entire house.
- Select the stamp (the entire house in this model)
- Use the Move tool to shift the “stamp” (again, for us, the house) over the exact location of the TIN where you wish to make the impression.
Activate the Stamp Tool. The mouse pointer will now become an arrow (white, unlike the black “Select” arrow).

- Click on the TIN. This will create an identical impression on the TIN, in the shape of the stamp.
- Move the mouse up or down to fix the measure of the offset of your impression. You could even set the extent of the offset by typing the exact value in the VCB.
- Click when you feel that the offset of the impression from the ground plane is just right.
- You can smooth or soften the offset region to make it look cooler.
5.7 The Drape Tool

The Drape Tool is perfect to set edges on a terrain (e.g., roads and pathways).

You could activate the Drape Tool either by clicking your way to it or just click on the “Drape” button in the Sandbox Toolbar.

5.7.1. Using the Drape Tool

Workshop: Draping a Path on a Terrain

Suppose you’ve made a terrain, you’d like to use and want to put a pathway on it, then the Drape Tool will do just that. The following steps will make the process clear:

- Make a TIN—a terrain, from the Scratch of Contours tools.
- Use the free hand tool or any other of the drawing tools to make the edges you’d like to drape over the terrain. In this case, we’re making a kind of irregular pathway with the Freehand tool.
You could make a regular road using the Arc Tool and the [Ctrl] key, but we’re making a path and so the irregular freehand edges.

- Select the shape (the pathway) and use the Move tool to shift the pathway over the terrain. You could lock the movement using the ‘Up’ arrow of your keyboard to make the shape move vertically and the ‘Right’ or ‘Left’ arrows to position it directly above the TIN.

- Activate the Drape Tool as specified above. Make sure that your line work is within the parameters of the terrain you’re draping it on. You can check this out by using the Top view (Camera > Standard Views > Top).
- Click on the terrain. This will “drape” the shape of the path on the TIN.
- Select and delete the road that’s floating above. You can now fill in colours into the road (or whatever line work you’ve created).
5.8. The Add Detail and Flip Edge Tools

As you gravitate towards more complex models, you’ll find the need to work on a really minute scale on the terrain you’re creating. To facilitate control over your TIN at such a micro level, SketchUp provides two tools: The Add Detail Tool and the Flip Edge Tool.

Although this results in better terrains and smoother surfaces, this could seriously slow down performance because the number of calculations increases drastically, so must be used with prudence.

5.8.1. Details about Adding Details

To make a terrain more detailed, do the following:

● Make a TIN.

Here’s a Sandbox from Scratch to begin with

● Activate the Add Detail Tool as specified above. The cursor now becomes an arrow.

Make sure that the TIN is ungrouped (if it isn’t, right click and click on the Explode option in the menu context menu that appears).

● Click somewhere on or in the TIN. The point at which you click will set the new vertex for triangulation.

You can select different objects, using [Shift] to extend your selection and dragging the mouse around to select multiple items.

● If you drag the mouse up and down after choosing a vertex, you’ll see the point (and the other neighbourhood points) of the TIN being offset from the ground plane. If you want to ensure that the offset is perpendicular to the TIN, simply hold down the...
[Shift] button of your keyboard while dragging the mouse up or down. If you’d like to add detail without offsetting the new vertex, hold down the [Ctrl] key.

You could smoothen or soften the regions you’ve added details too to make it look better.

5.8.2. Using the Add Details Tool To Create Smoother Areas

If you pre-select a section of your TIN using the Select Tool, you could then use the Add Details Tool to divide and sub-divide those triangles to create a smoother area.

The way to do it would be thus:

● Create a Sandbox from Scratch as shown earlier and explode this one too. Use the ‘Select Tool’ to select a portion of the TIN.
● Activate the Add Details’ tool. The selected portion will immediately divide into more miniscule triangles.
● Select the same region again and repeat the previous action. The little triangles will subdivide into smaller ones. Now if you extrude or play around with this section, the shapes that will form will be less jagged and more smooth.

Try angles for smoother triangles

● Activate the Smoove Tool. Click and drag to raise the selected portion. Instead of rising up like a stalagmite, the TIN will swell up like a smooth hillock.

You can also split a single triangle or edge using the add detail and immediately Smoove it in the direction you want.

5.8.3. Flipping about in the Sandbox
Sometimes adjacent triangles in a terrain are so aligned as to create plateaus (flat spaces) which don’t suit your purposes.
Typically, in TINs created from contours, SketchUp sometimes creates two triangles pointing opposite to each other (sharing a common base). It’s useful to split these up and change the direction of one of these triangles so as to facilitate smoother manipulation of complex triangulated surfaces. The Flip Edge Tool does exactly that. You can activate the Flip Edge Tool from the Tools menu.

In the image below, you can see a Sandbox created from contours with the triangulated surface revealed. (If you can’t see the Hidden Geometry in a Sandbox you’ve created, remember to click the ‘View’ menu and check the ‘Hidden Geometry’ option.)

But the two large triangles creating a flat space in the middle of the TIN have been flipped to make several more manageable ones.

A few simple steps will help you un-mangle the triangulation on a TIN:

● Use the Sandbox from Contours Tool to make a terrain.

● Explode (by right click) or reveal the Hidden Geometry (using the View Menu).

● Select the Flip Edge Tool (Tools>Sandbox>Flip Edge).

● As you move the cursor over the TIN, you’ll be able to highlight edges you should flip. Select by clicking on an edge.

● The shared edge (of the two triangles) will be removed and an edge perpendicular to it will appear in its place.
5.9 Workshop

**A Park with a Walkway**

The aim of this workshop is to use as many of the Sandbox tools as possible to create a garden with a walkway and other typical things that you’d find in a park (using components).

To create the park with the path, do the following:

- Activate the *Sandbox from Scratch* tool.
- Create a sandbox—a grid of length 100' and breadth 80’. You can do this by specifying the exact lengths in the VCB.

- Use the context click menu to explode the surface.
- It’s now time to make a few hillocks in the garden, so we’ll activate the Add Detail Tool. This will result in the surface dividing into a triangulated terrain.

- Use the Select Tool to select two or more sections of the park you’d like to make into little hills. Click the Add Detail Tool.
again so that the selected portions get subdivided into more minute triangles. This will help us to get smoother and more rounded surfaces rather than pointed peaks. You could further add detail to the selected portions to augment the triangulation.

- Select a vertex on one of the detailed regions you’ve created. Click on the Smoove Tool. The selected portion will turn yellow with yellow pixels visible at the vertices.

- Use the mouse to raise (offset) the selected vertices to the height you require.
- Repeat! In this case, we’ve used the VCB to set the value of the radius of the first Smoove offset at 20’ and the second one to 10’ to create two different sized hillocks.
- It’s the time to create the walkway. Use the Rectangle tool to create a rectangle along the ground plane (not on the grid we’ve made, but elsewhere). Use the VCB to specify the length (35’) and the breadth (100’).
- Create another rectangle inside the first of approximately the
dimensions (20’80’). Select the inner rectangle and delete it. You now have a rectangular walkway.

- Use the Move Tool to shift the walkway directly above the TIN you have created. Shift to Top view to ensure that the frame is within the parameters of the TIN (Camera > Standard Views > Top).

- Once the frame is in position, select the rectangle and activate the Drape Tool.
- Click on the TIN. The selected edges will drape over the terrain.
- Delete the floating walkway as you’ve got no use for it anymore (unless you want to make it component).
- You now want to put in several components—typical park stuff—like benches, plants and trees. All of these are available in the ‘Landscape’ set of components. (Window > Components > Landscape)
- Use the Window > Components > Landscape way to choose one of the park bench components and put two of them within the inner rectangle of the walkway.
- Activate the Paint Bucket tool and start adding colours to your terrain. You could make the walkway stony and the rest of the terrain grassy (as shown in the image below).
- We’ll now add a water fountain which we could place between the two offset regions of our terrain. This isn’t one of your reg-
ular components and so you’ll have to download one of the many water fountains from the 3D Warehouse of Google SketchUp’s resources on the web (http://sketchup.google.com/3dwarehouse/) and Copy-Paste it onto our terrain (you could use the keyboard shortcuts [Ctrl] + [C] and [Ctrl] + [V]).

- Select the fountain you have pasted and use the Move tool to raise it above the level of the TIN.
- Select the Stamp tool. Click on the stamp (in this case, the lower face of the fountain).
- Click on the TIN. A copy of the bottom portion of the fountain will be indented into the surface. Use the mouse to offset it a little above the ground plane.
● Use Move Tool to settle the fountain on the offset section you’ve created (by locking on to the vertical axis).
● Activate the paint bucket tool and layer a material on the offset portion of the stamped region. (Window > Materials > Tiles).
● Now put a few trees from the Components Box and your model is done without a muddle.

You’re probably so impressed by the garden you’ve created, you want to take a nice long walk in it. But don’t run off just yet. There’s plenty of fun to be had with models. But that warrants another chapter.
More Fun With Models

We've already been through making basic buildings, but there's more—with the Follow Me tool, you can go from making crazy, unconventional roofs, not to mention other weird shapes. And when you're trying to imitate life, there's always Photo Match...
6.1 The Follow Me Tool

The follow me tool is used to make a 'shape' follow along a given path and duplicate itself along the way. It is akin to the way we used to make soap bubbles when we were kids. We dip the ring in the soap solution, and then just sweep it along in the air to make those bubbles—same with Follow me: make a basic shape (only not just a ring, you can make any shape) and then drag it along a path. You can also make spheres and cones using this tool.

6.1.1 Basic Steps

Here is a quick way to get you started with Follow-Me. We will make a pipe shaped structure on the surface.

1. Make a closed shape on the surface. Let us start with a circle
2. Draw a line perpendicular to the face of the circle. This line acts as the path for the follow me tool to follow
3. Select the follow me tool from Tools > Follow Me
4. Click on the surface of the shape you want to duplicate. In this case, it's the circle
You can incorporate variations on your own and see what it leads to. As you can see, it’s a very useful and powerful tool. It is especially useful for making spheres, cones and other surfaces. It is also extremely useful for making molding for surfaces. Just change the shape of the face to follow to the selected one.

### 6.1.2 Making Parapets

After that basic demonstration of how to use a follow-me tool let us consider how to make edges / parapets in structures.

1. Select a structure you want to design on. In this case consider a plain rectangular building.

2. Draw a 2D shape at the edge of the building. This shape will be the way you want the entire parapet to look like. Here we have taken a rectangular parapet which is arced from the bottom.
Subtracting

When you have to construct a bevelled or chamfered shape, just draw the shape on the face of the existing structure and use the follow-me tool to drag it along.

(Continuing with our previous project)

1. Select the face of the structure and make the desired shape

3. Now select the follow-me tool and click on the 2D shape we just made. Then drag it along the upper edge of the building.

4. Keep dragging till you reach your starting position once again

5. The parapet is complete!

6. Note: If you want the parapet to be at each ‘floor’, just draw the 2D shape at the desired level on the building and drag it along the desired edge.
6.1.3 Making Spheres
Another great use of the Follow me tool is to make spheres.

1. Create a circle on the surface.
2. Copy that circle and paste it in the same area, but above the previous circle.
3. Now use the Rotate tool to rotate the ring by 90 degrees.
4. Now place the ring perpendicular to the previous circle and exactly cutting the diameter of the previous circle. (It usually snaps to the circle’s diameter when you move it closer, but if you are finding it hard to align, zooming in will help.)

2. Use the Follow-me tool to drag it along the upper edge to make a chamfered surface.
Making Lathe surfaces:
Machine made surfaces like cones, and turned pieces are made like the traditional Indian potter makes his earthen pots. But instead of rotating mud on the wheel, we use the follow me tool to have it follow a circular path with a fixed pattern. It much like the first part where we had the 2D shape follow along the path of the building to make the parapet.

Let's begin by making a simple cone.

1. Begin by making a circle on the surface. Now make a triangular shape using the Line tool.
2. One line starting from the centre of the circle extending to your desired length on the blue axis.
3. Now click the follow-me tool and select the first circle.

5. Use the Select tool to select the perpendicular ring making sure that you have selected both halves (lower and upper) of the ring.
What more is, not just cones, you can make steeples and other architectural structures using this method. The only modification in the previous example that you need to do is to change the triangle’s opposite line to a shaped line as you desire. As long as it touches the two endpoints of the previous lines, it will get shaped accordingly.
Making a Steeple

Here’s a quick example which we will use to modify our previous cone a bit to make it shape like a steeple of a temple

Repeat the same steps till step 4 and then continue thus:

5. Make a much more acute triangle by making a line from the top to mid-way on radius of the circle

6. Make another line from the outer edge of the circle towards mid-way of this new triangle.

7. Make a third line which starts midway of the first and ends mid-way of the second triangle.

8. Now use the eraser tool to erase the lines intersecting in between these triangles until all you have is the outer face of the shape.

9. Just one more line to erase...

10. Select the triangular shaped face and then as our previous steps, use the Follow Me tool to drag around the perimeter of the circle.
6.2 Making Buildings With Photo Match

You don’t always (if ever) have access to architectural drawings and floor plans to help you out, especially if you’re trying to imitate a real life building. This, thankfully, is where Photo Match comes in—simply put, it lets you use a photo to recreate any building you want. In this case, we’ll see if we can create a convincing replica of this barn (we got the photo from www.morguefile.com, which specialises in royalty-free high-res photos).

Drive out the cows before you start...

Start with a new SketchUp document. Leave Bryce (the man who’s there by default) undeleted for now. Choose Camera > Match New Photo and navigate to the photo you want. It helps if you can see the bottom corner of the building you want to model—we’ll get to why in a bit.

Here’s what you’ll see on your screen: the Match Photo dialog, the three axes, a yellow square that represents the origin, two red and two green lines (called perspective bars) on either side of the photo—you can move them using the handles at either end. We’ll be using these bars to set up the red and green axes, and consequently the scene’s perspective.
Our first task is to line up the green axis with the side of the barn. Drag the green perspective bars and align them with two parallel lines on the barn’s side. In this case, we’ve used the bottom of the roof, and one line of tiles a bit higher up. You should use the Zoom tool plenty to get this right.

Now we need to do the same for the red axis. Since we know that the red and green axes need to be perpendicular to each other, we’ll choose a surface that’s perpendicular to the surface we chose for the green axis—in this case, the front of the barn. Let’s drag the red perspective bars to align with the barn’s upper windows and the main door.

Finally, the blue axis. Drag the origin to the bottom corner of the building—this’ll help you get a reference point from where you can (or rather, must) start building. If the blue axis doesn’t line up perfectly with the vertical edge of the building, you’ll need to tweak the red and green perspective bars a bit.

But wait! Clearly, something’s off—Bryce is too big compared to the barn. Click and drag your mouse cursor on the blue axis, and you’ll be able to zoom in and out till Bryce’s height is more convincing. Once you’re satisfied, click Done in the Match Photo dialog to begin modelling.
An important thing to remember while you’re modelling is that while you should be using the Zoom and Pan tools liberally, you shouldn’t use the Orbit tool in the beginning, or you’ll lose the reference points in your photo. To get back, however, click on the tab at the top of the screen.

Now use the modelling expertise you’ve gained so far to trace the front face of the barn, then use the Push tool to make it 3D. Remember a few things while you do so:

1. Always start at the origin, simply because you need to have a fixed frame of reference.
2. When you want to continue working on your model, continue from a surface that already exists—starting surfaces in the air can have annoying results.
3. Once you’ve got the basic framework down, use the Orbit tool to concentrate on the details.

And now, our favourite part. If you’ve shut the Photo Match dialog, open it again (Window > Match Photo). Click on Project Textures from Photo.

Your model will look transparent, but in reality, the faces have taken on the photo behind them. If you orbit around your model now, you’ll see that the two faces you used as reference are now mapped to your model!
You don’t need Photo Match just to replicate buildings—you can also take models you’ve already made, and align them with a photo. While you’re setting up the perspective bars, un-check Model in the Photo Match dialog to give you a more uncluttered workspace.

Photo Match is easily the most fun you can have with a photo in SketchUp, so go wild!
Once you’ve had your share of fun with your model in SketchUp, you can show it off to the world. In this chapter, we’ll look at how to get a peek at your model using section planes, and animate walkthroughs. For the purpose of this exercise, we’ve downloaded a rather nice Portuguese villa from the Google 3D Warehouse.
7.1 Section Planes

If you’ve built a complex model, explaining its intricacies can be quite a pain—what if you had to show off the interior of that house you built? Let’s look at the villa we’ve downloaded and how you can give your audience a peek inside.

We’re going to create a horizontal section plane that’ll cut through the lower storey of the villa. Choose Tools > Section Plane and place the plane on a horizontal surface to align it. You’ll see that everything above the section plane has been hidden—exactly as if you’d taken a really sharp knife and sliced through your model. You can now use the Move tool to position the section plane higher or lower.

Just like any other plane, you can move and rotate the section plane as much as you like. To shut off a section plane, right-click on it and deselect Active Cut. As a rule, you can only have one section plane active at a time, even though you can create as many
as you want. If your section is facing the wrong way, right-click on it, and choose Reverse.

To create a complete cutaway of your model (literally, a slice out of it), right-click on the section plane and choose Create Group From Slice.

7.2 Looking Around

To truly get an idea of what a home will look like, there's nothing like simulating your walk inside it. At the bottom of your Large Tool Set, you'll see an icon with a man on it—an eye and a pair of footprints—these are the tools we’re going to be using now. To start with, click on the Position Camera icon (the one with the man on it) or choose Camera > Position Camera. This tool’s function is self-explanatory, but the neat thing is that when you click on a location to position your camera, it’s placed at an eye height of five and a half feet above that point—the average human eye's height. You can change this using the VCB.

Once the camera’s positioned, you’ll notice that your cursor has been turned into a pair of eyes—this is the Look Around tool (the eye icon, or Camera > Look Around). Using it is simple—click and drag around your screen to look around. Now that you’ve reached the door of this villa, walk in and enjoy the view. Choose Camera > Walk or the footprint icon. Click and drag on your screen to begin walking—dragging upwards makes you walk forwards, dragging downwards takes you behind, and so on. Dragging to the side will let you turn while you walk. A cross will appear on your screen where you click—the farther you drag
from it, the faster you’ll walk. You can also hold down [Ctrl] to run. If you hold down [Shift], you can move straight up, down or sideways.

You’ll notice that the Walk tool has collision detection turned on—you can’t walk through walls and doors. The good thing about this is that when you approach stairs, you actually get to walk up them as you would in real life, but in this case, we’re hindered by the closed door. To turn off collision detection, hold down [Alt]—now you can walk through whatever you want.

While the Walk tool is active, middle-clicking and dragging on your screen activates the Look Around tool (and not the Orbit tool). Walking around this particular villa makes us rather claustrophobic, and we wouldn’t blame you for feeling the same. The default field of view—the angle between the limits of what you can see on your screen—is set to just 35 degrees. To get a better view of your surroundings, set this to 60 degrees. Choose Camera > Field of View and enter 60 in the VCB.

A field of view of about 60–70 degrees works best for interior views—the only downside is that edges look a little weird at the ends of your screen, but at least the claustrophobic feeling won’t be
there anymore. For outdoor views, the default 35 degrees ought to do just fine.

More views of the villa, just because we can

7.3 Welcome To The Scene

When you’re showing off your model to people, you can’t really expect them to have the patience to twiddle their thumbs while you struggle with the Orbit, Pan and / or Walk tools to show them different areas. In a PowerPoint presentation, you wouldn’t create each slide in front of everyone, would you?

This is where the concept of scenes comes in. These are essentially snapshots of your model from locations you choose. When we say “snapshots”, though we aren’t talking actual photos, but rather just saved camera angles, when you make changes to your model after creating a scene, you’ll see those changes in the scene. Choose Window > Scenes to open the Scenes dialog.

Now set up your view the way you want to. We’re first going to do a fly-around view of the villa, and we’ve also turned on X-Ray in the Styles dialog (you can read about that in Chapter 3)—primarily because it’s cool. We’ve also turned off the axes in View > Axes. Once you’ve set up the first scene, click on the Add button to create a new scene. You’ll notice that a new tab called Scene 1 has been created at the top of your viewing area, and an entry has been created in the Scenes dialog.
The road ahead is simple—set up your view each time, and create a scene every time you’re satisfied. To switch from scene to scene, just click on its tab—you’ll even see that SketchUp gives you a smooth transition between scenes.

To animate your scenes automatically, right-click on the first tab (we’re assuming you want to start the animation from there) and choose Play Animation. SketchUp pauses for a short while at each scene before moving on to the next scene. This is expected behaviour—remember, the primary purpose of scenes is to show your model off from different angles, not to fly around without stopping. To change the settings for this, choose Window >
Model Info. Under Animation, you can enable or disable transitions, set the time that it takes for each transition, and how many seconds to pause at each scene.

The great thing about scenes is that creating them adds almost nothing to your file’s size, so you can create as many of them as you want, although animating them can take a bite out of your system’s resources. If you’re creating a large number of scenes, names like Scene 1 and Scene 2 just won’t do—something like “Kitchen Interior” works much better. To change the name of a scene, open the Scenes dialog and edit them.

If you want to make changes to a scene, select its tab, tweak your view, right-click on the tab and choose Update.

**7.3.1 Walkthroughs**

Creating a walkthrough—literally walking your audience through your model is not unlike a regular animation, but there are a few things that’ll need your attention before you just get up and walk off into your model.

Firstly, there’s the disadvantage that you can’t just create a path and create a walkthrough along that—for intricate walkthroughs, this can get quite annoying. However, like we mentioned before, creating a scene doesn’t add to your file size significantly, so there’s nothing stopping you creating as many as you need.

One thing you need to watch out for is turns—SketchUp transitions from one scene to the next on the shortest path, so if you create a scene on one side of a wall, walk around it and then create another scene, SketchUp will just...
take you right through the wall. What you need to do is create a
scene just before the turn, and one just after. To prevent it from
looking like a robotic turn, look at the turning when creating your
first scene, and after you take the turn, look at the object you want
attention drawn at. The screenshot explains it better.

**7.3.2 Animating Section Planes**

SketchUp may let you animate your camera, but it doesn’t let you
animate your model—for example, you can’t create an animation of
a wall rising. However, with a little cheating, it’s at least possible
to create an animation which looks like a section plane descend-
ing on your model.

Start by creating a
number of section
planes and deactivate
them all. Set up your
first scene and save it.

Now activate the
first section plane and
add a scene. Repeat this
for the remaining
planes. In the Model
Info dialog (Window >
Model Info), set Scene Delay to 0, so that the animation moves
smoothly. Of course, if you’re doing this to actually present the
sections and not for fun as we are, skip this setting. Play the an-

**Fun with sections**

**Setting up the section planes**
information to see whether you like it. If you don’t want to see the translucent section planes, turn them off under View > Section Planes.

If you aren’t content with a small audience, turn to the next chapter to learn how you can share your creations with the world.
You've come a long way—houses, lathed surfaces, shadows, fog—you've done it all. Now it's time to share your creations with the world... E-mail your friends, share them with the Google 3D Community, and even get featured on Google Earth!
8.1 Export Quality

We’ve shown you how to present your model within SketchUp, but what if you want to send pictures of it to your friends or colleagues over e-mail? When you’re done setting up the view you want to send, choose File > Export > 2D Graphic to create a picture of your model. Under the Cancel button in the dialog is the Options button, which gives you the Export Image Options dialog. Here, you can choose whether the size of the exported image is the same as it is on your screen (not a good idea if you want to print—use a larger resolution for that), and whether you want to anti-alias (smoothen) the edges. There’s a huge difference in quality if your images are anti-aliased, so don’t uncheck that option.

A silly thing about exporting in 2D is that the resolution of the output image is proportional to your view size—so if you’re working on a 4:3 monitor and want to export a 16:9 widescreen image, you can’t do it by just keying in a resolution. Instead, you can use a simple workaround—resize your SketchUp window to get the wide view you want, and

The Export Image Options dialog

The difference between an aliased and an anti-aliased image. Notice the jagged edges in the aliased image
then export. For added effect, you can increase your camera’s field of view.

Exporting your scenes as an animation works the same way—choose File > Export > Animation, and in the dialog, use the Options button to change the resolution and video codec for your animation.

8.2 A Mark On The Earth

One of our favourite features in SketchUp is its ability to plant models on Google Earth—so if you’ve just made a model of your building, you can place it right where it belongs. The flow of events is simple—bring a location from Google Earth into SketchUp, model on it, and send it back to Google Earth. Before you begin, turn on the Google Toolbar (View > Toolbars > Google) for your convenience.
Now for the first part—selecting a location on Google Earth. We’re presuming you know your way around Google Earth—if not, it shouldn’t take you more than ten minutes to get a hang of it, anyway. Most people use Google Earth to create models of buildings, so we’ll stay with that approach for now.

Even though close-up views on Indian locations aren’t as crisp as those in the US, you should fill up your screen with the building you want to model. You should also wait for at least 95 per cent of the image to load, if not 100. Now go over to SketchUp and click on the Get Current View button on the Google toolbar (or Tools > Google Earth > Get Current View).

There are several neat things about the way SketchUp gets your view. Firstly, it’s accurate—if your building is 100 feet wide in real life, it’ll be so in SketchUp—use the tape measure if you don’t believe us. Secondly, it stores the geographic information—if you were to centre over the neighbouring building and get that location in SketchUp, it’ll create a tile next to the one you created first—you can create the whole neighbourhood this way.

Now to start modelling—you can either start with the line tool, trace the outline of the building you want to imitate, or import an existing model you have (File > Import) and place it on the Google Earth view.

If your site is on a slope or generally non-level ground, you should
Every time you get Google Earth’s current view, it’s placed relative to your first view.

This is what building models generally look like in Google Earth.

A view of the hills on the outskirts of Navi Mumbai. Turning on Terrain gives us a better idea of the landscape.

use the Toggle Terrain button in the Google Toolbar. This also shows you slopes and undulations in your current Google Earth View.

Once you’ve had your fun, click on Place Model on the Google Toolbar, to take your model back to Google Earth. Under

The model we created, now in its proper location. Your view is even oriented to the same angle as in SketchUp.
Places in Google Earth, you’ll see a new temporary place called SUPreview1. Right-click on it and choose Save As to save your model as a Google Earth KMZ file. If you e-mail this file to your friends, they’ll now be able to open it in Google Earth and look at your model in all its glory.

8.2.1 Optimising Your Model
When you’re modelling for Google Earth, efficiency is important—more so than how intricate your model looks. The first thing to do is to eliminate any redundant edges and faces using the Eraser tool. Go over your model in detail, and if you find edges whose absence doesn’t affect your model, make them go away.

Second, you can reduce the level of detail in your model by using circles with fewer sides. The default circle has 24 sides, so when you extrude it, you’re creating 24 new faces. To convey the general idea, you don’t need more than 12 sides, so when you’re constructing your next circle for Google Earth, enter 12s in the VCB to create a 12-sided circle.

8.3 In The Warehouse
When you truly want to share your model with the world, nothing beats Google’s 3D Warehouse. It’s an online repository where anyone with a Google account can share their models with others, and download models they like.

There are two ways for you to get models from the 3D Warehouse—through your browser (go to http://sketchup.google.com/3dwarehouse) or through SketchUp itself (choose File > 3D Warehouse > Get Model).
When you first visit the 3D Warehouse, you’ll see that it’s organised in collections—not much to explain there. You can visit collections that interest you, browse their sub-collections and download models from there.

Getting models is all rather easy—now to share your own models.

**8.3.1 Uploading To The Warehouse**

Before you begin uploading, here are a couple of things that you want to keep in mind:

No X-rated stuff, please—the 3D Warehouse is a family-friendly zone. Post any offensive content and you’ll be out in a flash.

No plagiarism—you mustn’t download a model from the warehouse and then upload it as your own. It’s stupid, but people have still tried it.

In the lower right corner of your browser window, you’ll find a link to the online help. If you’re ever lost in the warehouse (highly unlikely), use it liberally.

When you’re ready to upload your model, set up your view to an angle you like. When you upload, the 3D Warehouse will automatically create a preview image for your model using the view you upload. Now go to File > 3D Warehouse > Share Model. If you haven’t used the 3D Warehouse
before, you’ll have to sign in to your Google ID and choose a nickname for yourself first. After that, there’s a short form you have to fill, where you will enter details about your model. The fields are pretty self-explanatory, so we won’t go into them here.

Once the upload has taken place, you’ll see a page for your model. While you're signed in, you can edit this model’s information, or delete it from the warehouse.

The model you upload may be geo-located—this is true if you’ve built it on a site you chose on Google Earth. Geo-located models can be considered for inclusion in Google Earth as default models, so make accurate models, place them right, and keep your fingers crossed!
To wrap up this Fast Track, we present some tips to save you time while you’re using SketchUp—things that we had to learn the hard way while preparing this volume for you.
9.1 Modelling Tips

These tips ought to make modelling a tad easier for you.

9.1.1 Encouraging Inferences
Let’s suppose you want to draw a shape like the one in the screenshot here, using the Line tool.

You start at the origin and make edge 1 on the green axis, then draw 2 parallel to the red. Edge 3 needs to be exactly half the length as 1, but silly you—you didn’t bother looking at its length. The alternative? Line up the endpoint of edge 3 with the midpoint of edge 1. Unfortunately, you can’t get an inference, so you don’t know where to end the edge. Here’s what you do:

Hover your cursor over the midpoint of edge 1 for a while. Now slowly draw it away in the direction of edge 3—you’ll see now that a dotted line has appeared, and this is the inference you’re looking for. Edge 4 is exactly half the length of edge 2 using the same method.

9.1.2 Disable Continuous Lines
When you use the Line tool, you’ll notice that every time you end one line, the tool’s prepped to draw you another one starting where the previous ends—this is called “rubber-banding”, and can
get pretty annoying sometimes. To turn this off, go to Window > Preferences, and un-check Continue Line Drawing under the Drawing item.

#### 9.1.3 Selection Tips
It should already be obvious to you that you can click and drag the Select tool to select multiple edges and faces. However, even the direction that you drag the tool can change the way these faces are selected.

If you click and drag to your right, only faces and edges that are completely inside your selection box are selected. If you click and drag to your left, every edge and face that even touches your selection box becomes part of your selection.

The first image is the result of dragging to the right, and the second is the result of dragging to the left

#### 9.1.4 Fun With Push / Pull
You already know that if you hover over different parts of your model while pushing a face, you can set the length of extrusion. Another neat tip is that if you double-click a face with the Push tool, the face is automatically extruded the same length as your last Push / Pull operation. This also applies to the Offset tool.

If you’re having trouble creating holes with the Push tool, look for two things: firstly, faces must be parallel for hole-making to work. Secondly, check for any stray edges in the vicinity. If you hit an edge, you can’t make a hole.
9.1.5 Complex Roofs With Follow Me

If you’re bored creating flat and gabled roofs, here’s one trick you ought to try—this is especially good if you want to apply a roof to a complex building quickly. Begin with creating eaves for your house (refer to Chapter 4 for this).

Draw a triangular profile on the top edge of the roof, anywhere you like. You could also create a semi-circular profile, or anything that appeals to you.

Use the Follow Me tool and drag this profile along all the edges of the roof. Make sure you end at the point you started. Your roof probably looks like a mess right now—we’ll fix that in a bit. Select the whole roof now, right-click on it and choose Intersect > Intersect with model. Now use the Eraser tool to remove edges and planes that don’t belong.
9.1.6 Lazy Way Out

Remember creating stairs using the Component method in Chapter 4? We created a stringer on one side of the wooden steps—care to go through the trouble of doing it again for the other side? We thought not. Thankfully, for symmetrical models, you can get away with modelling just half of what you need. We’ll start with half a step, with a (rather strange) railing.

The first thing we’re going to do is turn this into a component. Now use the Move tool in copy mode (hit [Ctrl]) and create a copy of this step. Right-click on the copy and choose Flip Along > Component’s Red (in this case) to mirror the copy. Now use the Move tool again so the two components line up perfectly. You can now double-click one of the components to change it, and those changes will be reflected in the other component.

To get rid of the edges at the seam of the two components, hide them—double-click to edit the component and use the Eraser tool ([E]) with [Shift] held down to hide the edges without deleting them.

9.1.7 Saving Components Without Saving Models

If you’ve got a scene with lots of components, and want to save only one for use in other models, just right-click on it and choose
Save As. You’ll be able to save just that component with the same name that you gave it when you created it.

### 9.1.8 Using Follow Me Predictably

The Follow Me tool can often go AWOL when you’re using it along complex paths, but fret not—there’s a better way to use Follow Me, sans headache. Start by selecting all the edges that make up your path. Now select the Follow Me tool and click once on the face that you want to extrude. Ta-da! If you did that the way we wrote, you should have yourself one hassle-free extrusion.

![No more Follow Me tears!](image)

### 9.1.9 Crazy Models With Circles

If you try to use the Push tool on the curved side of a cylinder, SketchUp won’t let you. However, we must remember that this cylinder has been created with a 24-sided circle—where did all those sides go?

To show these sides, choose View > Hidden Geometry. Now you can not only see these sides, but even use the Push tool on them!

![Hidden geometry opens up a world of possibilities](image)

### 9.1.10 Taking The Right Picture For Photo Match

If you’re taking a picture of a building to use with Photo Match, remember these few things:
When you take a photo, make sure that you can see perpendicular surfaces in the shot—that’ll help you set up the perspective bars a lot better.

If possible, face the building at a 45-degree angle. You’ll wind up with a photo where perpendicular surfaces aren’t too distorted, which in turn means better results when you’re modelling with Photo Match.

### 9.2 Presentation Tips

You can model like a pro, but you need to have some presentation skills to elicit your daily quota of “ooh”s.

#### 9.2.1 Photo Textures On Curved Surfaces

Applying photos as textures on curved surfaces can be painful when done directly, but there’s a rather simple workaround. Starting with a curved surface, draw a rectangle right in front of it, making sure it lines up.

Now apply the photo you want to the rectangle. Right-click on it and choose Texture > Projected. Select the Paint Bucket tool (B) and click on the curved surface. You’re done!

---

**Lining up a rectangle with the curved surface**

**The texture’s been projected**

#### 9.2.2 Sections Done Right

Even if you’re not an architect, it helps to know their rules when it comes to sections:

Make sections at four feet over the ground. This way, all the features of a house—doors, windows and so on—are cut through, but most furniture remains safe.
Never cut through columns. The look like walls when they’re cut, and that can lead to confusion.

Always cut through stairs or elevators—you audience will appreciate knowing where the access to the next storey is.

**9.2.3 Indoor Lighting Worries**

In chapter 7, you might have noticed that the lighting inside the villa is rather dull, and can make for a boring walkthrough. If you’re in a building that has multiple storeys, you obviously can’t delete the ceiling to let the light in...

Open the Shadows dialog (Window > Shadows) and drag the Dark slider towards white to brighten up the indoors a little.

If you’re working with a single-storey building and don’t want to delete the roof, you can have it not cast any shadows. Select the ceiling (or roof, as the case may be), right-click on it and choose Entity Info. Un-check the box against Cast Shadows. You should have a much brighter indoor scene now.

9.2.4 The Steven Spielberg Effect

This technique was popularised by Spielberg in *Jaws*, and has been much abused since—which is why we have no qualms abusing it a bit more. It’s purely for fun, so you could use this to spice up a boring presentation. This works best if your camera is set up close to the ground.

Set up your scene as in the screenshot. The two boxes will serve as a reference. Now set up your camera in such a way that the two boxes are at the edges of your view. Tweak till you’re sat-
isfied, and save a scene (Window > Scenes; click the Add button).

Now choose Camera > Field of View. Click and drag on your view till you’ve got a considerably distorted wide-angle view of the object you’re focusing on (in our case, the house). Now adjust the camera so that the two boxes are back at the edges of your screen. Create a scene here.

When you transition between the scenes, you’ll be treated to a cool effect. However, this is something that demands a lot of tweaking, so you won’t get it right the first time. Or the fifth, for that matter.