Fast Track
to
Excel
2007

By Team Digit
Credits

The People Behind This Book

EDITORIAL
Deepak Ajwani Editor
Ram Mohan Rao Writer, Copy Editor
Robert Sovereign-Smith Copy Editor
Nimish Chandiramani Copy Editor
Abey John Writer
Srikanth R Writer
Samir Makwana Writer
Ashfaq Tapia Writer

DESIGN AND LAYOUT
Shivshankar Pillai, Vijay Padaya Layout Designers
Sivalal S Layout and Cover Design
Harsho Mohan Chatteraj Illustrator

© Jasubhai Digital Media
Published by Maulik Jasubhai on behalf of Jasubhai Digital Media. No part of this book may be reproduced, stored in a retrieval system or transmitted in any form or by any means without the prior written permission of the publisher.

May 2007
Free with Digit. Not to be sold separately. If you have paid separately for this book, please e-mail the editor at editor@thinkdigit.com along with details of location of purchase, for appropriate action.
Number Numbness

That's what Excel takes care of. Make no mistake: Excel is a very, very powerful data handler. From cosmetic enhancements to advanced analysis, Excel does it all.

The latest version—Excel 2007, which this little book covers—has undergone more changes in this release of the Microsoft Office suite than have the other programs. With so many of us upgrading to Office 2007, we felt the need to cover Excel 2007 in detail, even though we introduced Excel in an earlier Fast Track edition.

Our purpose here is threefold. First, to give you a feel for the new (2007) interface and functionalities; second, to give you an idea of much that Excel is capable of doing; and third, to guide you through some topics in detail, so you can get Excel to work well for you.

After starting off with the basics, we go into the details of data presentation—that is, formatting, alignment, and such. Next come several chapters on actually dealing with data, such as dealing with cell references, sorting, organising data into levels, and such. A chapter on PivotTables exposes you to this wonderfully useful tool. Then comes the topic of charts, one of the primary uses for Excel—visualising data.

We've included two little chapters on macros and graphic elements respectively, and we round off with a chapter on Excel formulas and functions.

We candidly admit that because of its complexity, Excel is a hard topic to cover in perfect detail. You might just find that, for example, a macro or a formula doesn't work exactly as we've explained. In such cases, thankfully, there's always Excel's Help pages to refer to. But we should reiterate that we've striven to make this book such that you'll need to refer to the Help as little as possible, except in the case of formulas and functions, which could fill three entire Fast Track editions!

If you've got data to handle, you need Excel. And if you've got Excel, you need this book. And if you've got this book, you're on your way to unleashing the capabilities of the best spreadsheet app of all time—well begun is half done!
<table>
<thead>
<tr>
<th>Chapter 1</th>
<th>The Basics</th>
<th>9</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.1</td>
<td>Introduction</td>
<td>10</td>
</tr>
<tr>
<td>1.2</td>
<td>The Changes</td>
<td>10</td>
</tr>
<tr>
<td>1.3</td>
<td>File Types</td>
<td>16</td>
</tr>
<tr>
<td>1.4</td>
<td>Using Fluent</td>
<td>17</td>
</tr>
<tr>
<td>1.5</td>
<td>Working With Excel 2007</td>
<td>25</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2</th>
<th>Document Appearance</th>
<th>35</th>
</tr>
</thead>
<tbody>
<tr>
<td>2.1</td>
<td>Templates</td>
<td>36</td>
</tr>
<tr>
<td>2.2</td>
<td>Styles</td>
<td>37</td>
</tr>
<tr>
<td>2.3</td>
<td>Themes</td>
<td>40</td>
</tr>
<tr>
<td>2.4</td>
<td>General Formatting</td>
<td>42</td>
</tr>
<tr>
<td>2.5</td>
<td>Conditional Formatting</td>
<td>44</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 3</th>
<th>Calculations Made Easier</th>
<th>49</th>
</tr>
</thead>
<tbody>
<tr>
<td>3.1</td>
<td>All about cell references</td>
<td>50</td>
</tr>
<tr>
<td>3.2</td>
<td>Defined Names</td>
<td>51</td>
</tr>
<tr>
<td>3.3</td>
<td>Referring to another Worksheet</td>
<td>52</td>
</tr>
<tr>
<td>3.4</td>
<td>Absolute, Relative, and Mixed References</td>
<td>53</td>
</tr>
<tr>
<td>3.5</td>
<td>Referring to another Workbook</td>
<td>54</td>
</tr>
<tr>
<td>3.6</td>
<td>3D References</td>
<td>56</td>
</tr>
<tr>
<td>3.7</td>
<td>Excel Tables</td>
<td>57</td>
</tr>
<tr>
<td>3.8</td>
<td>Creating formulas to calculate values</td>
<td>58</td>
</tr>
<tr>
<td>3.9</td>
<td>Moving, copying, and editing formulas</td>
<td>60</td>
</tr>
<tr>
<td>3.10</td>
<td>Validating data during entry</td>
<td>61</td>
</tr>
<tr>
<td>3.11</td>
<td>Finding and correcting errors</td>
<td>64</td>
</tr>
<tr>
<td>3.12</td>
<td>Tracing a formula</td>
<td>67</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 4</th>
<th>Organising And Interpreting Data</th>
<th>69</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.1</td>
<td>Data Tables</td>
<td>70</td>
</tr>
<tr>
<td>4.2</td>
<td>Sorting and Filtering</td>
<td>73</td>
</tr>
<tr>
<td>4.3</td>
<td>Organising Data Into Levels</td>
<td>77</td>
</tr>
<tr>
<td>4.4</td>
<td>Summarising Data</td>
<td>79</td>
</tr>
<tr>
<td>4.5</td>
<td>Using Indexed Data</td>
<td>81</td>
</tr>
</tbody>
</table>
The Basics

The new version of Microsoft Office, the de facto office application suite on most PCs, was in the works for a long time. But between MS Office 2003 and MS Office 2007 are conspicuous changes which justify the long gestation.
1.1 Introduction

For those of us who went over to the OpenOffice camp—partly because of the cost, partly because of the bloat, and partly because of the sense of geeky pride from not succumbing to the “dark side,” MS Office 2007 will be hard to resist—thanks largely to the gorgeous new interface. MS has gone that extra yard to entice people back into its fold by offering a 60-day free trial of the software. A sub-300 MB package containing four constituents of MS Office—Excel, Word, PowerPoint, and OneNote, called MS Office Home and Student 2007, can be downloaded from http://us7.trymicrosoftoffice.com/default.aspx?culture=en-US (http://tinyurl.com/yredyg) after signing up for a free serial. While one can appreciate the UI immediately after installing, it needs to be activated online before it can be used to create or modify documents. Microsoft also offers an online demo of the new software.

The minimum system requirements for Office 2007 are Windows XP with SP2 (it will not install if SP2 is not detected) or later, a 500 MHz CPU, 256 MB of RAM, a monitor supporting 1024 x 768 resolution, and 1.5 GB of hard disk space. But Microsoft admits that this will not be adequate to use all the features of the package. For example, to be able to use the Grammar and Contextual Spelling features in Word 2007, at least 1 GB of memory is required; the Business Contact Manager feature in Outlook 2007 requires a 1 GHz CPU.

1.2 The Changes

1.2.1 The New User Interface

The MS Office user interface has been revamped, and the change is revolutionary rather than evolutionary. Microsoft describes it as a “results-oriented user interface” and elaborates, in the help file: “Commands and features that were often buried in complex menus and toolbars are now easier to find on task-oriented tabs that contain logical groups of commands and features.” We can’t put it better.
The UI is such an important piece of programming artistry that it even gets a separate name—“Fluent.” Microsoft Office Fluent is the common UI presented in Word, Excel, PowerPoint, and Access. Fluent has many components, with the most important one being the Ribbon. The other notable components are named the MS Office Button, the Mini Toolbar, and the Quick Access Toolbar. Feature-wise, Formula AutoComplete, Live Preview, and Gallery are notable inclusions, but these do not appear as controls, rather as usage aids. All these components are discussed in detail in the next section. Fluent also sports a new charting engine which goes a long way in making presentations and charts look... awesome. The interface is definitely a beauty, with the rounded corners, shiny buttons and translucent panels, but those with a more sombre inclination would not like the fact that there’s no option to switch to a less flashy interface.

1.2.2 Components of Fluent

We now take a closer look at the new UI as implemented in Excel 2007.

The MS Office Button is the replacement for the File menu of the previous versions. This button occupies the left-hand top of the window. It contains the options found previously under the File menu, like Save, Print, program options, etc. It can be activated by the [Alt] + [F] shortcut key combination as before, despite “F” not appearing either in its name or on the button.

The Ribbon is the replacement for all the other menus and toolbars. It is a banner that occupies the top of the window. Its design
EXCEL 2007

THE BASICS

is tab-based, and the corresponding options and icons are displayed whenever a tab is selected. By default, the Ribbon has seven tabs—Home, Insert, Page Layout, Formulas, Data, Review, and View, and between them they cover most of the common user options. Other tabs, called Contextual Tabs, appear as and when needed depending on the object being worked with. In the case of Excel, the Developer Tab appears only when enabled in the application’s preferences window.

The icons under each tab are grouped logically into blocks on the Ribbon, and only the most frequently-used command icons are displayed. In case more options need to be displayed, a small link at the bottom of the block can be clicked to pop out a separate window containing all the options.

Besides the preset tabs, context-sensitive tabs appear on the Ribbon depending on the object selected. For example, tabs relating to charts—like Design, Layout, and Format—only appear after a chart is created or selected.

The Mini Toolbar pops up on selecting a particular cell’s contents. When dealing with a block of cells, it pops up next to the context menu, on right-clicking. The Mini Toolbar contains the frequently-used formatting options, and significantly decreases the mouse navigation involved. Options in the Mini Toolbar include font changes, numbering and bulleting, and more.
Formula AutoComplete is another useful feature along the same lines as the Mini Toolbar. It is a window that pops up next to the cell whenever a user begins to type out a formula in it. The window contains a list of functions matching the letters typed by the user, with a brief description of what the function achieves. On selecting a function, the window displays the syntax of that function, thus decreasing the chances of the user making an error.

The configurable Quick Access Toolbar appears at the top left, next to the Office Button. It is a placeholder to add buttons for easy one-click access. If required, buttons can be added to or deleted from the toolbar, by using the adjacent Customize button. The Toolbar by default has a file save, undo, and redo buttons.

Other thoughtful touches include the much easier zoom control. This is now present as a horizontally sliding control at the bottom left of the window. Next to the zoom control is the Page View control, which can be used to check the Page Break preview and the print page layout with one click.

1.2.3 Features
Live Preview is a useful feature in the new UI. Unlike earlier versions where the results of formatting would be visible only after they were applied, in this version, just hovering the cursor over a
formatting option will reflect the change in the content. This removes the need for undoing any applied changes if one is not satisfied.

Conceptually similar to the Live Preview feature is Gallery, a feature that rather than merely listing the name of an effect, graphically displays its sample application, making it easier for the user to choose a desirable effect. For example, rather than display the possible colours for a table, the gallery displays the table in various colours.

While the emphasis of the UI is to make it easier for newcomers to work with the application, veterans will not be put off, since the same shortcut combinations are usable. If needed the ribbon can be switched off, to maximise viewing area, by double-clicking on any tab.

1.2.4 Internal Changes
Besides the changes in the interface, the computational limits of Excel have been pushed further. The number of rows and columns have been increased to 1048576 and 16384 respectively. Contrast this with the earlier limits of 65536 rows and 256 columns. To be able to handle this larger spreadsheet, MS Office now is able to use up all the RAM supported by the OS (4 GB in case of a 32-bit OS; specifically, in Excel, there is a 2 GB limit), compared to the previous maximum of 1 GB. And the software has also been optimised or multi-threaded to make better use of multi-core CPUs. Under certain circumstances, as mentioned at http://blogs.msdn.com/excel/archive/2005/11/03/488822.aspx (http://tinyurl.com/2lv88a), this allows Excel 2007 to complete a task twice as fast as the previous version. Other enhancements include the increase in the number of characters a cell can
hold—from 1024 to 32768; an increase in the number of unique colours allowed in a spreadsheet—from 56 to 4.3 billion; etc. The entire list of enhancements can be found at http://blogs.msdn.com/excel/archive/2005/09/26/474258.aspx (http://tinyurl.com/b6xd7).

The new UI would give an impression of a development bias towards presentation and appearance aspects in Office 2007. And this impression is further fortified by the inclusion a few new visually exciting features. Newly introduced in this version is the concept of themes, which allows a set of formatting options to be saved and/or applied as a unit. The same theme can be applied across Office applications—Word, Excel, and PowerPoint—making it possible to easily create similar-looking documents. Also, now, there are more options to spruce up a spreadsheet with images, diagrams, graphs and charts, and Word Art. Graphical components and charts in a spreadsheet can now be rendered in many more styles and colour combinations, and have greater customisation options. The new charting engine in Office 2007 is responsible for all the snazzy graphics.

While the above-mentioned examples of an emphasis on visual appeal—better looking charts and colour coded documents—would seem irrelevant to some Excel users, Excel now has the ability to use cell properties, and not just cell contents, as parameters for data manipulation. For example, if after Conditional Formatting, one has a range of cells with different colours, it is now possible to sort the range on the cell colours, so that all cells with the same colour are grouped. Combined, these two capabilities make Excel an even better tool for interpreting large amounts of data. CF is discussed in detail in the Chapter 2.
1.3 File Types

To store documents, Office 2007 now uses the Office XML format, which is based on XML (eXtensible Markup Language), a platform-independent and open-standard language. Any application that can work with XML, irrespective of the operating system or system hardware, can be used to work with Office documents saved in the new format. The new file formats also use ZIP technology to compress files. Microsoft claims that a document saved in the new format will be up to 75 per cent smaller than when stored in the previous format.

There is more than one new format introduced in Excel 2007. Excel workbooks are by default now saved in the XLSX format. This file format doesn’t support the execution of macros, and therefore is not advisable in case a spreadsheet contains them. The XLTX format is used to store template spreadsheets that do not support macros.

The other format, which supports macros, is XLSM. Spreadsheet templates containing macro code are saved as XSTM files. By creating distinct file formats for macro-including files, it has now become easier to identify such files before opening them. This allows the user to take precautionary measures to prevent any malicious code embedded as a macro from executing on opening the file.

The file format which is optimised for faster saving and loading is XLSB. Unlike XML based files, which use ordinary text to store data, XLSB files are stored in unzipped, binary format. This makes it application dependent, unlike the XML based files.

The last new format is XLAM, which is used to save files that include add-in generated data. Add-ins are sub-applications that extend the functionality of Excel.

For compatibility with the previous versions, the XLS format needs to be used. Needless to say, documents saved in the older for-
Excel 2007

The Basics

1.4 Using Fluent

1.4.1 Using the Office Button

Most of the options under the Office Button are a familiar sight to users. The options Open, Save, Save As, Print, and Print Preview remain unchanged. Under the Prepare Menu, one can use the Inspect Document Option to vet the document for any private
information that may have not been deleted, and may potentially be misused—for example, comments, annotations, and hidden text that are only meant for an internal audience. The Compatibility Checker will reveal features that will be lost if the document is saved in a format that can be opened in older versions of Office. The Encrypt Document option can be used to add a password to a spreadsheet.

The Excel Options button reveals the options to configure Excel. Besides other options, the default colour—blue—of the UI can be changed here. By default, Excel uses ClearType, a Microsoft technology that improves the appearance of text on-screen, especially LCD screens. This can be disabled here. The Mini Toolbar and Live Preview features can also be disabled here.

1.4.2 Using the Ribbon
As mentioned, there are seven tabs by default on the Ribbon. We quickly review the contents under each tab.

1.4.2.1 The Home Tab
Under the Home tab are the main formatting tools. Here one will find all font formatting and paragraph formatting options. This tab also contains the Clipboard Block, which contains tools like copy and paste. The clipboard tool tracks the contents of the clipboard, and if required, it can be launched by clicking on the bottom left corner of the block. This will reveal the previous entries in the clipboard, and if required, any of the entries can be selected for pasting in the document. The Font Block contains the usual
Here are the buttons available to you under the Home tab

font formatting tools and more options, and be accessed by clicking on the pop out link at the bottom left of the block. The Alignment block contains the cell text formatting tools, like indentation, alignment, etc. This block also offers more options through the pop out. The Number block offers options for formatting cell content of different types, like date, percentage, etc. The Styles block offers the powerful Conditional Formatting tool, which is discussed in detail later. This block also offers a way to easily format a group of cells as a unit by using the “Format as a Table” tool. Preset Colour combinations can also be applied by using the Cell Styles tool. The Cell Block allows inserting, deleting and formatting cells, rows, columns and sheets. The Editing block contains tools to find, replace, sort data, clear cell contents, etc.

1.4.2.2 The Insert Tab

This one contains tools to insert different types of content in the spreadsheet. All these are grouped into different blocks. The Table block allows insertion of a Table or a Pivot Table. The Illustrations Block has tools to insert Pictures and Clipart. Of special interest is the Smart Art Tool, which is a new feature. This contains pre-built diagrams depicting scenarios like Flowchart, Hierarchy etc. The pre-made diagrams save the user considerable time and effort. The Chart block contains tools to insert charts of different types like Pie, Bar, etc. The Hyperlinks block allows inserting links to other sheets in the same spreadsheet or to other spreadsheets locally or to any document online. The Text block contains tools to insert textual content like Word Art, Headers and Footers, and content from other sources like Word or PowerPoint documents, etc.
1.4.2.3 The Page Layout Tab
This contains the usual Page Setup options like Page Orientation, Margins, Background, etc. under the Page Setup block. The Scale to Fit and Sheet Option group different tools to modify the spreadsheet viewing options. Under the Arrange Block, one can modify the arrangement of the different objects in the spreadsheet like Pictures, Graphs, etc. The Themes block has the tools to specify document themes, which is explained in detail in Chapter 2.

Options for the Page Layout tab

1.4.2.4 The Formula Tab
The Formula Tab offers different options to manage different functions in the spreadsheet. In the Function Library block, all the supported functions are listed under different categories—Financial, Engineering, Statistical, etc. The Formula Auditing block lists tools to verify dependencies and other aspects of the formula in the spreadsheet. The Defined Name Block contains tools to create and manage cell blocks by giving them names. The Calculation Block contains tools to control how Excel calculates values in the spreadsheet.

Inserting formulae was never simpler with the Formula tab

1.4.2.5 The Data Tab
This tab has the tools to organise, summarise, and analyse data in the spreadsheet. The Get External Data block groups tools to get data from external sources into the spreadsheet. Excel supports data importing from text files, XML files, SQL databases, and more. Connections to databases can be controlled by using tools in the Connection Block. Sort and Filter, Data Tools and Outline blocks contain tools to manage data tables in the spreadsheet.
1.4.2.6 The Review Tab
This one contains tools to verify non-numerical data in the spreadsheet, in the form of a dictionary and other tools grouped under the Proofing block. The Comments block contains tools to insert and manage comments in the spreadsheet. The Changes block contains tools to track changes made by other users in the spreadsheet and also to restrict write permissions to the spreadsheet.

1.4.2.7 The View Tab
This tab contains tools to control the display of the spreadsheet, categorised under the blocks titled Workbook Views, Show/Hide, Zoom, and Window. The Macro Block can be used to view existing macros and create new ones.

1.4.2.8 The Developer Tab
This remains hidden by default, and needs to be enabled from the Excel Options window under the Office Button. Under the Developer Tab, one can find the tools needed to use Excel as an application to accept user input, under the Control Block; besides tools to manage macros, under the Code block. The XML block contains tools to import and manage XML data sources.
1.4.2.9 The Smart Art Tools Tab
The two tabs under the Smart Art Tools category, Design and Format, appear on selecting or inserting Smart Art objects. These tabs contain the tools to create, modify, and format Smart Art graphics. Unlike the other tabs mentioned above, the Smart Art Tools tab and the others that follow are contextual in nature and appear only when the concerned object is created or selected.

1.4.2.10 The Table Tools Tab
The Table Tools tab, and its sole sub-category, the Design Tab, appear only if a Table is created or selected. The Properties block contains the options to change the table name and its data range. The Tools block has tools to summarise the data as a Pivot Table. The Table
Style options and Table Styles blocks contain the various style options for the table.

1.4.2.11 The PivotTable Tools Tab
This tab has two sub-categories, Options and Design, which contain all the options to work with PivotTables. They appear only on inserting or selecting a PivotTable.

1.4.2.12 The Picture Tools Tab
Inserting or selecting a Picture will cause the Format tab, a sub-category of the Picture Tools tab, to appear. Under it, one can find options to modify picture parameters like contrast and brightness under Adjust Block. The presentation of the picture, its angle, border, shadowing, etc. can be altered under the tools grouped under the Picture Styles block. The Arrange block provides tools to change the position of the picture, while the Size block allows the picture to be cropped or resized.
1.4.2.13 The Chart Tools Tab
Inserting or selecting a Chart will cause the Chart Tools tab to appear, with three sub-categories. These are the Design, Layout, and Format tabs. Under these three tabs, grouped in blocks, are the tools to modify the data ranges, type, presentation of the chart, and other aspects of the chart.

1.4.2.14 The Header and Footer Tools Tab
This tab, with its Design sub-category, appears when dealing with Headers or Footers. It contains various values that can be inserted as headers or footers, like page number, date, time, etc. Here, one can also modify the location of the header and footer.

1.4.2.15 The Drawing Tools Tab
The Format tab under the Drawing Tools tab appears on selecting or creating Word Art and Shapes. This contains the various colouring, rendering, and sizing options for such graphics.
All the above-mentioned tabs will be discussed in detail in the following chapters when their usage is deliberated upon.

1.5 Working With Excel 2007

We now cover a few basic operations in Excel.

1.5.1 Entering and Editing Cell Entries
Entering a value in a cell involved selecting it and typing out the value. To change the value in a cell, you can either double-click on the cell or select the cell and press [F2]. After the necessary changes are made, selecting another cell or pressing [Enter] completes the process. Of special mention here is the Formula AutoComplete feature newly incorporated in Excel.

1.5.1.1 Formula AutoComplete
This feature makes it easier to work with functions. Every time the user begins to start typing out a function, a pop up appears below the cell listing all function starting with that letter. The highlighted function has a brief definition alongside. The function list can be scrolled using the Up and Down direction keys, and after the desired function has been identified, it can be inserted into the cell using the [Tab] key.

After the function has been inserted, the pop-up displays the syntax. This makes it easier for the user to input the correct values or cell references. The parameter deserving attention is displayed
The optional parameters are circumscribed in square brackets. Clicking on the function name in this pop-up launches Excel Help and takes the user to the page containing a detailed description of the function.

It is possible to nest many functions, and every time a new function is started, a second pop-up appears listing the available function options. After inserting a new function, the pop-up displays the syntax of the latest function. The pop-up remains active till the final function is properly closed, with round brackets.

1.5.2 Moving and Copying Data

The controls to move or copy data from one location to another is grouped under the Clipboard block, under the Home tab. One can also use the context menu for this purpose. Select the cell or range of cells that needs to be copied or moved. Choose Copy or Cut from the Ribbon. Then select the cell where the data needs to be relocated, the target location, and click on the paste button. This will overwrite any data previously existing on the selected cells. By default, the cells are copied carte blanche, including cell content, cell formatting, comments, formula, etc. To fine-tune the content that is transferred, one needs to use the Paste
Special option. Here, one can pick and choose which of the contents need to be transferred.

Besides data relocation, Paste Special can also be used to perform the basic mathematical operations simultaneously. If the target location is already populated, rather than simply pasting source data over them, operations like Add, Subtract, Divide, and Multiply can be performed. So after the paste, the results of the operation on the source and target data are displayed. Paste Special can also be used to convert a row of cells into a column of cells and vice versa by using the Transpose option. Paste As Hyperlink is a feature that allows a hyperlink to the source location to be created at the target location. Clicking on the hyperlink takes the user to the source location. Paste as Link creates an equation with an absolute reference to the source location at the target location.
If one would like to avoid overwriting existing data at the target location, the option Insert Copied Cells, available in the context menu, can be used. This allows the existing cells to be shifted either down or to the right to make space for the additional data.

**1.5.3 Adding and Managing Comments**
Tools to add and manage comments are grouped in the Comments block under the Review tab. Here one can add comments, delete comments and browse through all comments sequentially. Comments are visible only when the mouse cursor hovers over the cell which contains it. Cell with comments are marked with a red tack on the top right. To make the comments visible permanently, the Show All Comments option can be used. All the above options are also accessible from the context menu available by right-clicking on a cell.

**1.5.4 Finding and Replacing Data**
The tools to achieve this are grouped under the Editing block under the Home Tab. Excel now can even search for (and replace/modify) cell properties, not just cell contents. For example, now it is possible to search for cells which have single-lined borders, and modify the border into a double-lined one.

To use the Find function, one can either use [Ctrl] + [F] ([Ctrl] + [H] for Find and Replace, though the Find window invariably carries the Replace tab), or click on the Find option (or Find and Replace option) under the Find and Select menu. To search for
cell content, the necessary options are presented, but to search for Cell properties as well, the Extended Options needs to be accessed by clicking on the Options button. This reveals all the possible parameters on which a search can be conducted. Among the parameter options, besides cell value, are cell colour, cell border, font colour, text alignment, text formatting, and more. The user can either select from these options, or choose to use the formats already applied to a cell by using the “Choose Format from Cell” button. Other conditions like the scope of the search and whether to match case can also be specified. In case matching occurrences need to be modified or replaced, one can use the Replace tab to specify the modifications. Here, too, format changes can be user specified or adopted from a cell.

For finding matching occurrences of these parameters, the Find All button can be clicked, and all occurrences are displayed in the same window. Clicking on any of the entries takes one to the specific cell matching the criteria. If needed, the replacements can be made individually, or the Replace All button can be used to make all modifications at one go.

The Find and Select menu also offers other tools to quickly get to specific data on a spreadsheet. In the Find and Select drop-down, selecting any of the entries—like Comments, Formula, etc.—will highlight those cells containing that specific resource.

One can use the Selection Pane to view a listing of all objects in the spreadsheet and
control the visibility of each. The Go To entry can be used to get to a particular cell, and its enhanced version—Go To Special—can be used to get to cells containing specific content, like a formula, a comment, etc.

1.5.5 Sharing Data across Excel, Word, and PowerPoint

All three applications mentioned above allow other document types to be embedded in their respective documents as Objects. Since the Ribbon is the same for all applications, the process to embed a Word document into an Excel spreadsheet is similar to the one required to embed a spreadsheet into a PowerPoint Presentation. The sole difference, of course, is the document type to be selected in each case. We shall discuss only one scenario for each of the methods: inserting a Word Document into an Excel sheet by using the embed object procedure, and inserting a spreadsheet into a PowerPoint by using the Paste Special Routine.

Since they share the same lineage, it is much easier to transfer data across these applications, in comparison to using data from other applications like OpenOffice Writer. There are two ways to do so. The first one is by using the capability to insert an external document as an Object, and the other is to use the Paste Special Feature to insert data from another application.
1.5.5.1 Insert Object
The tool to embed an object is available in the Text block under the Insert Tab. The Object button opens a window, listing, under the Create New tab, all the possible external document types that can be embedded. Selecting a Microsoft Office Word Document type will create a text box for text to be entered. To insert an existing Word Document, use the Create from File tab to choose the relevant document. The options listed alongside allow the embedded document to be shown as an icon or as text, and also allow the document to be linked from the spreadsheet. Enabling linking will keep the embedded document updated every time the source document is changed. Otherwise, a static, current copy of the document is embedded in the spreadsheet.

1.5.5.2 Paste Special
The Paste Special Routine is much easier and quicker, and is recommended in all cases except where the copied data in the clipboard is not correctly identified. For example, if the source data is copied from an OpenOffice document, the Paste Special routine will not list such an object.

To insert an Excel spreadsheet or part of it into a PowerPoint presentation, just copy the required cells in the spreadsheet, open the presentation, and choose the Paste Special option from the drop-down menu under the Paste button in the Clipboard Block under the Home Tab. This will pop up a window listing the document types in the clipboard, among which the data from Excel will
be identified. If needed, the option to Paste Link can be enabled so that changes in the source are reflected in the current document.

Irrespective of the method used, the unlinked embedded object can be edited from within the host document by double-clicking on it or by using the Document Object option in the Context menu of the object. This will cause the default Ribbon to be replaced with the Ribbon from the native application of the source document. After the changes have been made, on clicking outside the object, the default Excel Ribbon contents reappear. If the document is linked during the embedding process, editing the document separately launches the native application, and during the editing process, the object remains greyed out in the host document, to avoid a sharing violation.

Linked external data needs to be updated when the host document is opened to reflect changes, if any. The user’s permission is sought before the updating process is launched.
1.5.6 Saving a worksheet as a Web page

To save a spreadsheet to be viewed by a browser, one needs to use the Save As menu available under the Office Button. Selecting the Other Formats Option will open a windows with a “Save as Type” drop down. Select the “Single File Web Page” format to save the spreadsheet as a Web page. If a workbook has more than one spreadsheet, a particular spreadsheet or a range of cells can also be saved by selecting the relevant option presented in the same window. It needs to be noted that the file is saved in the .mht or .mhtml format. Multiple spreadsheet files saved in this format are only accessible with Internet Explorer. Files containing a single spreadsheet can also be opened with Opera.
The Visual aspects of a spreadsheet receive a lot of attention in Excel 2007. In this chapter, we look at the features in Excel 2007 that make it easier to manage the formatting options of a spreadsheet.
2.1 Templates

Spreadsheet templates make it easier to create spreadsheets that look and work similarly. The need for templates can be easily felt when a user has to frequently create spreadsheets sharing similar formulas and formatting, with just the user-entered data changing. By creating the spreadsheet once and using it as a template for every subsequent spreadsheet, considerable time and effort can be saved.

Excel comes preloaded with seven templates, and more can be freely downloaded from the Microsoft site. The preinstalled templates are displayed when the Installed Templates button in the New Spreadsheet menu—under the Office Button—is clicked. These include those designed to be used as Sales Report, Expense Report, etc. The themes on the MS site can be viewed and downloaded in the same window. The online templates are categorised and listed under the Microsoft Office Online heading. Categories like Receipts, Planners, Reports, etc., are listed here, and clicking on any of these will reveal the templates available at the Windows site. The templates can be previewed and downloaded from there.

A user can create custom templates from normal Excel files (.xlsx) or macro-included Excel files (.xlsm), by using the Save As button to save them as ordinary templates (.xltx) or templates with macros (.xltm) respectively. If the custom template so created is saved in the default user template folder (Documents and Settings\Username\Application Data\Microsoft\Templates), this template shows up under the My Templates collection when a New Spreadsheet is created. The “New from Existing” option can be used to load a template saved elsewhere or to use an existing spreadsheet as a template.
Template files are similar to regular files in almost all respects. The sole difference is that after using a template, on saving the document, a new file with the default Excel extension is created (.xlsx). This protects the template from being overwritten by the user. If a template file needs to be modified, it again needs to be saved as a template (.xltx) by using the Save As option.

2.2 Styles

2.2.1 Cell Styles
A Cell Style is a combination of the different format options that can be applied to a cell and its contents, like Cell colour, Border, Number Formatting, Font style, Font colour etc. By defining a cell style, consisting of the different formatting options, it becomes possible to apply all of the formatting in one stroke, rather than individually.

Under the Cell Styles drop-down, one can find the different suggested style options under the “Good, Bad and Neutral”, “Data and Model”, “Themed Cell Styles”, etc. headings. The “Good, Bad and Neutral” group lists three cell styles, besides Normal formatting—Red Font in Red Background, Green Font in Green Background, and Yellow Font in Yellow Background, labelled Bad, Good and Neutral respectively. The labelling allows those styles to be used as colour codes; for example, cells marked with the “Bad” style can convey the meaning to the user (if using the same version of Excel) that the particular cell contents met with disapproval.

Besides the suggested styles, a user can create custom styles, using “New Cell Style” in the same drop-down.
Selecting this will open a window where the range of options available to the user is displayed. Besides cell colour, a style can influence other aspects like font features, cell border, cell protection, and alignment. The Format button will pop up a window with all available options. After selecting the required combination, the style can be named and saved, and will appear in the Cell Style drop-down.

If desired, cell styles from other spreadsheets can be imported into the current one, by using the Merge Cell Styles option.

2.2.2 Format as Table
This option allows a range of cells to be marked and manipulated as a unit. A Table can be seen as a subset of a spreadsheet, and consisting of data that is related. Converting a range of cells as a table allows Data Manipulation tools, like Sorting and Filtering, to be used on it.

The “Format as Table” button not only offers formatting options for the range of cells, but also by default inserts data manipulation controls in the first row, called the header row, of the table. The data controls allow sorting and filtering the table data.

Excel preloads a few colour schemes for a table. These are displayed as a Gallery (recall the Gallery feature of the new UI) on clicking the “Format as
Table” button. After the desired scheme is selected, the range of cells to be used for the table needs to be identified. The formatting is then applied.

By default, if the range of cells did not have a header row, the first row is taken as the header row, and will now sport small drop-down menu buttons. These can be used to perform data manipulation operations on the table, as discussed in detail in Chapter 4.

If the preloaded options are not satisfactory, the user can create custom styles by using the New Table Style and New Pivot Table Style links in the Format as Table drop-down. This will pop up a window presenting the different areas in the table that can be formatted. The adjoining preview area will display the results of the selections. Once a satisfactory scheme is arrived at, it can be named as saved, and will henceforth be presented in the Format as Table drop-down list. If the user prefers to use the just created colour scheme as the default in the current spreadsheet, the option to “Set as Default Table Quick Style for this Document” can be enabled.

Selecting a Table will create a new tab in the Ribbon: “Design”. Under this tab, the user can further tweak the Table Style. Under the Table Style options, besides other things, the Header Row can be disabled in case the user has no use for the data tools. The Table Styles block displays a gallery of the other possible table styles.
While the process of converting a range of cells to a Table is easy, the reverse is relatively cumbersome. Re-converting a table to a normal cell range requires one to first remove the formatting. If the range did not have a header row and if it was automatically included while Formatting as a Table, it has to be deleted by disabling the Header Row from the Table Styles Block. Then the formatting can be removed by using the Clear option presented in the Table Styles drop-down in the Design Tab. After the formatting is removed, one can use the “Convert to Range” button in the Tools block under the Design tab.

2.3 Themes

Grouped in the Themes Block, under the Page Layout tab, is another new feature of Office 2007—Themes. This, as is obvious, offers an easy way to create a colour co-ordinated document. Office comes preloaded with 20 themes, and more can be downloaded from the Microsoft site by using the “More Themes on Microsoft Office online” link, which opens [http://office.microsoft.com/en-us/templates/CT101043361033.aspx](http://tinyurl.com/yeo9ss) in the default browser. The same themes are available across all applications that use the Ribbon—namely Word, Excel, and PowerPoint, so it becomes easier to create documents in these applications sharing the same colour scheme.

Themes influence colour and font characteristics of spreadsheet data, and the rendering style of embedded graphics like Chart, Word Art, etc. The Themes block also contains buttons to manage these three sub-categories of a theme. The components of a theme can be mixed and matched according to the user’s needs. For example, the default colour scheme of the Verve theme can be replaced with that of the Equity theme, as can the Font and Effects. If none of the existing themes’ colour codes is to the user’s satisfaction, a custom colour code can be created and applied. The same can be done in the case of the Fonts. Effects,
unfortunately, cannot be user-created, and the user is limited to choosing from one of the themes.

To apply a theme, one clicks on the Theme button. Thanks to the Live Preview feature, hovering the mouse over any theme causes the spreadsheet to reflect the changes. To apply a theme, just click on the desired theme. To change the colour code of a theme, use the Colors button. The Live Preview will show the expected changes as the mouse hovers over each entry. To apply any colour code, just click on the relevant entry. To create a custom colour code, one uses the Create New Theme Colours in the same drop-down. This will open a window containing all the items whose colour can be changed. The adjoining preview area will show the changes. After a satisfactory scheme is created, it can be named and saved. This will be shown in the Colors drop-down above the default colour schemes, and can be used just like the others.

To change the default fonts of a theme, one selects the Fonts drop-down. A live preview of the changes is shown as the list is scrolled. The required font can be applied with a click on the relevant entry. To create a custom font combination, one uses the Create New theme fonts link at the bottom of the drop-down. This will reveal a window where one can choose the desired font. After a suitable selection has been made, the combination can be
named and saved. This custom creation will appear on the Fonts drop-down, and can be selected. The Effects button lists the different colour schemes that can be used for the embedded graphics objects in the spreadsheet.

The custom-created combination of Colour, Fonts and Effects can be saved as a custom theme using the “Save Current Theme” option in the Themes Menu. User-created themes appear above the default themes in the Themes drop-down menu.

2.4 General Formatting

The most popular formatting tools are under the Home tab.

2.4.1 The Font and Alignment Block
The tools to change the font family, font size, cell border, text alignment, etc. are covered in the Font block. Worthy of mention is the Live Preview available for the font family, font size, cell colour, and font colour selections.

In the Alignment block, one can find the controls to change the horizontal and vertical alignment and the indenting. A control to modify text orientation is also available. This allows chang-
ing the orientation of the text easily. Quickly apply-able options include rotating the text by 45 or 90 degrees clockwise or anti-clockwise. Text can also be set vertically. More options are available by clicking on the small link at the bottom left of the block.

There exists a control to wrap the text so that the cell height increases to accommodate multiple lines of text, in case all the text cannot be displayed in a single line. The “Merge and Center” control can be used to quickly merge adjoining cells or Unmerge them.

The “Merge and Center” control has a drop-down menu containing the following options. First, the “Merge and Center” option not only merges the selected cells, but horizontally centres the content in one go. If content exists in more than one of the cells that need to be merged, a warning is displayed, reminding the user that cell content will be lost. The “Merge Across” option only merges cells column-wise, leaving the rows intact. “Merge Cells” will merge all selected cells. “Unmerge Cells” will undo all merge operations.

2.4.2 The Number Block
The Number Block contains the controls to set various cell content types, like currency, text, number, etc. The drop-down lists all possible data types. Other controls available offer quick formatting for percentage, currency, and inserting commas, and adding or decreasing the decimal places displayed for a fraction.
The Number, Font, and Alignment Blocks have a link at the bottom right that can be used to access the extended cell formatting options.

### 2.4.3 The Cells Block

The Cells Block contains the Insert and Delete controls, which can be used to insert and delete rows, columns, and spreadsheets. The Format button can be used to adjust cell height and width manually, or set it to adjust automatically to accommodate the content. The drop-down also lists the visibility options, which can be used to hide a row or column or sheet. To rename a sheet, one uses the Rename Sheet link. The “Move or Copy Sheet” link can be used to do just that. Sheets can be moved to a different workbook if needed, or can be saved as a separate workbook. There are also options to lock a cell to protect its value from being modified; the spreadsheet also can be locked to prevent unauthorised access. The Format Cells link allows the user to access additional cell formatting options. The sole feature in the extended options window that is not accessible from the links on the Ribbon is the one that can cause the text to shrink to fit a cell. This is available under the Alignment Tab in the same window.

### 2.5 Conditional Formatting

Graphs have been an integral part of data interpretation. Because graphs put across information pictorially, they considerably ease the process of getting the gist of a large table of figures without getting lost. Conditional Formatting (CF), in many ways, harnesses the same power of pictorial representation to describe data, making the information readily apparent and precluding the need to peruse through a table of figures.
As already mentioned, CF makes it easier to distinguish between values by using visual cues. CF allows a cell to be formatted in all possible combinations. This includes cell colour, font colour, font size, font style, and more. It even adds a new type of formatting that involves the use of icon to distinguish between cells. While there are a lot of formatting options, the “condition” options are almost as varied. CF supports conditions like greater than or less than, equal or unequal, duplicates or uniques. It can also check for non-numerical conditions, like the presence of certain text or a date. Any user-created formula that returns a logical value can also be used as the criterion in CF.

CF is accessed from the Home Tab under the Styles Block. Since CF applies to a range of cells, it is expected that a range of cells be selected before using CF. The formatting capabilities under conditional formatting can be broadly divided into two types. These are as follows.

2.5.1 Formatting All Cells in a range based on their Values
This would result in all cells in a range being given some visual cue based on certain criteria. CF comes preloaded with three types of format styles for this category: Colour Scales, Data Bars, and Icon sets. By default, selecting a range of cells and applying any of these CF styles will cause Excel to calculate the maximum and minimum values in that range and apply the corresponding visual cue. Data Bars involves displaying a bar in the cell, with the cell value determining the bar length. The resulting effect is similar to plotting a bar graph right in the column. A Colour Scale uses a two or three-colour colouring scheme, with the mix of the colours being controlled by the cell value. An Icon set uses a set of three, four or five icons to convey the information, with the value of the cell determining the colour/type of icon used.
2.5.2 Formatting Selected Cells in a Range based on their values

This other type of CF causes only those cells in a range that fulfil a certain condition to be modified.

By default, Excel offers a few preset conditions under the headings Highlight Cell Rules and Top/Bottom Rules. The Highlight Cells rules can be used to quickly identify cells whose values meet criteria.
like Greater than, Less Than, Equal to, and Between—user-defined values. Other preset conditions allow easy marking of cells that have duplicate values, or cell content matching some text or date criteria. All these conditions require the user to specify a value to compare the cell content with. The Top/Bottom rules can be used to quickly identify cells whose values meet certain statistical criteria, like Top 10 or Bottom 10, Top 10% or Bottom 10%, Above or Below Average. The default cut-off of 10% can be changed by the user.

In all the above cases, Excel offers a preset format style which can be changed. The formatting options differ in this category of CF. Here, Excel permits formatting other features like font colour, font style, and cell border, besides cell colour.

Besides the default conditions, Excel allows the user to specify a formula. Cells where the formula evaluates to 1 or True are selectively formatted. For example, this would be useful to mark
those cells whose values exceed
the value in another cell not in
the same range. As long as the
CF rule is active, changes to the
cell value in the external cell
will cause formatting changes in
the cell range.

The CF Rules manager, accessible from the CF menu, keeps a
list of all CF rules operating on
the workbook. Here, existing rules can be edited or deleted, and
new ones can be created. Custom User CF rules can be created by
using the New Rule link in the CF menu. This will open the New
Rules window listing all condition and formatting options for
both CF categories.

To remove the formatting from the cells, one uses the “Clear
Rules” link under CF.
Excel offers some very powerful features that can help you create complex spreadsheets with calculations of data spread over thousands of cells. Get all the dope you need to become an Excel power user in this chapter!
3.1 All About Cell References

Any calculation starts with a cell reference. In Excel 2007 you have 1,048,567 rows and 16,384 columns. The alphabetical columns and the numbered rows intersect to give each cell a unique reference. When you enter values into cells and want to refer to those values elsewhere, you will use the cell reference. See the simple cell reference in the below figure.

The cell reference can refer to a single cell as in the example above, or to a range of cells in the worksheet (or other worksheets in the same workbook). It can be a simple calculation using the addition, subtraction, division, or multiplication operators, or it can be a complex formula. For example, to total a list of numbers in a row or column, click on the first blank cell next to the numbers and select the AutoSum button on the Formulas tab. Excel will automatically select and total the list of preceding numbers.

When you enter cell references into a cell, you will normally enter the “=” sign first. This will inform Excel that you are about to perform a calculation. You can either enter it in directly into the cell or use the formula bar (“fx”) at the top. Generally, for simple calculations, it may be convenient to enter it in directly into the cell, and use the formula bar for longer complex cell references and formulas. In any case, as you enter the references to various cells in your cell, Excel will automatically highlight these cells in various colours to help you visually locate where these cells are located. Try it out by copying the above example into a worksheet.
3.2 Defined Names

You can also use Defined Names to use in your references. A Defined Name is a special, custom name you assign to a cell, a range of cells, or a range of non-adjacent cells (that is, cells that are not next to each other; you select multiple such cells by holding down [Ctrl] and clicking on each cell you want to include). This is useful especially in large and complex worksheets where you can get easily confused by just the cell references.

To create a Defined Name, select a cell, a range of cells, or a set of non-adjacent cells, and click on the left end of the Name box. (This is the box before the “fx” formula bar at the top.) Give a name for your selection and hit [Enter]. For example, in the figure, the area sales of Sales Division 1 has been selected together and given the name “SalesDiv1”.

Now, suppose you wanted the total of this list. Instead of giving a cell range reference [$SUM(B3:B6)$], you would simply say $SUM(SalesDiv1)$. This will greatly simplify your tasks, especially in large, complex sheets, where it will be difficult to keep track of cell references without getting confused.

A few things to note with named ranges: the name can be any alphanumeric string of letters or numbers but without any spaces. If you want to do any mathematical or formula operations on more than one range, you will have to specify each range individually. In the above example, if you wanted the totals of all the sales divisions, you would write:

$SUM(SalesDiv1)+ SUM(salesDiv2)+ SUM(salesDiv3)$
and not
$SUM(SalesDiv1•SalesDiv2•SalesDiv3)$
To change a formula or part of a formula to a defined name, or if you find it too cumbersome to type out the names, you can also use the [F3] key to pop up the “Paste Name” window, which will contain the list of all the defined names in your workbook. First, select the cell where you want to create or change a formula. If required, select the section of the formula you want to change and press [F3]. A Paste Name window will pop up, and you can select the names you want to use.

3.3 Referring to Another Worksheet

You can also create a reference to another worksheet. The easiest way to do this is to click in the cell where you wish to create the reference, type in the equals sign (=), then switch to the other worksheet and select the cell that contains the value you need.

In the figure, the value for the Marketing Budget (to be entered in the Sales worksheet, cell B8) is in cell B2 on the Marketing worksheet. When referring to another worksheet, the name of the worksheet followed by an exclamation mark should be prefixed to the cell reference. In this example, “=Marketing!B2” means, “use the data in cell B2 in the Marketing worksheet.”

You can also go to cell B2 on the Marketing worksheet, copy the cell, switch to the Sales worksheet, right-click on the Marketing
Budget cell (B8), select “Paste Special…”, and click on “Paste Link”. The reference to B2 will be pasted into the cell. In either of the two methods, any changes to the value of B2 (in the Marketing sheet) will automatically be updated in cell B8 on the Sales sheet.

There is one important difference, though, between using the Link command from the Paste Special menu and entering the cell reference manually. Using the Link command, the reference is absolute; using the other method the reference is relative. See §1.5.2 for more details.

Normally, values and the results of formulas are automatically calculated and updated into the cells as you enter them. In some cases, you may wish to not run the calculation till you have prepared all the formulas and data for your worksheet. If you do not want the values / formulas to be automatically updated, turn off Automatic Calculation: click on the Office Button, select Excel Options, click on Formulas, and select Manual under the Calculation options. Or switch to the Formulas tab, select Calculation options, and choose Manual. Now, whenever you want to calculate the values in your workbook, you will need to press [F9] or the Calculate Now button for Excel to calculate the formulas and values in your workbook. To calculate only the current worksheet, press [Shift] + [F9] or the Calculate Sheet button.

### 3.4 Absolute, Relative, and Mixed References

An absolute reference is a cell reference that doesn’t change wherever you move your data. On the other hand, a relative cell reference will change every time you move your data.

Copy the data in columns A and B in the

![Absolute and relative references](image-url)
figure into a worksheet. Now in cell C2, type, without the quotes, “=B2*$B$8”, then hit [Enter]. Select cell C2 again and hover over the bottom right corner of the cell till the mouse pointer changes to a plus sign. Then click and drag downwards to cell C6.

In the above example, the US Dollar to Indian Rupee conversion rate is specified in cell B8. In the Indian Rupees column, there is an absolute reference to cell B8 and a relative reference to the US dollar values of the items in the US dollar price column. An absolute reference is denoted by using the “$” symbol prefixed before the column reference and the row reference. In this example, the absolute reference to cell B8 is denoted by $B$8. Thus in column C, the reference to the cells in column B is relative, but the reference to the cell B8 is absolute.

You can also have a partially absolute reference, that is, the reference will be absolute for either column or row. Continuing with the above example, if you use $B8$, the reference will be absolute with reference to Column B but relative with reference to the row. Similarly, B$8 will be absolute with reference to row 8 but relative with reference to column B. You can also switch between the reference types easily: highlight the reference type you want to change and press [F4] to cycle through relative, partially absolute, and fully absolute reference modes.

3.5 Referring to Another Workbook

Not only can you refer to another worksheet in the same workbook, you can also refer to cells and cell ranges in other workbooks. You can merge data from several workbooks into a single worksheet, use formulas to manipulate the data, and also use relative or absolute referencing that will change according to how you move the data in your worksheet.

References to other workbooks will be of the form

=SUM([Sales.xlsx]Annual!B23:B49)
This type of syntax is used when the source workbook (the workbook that contains the data you want to use) is open. In this example, the name of the source workbook is “Sales.xlsx”, the worksheet which contains the data is “Annual” (note the “!” after the worksheet name), and the range where the data lies is cell B23 to B49.

When the source workbook file is not open, then the reference includes the full path to where the workbook is stored, as so:

=SUM('D:\Div1\[Sales.xlsx]Annual!B23:B49)

What will make tasks simpler, however, is the use of defined names. Simply refer to the source workbook and the named range you want to total. For example:

=SUM(Sales.xlsx!SalesDiv1)

Alternatively, if the source workbook does not have defined names, you can create your own defined name in your main workbook. Open both the source and main workbooks. Click Define Names in the Formulas tab, select “Define Name…”, and in the resulting pop-up box, give a name for the selection you are about to make. Clear the “Refers to” box and ensure that the cursor is blinking in this box. Then switch to your source workbook and select the range or cells you want to include, and click OK. You can then use this named reference in your main workbook as you would with any other reference.

You can also control how and when the external links are updated. If the source and main workbooks are open, any changes in the source workbook will be automatically reflected in the main workbook. If, for example, the main workbook is closed and the data is changed in the source workbook, then when the main workbook is opened, a security alert will pop up informing you, “Automatic update of links has been disabled”. To enable it, click the Options button and select “Enable this content”. As a security
precaution, it is a good idea to do this every time you open your main workbook.

Alternatively, in the Data tab, in the Connections group, select Edit Links. All the links in the workbook that connect to external workbooks will be displayed in the pop-up. You can then choose to update all the links, or selectively decide which you want to update and which not to.

### 3.6 3D References

A 3D reference is where the data is in the same location on multiple worksheets. For example, in the figure, there are three marketing budgets for three departments: electronics, foods, and retail. They are identical, and the data in all the cells refer to the same budget heads.

For example, to get the total for Personnel Budget for all three departments per month, you can do the following. Click on the January Personnel Budget cell (B5), type “=”, followed by `SUM()`, set the cursor to within the brackets, with the cursor blinking inside the brackets, click on the first worksheet tab “Marketing Budget -
Electronics", hold down the [Shift] key, and click on the last worksheet tab “Marketing Budget - Retail”.

'Marketing Budget - Electronics:Marketing Budget - Retail'! will be inserted inside the brackets. Next, select the range C7:10. Your final formula will look like

=SUM('Marketing Budget - Electronics:Marketing Budget - Retail'!C7:C10)

This formula tells Excel to total up the column C7 to C10 in the sheets from “Marketing Budget - Electronics” to “Marketing Budget - Retail”. Once you’ve created the formula for one cell, you can fill the relative data in the other cells by moving the pointer to the bottom right corner of the cell till it changes to a plus sign, which you can then click and drag along the same row to fill the details in the rest of the rows.

If you add any new worksheets in between these worksheets, Excel will include the data in cells C7 to C10 for all these worksheets. If you delete a worksheet or move a worksheet outside this selection of sheets, Excel will remove the data from the collection.

3.7 Excel Tables

The normal way to manage data in Excel is to specify a range, and use references and formulas to manage and manipulate the data. Excel Tables (previously Excel lists) is a feature where you can treat tabular data as an actual table. This makes things much easier to manage and work with.

You can create one, or convert an existing data range into an Excel Table. To create a table, select a range of cells on your worksheet and click on the Table button in the Insert tab, or to convert
a range, select the range and click on the Table button. A window asking you to confirm the range (with the option to include table headers) will pop up. Once you make your selection, a blank table with default names for columns (column1, column 2, etc.) will be created, or if you’ve checked the “My table has headers” option, it will use the first row as the headers. After you create the Table, the Table Tools become available and the Design tab is displayed.

Whenever you click inside the table, the Table Name will be shown. Excel will automatically give a table name—Table1, Table2, etc.—but you can give it a more meaningful description by clicking on the Table Name in the Properties section of the Design tab. You can then reference this table in other formulas or data calculations as required.

3.8 Creating Formulas to Calculate Values

Formulas are the basis for all calculation in Excel. They are essentially specialised equations and start with an equals (=) sign. The formula =7*5+3 will display the result 38 in a cell. This example is one of the simplest types of formulas you can use.

The other type of formula is where you use the cell, range, 3D range, name, or table name reference to perform calculations. Other than the standard arithmetic operators (+, -, *, /) and references, you can also use: %, ^, functions, and constants.

% is nothing but percentage, and you can either click on the % button or enter it in manually. The ^ symbol (caret) calculates the exponents of data: 2^8 is 256.

Functions are pre-built formulas that only require you to provide the cell references or specific values. For example, SUM is a frequently-used function to total up cells. Functions are great time-savers and allow you to focus on getting your results rather than waste time telling Excel what to do. There are hundreds of
inbuilt formulas you can use. Click on the Formulas tab and choose the required function from among the given categories.

Constants are numbers or values that are not calculated. For example, dates are constants (10/2/2007), and the function \( \pi \) is a constant. It corresponds to 3.14 accurate to an almost infinite number of decimal places.

Most formulas follow the syntax “\( \text{formula(value1, value2, etc.)} \)”. Here “formula” corresponds to the name of the formula, and \( \text{value1, value2, etc.} \) correspond to the values that the function requires compulsorily or optionally. Thus, the function “\( \text{Convert(number,from_unit,to_unit)} \)” corresponds to the engineering Convert function, which converts data from one measurement unit to another. In this example, if you wanted to convert 3784 days to years, your formula would be like

\[
\text{=CONVERT(3784,"day","yr")}
\]

Similarly, you can search for and use other formulas. The basic principle will remain the same but the possible values will change. In some functions, a set of core data values will be required with optional data being included or excluded. The details of each function and how to use it with examples in most cases can be found in the help documentation. If you are not sure about which function to use, click on the Insert Function button. This will display a dialog box from where you can type a short description for what you want to do, and Excel will give a list of closest matching function names, which you can then review and choose from.

You can also have one function nested in another. Example:

\[
\text{=CONVERT((CONVERT(3784,"day","yr")),"yr","day")}
\]

will give you the result 3784 after converting 3784 days to years and then the resulting years back to days.
You also have comparison operators:

\( =, >, <, \geq, \leq, \sim \)

These are: equal to, greater than, less than, greater than or equal to, less than or equal to, and not equal to, respectively. If you want to compare the values in two cells using this operator, you would, for example, enter it as: \( A1=B1 \). That is, Excel is asked the question: Are \( A1 \) and \( B1 \) equal? The result will be displayed as TRUE or FALSE depending on the data in these two cells.

There are lots more functions that are available in the Excel. For example to show you the current date and time in a cell use the formula, \( =\text{NOW()} \). If you want to just see the current date use \( =\text{TODAY()} \).

You can build complex functions using the logical operators \( \text{AND}, \text{IF}, \text{IFERROR}, \text{TRUE}, \text{FALSE}, \text{NOT}, \text{and OR} \). These operators can be used to conditionally respond to the results in a cell.

The text operators are also powerful tools that can help you manipulate text and do advanced functions. For example, you can use the \( \text{CONCATENATE} \) function to join text from different cells into one cell.

Another useful function is \( \text{COUNT} \) and its variants; this function will show you the count of cells based on criteria that you can specify.

### 3.9 Moving, copying, and editing formulas

You edit formulas by clicking inside the cell and selecting the values you wish to change or replace. For example, if a cell had the formula \( =\text{SUM(A2:A10)} \) and the name of the range A2 to A10 was TotalCost, you could edit this formula by clicking inside the cell and replacing A2:A10 with TotalCost. The formula would then look like: \( =\text{SUM(TotalCost)} \).
You use the Cut and Copy commands to move or copy formulas respectively. If you use the Cut command, the cell references will not change whatever be their type—relative, absolute, or partially absolute. If you use the Copy command, the cell references may change depending on the type of cell reference.

To copy the formula, select the cell with the formula and press [Ctrl] + [C], or right-click and select Copy. Move the mouse to the new cell where you want to the formula to be copied, and select Paste or Paste Special > Link, or use [Ctrl] + [V] to paste the formula into the new cell. Make sure that you verify that the formula is referencing the correct data cells and that the result is in line with what is to be expected.

If the data is not as you expected, you can try switching the cell reference by using the [F4] key as explained earlier. Select the cell reference you want to change and press [F4] to cycle through the various possible combinations of cell reference types.

To move the formula, select the cell with the formula and press [Ctrl] + [X] or right-click and select Cut. Move the mouse to the new cell where you want to the formula to be copied, and paste the formula into the new cell.

3.10. Validating data during entry

When you are entering data, you can limit your chances of error and make data entry easier by defining the valid entries. You can have Excel automatically validate the entries in a cell based on a whole number, decimal number, date, time, length of text, or a custom formula. You can define the upper and lower limits for valid ranges for the numbers and time units, define a list of items that must be used, provide a custom message to guide the users when they try to enter data, and also provide error messages when they attempt to make a wrong entry.
To perform validation of the data entry in a cell, select the cell first and then choose the Data Validation command. This can be found on the Data tab under the Data Tools group.

In the resulting pop-up, you will get an “Allow” drop-down list. This list contains the types of data that you can control for entries.

To control the validation on the data entry for the cell, select the data type first. The choices you have are: Whole Number, Decimal Number, List, Date, Time, Text Length, and Custom.

If you choose Whole Number, Decimal Number, Date, Time, or Text Length, you have the further option to specify whether the data should be between, not between, equal to, not equal to, greater than, less than, greater than or equal to, and less than or equal to a maximum and minimum value. In such a case, any data that falls outside this range will result in an error warning if you give a customised error message in the Error Alert tab. You can also give a custom message on the Input Message tab which will be visible to users when they choose that particular cell.

If you choose the Custom data type you will have to specify a formula that will be used in validating the data entry. You will need to enter a formula that calculates the logical value TRUE or FALSE.

If you choose List you will need to specify a list on the same worksheet or a named range on another worksheet. To do this, first create a list on the same worksheet, or on another worksheet, and give it a name. Then click on the cell and choose Data Validation. Select the List option in the Source box, select the cell range in the same worksheet or enter the name of the range on
the other worksheet. Specify any custom Input Message and Error Alert messages you want to show your users and click OK.

The cell can be left blank without data entry if you select the Ignore Blank checkbox. If you clear this checkbox, you will be required to enter data.

In the List option, the “In-cell dropdown” option can be used to show an arrow when the user selects the cell. The user can then click on the cell and select the data from the drop-down list.

Finally, to minimise errors and to prevent your cells from being accidentally (or deliberately!) deleted, you can enable protection for your worksheet. To do this, first select the entire worksheet, right-click, and select Format Cells. In the Protection tab, select Locked, and click OK. Next, select the cells you’re going to allow users to edit. Open the Protection tab and clear the Locked tab. What this has effectively done is designate the entire worksheet as locked, with only the cells that users are allowed to edit being marked as unlocked.

Next, go to the Review tab, and in the Changes group, select Protect Sheet. In the resulting pop-up box, choose the actions that you will permit users to do on the worksheet, give a password for the protected sheet, and click OK. You can also leave it as a blank password but any user can unprotect the sheet without the password. The blank password is useful if you are more worried about forgetting the password and just want to prevent accidental data entry without being too concerned about security.
3.11. Finding and correcting errors

As formulas get more complex, the chances of errors creeping in become higher. Some errors will announce themselves to you with some error condition; others may not be so simple—you may have given an incorrect reference that will make for a wrong result.

When Excel itself reports errors with the formula, they are relatively easy to correct. There are different types of standard error conditions that will give you a good indication of where exactly to look to correct the error.

First, however, you have to take certain precautions when entering formulas:

- Ensure that the brackets are properly matched. This is especially a problem with nested formulas (one formula inside another which again maybe inside another formula). Take care to ensure that all the brackets are correctly used. Excel will normally catch any bracket errors, but it can miss them when the formula is complex. The maximum level of nesting in any case is 64.


- Ensure that all the required values (or “arguments” as they are called) are entered into the formula. Each formula may have required values and optional values; at the minimum, the required values have to be entered to prevent Excel from bringing up an error.

- If you refer to cells in other worksheets, ensure that the worksheet name is enclosed in single quotes. If you are referring to links in an external workbook, ensure that you have entered the full path to that workbook.

Excel error checking is rule-based, and it tries to learn your preferences as it goes. Any errors which you ignore, Excel will also
ignore when the error is repeated. These errors will be hidden from you, and you will need to manually reset it if you want to see them. To do this, click the Microsoft Office Button and select Excel Options, click on the Formulas tab, and under the Error Checking section, click Reset Ignored Errors.

In the Error Checking Rules section, check or clear all the rules that you want you want Excel to use to check for errors.

You can also get Excel to check for errors one at a time, much like a grammar error checker. If you want Excel to recheck all the errors first, reset the ignored error check. Next, select the worksheet you want to check for errors, and on the Formulas tab, in the Formula Auditing group, click on Error Checking. The Error Checking dialog box is displayed and it will take you to the first error in the worksheet. The dialog box will show the formula (or a part of it if it is too long), a diagnosis of the error, offer a suggestion on what is to be done, provide additional help, and provide the option to ignore the error or edit in the formula bar. You can make your choice on what action to take and then click Next to go to the next error.

If you want Excel to display errors as you work, ensure that the Enable Background Error checking checkbox is ticked in Excel Options > Formula. Now when an error occurs with a formula, Excel will instantly display an icon of a golden-coloured diamond shape with a red icon inside it. This means there is an error in the formula and that it needs to be corrected. Clicking on the icon will
give you a list of options that will help you decide on what action to take. If you specify Ignore Error, this type of error won’t be checked for again till you reset the error checking.

If you have too many formulas or your sheet is very complex, you can gather all your formulas into one place and “watch” them conveniently. By using the Watch window, you can keep track of all your formulas in a single window and see the result of any changes without having to scroll through the entire worksheet.

To enable the Watch window, first select all the formulas in your worksheet. Go to the Home tab, and in the Editing group, click Find & Select and go to the “Go to special...” command. A dialog box will pop up, where you select the radio button option “Formula” and leave all the boxes under Formula checked. Click OK. This will select all the formulas in the worksheet.

Next, switch to the Formulas tab and select the Watch Window under Formula Auditing. In the dialog box that pops up, click on the Add Watch... button. All the selected cells will be displayed in a dialog box which you can then confirm by clicking Add. You can, of course, remove any formula which you do not want to watch for changes.

As cells are updated and data is modified, the watch window will display the changes as they happen. You will not need to scroll to different parts of the worksheet to see how your data changes. This can be especially helpful with large spreadsheets as you will be able to see the results and instantly be alerted to any errors.
There are a number of ways to trace a formula so you can check it for errors if needed or just review the logical steps it takes in calculating the result.

Formulas can be evaluated step by step. This will show you the logical steps taken in calculating the result, and is especially useful when you are dealing with large, complex nested formulas, which can easily get very confusing.

To evaluate a cell with a formula, first select the cell and click on the Evaluate button on the Formula Auditing group in the Formulas tab. In the resulting dialog box, you’ll be able to see the entire formula first. Click on the Evaluate button, and the first calculation in the sequence would be calculated. Once you are satisfied with the result and the logic of the step, click on the Evaluate button again to go to the next part of the formula to be evaluated... and so on.

This process will help you confirm that there are no incorrect references and that the logical steps involved in the formula calculation are as you want them to them.

You can also trace a formula visually by looking up the Precedent or Dependent cells. Precedent cells are referred to by a formula in another cells. Dependent cells have formulas referring to other cells. The Trace Precedents and Trace Dependents commands will graphically display the relationships that a formula has with other cells.

To view the Precedence and Dependence of a formula, first go to Excel Options in the Office Button, select Advanced, and scroll...
down to the “Display Options for this workbook” section, under the “For object, show” section, ensure that All (or Placeholders) is selected. If you have any external references to other workbooks, open those as well.

Next, select the cell whose formula you want to trace. In the Formulas tab, click on Trace Precedents and/or Trace Dependents as required. Blue arrows will show the references to and from the cell if there are no errors. If there are errors, a red arrow will be shown. If the data is in another worksheet, a worksheet icon will be shown.

You can click on the Trace Precedents and Dependents button again and again to trace the formulas to multiple levels. To remove all tracer arrows, click Remove arrows. Once all the levels have been traced, Excel will inform you that there are no more levels to trace. You can double-click on the black arrow which points to an external reference and in the resulting Go To pop-up window, select the sheet where the reference is.

Tracing the cell reference in this way will help you to visualise where all the data is coming from, and analyse for logical errors and inconsistencies.
Creating and maintaining long lists and tables of names and numbers can be worthwhile only if all that data can be easily sifted to cull relevant information. Excel packs in all the required features, in the form of data functions or data tools, to organise and interpret the data in spreadsheets. We shall discuss them now.

Charts and Graphs, which are also a part of Data Interpretation, are discussed in Chapter 6.
4.1 Data Tables

Excel can perform calculations on data, which you know very well. The fact is, you can also make decisions based on the data: what if this variable were this much more? It turns out that this is actually called “What-If Analysis.” This deals with observing exactly how changes in the input cause changes in the results of a formula.

In Excel, a Data Table is the tool to perform a What-If analysis on a formula. It’s pretty simple: the changes in the results of the formula—caused by changing the values of the input variables—can be tabulated in a Data Table.

At the centre of a What-If analysis lies the formula. Since the Data Table in Excel 2007 can support a maximum of two-variable What-If Analysis, the formula being put to the test needs to meet this condition. There’s no real magic happening here: you can do a What-If Analysis by replacing the input variable and noting the results. But since you have Data Tables, it’s simplified. Just command Excel to make a Data Table, and change what needs to be changed—and the What-Ifs appear all nice and neat in the table.

Now for some rules. The different values that you intend to test your formula with need to be filled in a single column or row, if only one input variable is changing. You can’t have them scattered. If two input variables are changing, the two series of numbers need to be put in a column and a row. Excel has strict rules about the relative positions of the rows and columns and the formula-containing cell, and you need to follow these for the tool to function.

You fire up the Data Table tool from the Data Table Link under the What-If Analysis drop-down in the Data tab.

To make it easier to understand what’s going on, let’s use a simple example involving capital and rate of interest. Say cell B1 contains Capital Amount and cell B2 contains the Rate of Interest. The formula to calculate interest (Capital multiplied by Rate of
Interest) is B1*B2. We can use a Data Table to see how changes in Rate of Interest and/or Capital influences the interest amount.

**Case 1: One-Variable Data Table**

For this purpose we shall assume that the rate of interest is fixed at 10%. So cell B2 contains “10”.

We can list different capital amounts in Column A, in the cell range A5:A10. Excel dictates that the formula, in the case of a One-Variable Column Data Table, should be in a cell that is one column to the right and one row above the first value of the input column. In our case the formula should be in the cell B4.

Having ensured this, select the cell range A4:B10, consisting of the input values and the formula cell, and launch the Data Table tool by clicking on the Data Table Link. A window will pop up and ask for the “Row Input Cell” or “Column Input Cell.” Since our data is in columns—that is, we are dealing with a Column Data Table—the Column Input Cell needs to be mentioned. This will be the input factor which will be changed with the values in the column. In our case, since we are changing the Capital amount, the Column Input Cell is B1. Clicking on OK will populate the cells B5 to B10 with the different interest figures calculated by changing the Capital figures in A5 to A10.

In the above scenario, we could have used the cells B5:G5—that is, a row—to populate the different Capital amounts. In this case, the formula needs to be in the cell that is one row below and one column to the left of the first value in the input row. This means the formula has to be entered in the cell A6. The cell range A5:G6 has to be selected before launching the Data Table Tool. The Row Input Cell
will be B1. After the process is done, the cell range B6:G6 will be populated with the different Interest Values arrived at by changing the capital values listed in B5:G5.

Case 2: Two-Variable Data Table
To study the effect of simultaneous changes in Capital Amount and Rate of Interest on the Interest amount, we need to create a Two-Variable Data Table. In this case we can populate the cells A5:A10 with different Capital Amounts, and the cells B4:G4 with different Interest Rates. This relative position of the Row and Column is dictated by Excel. Excel also dictates that the formula has to be in the cell where the Input Row and Input Column meet, which in our case is the cell A4.

Now select the cell range A4:G10, and launch the Data Table tool. The Row input cell is B2 (Rate of Interest) and the Column Input Cell is B1 (Capital Amount). On completion, the cell range B5:G10 will be populated with the different Interest amounts.
4.2 Sorting and Filtering

You’ll often find yourself needing to sort and filter data in Excel. The Tools to perform Sorting and Filtering operations on a range of cells are in the Sort and Filter block under the Data Tab. These are also accessible from the Sort and Filter button in the Editing Block under the Home Tab.

4.2.1 Sorting

To sort a range of cells, you select a cell in the column to be used as the sorting criteria, and click on the Sort Ascending or Descending button in the Sort and Filter Block. Alternatively, you can right-click on the cell and use the Sort menu to choose the desired sorting operation. The Alternative Menu offers more sorting options, like sorting based on cell colour, font colour, and cell icon (allotted by Conditional Formatting using Icon Sets).

Since the above allows only one sorting key column, if more complex sorting rules are to be applied, you can use the Sort button in the Sort and Filter block. This opens a window that allows multiple levels of sorting. By default, one level is already presented, and more can be added by using the Add Level button. Under the possible Sort Key criteria, you’ll see that Cell Colour, Font Colour, and Cell Icons can also be used. Under the Order drop-down, you can specify the sort order.

The sequence of the sorting levels is important. Controls to change the sequence are also available in the same window. While there exist quick access button to sort columns with a single click,
sorting rows is not as easy. In the Sort Window obtained as mentioned earlier, click on the Options button. Here, set the Orientation to “From Left To Right”. By default, text sorting is not case sensitive; this behaviour, too, can be changed from the Options window.

A Custom List allows you to sort data in certain hierarchical order not already recognised by Excel. You’ll realise the importance of this when you’re sorting a column containing the names of the months. Normal sorting in ascending order would result in the names being arranged alphabetically with April ending on top. If you want to sort the names in ascending chronological order, which would end with January at the top, Excel needs to be informed about the hierarchy to be observed. The Custom List fulfils this purpose. Thoughtfully, Excel already has custom lists of the names of months and weekdays. This allows the columns containing either of this type of data to be sorted chronologically, besides alphabetically. If needed, you can also create a custom list. To use the Custom List as the sort key, this needs to be selected in the Sort Order field.

Sorting options are also available on formatting a range of cells as a table. On the creation of a table, the Header Row cells will contain data controls offering Sorting and Filtering Options similar to those discussed earlier.
4.2.2 Filtering

When you use filtering, you limit the visibility of a table’s contents to only those entries that match the criteria specified in the filter. To perform a Filtering operation on a range of cells, select any cell in that range and click on the Filter button. This will cause the first row of the range to be converted into a header row with each cell containing a drop-down menu that shows the filtering options. The drop-down contains a few inbuilt filters that can discriminate between numbers and colours of the cells.

The Number Filters link already offers a few filter criteria like Above, Below, Greater Than, etc. Selecting any of these will open up a window to choose the threshold value. This window can also be used to create a Custom Filter, and you can also use wildcard characters like “?” and “*”. You can also create a compound criterion by adding the AND/OR clause and adding another condition. The Above Average and Below Average filters simply calculates the average for the column, and displays only those which fulfil the corresponding condition.

You clear Filters by clicking on the Clear button in the Sort and Filter Block. The Advanced button allows creating more complex filter conditions than those already mentioned. Conditions that can be used under Advanced filtering can include simple mathematical operations, wildcards, and even functions supported by Excel.

Before using Advanced filtering, a little preparation is needed.
To be able to use this feature meaningfully, all columns in the range should have a Heading. The heading of the columns that will be used as the condition has to be copied to another place, to be used as the Criteria Range. To specify a condition, the following rules apply:

A condition has to be a formula. Since simply entering a formula will cause Excel to execute it, the Formula must be circumscribed with quotes and prefixed with an equals sign (=). For example, to check for cells with a value greater than 10, the Criteria cell will contain the value

`=“>10”`

To specify a compound condition with an AND, you use the same row. To specify a compound condition with an OR, you use a different row. For example, to filter cells under the title Cash whose values are between 50 and 60, you create a Criteria Range with two columns having “Cash” as title, and insert `=“>50”` and `=“<60”` as values in the same row. To filter values less than 50 or greater than 60, you use the formulas `=“<50”` and `=“>60”` in the same column, in different rows. You can also create conditions for all columns simultaneously.

### 4.2.3 Performing operations on Filtered Lists

Since entries in a filtered list are just hidden—they’re not deleted—values of the hidden cells are also considered while performing operations or using functions on the range. To get around this problem, under the Find and Select button in the Editing block under the Home Tab, use the Go To Special link and enable “Visible Cells Only”.
4.3 Organising Data Into Levels

Large spreadsheets can be cumbersome, partly because of the scrolling involved to get to the desired location. Excel has tools to Go To a particular cell quickly, and allows freezing windows so it is possible to keep sight of important figures while scrolling to a different location. Adding to these features that ease the management of large spreadsheets is the concept of Levels. You can see how useful this feature is by comparing it to the tree listing of Folders in the Windows Explorer Folder Pane: you can expand the listing of the drives in the system to reveal the top levels folder in the drive. Those Folders, which in turn contain other folders, have a “+” next to their folder icon. Clicking on the “+” will cause the node to expand to reveal the folders under it. This continues until the “+” mark in the node is replaced with a “-”, which signifies that there are no further nested folders in that node. Clicking on the “-” causes the node to roll up the listing of folders under it.

To make a large block of data manageable, Excel allows you to select cell ranges in it and mark them as groups. Groups are like folders in the Windows Explorer tree listing; they can be expanded or collapsed with a single click. Remember that the cells forming a Group need not meet any criteria, and need not share a common feature.

Groups can be created horizontally or vertically. If you’re doing Vertical Grouping, a scenario similar to the Windows Explorer Folder Pane is created, with a pane appearing on the left margin containing the “+” and “-” controls. If you’re doing Horizontal Grouping, a pane appears on the top and the nodes
and the expanding and collapsing occur horizontally. You can also nest groups of cells as well, which is where the term “Level” becomes relevant. A nested groups of cells can only be accessed if the group encompassing it is expanded, just as in the case in Windows Explorer where the folders inside another can only be seen if the latter is expanded. The level denotes the order of nesting of the group.

To create Groups and Levels, you have the tools under the Outline Block in the Data tab. To create a group, select the range of cells and click on Group. You can then choose whether the group is to be created row-wise or column-wise. Depending on whether the grouping was done row-wise or column-wise, a set of controls appear on the left margin or the top margin of the spreadsheet. A set of buttons labelled 1 and 2 appears at one end—either the top of the left margin or the left end of the top margin. This set of buttons shows the levels of nested groups in the spreadsheet, and allows quick access to any specific level.

Excel supports up to eight levels of grouping, so the number of controls can go up to nine. Besides the buttons, the “+” and “-” controls, as in the Windows Explorer Folder Pane, also appear in the same area. The significance and use of the “plus” and “minus” controls are similar to those of their counterparts in Windows Explorer.

When you click on the Control with the largest number, you’ll reveal the ungrouped spreadsheet. As you click lower-number Controls, the nodes of those levels are expanded.

Many groups can be created in the same level, and you’d do well to create a
new group when all existing groups are collapsed or when the lowest-level button is active. If two groups overlap, the common cells in both groups are grouped at the next higher level.

The hidden cells, when the nodes are collapsed, are not available for use in any formula, and charts prepared from the visible items will change to reflect the changes in the visibility of the source range.

The Ungroup button in the same block can ungroup a cell range. To remove all groups in the spreadsheet, select one cell and use the Clear Outline option. Auto Outline automates the process of creating levels, and is used with the Subtotal feature to Summarise data, as discussed next.

### 4.4 Summarising Data

Grouping large blocks of data facilitates the handling of large spreadsheets by reducing the scrolling required. But this in no way offers any information regarding the contents of the spreadsheet. Summarising is an important process used to convey the important points pertaining to a large block of data.

Summarisation usually involves collating the important or interesting bits of information about a large block of data. Information like Total, Maximum, Average, Number of Records etc, are part of any summary report. Excel offers the Subtotal tool to accomplish summarisation of a large block of data. The name is a misnomer, since the same tool can be used to generate other summary information like Average, Maximum, Number of records, etc. As part of the summarisation process, Excel creates Summary Rows to report the statistics of a group of similar entries. An overall summary for all the groups is also added. When combined with Excel’s ability to create levels of groups, you can easily manage and summarise large blocks of data.
Before a range of cells can be summarised, it should have proper column headers. It also needs to be sorted on all columns that will form the summary group. For example, to create a product-wise, monthly summary of the sales performance of the salesmen in an organisation, the data should not only be sorted on the name of the salesman, but also on the month and product name. In this case, what you need is a multi-level sort.

The Tools to summarise data are available under the Outline block under the Data Tab. After the sorting is complete, you select a cell in the range and click on the Subtotal Button. This will open a window listing the various summarising options. The column whose value is to be used as the key needs to be identified under the “At each Change in” field.

Besides Sum, other summarising operations like Count, Average, Maximum, etc. are also provided under the Use Function field. The columns which need to be given a subtotal row can also be selected. You can also choose whether to display the summary data below or above the data. The result of performing a Subtotal routine is that a row is inserted, at every change in the value in the Summary column, which will carry the results of the chosen summary operation. A final grand total row is inserted at the end of the cell range carrying the summary figures for the entire range.

When the Subtotal process is complete, the Group controls make an appearance on the Left Margin. The use and significance of these controls have already been described in the previous section. If the Group controls are not needed, the Clear Outline link under the Ungroup button can be used. To re-apply the controls, use the Auto Outline option under the Group button.
The grouping added by the Subtotal Routine is based on the number of sort levels used. In our example of the performance of the salesmen in an organisation, the result of a Summarising operation will have a three-level grouping, with the product group nested in the monthly group nested in the Salesmen group.

4.5 Using Indexed Data

A spreadsheet can be indexed, or sorted, by using any of the columns as the sort key. After a spreadsheet has been indexed, it becomes easier to look up information in it. While this would be easy in case of small spreadsheets, large spreadsheets would require a lot of scrolling or repeated use of the Find and Select tool. Excel packs in two functions that automate the index lookup process.

4.5.1 The **VLOOKUP** and **HLOOKUP** Functions

**VLOOKUP** is a function that looks up a user-specified value in the first column of a cell range, and returns the value of any cell in the same row. For example, if the details of the students of a class is stored in a table, with the table being sorted on the Students’ Roll Number, and the other columns being Name, Age, Address, VLOOKUP can be used to return the Address of a student by providing his Roll Number.

The syntax of **VLOOKUP** is

**VLOOKUP(Value to Lookup, Cell Range, Column Offset of cell to be returned, Type of lookup toggle).**

The “Value to Lookup” can be Text, Number, or a Logical result.

The “Cell Range” is the reference to the range that has the column containing the value to be looked up as the first column.
The “Column Offset” is the position of the column, counting from the left, from which the cell value is to be returned. So to return the value from the second column of the range, the Column Offset will be 2.

By default, VLOOKUP looks up an approximate value if an exact value is not found. For example, if the value being looked up is 300, in the absence of 300 the nearest value is looked up and the cell value in the offset column is returned. If only the exact value is to be returned, the default behaviour can be curtailed by specifying FALSE in the Type of Lookup Toggle field. In this case, if an exact match is not found, the “#NA” error is displayed. Since this field is optional, entering TRUE, or leaving this field empty, will result in the default behaviour.

Before VLOOKUP is used in its default mode, the cell range needs to be sorted in ascending order of the sort key column. If only exact matches are to be looked up, the sorting is not needed.

HLOOKUP is similar to VLOOKUP, the difference being that HLOOKUP looks up data in the first row of a cell range. The HLOOKUP Function has a similar syntax, with Column offset being replaced with Row Offset. (In case it isn’t obvious, the V and H in VLOOKUP and HLOOKUP stand for Vertical and Horizontal respectively.)
Pivot Tables

The PivotTable is one of Excel’s most powerful tools. It helps you drill down deep into numerical data and see unanticipated scenarios, with which you can make better-informed decisions. It helps you summarise and analyse data, see comparisons, patterns, and trends both in tabular form as well as in PivotChart reports. This chapter will show you how to get the best out of PivotTables.
5.1. Creating And Using PivotTables

To create a PivotTable, you need to have your data source ready first. This could be an Excel Table, a range of cells that contain the data you require, or an external data source like an Access database.

Click anywhere inside your source data, select the Insert tab, click the PivotTable button, and select either PivotTable or PivotChart. If you select PivotChart, it will create a chart based on your data elements selection (see later in this section for more on data element selection). However, it is better to create your PivotTable before delving into charts—this will give a better idea of how your data looks, and you can fine-tune your data view before making the charts. The chart option is useful when you are ready with your data and you are certain about how your PivotTable should be and all you need to do is quickly make your chart.

In the Create PivotTable Wizard’s pop-up window, the range will get automatically selected, and the radio button “Select a table or range” will be highlighted. You can change the range by clicking back on the worksheet and selecting a new area, or by manually entering the cell references. You can also take a reference from a different worksheet or workbook. If your source data is in a different worksheet, switch to that worksheet and select the range there. However, you typically will not need to do this as you can just switch to the source data worksheet and run the PivotTable Wizard, which will prompt you to create a new worksheet. If you want your PivotTable in a different workbook, open that workbook as well as your source data workbook first. Run the PivotTable Wizard in your target workbook (the workbook where the PivotTable will be created), click inside the “Table/Range:” field, and switch to the workbook with the data and select the range.

You can also specify a name for the source data range, or convert it into an Excel table and use the table name. Using tables can be very useful when your source data keeps changing. As data gets
added or deleted from the table you need not change the cell reference range in your PivotTable, something you’d have to do if you specified just a cell range or used a name for the range. Because you are using a table name, Excel will automatically include or exclude any data rows added or deleted from the Excel Table. See Chapter 3 to learn about Excel Tables.

In the below example, the sales for October 2006 is an Excel Table with the name “Sales_Oct06”. This makes it easy to keep track of the data when any additions or deletions need to be done.

You also have the choice of choosing another data source by clicking on “Use an external data source” radio button. External data can come from many sources including text files, from databases like Access and SQL Server, from Web sites, and many more. If your data is not in Excel, you can import the data using the connection tools in the Get External Data group on the Data tab.

Finally, you can have the PivotTable on the same worksheet or on a new worksheet. Select “New Worksheet” and click Next or “Existing Worksheet”, specify a location, and click OK. An empty PivotTable report is added to the location you specified.
Once the blank PivotTable report is ready, you can customise it to show the data as you like it. In the PivotTable Report page, on the left you will see a pane with five windows. This is the PivotTable Field List. The first window shows all the fields (or data elements) that can be added to the report. These can be dragged and dropped into the four windows beneath.

The “Report Filter” window allows you to narrow down the report using specific criteria. The “Column Labels” window specify what data will be displayed in the columns. The “Row Labels” window specifies what rows will be displayed in the rows. The Values window tells you which values will be shown in the various fields. Each of these windows corresponds to certain parts of the PivotTable report.

You can select the “Defer Layout Update” checkbox to prevent the changes from being shown instantly. This may be useful when you want to focus on designing your layout and don’t want to be distracted with till you’ve organised all the data elements and formulas as you wish to see them. Once you’ve done that, you can click “Update” to show the changes.
Drag and drop the columns from the main upper window into any of the four windows. As long as you keep the layout of the PivotTable report in mind, you will be able to logically decide on what needs to go where. You can experiment with different ways of viewing the data by moving the columns around and watching the data change dynamically. This way you will come across different ways in which the data can be viewed. Some will be ways you've never thought of before, or wondered about without an idea on how to extract the information from your raw data. Some selections will turn out to be meaningless, but you can create powerful and well-designed reports when you use the correct data elements in their correct places and apply the most appropriate formula.

5.2. Analysing Data With PivotTables

Selecting data fields

Explaining how to analyse data using PivotTables is best done with the use of an example. Note, however, that this explanation will be limited, and is more to give you an understanding of the depth and complexity in data analysis that you can achieve with PivotTables.
In our example, we have used the sales data for a Web hosting company's sales for October 2006 for their three departments: Web Design Sales, Web Hosting Sales, and Bandwidth Sales.

We can create a simple PivotTable report by clicking on the fields: Customer ID, Web Design Sales, Web Hosting Sales, and Bandwidth Sales. Excel will automatically make the following selections: Customer ID will be moved to the Row Labels, the Sum of Sales for the three departments will be shown in the Values area, with Values as the corresponding Column Labels. The result will be as in the figure below.

The report now shows the total sales for each customer for each department. You can change the Row labels to show sales by date by dragging the Date field to the Row Labels window. This will then show the data in a nested manner depending on which data element is first. If the Date field is below the Customer ID field then you can see the sales for each customer by their respective dates.

You can then collapse or expand the nesting by clicking on the “+” button next to each Customer ID. Nesting is a powerful function that enables you to combine two data fields in one view and
will help you analyse the data both at the summary and detail level with the single click of a button.

If you move the Customer ID to the Report Filter area, you will now see the sales by date. By default, Excel will select all the Customer IDs for display—denoted by "(All)" in the filter field. You can then narrow the selection and choose to see the sales data for a limited set of customers—a minimum of one.

You can select on the "All" checkbox to show all the customers or select one or more Customer IDs from the list. Make sure that the "Select Multiple items" checkbox is ticked before selecting more than one customer. Report filters help you narrow down data based on criteria you specify. You also click on the drop down arrow on the Row Labels heading and get access to additional row level filtering options. Using this option you can select multiple filtering criteria to narrow down your selection.

Any of the data fields in the four window areas (Report Filter, Column Labels, Row Labels and Values) can be further manipulated by simply click on the data field and selecting an option from the menu which pops up. The first three sets of options enable you to
move the data fields around, in between the other windows or remove them. The Value Field Settings option allows you to further customise how the data should look. Value Field Settings help you control how the data should be summarised and how the values should be shown. The “Summarize by” tab allows you to choose from various options on how the data should be summarised. The “Show values as” tab enables you to further apply rules on how the data should be calculated and displayed. For example, you may show the sales of the three departments as a percentage of the total sales of each department. In this case you would select “Sum” in the “Summarize by” tab and “% of total” in the “Show values by” tab. You may then apply additional filters to narrow down your selection and view your data as you please. For example, the figure below shows the sales as a percentage of total sales for web design in descending order.

By right-clicking on any of the fields in the Row Labels column, you get quick access to some filter options with which you can sort, filter, group, ungroup, or move the data.
If the built-in functions and calculations do not provide you with the results you want, you can use your own formulas to calculate the results required. You can either create a formula that will calculate the results for a field (Calculated Field) or for one more item in the field (Calculated Item).

To create a formula based on the Calculated Field click on Options and in the Tools group select Calculated Field from the drop-down of the Formulas button.

In this example, we have created a new Field called Field2, where the total of Web design and Hosting is shown. To create a formula based on a Calculated item, click on Options and in the “Group” section, click on Ungroup and click on the field where you want to add the calculated item. Then click on the Tools section and select Calculate Item. Depending on which cell you have selected in the PivotTable, the Calculate Item field maybe enabled or disabled. If it is disabled, Excel will not be able to perform item level calculation on that field.

In this example, we have inserted a row into the PivotTable
Report that shows the total count of the Customer ID A15 for sales from the three departments.

Finally, you can get a quick view of all the formulas in your PivotTable by clicking the List of Formulas option in the Formulas button in the Tools group. Advanced users can also get more fine-grained control by specifying the order in which you want the formula to be solved by using the Solve Order option in the same Formulas button drop-down.

5.3. Editing And Formatting PivotTables

You cannot directly edit the cells in a PivotTable, but you can change the values in the source data, refine the formulas, and rearrange the data using the Report Filters, Column Labels, etc. Once you’ve made the changes, you can refresh the PivotTable by right-clicking and selecting Refresh to get the revised data.

Once you have the data and all the elements you require, you can format your PivotTable to make it look attractive and enhance its readability. Using charts is one way to present the data in a visual form that is easily accessible to the users. To create a chart, click on the PivotChart button under the Options tab. Choose the chart type and click OK. You can use the PivotChart Filter Pane to adjust the look and feel of your graph.

Other than PivotChart, you can apply different kinds of formatting to the PivotTable itself that will improve its look and feel in print or other reports.

One option is to manually format the PivotTable, an individual cell or a cell range in the table using the Format cells option when you right click. This option will enable you to control the formatting exactly as you want it. Note, however, that the Merge Cells option in the Alignment tab will not work in a PivotTable report.
There are three basic formats to present the PivotTable report in: Compact, Tabular, and Outline. Click on the Report Layout button in the Layout group on the Design Tab to choose which format you want it to be in.

The Compact format minimises the data to show it in one screen as far as possible. The Outline format is the classic PivotTable format, and the Tabular format presents the data in a table format to make it easy to copy it from one sheet to another.

In the PivotTables Styles group you can select pre-formatted colour templates that make it easier and simpler to quickly choose a colour template. Click on the down arrow button to choose from a variety of style and colour combinations. You may choose one you like and then manually change the formatting for any particular elements that you want to have a different look. In the PivotTables Styles Options group, you can further control how the formatting should appear. For example, after selecting your colour template, you can specify that you should have alternate colour bands in rows (Banded Rows). You can further format your PivotTable in the Layout & Formatting tab in the PivotTable Options window under the PivotTable group in the Options tab. Similarly, you get further formatting options under the Field Settings option in the Active Fields group.

You can also use a conditional formatting option to get the...
most out of your data. This is especially useful when you want to highlight exceptions in the data that may otherwise not be quickly visible. To quickly apply conditional formatting, switch to the Home tab after selecting your range of cells. Select the Styles group and use the options in the Conditional Formatting button. These options allow you to specify rules on how the data within the selected range should be highlighted.

5.4. Creating PivotTables From External Data

To connect to an external data source—which could be an OLAP (Online Analytical Processing) server, text files, Access database or any other valid source of data—you can use the Workbook Connections dialog box. Note that with the new security features access to external data sources may be disabled in Excel 2007. You will need to enable them from the Microsoft Office Trust Center in Excel Options under the Office Button.
To access the Workbook Connections dialog box click on the Connections button under the Connections group in the Data tab. Click on the Add button and you will see a list of existing connections that you can use.

If this is the first time you are connecting to the external data source, then depending on the source you are connecting to, you can use one of the options in the Get External Data group in the Data tab.

Clicking on Existing Connections will open a dialog box which is the same as the one you get when clicking on the Add button in the Workbook Connections dialog box.

You can click on the Other Sources button if you want to get access to data from SQL Server, Analytical Services, and XML. You can also use the Data Connection Wizard and Microsoft Query to
create customised connections and queries to relational database systems.

You can also import data from text files, Access databases and even directly from the Web. Of these, the ability to directly import from the web is a brand new feature. Simply click on the From Web button and type the URL of the address you wish to use in the dialog box.

The window will access the Web like a regular browser but with a difference: a special yellow arrow highlight will tell you what you can import into Excel. Select the sections you want to see in Excel by clicking on it. The yellow arrow will change to a green tick-mark. Once you are satisfied with your selection, click Import. Excel will ask you where you want to put the data. Choose the required location and click OK. The import function may not however work uniformly with all sites—especially sites where data is being dynamically generated from a database every time you access it. You can also specify additional conditions like background refresh where the data will be kept synchronized with the website. This of course, assumes that you have an always-on Internet connection.
In Excel, graphical representation of data series is done using charts. Charts have always been an integral part of spreadsheets. Over time, charts generated by spreadsheet programs have improved in terms of visual appeal.
Trends and patterns in data can be observed from charts, trends which might go unnoticed from numbers in a worksheet. For instance, if you have a table with two or more data series, you can use charts to quickly draw inferences from it. If used wisely, charts can give a comprehensive overview of worksheet data.

6.1 The Chart Group

The Chart group consists of over all eleven types of charts, each with its sub-types. To view the Chart group, click on the Insert tab or press [Alt] + [N].

Charts and worksheets go hand in hand with spreadsheets when looking for trends or patterns in your data. Choosing the right chart is completely dependant upon the type of data in your worksheet. You can use a particular set of numerical data to check out all the chart types, most commonly, worksheets that have two data series. Worksheets with more than two data series cannot be used with all chart types.

Excel gives you a number of options to manipulate your chart for optimum representation of your data. Unfortunately, no new chart types or features have been added in the step up to Excel 2007 from 2003.

6.2 Types Of Charts

Records of daily expenses, the inventory of a storehouse, sales figures, estimated expenses on construction, the records of marks in examinations, etc., can be used to make charts.
The choice of the appropriate chart type depends upon how you want the data to be represented. If you can’t figure out what chart type best represents your data, try out all the charts on offer in Excel 2007.

6.2.1 The Column chart
A Column chart is the most popular type, and the emphasis is on data that shows time variation.

To view the gallery of Column charts, go to Insert > Column, and the gallery will drop down. There are five sub-types of charts, namely 2-D column, 3-D column, Cylinder, Cone, and Pyramid.

A data series can be represented with differently-coloured columns. Also, data series can be stacked upon corresponding data points for relative representation of two or more data series. This could be used to compare sales of two product substitutes in a specific period.

6.2.2 The Line chart
For continuous plotting of data series and viewing trends, Line charts are very popular and widely used. Usually, equal intervals are displayed over the category axis, where more emphasis lies on trends portraying relative importance to values. Under this are seven sub-types, divided into 2D and 3D.
Within 3D, there is only one sub-type that uses data series with 3D effects. But this sub-type does not display it very well. 2D has six sub-types listed under the menus, which are further sub-listed into “With Markers” and “Without Markers”.

Of these, the latter displays trends over time, or other categories, while the former displays the contribution of each value over time or other categories. A third has a 100% stacked line that displays the trends of percentage that each value contributes over various categories and time.

6.2.3 The Pie chart
A Pie Chart is used on one data series to display relative proportions or contributions to a whole. This type contains six sub-types, classified into 2D and 3D.

In the 2D sub-type, the first is like a normal pie, displaying the contribution of each value; the second is an exploded pie with the pieces apart. Then there is a small pie made from a larger pie chart, and a bar graph representation of a pie chart containing details of each slice. 3D has two sub-types; one has all the data series held together, while the other has an exploded pie with data values in shape of slices.

Emphasis can be placed on a particular slice of the chart by using different colours, broad patterns, or by labelling them. Remember, in a pie chart, only positive values are allowed—using negative values will just convert them to positive integers.
6.2.4 The Bar chart
Bar charts have fewer sub-types than Column charts, with five categories: 2D bar, 3D bar, cylinder, cone, and pyramid. Each sub-type has three different ways of being represented: bars of different values adjacent to each other, data values stacked over each other, or data values stacked over each other with a 100% stacked bar.

6.2.5 The Area chart
Area charts are similar to line charts, but the area between the lines is filled in with separate colours. In this type of chart, the emphasis is more on the magnitude of values and less on changes over time.

Area charts has two categories: 2D and 3D display. In the 2D type, you will find three sub-types: data values plotted with area fill, stacked area fill, and data values plotted on a 100% stacked area.

6.2.6 Scatter Chart
Scatter charts are best suited for showing the correlation between data values that might not be easily observed. For example, for data series like expenditure, sales, insurance, etc., this type of chart is an apt choice.

Both the axes on the chart have numeric values and a legend field. The five sub-types can be used to display correlation using the different variations.

The sub-types of the Scatter chart are Markers, Smooth Lines & Markers, Straight Lines & Markers, Smooth Lines, and Straight Lines.
6.2.7 Other charts

Apart from the six chart types mentioned, you will find the Other Charts option. This has five chart types listed under it. One of the reasons for listing them separately is their specific use over only certain types of data.

6.2.7.1 The Stock chart

As the name suggests, this type of chart is a best fit to deal with stock market data. Between three to five data series are required before you can use this chart. Four sub-types are under this type, and each uses different values for high price, low prices, closing price, open prices, and volume. The sub-types have series of values in a particular order: High-low-close (three series), open-high-low-close (four series), volume-high-low-close (four series) and volume-open-high-low-close (five series). Thus, two sub-types use trade volume and the other two use trade value. Also, the sub-type using three series can be used for displaying other data, for example, temperature: high-low-close.

6.2.7.2 The Surface chart

Surface Charts display two or more data series across two dimensions on a continuous surface like a curve, with colour distinctions between each series. Four sub-types are listed. However, 3D points are not plotted, and such charts are used for data that contains more than two numeric data series.

6.2.7.3 The Doughnut chart

The Doughnut is similar to a Pie chart, but data is displayed in the form of a doughnut. The advantage is, it can display more than
one data series. Also, the space between the charts can be used to fill in information about the chart. Of the two types available, one is a regular doughnut, while the other is an exploded depiction.

6.2.7.4 The Bubble chart
This is similar to an XY chart, where sets of three values of data are displayed with differently-sized bubbles plotted like a scattered chart and an area chart. The drawback of this type of chart is, if there is a lot of data, the bubbles might overlap. Two sub-types are available, basically letting you display the bubbles as 2D or 3D.

6.2.7.5 Radar chart
For relative comparison among items, the Radar Chart is a good option. Using a radar chart, changes in data can be shown by relative mapping of data on the axis from a centre point. The radar chart has three sub-types—Lines, Markers, and Fill. The Lines type connects different data series with lines; Markers will place dots at corresponding points, and the Fill will just fill a colour in the areas covered by each data series.

6.3 Creating And Customising A Chart

To make a chart, follow these steps.
1. After feeding the data into the worksheet, select the range of data you wish to chart. Go to Insert, and you will see the Charts
group. Here, select the type of chart you want to create. Then choose the sub-type and the style.

2. Next, make sure that the data range you want to plot is charted along the appropriate axis. You can change the data range on either axis—vertical (X-axis) or horizontal (Y-axis). To perform this function, select either vertical axis or horizontal axis on the chart area. To perform this function, select Chart from the Design tab; in the Data Group, click on Select Data to display the Select Data Source dialog box and right-click to choose the Select Data option. Select Data Source. A dialog box will pop up.

3. If you wish, you can switch the view of the data to be charted from Rows to Columns of the worksheet at the Select Data Source dialog box. If you’ve know your formulas, you can manually feed the data range in the Chart Data Range box. Click OK to see the new chart.

4. You can now name the Chart Titles, and the data sets on the X, Y, and Z axes. The axes can be further customised.

5. From the Gridlines option, add/remove Gridlines across all axes.

6. Place a legend at the top, bottom, corner, or left or right side of the chart.

7. For Data Labels, see §6.5.

8. If you want to show the Data Table on the chart, select the Data Table checkbox.

### 6.4 Formatting Chart Elements

Once you’ve made your chart, you can begin formatting the elements: Either use the Format tab located under the Chart Tools tab, or you can select a Chart element, right-click, and select Format.
To change the appearance, select the Design Tab and view the Gallery of Chart Styles. The other tab groups under the Design Tab are Type, Data, Chart Layout, and Location.

In the Format menu, you will get the tab groups as Current Selection, Shape Styles, WordArt Styles, Arrange, and Size. On the Layout Tab, the tab groups available are Current Selection, Insert (pictures, shapes, and text box), Labels, Axes, Background, Analysis, and Properties.

1. **Current Selection**
   Choose the Format Selection Button in the Current Selection Tab group to customise an element. To reset all the customisations you’ve made, use the Reset to Match Style option.

2. **Shape Styles**
   Under this tab, you get a variety of options to customise the Shape Styles of the Chart Title. You can change the shape styles by clicking on the More button (the little down arrow), change the fill and outline, and select various shape effects.
3. WordArt Styles
For text formatting, choose the appropriate buttons from the WordArt Styles options. You can choose the Shape Styles More to select colour, Shape Fill to fill colour in the box, Shape Outline for a new outline colour, and Shape Effects to add effects to the Text to the Chart Title.

4. Arrange
Using this tab group, you can arrange your selected objects located on the Chart. It has three options—Selection Pane, Send to back, and Bring to front. Choose the Selection Pane option and it will appear to the left of the worksheet if you want to view the selected objects and change their order and visibility. Also, you can bring the selected object to front or send it to the back by using the Bring to Front and Send to Back options.

5. Size and Properties
Using the Size tab group, you can specify the size and positioning of the object and specify alternative text. The height and width of the chart can set using the options listed. Alternative text can be added if required.

6.4.1 Formatting Elements
To format almost anything in a chart, just select it, right-click, and click Format. A dialog box to Format Chart Area / Chart Titles / Legend / Plot Area / etc., will appear with formatting options. Here, you can choose to Fill with solid colours or a gradient, change border colours, border styles, add shadows, 3D effects, and change alignments.

6.4.2 Formatting Category Axes
Click to select an axis and then right-click and select “Format Axis...”. Here you will be able to modify the intervals between Tick marks (each measurement point on the axis), the interval between labels, the label distance from the axis, the axis type (data or text), Major and Minor tick marks, axis labels, vertical axis crosses and the position of the axis.
6.5 Data Labels

The Data fed in the worksheet and chart containing labels can be customised. Adding data labels gives a better representation to the chart.

Click on the Chart, then in the Layout tab, click on Labels. Here you will find Chart Titles, Axis titles, Legend, Data Labels and Data Table. Under Data Labels, you can add, customise position, and remove labels. You can also add a data series name, category names, and more.

6.6 Finding Trends In Data

By now you should be comfortable with creating charts and drawing inferences from them. You can now proceed to learn how to find trends/regression from your chart.

Let’s suppose you have records of books bought in the last six years (2001-2007), and you want to find some trends. The trend obtained can help you make better decisions in the future when buying books.

Click on the chart, and go to the Layout tab. Under Analysis, click on Trendline and select More Trendline Options. The Format Trendline option box will appear. Here, the
Trend/Regression Type options are displayed. Select one out of Exponential, Linear, Logarithmic, Polynomial, Power, and Moving Average. For the Polynomial type and the order and Moving Average type, the period can be customised as required—in our case, Linear type. Next you can provide the name by clicking Custom in the Trendline Name options.

In the Forecast Area, select either Forward or Backward as the display period, and then add 2 in the Forecast area. Click OK, and the trend line will be visible on the chart.

6.7 Creating, Re-arranging, And Formatting PivotCharts

PivotTables are hard to make, and can look like a screen filled with boring data. You can jazz it up by creating a PivotChart. Creating a PivotChart can be fun if you’ve already made a proper PivotTable.

Click on Insert, then go to Tables > PivotChart. Select any cell in the PivotTable and go to PivotTable Tools > Options > Tools > PivotChart. In the Insert Chart dialog box, select a type of Chart and click OK. You will now see a PivotChart with the PivotChart Filter Pane. Here, you have the following options: Report Filter, Axis Fields (Categories), Legend Fields (Series), and Values (Sum Total). If you want to add a PivotTable Field List in the worksheet, click on the button next to “Active Fields on PivotChart”.

From the PivotTable Field List, you have three options to customise the data series:
1. Drag-n-drop the data series in the Area Selections box
2. Check-uncheck the check box of that particular data series, or
3. Right-click on the data series in the Fields list to add to Report Filter, Legend Fields, Axis Fields, or Values.

To sort the data series listed in the PivotTable Field List, hover the cursor over it and you will see a small arrow. Click on this for more sorting options. The PivotTable Field List can be customised by ticking the different options listed on the top of PivotTable Fields List. After you’ve customised the options in the PivotTables Field List, right-click on the PivotChart and select Refresh Data. You can find the changes you made (if any) in the PivotTable Fields List on the PivotChart.

**Re-arranging a PivotChart**

If you want to make life easier, move the PivotChart to the same worksheet as the corresponding PivotTable. From the PivotChart Tools Tab, click on Design, and select Move. Go to Move Chart > New Sheet. Click OK and open the new chart sheet with your PivotChart. The drop-down list of the PivotChart Filter options can be used to represent data any way you want. Choose one of the two drop-down buttons available: **Axis Fields** filter the categories charted along the vertical axis, while **Legend Fields** filter the data series shown in columns, bars or lines in the chart body identified by chart legend.

**Formatting a PivotChart**

Although PivotCharts are created from PivotTables, formatting a PivotChart is almost identical to the process with a regular chart. Just use the Design Tab to select the chart type and the sub-type. The Layout of the PivotChart can be customised by changing Chart Titles, Text Boxes, and Gridlines. Use Format to change the look of the graphics and the background. You might find a few options missing while formatting PivotCharts.
Macros

Macros, in general, allow you to automate repetitive tasks. In this chapter, we tell you how you can record and play back a macro, and also go a little bit into how you can use the VBA editor—which you’ve doubtless heard about—to modify your macros.
An Introduction To Macros

Macros let you automate a wide range of tasks, ranging from things like filling in a range with certain values to importing data from other worksheets too. But creating one is simple, even though they can be powerful.

(a) Think of a task you do often—like changing the font in a range of cells, or entering some formulas in a range of cells.
(b) Turn on the macro recorder, and perform that task once.
(c) Assign a shortcut key to the macro.
(d) Use the shortcut key to run it thereafter.

Macros not only help in speeding up the process of the repetitive task, they’re also a good thing because you’re sure it’ll be done the same way every time you run it, eliminating the possibility of an error on your part.

To create a macro, you can either use the macro recorder, or you can enter the instructions in the VBA Editor. We’ll come later to what the VBA Editor is, but just remember that that method requires you to have some programming knowledge. Also, do remember that even when you record a macro using the macro recorder, the code that is generated is in VBA (Visual Basic for Applications). So when you record a macro, you can just go to the VBA editor and check what you’ve generated. Here’s about creating macros using the macro recorder.

Preparing To Record Macros

Macros that get recorded are stored (as VBA code) in one of three places—as part of the workbook you’re using right then, as part of a different workbook (which you can specify), or in a globally accessible workbook called the Personal Macro Workbook. This workbook is called PERSONAL.XLSB, and is in the XLSTART (in C:\Program Files\Microsoft Office\Office 12) folder.
You can probably guess the difference between each of these. When the macro is stored in the current workbook or in a different workbook, it’ll only work when that respective workbook is open; if it’s stored in the “globally accessible” PERSONAL.XLSB, it’ll be accessible from any workbook—which means that whatever workbook you open, you can press the shortcut keys and the macro will work. This is what you’ll probably be using most often.

At the point of creation of the macro, you specify its name, and what the keyboard shortcut will be. Shortcut keys can be [Ctrl] along with a letter (from A through Z), or [Ctrl] + [Shift] along with a letter. No other types of names are allowed, such as [Ctrl] + [Alt] + [-].

The View tab on the Ribbon has a Macros command button, upon pressing which a drop-down menu with the following three options comes up:

- **View Macros**: This will open the Macro dialog box, where you select a macro to run or edit.
- **Record Macro**: This will open the Record Macro dialog box, where you define the settings for a new macro and then start the macro recorder.
- **Use Relative References**: When this is depressed, Excel will, of course, use relative references when recording the macro. This is
important. When, for example, your cursor is in cell A1, and your macro consists of typing in “Digit”, there are two possibilities:

(a) With the “Use Relative References” button not depressed, running the macro will produce the text “Digit” in whichever cell you are in at the time you run the macro, say H16.

(b) With the button depressed, the macro will record the relative position. So if your cursor was in cell A1 when you began recording, and you typed in “Digit” in cell A2, then, when you run the macro with your cursor in cell H20, you’ll get “Digit” in cell H21.

If you’re looking for a single button to record macros, you’ll need to add the Developer tab to the Ribbon. Simply click Office Button > Excel Options, then click “Show Developer Tab in the Ribbon” on the Popular tab. Click OK.
7.3 Recording And Using Macros

When you turn on the macro recorder—say from the Developer tab—you’ll need to first press Start Recording, and choose whether you want to use relative cell references. Then do whatever you need to be recorded. For example, you could choose to enter 23, 34, and 35 in a range of cells, then sum them up. But before you do this, it’s a good idea to give the macro a name more descriptive than “Macro1”. You cannot use spaces in the name, and the name must begin with a letter. Next, you enter the shortcut key, which is pretty intuitive—except for the small fact that you shouldn’t overwrite inbuilt functions by, say, using \[Ctrl\] + \[V\] (paste) as a shortcut. Next, select what location to store the macro in, the options for which we’ve already talked about.

Now for the actual task. Press “Start Recording”, and do what you need to be recorded—say entering three numbers and summing them, or inserting text at a particular font size and with a certain formatting. Click “Stop Recording” when you’re done. Your macro should work when you next use the shortcut key. You can also view all your macros by doing any of the following (and then you can run them):
○ Click the View Macros option on the Macros command button on the View tab.

○ Click the Macros command button on the Developer tab of the Ribbon.

○ Press [Alt] + [F8].

After any of these three actions, Excel will open the Macro dialog box. It will list the names of all the macros in the current workbook and in your Personal Macro Workbook. Click the name of the macro you want to run and click the Run button (or press [Enter]).

The Macro dialog box. You’ll use this often

A point to remember when running a macro is that if you run it in a worksheet that already contains some data in the cells that the macro modifies, you could lose the existing data. Why worry—just undo by pressing [Ctrl] + [Z], right? The problem is that a macro is not a single action: there are several steps that Excel performs while running the macro, depending on how complex the macro is. As a result, you might need to undo many times to undo the action of the macro.
7.4 The Visual Basic Editor

If you want to see the code of a macro you entered, you’ll need to open its “code” window—open the Visual Basic Editor by pressing [Alt] + [F11], then from the left, double-click the appropriate “module” that contains the code, and the code window will come up on the right. (We won’t go into what Modules are, because you won’t need it right now.)

Like we said, any macro you record gets stored as VBA code. What we’re telling you now is, you don’t necessarily need to record a macro: you can write it out directly. Here is an example of how you can write a macro entirely in the VBA editor. We’re including this here just so you can feel comfortable with what’s going on, and what on earth the VBA editor is!

To keep track of what you’ve written, use comments. Anything you type in after a single quote will appear green in the VBA editor, and it will be ignored when the macro is running.
So here goes: open the VBA editor by pressing [Alt] + [F11]. Then go to the Project Explorer at the top left, and select “VBAProject”. There, right-click and insert a “Module”, or go to “Module 1” (for example) if it’s already there.

You might see a couple of macros already in the code window at the right. Remember that macros start with “Sub” and end with “End Sub”, and then you can place your macro text anywhere you want—for example, after one “End Sub” that’s already in the module.

Now, the following code will copy a range of cells and paste them in the current cell:

' This is my first macro
Sub CopyARange() ' This is the name of the macro
    Range("C24:C35").Copy Destination:=ActiveCell
' To-do: Get help on what ActiveCell and .Copy are
End Sub

The lines that begin with a single quote are ignored. The range here is C24 to C35. You run the macro using the procedure we already described.

For another simple example, here’s how to fill cells D1 through D4 with the squares of the numbers beginning from 5—that is, 25, 36, 49, and 64. This code requires you to go through several numbers—four of them—so we use what is called a “for loop”:

Sub Squares()
    For x = 5 To 8
        Cells(x, 4).Select
        Selection.Value = x^2
    Next x
End Sub
Line by line, here’s what the code does:
1. The declaration that this is a “subroutine”—something that will be executed when it is called upon to do so.
2. Do the following for the values of x from 5 to 8.
3. Select the cells in row x and column 4, with x being dictated by whatever iteration of the loop the program is in.
4. Set the value of the cell to the square of the row number.
5. “Next x” indicates the end of the loop.
6. End this subroutine.

You’ll often be using the for... next loop in Excel, because many things need to be done repetitively across cells.

Now about help: say you see, in your macro, which you recognise by name, you see something like “ActiveCell”. You don’t know what it does. Simply highlight it, and press [F1], and you’ll get help—you’ll see what “ActiveCell” means, in what contexts it’s used, and so on.

Record various macros, look up the help in this manner, and you should get a hang of how to code in VBA—or at least modify your own macros.

On to modifying macros: if the macro you want to edit is in your Personal Macro Workbook, you need to un-hide the workbook. To un-hide the PMW, click the Unhide command button on
the View tab. (If you can’t find it, press [Alt] > [W] > [U].) The Unhide dialog box will open, showing the PERSONALB workbook in its Unhide Workbook list box. Click PERSONALB in the list box and press [Enter].

In general, to open a macro for editing, press [Alt]+[F8] which, like we said, opens the Macro dialog box. You’ll find that you can click on a macro name and try to edit it, but if the macro is in a non-open worksheet, you’ll get a dialog saying you can’t edit it and that you need to un-hide the workbook first. Do this the same way you’d un-hide the PMW.

7.5 Editing With The VBE

Do the following. Begin recording a new macro; position your cursor in cell A1, and type in “I am recording a macro.” Then colour it reddish-brown, underline it, give it a font, and make it larger. Stop recording the macro.

You know what the macro will do—when you press the short-cut key, it will bring up that text in that style in that location (unless you used a relative location). Now, open the VBE, and in the appropriate module, find the code for the macro, which will be something like this:

```vb
Sub Macro2()
' Macro2 Macro
' Macro recorded 01/01/1970 by digit_fan
'
' Keyboard Shortcut: Ctrl+Shift+A
'
    ActiveCell.FormulaR1C1 = “I am recording a macro.”
    Range(“A1”).Select
    With Selection.Font
        .Name = “Cambria”
    End With
End Sub
```
Now what do all the above mean? It’s easy to see that you can edit the size to be something other than 14; it’s easy to see that you can edit the font to whatever you want. “ColorIndex”, too, can be played around with. But for all the rest, you’ll need to use Excel’s inbuilt help. Like, what is “OutlineFont”? What is “Shadow”?

At this point, we can tell you three things:

1. Play around with the macros (subroutines). In our text example above, position the cursor somewhere other than cell A1 and see what happens. It prints out the text without the formatting. Why? Go figure—literally! Learn by experimentation.

2. If you’re not the experimentative kind, create the macros you’re most likely to use, then use the inbuilt help for each small thing. You should get the hang of it soon enough—at least enough for you to be able to edit your own macros.

3. If you want to write your own macros for all kinds of stuff: we hate to tell you this, but VBA is a vast topic—we could use a couple of Fast Track editions just for that! For now, download Microsoft’s Office 2003 Editions: Excel VBA Language Reference, if you’re interested, from www.microsoft.com/downloads/details.aspx?familyid=2204a62e-4877-4563-8e83-4848dda796e4&displaylang=en (http://tinyurl.com/56rj5).
The graphical elements in Office 2007 have been reborn: they’re more swanky and contemporary than ever before. They have been revamped suite-wide, and are now available as a full-blown feature in Excel 2007. The use of the Ribbon feature makes it possible to select various styles and features in the fewest number of clicks, saving you time and making your job simpler.
Access the graphical elements from the Ribbon (Insert > Illustrations). You have options such as Picture, Clip Art, Shapes, and SmartArt. Alternatively, you can place any of these categories in the Quick Access Toolbar above the Ribbon for easy one-click access.

8.1 The Shapes Group

The shapes menu has all the basic shapes you would normally find in earlier versions of Excel. Apart from Lines, Basic Shapes, Block Arrows, Flowchart, Callouts, and Star Banners, there is a Recently Used Shapes option that intelligently stores all the shapes you recently used, for quick access. These shapes can be easily drawn and formatted too.

8.2 Drawing Basic Shapes

Drawing basic shapes is easy! Go to Insert > Shapes and then choose the shape you want to select. Next, drag the cursor diagonally across the worksheet to create the shape in the size you want.

If you want to maintain the horizontal or vertical aspect ratio of the shape while enlarging or reducing its size, you can hold down [Ctrl] while doing so. Alternatively, holding down the [Ctrl] + [Shift] keys will maintain both the horizontal and vertical aspect ratios of the shape you are drawing.

Under Shapes > Recently Used Shapes, there is a shape called Scribble. What this does is, it allows you to create custom shapes of your choice. So if you want to doodle or create a shape for your signature, this is the tool you should use. All the regular formatting settings apply to this shape, so you can further stylise your creative genius!
In comparative terms, the shapes feature is a major improvement over any other version of Excel developed by Microsoft, freeing you from the clunky diagrams of the past. This feature supports anti-aliasing, which gives your diagrams the smooth and professional edges you’ve always dreamed of.

8.3 Formatting Graphic Objects

Unlike its predecessors, Excel 2007 allows you to add all kinds of pictures to your worksheet. All image file extensions are supported, including the Macintosh PICT and WordPerfect Graphics formats! What is so special about it? The fun starts as soon as you add a picture or make a shape. You see a new menu item open up inside the ribbon called Picture Tools > Format, which allows you to format the image in ways that will make your colleagues jealous!

You can play around with any setting in the Ribbon

You can play around with the brightness and contrast or make your image greyscale, sepia, or any other colour you want it to be. If you happen to go overboard with these Adjust settings, you can always reset your picture to its original by clicking on Reset Picture.

The Picture Styles option allows you to add various default settings like a frame or a bevel effect, or a shadow, or even adding perspective. What’s really fascinating is that you can combine any number of these effects to create an effect to your liking. You can also use Crop to remove unnecessary parts of your image.

Let’s try creating the image shown in 5 easy steps...

8.3.1 Click Insert > Shapes and choose the smiley under Basic Shapes.
8.3.2 Holding [Ctrl] + [Shift] on the keyboard, left-click and drag it diagonally across the worksheet till you reach the desired size of your smiley. Now you can colour your smiley based on your preferences.

8.3.3 Go to Insert > Shapes and choose any shape under Callouts.

8.3.4 Holding [Ctrl] + [Shift], left-click and drag the mouse diagonally across the worksheet till you reach the desired size of your callout. Now you can colour your callout based on your preferences. Don’t forget to play around with the Shape Effects.

8.3.5 After that is done, click onto the callout to bring-up the Drawing Tools > Format menu. In there, click WordArt Styles > Text Fill and enter “Hello World” as your text.

You have now officially mastered the art of formatting graphic objects in Excel 2007!

8.4 WordArt

WordArt is another good feature in Excel 2007. This used to be the most underestimated feature of Excel, promising much more than it offered. Not any more. Thanks to the new formatting options which have been incorporated into the WordArt functionality, this option has become more powerful than ever before.
The function can be accessed by going to **Insert > WordArt** (on the extreme right). Once there, you can choose from a range of styles that suit your mood. If you’re the adventurous type, or you want to tweak your style a little, you can customise it by choosing among various options under **Drawing Tools > Format > Shape Styles**, and keep experimenting with all the options there.

Let’s try to make the above custom WordArt in 3 easy steps.

1. **Go to Insert > WordArt** (at the extreme right) and choose the style that you want from the drop-down list.
2. **In the new window that appears**, enter “Think Digit!”
3. **Now in Drawing Tools > Format > Shape Styles**, you can tweak either Shape Fill or Shape Outline or Shape Effects to create a style completely your own... Congratulations! Your skill in using Excel 2007 has increased a notch!
8.5 Pictures and ClipArt

The Pictures and Clipart functionality seems to have been tightly integrated to the Microsoft Web site in this latest edition of Excel. What is good to see is that searching for either clipart or images allows you to also choose from Microsoft’s online collection. It is good to see that there are approximately 1,50,000 images and sounds available at the Microsoft Office Web site; quite a few of them are royalty-free.

There is robust support for image files too. All image file extensions are supported, including the Macintosh PICT and WordPerfect Graphics formats. What this essentially means is that if you have a spreadsheet that was, say, created on a Macintosh with pictures saved in the .pict extension, you wouldn’t need to have QuickTime installed to view those images correctly. They will appear correctly without any need for third-party software.

Another wonderful feature with Picture and ClipArt is that it is integrated into all the new and wonderful formatting options available with Excel 2007. What that means is that an unlimited number of style variations can be applied to your picture or clipart.
It is common knowledge that the impact of graphics in spreadsheets increases recall. Yet, in today’s age, it is very difficult to create professional-looking corporate charts and diagrams using standard tools. Charting this information makes for a tremendous improvement. However, there are times when you want to represent data in a completely new format. This is where SmartArt graphics are best utilised. Though this is a function we see having great productivity in PowerPoint 2007, it’s availability suite-wide and is an added bonus to Excel. All the old charts—organisational, process, and Venn diagrams—have been reborn as SmartArt. Though you can
still do charts the traditional way, you can edit ready-made charts using the SmartArt functionality.

What SmartArt essentially does is, it allows you to select pre-defined styles from a variety of charts and allows you to enter contextual text wherever applicable. Text and positioning of shapes get automatically sized based on the style you choose. What’s more, you can seamlessly change from various pre-defined styles at a click of a button... Everything reverts to the pre-defined style instantly, without you having to change the font or colour or background.

Charts created using SmartArt can again be formatted with various pre-defined or custom Shape Styles and/or WordArt Styles. Here is a table of other SmartArt accessibility shortcuts.

<table>
<thead>
<tr>
<th>To do this</th>
<th>Press</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert a new SmartArt graphic</td>
<td>[Alt] + [N] + [M]</td>
</tr>
<tr>
<td>Open the online Help</td>
<td>[Ctrl] + [Shift] + [F1]</td>
</tr>
<tr>
<td>Switch between the Text pane and your SmartArt graphic</td>
<td>[Ctrl] + [Shift] + [F2]</td>
</tr>
<tr>
<td>Move from the Text pane to the Ribbon, which is a part of the Microsoft Office Fluent user interface</td>
<td>[Ctrl] + [Shift] + [F2] to move to the SmartArt graphic, and then press [Alt] to move to the Ribbon</td>
</tr>
<tr>
<td>With a shape selected, move between shapes in your SmartArt graphic</td>
<td>[Tab]</td>
</tr>
<tr>
<td>Indent text in the Text pane</td>
<td>[Tab]</td>
</tr>
<tr>
<td>Negatively indent text in the Text pane</td>
<td>[Shift] + [Tab]</td>
</tr>
<tr>
<td>Add a tab character to text in the Text pane</td>
<td>[Ctrl] + [Tab]</td>
</tr>
</tbody>
</table>
Select multiple shapes in the Text pane
Select a line of text in the Text pane, and then press [Shift] + [Down Arrow] to select the additional shapes.

With a shape selected, increase the size of a shape
[Shift] + [Up Arrow] or [Right Arrow]

With a shape selected, decrease the size of a shape
[Shift] + [Down Arrow] or [Left Arrow]

Resize the shape in very small increments
[Ctrl] + [Shift] + [Up Arrow], [Down Arrow], [Right Arrow], or [Left Arrow]

Move the shape in the direction that you want
[Up Arrow], [Down Arrow], [Right Arrow], or [Left Arrow]

Move or “nudge” the shape in very small increments
[Ctrl] + [Up Arrow], [Down Arrow], [Right Arrow], or [Left Arrow]

Rotate the shape in the desired direction 15 degrees
[Alt] + [Right Arrow] or [Left Arrow]

Rotate the shape 1 degree:
[Ctrl] + [Alt] + [Right Arrow] or [Left Arrow]

If you want to save the SmartArt chart you just made, go to Ribbon > Save As > Other Formats, and save the worksheet as a Web page! After it is saved, a new folder will be made, which will house your SmartArt chart image in the .png format.
In Chapter 3, we briefly touched upon what you can do with formulas, how to check for errors, and how to trace them. In this chapter, we delve deeper, looking at the basics of how to construct a formula using functions, plus an in-depth look at some of the more popular basic Excel functions.
9.1. The Basics

Formulas and functions are what make Excel more than just a printable grid of columns and rows. As explained in Chapter 3, you create a formula by using mathematical and calculation operators in combination with numbers or cell references (=5+3, =A1+B6, etc.) or by using pre-built functions that make it easier to do complex calculations in a single step (=SUM(A2:A10), etc.).

All formulas and functions start with the “=” sign. This indicates to Excel that what follows is a calculation. Calculations are done using operators. In many cases the operators themselves are sufficient to obtain the required results, without having to depend on functions. There are four types of operators in Excel 2007: arithmetic, comparison, text, and reference.

Depending on the operator, the order of calculation may also vary. Each operator has a different level of precedence: in a formula where more than one operator is used, Excel will calculate the result in a pre-determined sequence.

For example, the formula “=(2+5)*3/4” will first calculate 3 divided by -4, since negative values have the highest precedence. This will be followed by the multiplication and then the addition. Hence the result will be 1.75 and not -5.25, which would have been the result if you had used a simple left-to-right calculation order.
When two operators are of the same level, Excel will calculate from left to right. For example, “=2*3/4” will cause the multiplication to be done first, and then the division.

If you use parentheses, what is inside them will be calculated first, irrespective of the precedence order. For example, “= 2*(3/4)” will calculate 3 divided by 4 before multiplying by 2.

When you are using complex formulas where you may have multiple parentheses nested one within another, you will need to ensure that for each open bracket there is a closing bracket. If you make a mistake, Excel will bring up an error and automatically suggest corrections. For example, the formula “=SUM(SUM(A4:C4), SUM(A5:C5))” has the final outer bracket missing. Excel will detect this and suggest corrections, at which point you should review your formula and make corrections if needed.

What makes Excel so powerful is its inbuilt functions. To use them, click on the Formula tab. You get a wide range of functions and formulas that you can choose from the Function Library group.

The functions are in ten categories:
- Financial
- Logical
- Text
- Date & Time
- Lookup & Reference
- Math & Trigonometry
- Statistical
- Engineering
- Cube
- Information

And, by clicking on the More Functions button:
- The functions’ names are quite self-explanatory, but we’ll be delving into some of the function categories in more detail in later sections. The function categories Text, Lookup & Reference,
Engineering, Cube, and Information are advanced topics, and we will not cover them. You can find examples and explanations of those functions in the Excel help section.

Other than these above categories there is also the Recently Used button, which will show you a list of functions that have been recently used in Excel, as well as the AutoSum button. Clicking on the arrow next to the AutoSum button, you can get access to not just the Sum function but also to the Average, Count, Min, and Max functions as well. This is an improvement over earlier versions of Excel where you could only get access to the Sum function by clicking on the button. (See the Math & Trigonometry section for more on these functions.)

You also have the “fx Insert” function button that enables you to search for and select a function. Click on the button, and in the pop-up window, you’ll have multiple choices.

First, you can type in a brief description of what you are looking for in the function, and Excel will give you a list of possibilities based on matching keywords. Of course, this means you will need to be as precise and accurate as possible in the terminology you use. The search feature is useful when you do not know which category the function belongs to: if you do know the category, you can select one from the category drop-down list, and
narrow down the list of functions you’ll have to scroll through.

Clicking on any function in the “Select a function:” box will show you a brief description of what the function does in the space below the “Select a function” window. If you want to learn more about a particular function you can click the Help on this function link to open its help documentation.

Once you have made your selection, click OK to open the Function Arguments window. In this window, you enter specific values for the selected function. The available fields and values may vary; however, you will get a description of what is expected in each field. Some values may be required, others may be optional. At the minimum, you will have to enter the required values for the function to work and display a result without bringing up an error. Once you’ve entered the values you require to, click OK to display the result in your worksheet.

A function consists of some standard parts. In general, a function is of the form:

= function_name(arg1, arg2, ...argN)

All Excel functions—which are actually advanced formulas—start with the equals sign followed by the name of the function. This is followed by the open bracket, then followed by a number of arguments that may use any of the valid operators—arithmetic, comparison, text, or reference (as discussed above). Last comes the closing bracket.

An argument is a value that can be assigned by either specify-
ing it manually or by referring to a cell reference or a cell range reference. There are two ways of entering arguments in the Function arguments window—manually or by selection. For manual entry, you type in the cell reference or values directly into the Function Arguments box, or you can have Excel automatically fill in the reference for you. To do that, click inside in the field where you want to fill in the references automatically. Move the Function Arguments window to the side till you are able to select your cell range. Drag and select the cell range that contains the values you need. The range reference will be automatically entered into the selected field.

Some arguments require special formats for them to use the arguments. For example, functions in the Date & Time category may require that date arguments be specified in calendar form and not numerically.

Some functions may not have arguments. For example, the function “=PI()” will show the result of Pi to 15 decimal points. Likewise, the function “=TODAY()” will show the current date. In both these cases, no additional arguments are involved. However, note the opening and closing brackets. Whether there are arguments or not, these brackets are compulsory and follow the function name.

9.2 Logical Functions

Excel has seven logical functions: AND, FALSE, IF, IFERROR, NOT, OR, TRUE. All these functions, except for the IFERROR function, will
show either logical TRUE or logical FALSE after evaluating all these values in the function. Here is a brief overview of the functions.

- **AND(logical1,logical2,…..,logicaln)**: Verifies all the arguments and displays TRUE if all the results are logically true. If any of the arguments are not logically true, it will display FALSE.

  Example: =AND(A3=B6, F5<>234)

  Excel will here check to see if the values in A3 and B6 are equal, if they are not then Excel will display (return) the value FALSE. If A3 and B6 are equal, then Excel will evaluate the next argument. It will check to verify whether F5 is not equal to 234. If this is TRUE, then Excel will return the value TRUE. If it F5 is equal to 234, Excel will return FALSE.

- **FALSE()**: No arguments are used; this one just returns logical FALSE. Usually the FALSE() function is the result of a logical function (like AND, NOT, EQUALS etc) or used in combination with some other logical function.

  Example: =IF (A3=FALSE,D5+25,D10=D5)

  (See the IF function for an explanation)

- **IF(logical_test,value_if_true,value_if_false)**: Checks the logical value of the first argument. If it is TRUE, Excel uses the second argument; if that one is not TRUE, then Excel uses the third argument.

  Example: =IF (A3=FALSE,D5+25, D5+5)

  If cell A3 has a value of FALSE, then add 25 to D5 and return the value. If A3 does not have a value of FALSE, then add 5 to D5 and return the value.

- **IFERROR(value,value_if_error)**: Checks whether the first argu-
ment is returns an error, if it is returns an error, it uses the value in the second argument, else it displays the first argument’s value.


Divide cell A3 by 23. If the result is an error, then display the text “Sorry! Non computable error!”, else display the result of the division.

❍ NOT(logical): Checks if the argument is TRUE or FALSE. If TRUE, the value returned is FALSE. If FALSE, the value returned is TRUE.

Example: =NOT(A3=A4)

If “A3 is equal to A4” is TRUE, then the value returned will be FALSE. If A3 is not equal to A4, the value returned will be TRUE.

❍ OR(logical1,logical2,…logicaln): If any of the logical arguments are true, it returns the value TRUE; if all the arguments are false, it returns the value FALSE.

Example: =OR(A3=A4,B5<190)

If either A3 is equal to A4 or B5 is less than 190, then the value returned is TRUE. If A3 is not equal to A4 and B5 is equal to or greater than 190, the value returned is FALSE.

❍ TRUE(): No arguments are used; it just returns logical TRUE. Similar to the FALSE() function.

9.3 Date and Time Functions

Using date and time functions can becoming confusing if you do not understand how Excel treats dates and times internally. Externally, the data and time will be displayed in the human-friendly date/month/year format and its variations, and
time will be displayed in the 24-hour or AM/PM format. Internally, however, Excel automatically stores any date and time value in a serial number that is calculated based on January 1, 1900 being equal to the number 1, and every subsequent date being an increment of 1 from that date. That is, Excel will internally store January 2, 1900 as 2, February 2, 1900 as 33, and so on. Similarly, time is stored as a decimal fraction starting from midnight equal to 0.00000000, and, say, 6:33 AM equal to 0.27291700—and so on.

To work with date and time values, you would normally format the cells where the data is being entered. That is, if you wish to display the date and time in dd/mm/yyyy format and time in 12-hour format, you would select the cell, right-click, and select Format Cells, then use the Date and Time sections in the Number tab to select from pre-defined date and time formats. Or, you may use the Custom section to specify any non-standard date and time formats.

Excel normally displays the date and time based on the regional settings of the computer you are working on. This will be the default display for date and time. On most computers, the default date setting is usually in the American format mm/dd/yyyy, where the display will show month first followed by day and year. The Indian format is, of course, to have the date first followed by month and year i.e. dd/mm/yyyy. You can change the default display to this format by changing the Regional Settings in the Control Panel.
Excel, and even Windows in general, use the following formats in handling dates:

- dd displays the date in numeric format
- dddd displays the day limited to the first three letters
- ddd displays the full word of the day
- mm displays the month in numeric format
- mmm displays the month in words limited to the first three letters
- mmmm displays the full word for the month
- yy displays the year in two digit format
- yyyy displays the year in four digit format
- hh displays the hour
- mm displays the minutes unless the context makes it refer to month
- ss displays the seconds

Thus a custom format of the type

```
ddd, dd/mm/yyyy hh:mm:ss AM/PM
```

will display the date and time 12th May, 2006 7:18 PM and 34 seconds in the following manner:

Fri, 12/05/2006 07:18:34 PM

If you omit the AM/PM, then the time will be displayed in 24-hour format irrespective of how it is entered. Also note that you need not enter the day. You just enter the date and time and Excel will automatically pick up the correct day. Similarly, if you leave out the time, Excel will assume it is 00:00 (midnight). Also, if you leave out the year, Excel will assume you are talking about the current year. Thus, for the above format, if you wanted to enter 6 February 2007 with no reference to the time, you could simply enter 6/2 or 6 Feb. Excel will automatically apply the above date format and display:
With this basic idea of how Excel treats date and time functions we can go on to doing date and time calculations. The most common calculation you’ll use dates for is to find out the elapsed days or times between two dates. For example, if you want to find out the number of days between 14th April 2007 and 22nd May 2000, do the following:

Enter the above dates into two cells, say A1 and B1 respectively. Now you can simply type in, say, cell C1 “= A1—B1”. The result, however, may be shown in the date format, since Excel “sees” dates in both the cells and assumes that the format for the result should also be in date format. To change it to the number format, right click on cell C1, select Format cells, and choose the Number option on the Number tab. This will then show the number of days between the two dates. Likewise if you want to find out, say, the date 25 days prior to 14th April, you can use a formula as in the figure below. In this case, the result will directly show you the date.

### 9.3.1. Date Functions

**TODAY()**

Of all the date functions, the easiest has to be the TODAY function. Entered as “=TODAY()”, it has no arguments, and returns the current date in the cell. Note that the date in the cell will keep changing every time the workbook is opened on different dates. This function should not be used if you want the date to remain fixed.
whenever you open the workbook.

\[ \text{DATE(year,month,day)} \]
Example:
\[ =\text{DATE(A1,A2,A3)} \]
This combines the values in the arguments into a single cell. Thus if you have the year, month, and date and separate cells, you can use this function to combine it into a single cell and display it in the date format.

\[ \text{DATEVALUE(date_text)} \]
Example: \[ =\text{DATEVALUE(A1)} \] where \( A1 = '5/12/2006 \)
When you use the apostrophe sign before a number or date, Excel stores the value as text. Normally, you will not be able to perform any of the calculations because it is internally referenced as text. You use the DATEVALUE function to convert the text version of the date into an Excel number for the corresponding date. You can then use this number to perform calculations.

\[ \text{DAY(serial_no)} \]
Example: \[ =\text{DAY( ((DATE(07,03,25)))} \]
The serial_no argument returns any day of the month between 1 and 31. In the above example, the DATE function is nested inside the DAY function. Hence, the value returned by the DAY function will be 25, since the DATE function contains the value 2007 for the year, 03 for the month, and 25 for the day.
WEEKDAY(serial_no,return_type)
Example: WEEKDAY((DATE(07,03,25)),2)
The serial_no argument returns any day of the week between 1
and 7 or 0 and 6. The return_type argument is a number between
1 and 3. It specifies how the weekday should be handled. If the
return_type is 1, then 1=Sunday and 7=Saturday. If the
return_type is 2, then 1=Monday and 7=Sunday. If the return_type
is 3, then 0=Monday and 6=Sunday. In the above example, we want
to find out the day for the second return type where 1=Monday
and 7=Sunday. The value returned will be 1.

MONTH(serial_no)
Example: MONTH((DATE(07,03,25)))
The serial_no argument returns any day of the month between 1
and 12. In the above example, the value returned will be 3.

YEAR(serial_no)
Example: YEAR((DATE(15,03,25)))
The serial_no argument returns any year between 1900 and 9999.
Note that in the above example, the DATE function specifies the
year as 15, which Excel will refer to recognize as 1915. If you want
Excel to recognize to 21st century years, you will need to enter the
full year in the following format: YEAR((DATE(2015,03,25)))

DAYS360(start_date,end_date,method)
Example: DAYS360(A1,B2,FALSE)
This function calculates the number of days given the start_date
argument and the end_date argument for a 360-day year where
there are 12 months with 30 days each. The method argument spec-
ifies which calculation method to use: US or European. If using the
European method, the value of the argument will be TRUE. If using the US method, the value of the argument will be FALSE.

In the US method, if the starting date value is the 31st of the month, then this function will treat it as 30th of the month; if the ending date is the 31st of the month and the starting date is earlier than the 30th of the month, then the ending date becomes the first of the next month, else the ending date becomes the 30th of the same month.

In the European method, any date of 31st is treated as 30th of the month.

9.3.2. Time Functions

Similar to the date functions, there are some useful time functions as well.

**NOW()**

Like the TODAY date function, the NOW time function does not take any arguments. It simply returns the current system time into the cell, along with the date. Again, like with the TODAY function, you should note that the value stored in the cell keeps changing every time you open or calculate the sheet.

**TIME(hour,minute,second)**

Example: =TIME(A1,B1,C1)

Combines the time values for hour, minute, and second from different values or cells into a single cell. It’s similar to the DATE

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>TIME function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Hour</td>
<td>Minute</td>
<td>Second</td>
<td>Time</td>
</tr>
<tr>
<td>2</td>
<td>12</td>
<td>12</td>
<td>12</td>
<td>12:12:12 AM</td>
</tr>
<tr>
<td>3</td>
<td>12</td>
<td>14</td>
<td>55</td>
<td>12:14:55 PM</td>
</tr>
<tr>
<td>4</td>
<td>23</td>
<td>45</td>
<td>60</td>
<td>2:45:60 PM</td>
</tr>
<tr>
<td>5</td>
<td>26</td>
<td>0</td>
<td>0</td>
<td>2:00:00 AM</td>
</tr>
<tr>
<td>6</td>
<td>26</td>
<td>78</td>
<td>0</td>
<td>5:18:00 AM</td>
</tr>
<tr>
<td>7</td>
<td>26</td>
<td>78</td>
<td>85</td>
<td>9:10:25 AM</td>
</tr>
</tbody>
</table>

The TIME function with different values
function; however, the hour value should normally be between 0 and 23. If the value exceeds 23, then the number is divided by 24 and the remainder is taken as the hour value (see figure). Likewise, for the minute and second arguments the expected values should be between 0 and 59; if the values exceed 59, it is converted into hours and minutes and added, in the case of the minute argument to the minutes. Example: If the hour value is 1 and the minute value is 74 the hh:mm value will be 2:14, that is 74 minutes has been converted to 1 hour 14 minutes and added to the total. Similarly, for the second argument, if the values exceed 59, then it is converted into hours, minutes, and seconds and then added. See the figure to understand how this works.

TIMEVALUE(time_text)
Example: =TIMEVALUE(A1) where A1='8:15:46 PM
Similar to DATEVALUE, if the time is entered as a text in Excel by using the apostrophe before the time, then this function will convert it into the time format.

HOUR(serial_number)
Example: =HOUR(A1) where A1=9:30:24 PM
Extracts only the hour portion in the time value specified. In the above example, Excel will return the value 21, which is the value for 9 PM in the 24-hour format. Similarly, the functions MINUTE(serial_number) and SECOND(serial_number) extract the minutes and seconds in a specified time value respectively.

9.4 Financial Functions
Due to the use of financial terminology financial functions may seem the most obscure difficult to understand of all the functions available in Excel. We take you through the basics in this section. While some understanding of financial terms is always helpful you don’t need to be accounting whiz kid to use the basic financial functions. We show you how.

PV(rate,nper,pmt,[fv],[type])
PV stands for Present Value. This function calculates the Present Value of an investment. The arguments it uses are as follows.

RATE: This is the interest rate for a given period, usually annual.

NPER: This is the total number of payments during the life of the investment. This number is arrived at by calculating the length of time that interest is paid and multiplying this by the point in time when interest is earned. For example, a loan of 4 years with 12 monthly interests payments has an NPER value of $4 \times 12 = 48$ payment periods.

PMT: This is the amount paid at each period of the investment and usually includes principal plus interest.

FV: This is the principal plus interest that you want to earn after having made your last payment. If you do not enter this value, Excel assumes that FV=0.

TYPE: Enter 0 or ignore this argument when payment is made at the end of the period. Enter 1 if the payment is made at the beginning of the period.

For example, in the figure above, the annual rate for a loan is 10.25%. This has been divided by 12 to arrive at the per-month value for the RATE in the next column. The annual rate is converted into a monthly rate because the payment periods (NPER) and payments (PMT) are monthly. In the two examples, for a payment per month of Rs 1,500, the PV will be Rs 43,318.19. For a future value of Rs 45,000, the PV will be Rs 33,130.96. To calculate the PV on your investment, whip out your investment documents
NPV(rate, value1, value2,..., value13)

NPV (Net Present Value) is calculated on the basis of the rate and a series of cash flows represented by the arguments value1 to value13. These arguments denote a series of payments and income—negative values for payments and positives for income—which are equal and made at the end of each payment period. In calculating NPV, the argument value1 should exclude your initial payment, that is, value1 starts from the second payment.

Note that Excel will only take numerical entries in the international format, so 1 lakh will always be represented as one hundred thousand (100,000), 1 crore as ten million (10,000,000), and so on.

FV(rate, nper, pmt, [pv], [type])

The FV shows you the Future Value of an investment; the arguments are the same as in PV, the only difference being that you will have to specify the PV value in this case. For example, if you are 30 and plan to retire by 60, you can calculate the Future Value if you make an investment of Rs 30,000 a year.

PMT(rate, nper, pv, [fv], [type])

When you know the rate, the number of payments to be made, and
the present value or future value, you can use the PMT function to calculate the amount you will have to pay for each payment period (the instalment). For example, you can find out the instalment on a loan of Rs 45,000 where you know the interest rate (7.58%) and the number of payments to be made (48). You can reduce the down payment from PV and see how that will affect your instalment or vary the number of instalment months.

### 9.5 Maths & Statistical Functions

There are tons of mathematical, trigonometric, and statistical functions in Excel. You access them by clicking on the Formulas tab and selecting the functions from the Math & Trig drop-down, and the Statistical functions from the More Functions drop-down. We take a look here at some of the more common statistical functions.

#### ROUND(number,num_digits)

Excel takes the number argument and rounds it to the number of decimal places specified in the num_digits argument. If the num_digits argument is a positive number, then Excel rounds off the value to the specified number of digits. If the num_digits is a negative value, it rounds off the number to that many places left of the decimal point.

For example, when \( A1 = 2564897.5689456 \)
=ROUND(A1,4) will give the result 2564897.5689
=ROUND(A1,-4) will give the result 2560000

Normally By default, Excel will round up the result if your the last number of after the specified decimal places is greater than or equal to 5. For example, 1.5, when rounded to zero decimal places, will always round up the value to show as 2, while 1.4 will be rounded down to show as 1. If you want Excel to always round up (or round down) the result, you can use the ROUNDUP (and ROUNDDOWN) functions. In this case when ROUNDUP is applied any decimal will round up to the next higher number or when ROUNDDOWN is applied the decimal will round down to the lower number. Example:

=ROUNDUP(1.43237,2) will give the result 1.44
=ROUNDDOWN(2.5678,2) will give the result 2.56

Note that the default rounding by Excel would have given the first result as 1.43 and the second result as 2.57.

CEILING(number,significance)
When you want to round up to a specific unit then the CEILING function is the one to use. This can be best explained by means of an example. Assume you have a Excel shopping list of many items with the varying prices especially in the decimal portion—that is, you have one item for Rs. 102.35, another for Rs. 74.85 and so on. Now assume that for reasons of tidiness or totalling ease you either want it all to be either rounded to the nearest 50 paise or rupee. The CEILING function will do it for you.

=CEILING(102.35,0.5) will give the result 102.50
=CEILING(74.85,0.5) will give the result 75.00

In the above example, by setting the significance argument to 0.5 we tell Excel to round off the number to the nearest point fifth of a unit. Thus, if the significance is changed to 1 then the results will be 103 and 75 respectively.
TRUNC(number,num_digits)
If you want to just display the number to a specified number of decimal places without any rounding, you can use the Truncate function. If you want to simply specify just the portion without with the decimal places (the integer portion), do not enter anything for the num_digits argument.

For example, when A1 = 2564897.5689456
*TRUNC(A1) will give the result 2564897
*TRUNC(A1,2) will give the result 256487.56

EVEN(number), ODD(number)

The EVEN and ODD functions round up the number to the next EVEN or ODD number.

For example, if A1 = 564.258
*EVEN(A1) will give the result 566
And
*ODD(A1) will give the result 565

POWER(number,exponential)
This is the same as using the caret sign (\(^\)) to calculate the exponential of a given number. For example: \(2^8\) and \(\text{POWER}(2,8)\) will both give the result 256.

SQRT(number)
Calculates the square root of the number. Example: \(\text{SQRT}(150)\) will give the result 12.2474487139159. You cannot use negative values with the Square Root function. If you do have a negative value whose square root you want to find, you’ll need to use the absolute value function (ABS) to calculate it. Example: for a value of -234, you would enter

*SQRT(ABS(-234))
SUM(number1,number2,...)

This is by far the most popular and most widely used of all functions in Excel. Select the last cell in a list of numbers and click on the AutoSum button (Formulas tab, Function Library group) to automatically total up the column or row. You can also manually specify a range, a named range, a range in another worksheet or even one in another workbook.

Example: =SUM(B1:B34,Sheet4!A12:C34)
This will total up the cells B1 to B34 in the current worksheet and the cells A12 to C34 in Sheet4. Note that there is a maximum of 30 arguments separated by commas that you can use in a SUM function. If the number of arguments exceed 30 then you may need to break up the SUM function into two parts.

SUMIF(range,criteria,[sum_range])
For those of you plain bored out by SUM and looking for something more powerful, check out the SUMIF function. The SUMIF function or conditional summing, as its often called, allows you to total up a list based on specific criteria. The range argument specifies the range of cells that you want Excel to evaluate in the sum operation. The criteria argument, as the name implies, is the specific set of criteria that you want to apply to the sum operation, and the sum_range argument is optional, but indicates the range of cells that should be used in the sum function. If the sum_range argument is not specified, Excel will sum the entire range specified in the range argument after applying the criteria argument. This can be better understood by an example.
The above example is a list of books along with their categories and price. For the purposes of our totalling task, we are concerned with the book category and price, since we want to find the total price of the books in each category. Hence, the column that lists the category (column D) and the price (column E) become part of the range argument (D2:E58). In the example, we have extracted the totals for three categories of books: comics, thriller/mystery, and romance. These become part of the criteria argument. Finally, the price data we want Excel to total up lies in the E2 to E58 range. This we specify as the sum_range argument. Hence the formulas used to calculate the totals price of books in these categories will be:

- `=SUMIF(D2:E58,"=comics",E2:E58)`
- `=SUMIF(D2:E58,"=Thriller/Mystery",E2:E58)`
- `=SUMIF(D2:E58,"=romance",E2:E58)`

The SUMIF function is great when you have just one criterion to work with, but what if you need to use multiple criteria? This is where the Conditional Sum Wizard comes in.

First you need to activate this Wizard from the Add-ins dialog box. To do that, open the Excel option for it by clicking on the Office Button and then on the Add-ins section. At the bottom of the window next to "Manage:", select Excel Add-in from the drop-down list and click “Go...” Check the “Conditional Sum Wizard” and click OK. Excel will add this Wizard to the Solutions group in the Formula tab. Click on it to start.

In the first step, the Wizard asks you to select the range which contains the
information. Select the range and click Next.

In step two, Excel will try to intelligently guess which column contains the information to be summed up, and will provide you with a drop-down list of the columns with the specific criteria that you want to set. Once you've specified your selection, click next.

In step three, you can decide whether you want to copy the result to a single cell or copy the formula and its conditional values also. We've selected to do the latter. Click Next.

In step four, you select or type in the cell reference where you want the result to appear. Make your selection and click Next. Excel will now ask you to select the locations where you want to place the conditional text values you have specified. Depending on
the number of conditions specified, Excel will ask you for the locations to place each of them. When you are done, click Finish.

Similarly, you can run the Wizard again and build a list of totals based on conditions that you have specified.

\[
\text{AVERAGE(number1,number2,...), MIN(number1,number2,...), MAX(number1,number2,...)}
\]

The Average, Minimum, and Maximum function calculate the average, minimum, and maximum for a given list of numbers, respectively. If you have a long list of numbers, simply enter the function in a new cell and specify the range, or individually select each cell you want to include in the calculation. Example: \(=\text{AVERAGE}(A1:A10,B1:B5)\). Note that you can quickly access all three functions from the AutoSum drop-down button (Formulas tab, Function Library group).

\[
\text{COUNT(value1,value2,...), COUNTA(value1,value2,...), COUNTBLANK(value1,value2,...)}
\]

The COUNT and COUNTA functions count the cells that contain data. The difference between COUNT and COUNTA is that COUNT will only count those cells with numeric entries, while COUNTA will count both numeric and text entries. The COUNTBLANK function, as the name suggests, will count only the blanks in the list.

\[
\text{COUNTIF(range, criteria)}
\]

Similar to the SUMIF function, the COUNTIF function counts the cell in a range based on specified criteria. The range argument as the name suggests requires you to specify a range of cells over which you will apply the criteria argument. The range argument
can, as in other cases, refer to a cell range or a named range. The criteria argument can take many forms—some of which are explained below.

=COUNTIF(A1:D10,7)
Counts all the cells in the range A1 to D10 with the number 7

=COUNTIF(A1:D10,"Delhi")
Counts all the cells in the range with the text Delhi. Any text or expression should be enclosed in quotes—e.g.: "<13", "<>234", "Digit" etc

=COUNTIF(A1:D10,C7)
Counts all the cells in the range which matches the contents of the cell C7.

=COUNTIF(A1:D10,">"&C7)
When you want to use operators other than equality then you need to use quotes for the operator and join it to the cell reference using the & (ampersand) symbol. Thus in the above expression Excel will return a count of all the cells where the content “is not equal to” the content in cell C7.

=COUNTIF(A1:D10,"milk")
=COUNTIF(A1:D10,"orange")
=COUNTIF(A1:D10,"?eat")

Using wildcard operators is another powerful way to extract information from texts in cells. There are two wild card operators, * and ?. The asterisk (*) specifies to search for any text while the question mark (?) specifies to search for a specific length of text characters. In the first example above, Excel searches for all cells in the range ending with the text milk—e.g. chocolate milk, rose milk, etc. In the second example Excel searches for all text in the range containing the text orange—e.g. florida oranges, orange
float, etc. In the third example, Excel searches for all cells that contain the word ending in “eat”—e.g. treat. Note that with the wild card “?” words like meat and feat will fail, since there are two question marks specified in the search criteria, so only words with two letters and ending in “eat” will be counted.

For those wanting to get into advanced statistical analysis, there is also the Analysis Toolpak add-in. This is available from the Add-ins window, under Excel Options, which is accessed by clicking on the Office button. At the bottom of the Add-ins window, select Excel Add-ins from the drop down next to “Manage:” and click Go…. Select the Analysis ToolPak checkbox and click OK.

Once you’ve activated the add-in you can now access all these advanced functions by clicking on the Data Analysis button in the Analysis group on the Data tab.

What we have covered in this chapter is but a sampling of the
possibilities in Excel using functions and formulas. The advanced and specialised formulas in the categories Text, Lookup & Reference, Engineering, Cube, and Information (not covered here) also provide you with powerful ways to manage and treat data.

In most cases, for whatever you are trying to do, there is a good likelihood that you can achieve your result by using one function or a combination of functions. If you juggle a lot with numbers and text, taking the time to get familiar with Excel’s functions and formulas has the potential to leapfrog your productivity and save you time.