Fast Track to Windows XP

By Team Digit
Credits

People Behind This Book

EDITORIAL
Deepak Ajwani Editor
Robert Sovereign-Smith, Copy Editor & Writer
Ram Mohan Rao, Copy Editor & Writer
Jyotsna Rege Copy Editor
Deepak Dhingra Writer
Sanket Naik Writer
Jayesh Limaye Writer
Anup Nair Writer
Nimish Chandiramani Writer
Prakash Ballakoor Writer

DESIGN AND LAYOUT
Vijay Padaya Layout Designer
Sivalal S Cover Design
Harsho Mohan Chattoraj Illustrator

© Jasubhai Digital Media
Published by Maulik Jasubhai on behalf of Jasubhai Digital Media.
No part of this book may be reproduced, stored in a retrieval
system or transmitted in any form or by any means without the
prior written permission of the publisher.

February 2006
Free with Digit. Not to be sold separately. If you have paid
separately for this book, please e-mail the editor at
editor@thinkdigit.com along with details of location of
purchase, for appropriate action.
For a long time now, Windows XP has been the primary Operating System (OS) for the majority of the world. Though we at Digit have covered its features and provided you with tips on how you can improve your user experience, we have never had the chance to completely demystify it for beginners and intermediate users alike.

This Fast Track booklet is the perfect place to cover topics such as Windows XP. So we decided that we could do justice to it by allocating XP it’s own special place on your Fast Track book shelf.

This book will start from the fundamentals in Chapter 1, take you on a scenic tour of the Windows operating system museum of history, so you can see how much Microsoft’s operating systems have evolved.

Next is some simple tips and guidelines to help you get started with Windows XP, from installation to your first boot up and beyond. After that, you will be walked through the basics of using XP—learning to managing files, folders and documents, learning to print, working your way through the Control Panel, etc. Chapter 5 will show you how to get online, Chapter 6 will let you in on the secret of customised desktops and how to have complete control over the look and feel of your desktop.

Chapter 7 will walk you through XP’s support for digital audio and video, while Chapter 8 will help you get your hands dirty and tweak XP to suit your needs.

Chapter 9 and 10 will help you run your computer smoothly by dealing with maintenance and security respectively. Finally, Chapter 11 will show you the basic networking knowledge you need to set up a home network.

All in all, we’ve made it comprehensive, and are sure you’ll love this little ready reckoner for Windows XP.
Operating Systems—
The Basics

It controls everything on your computer—nothing is safe from this mysterious force we call the Operating System. We take a look behind closed doors to see what’s really going on in your computer.
Imagine this: you’ve bought a shiny new PC, and you are quite happy with it—your favourite programs run just fine, and life in general looks good. Soon, of course, your PC will become too slow to run the latest versions of your applications, and you will need to upgrade. You’ve changed your motherboard and processor and now fire up the program, only to realize that it doesn’t work! Believe it or not, this actually used to happen.

Programming for a computer usually meant knowing all the details about the hardware, and should that hardware change, programs would become useless and would have to be rebuilt to suit the new hardware. This was not so bad for early computer systems that were designed for just one or two purposes, but with the growing complexity of programs, it became necessary that programs be scalable and runnable on all computers, without having to bother about changing hardware.

The Operating System (OS) acts as a middleman between applications and hardware, with the help of which programmers don’t need to know the nitty-gritty of the hardware they write codes for. Their programs just need to talk to the OS, which in turn talks to the hardware. To achieve this, the OS provides programmers with an Application Program Interface (API), which lets them write programs that can communicate with the OS.

Your computer has many resources that help applications achieve their purpose. The most important, of course, is the CPU. There is also memory, hard drives, network connections, and several other pieces of hardware. The most important function of an OS is to manage all these resources and make sure that each application gets its fair share of all the resources it needs—they should get enough of the CPU’s time to get their instructions processed, enough memory to store their data in, and should be able to talk to any piece of hardware it wants to.
Finally (though not always), the OS talks to the world—it provides a user interface, which lets users give instructions to the OS or run applications of their choice. Earlier, OSes used the *command line interface*, where users would type in what they wanted the OS to do. Today's OSes give us a *Graphical User Interface (GUI)*, pronounced “gooey”. We use the mouse to point to and click on the pretty icons and they magically start our programs.

While the things they do remain the same all over, different operating systems do things differently, depending on what they are designed for.

1.1.1 Real-time Operating Systems (RTOS)

Real-time operating systems are no-frills operating systems designed for one thing—performance. They are typically used in scientific research, industrial robots and devices like mobile phones. They offer little, if any, user interaction.

Real-time computing means that the system must conform to very strict time-constraints or deadlines. For example, if the time taken for a robot to lift an object and move it from point A to point B is 10 seconds, then it must be 10 seconds always—nothing less, nothing more. Imagine what would happen if a car’s fuel injection system injected petrol into the engine before it was ready for it—at best, the engine might sputter, but at worst, it could suffer serious damage!

Real-time OSes are the toughest to write—programmers need to use specialised algorithms to manage resources and ensure that the system’s deadlines are always met.

1.1.2 Single-Task Operating Systems

As the name suggests, these operating systems are capable of running only one task at a time. All system resources are devoted to this single task, and are returned to the OS once the task is complete. Most mobile phone OSes are single-task systems.
1.1.3 Multi-Tasking Operating Systems
All modern OSes—Windows, Linux, Unix, Mac OS X and others—are capable of multi-tasking: running many programs at the same time. Resources are shared by all the programs turn by turn on a ‘time-sharing’ basis. The operating system decides which program is allowed to use the computer’s resources and when.

Multi-tasking operating systems are loved by one and all—users can run many different applications at the same time, programmers can write programs that perform multiple tasks simultaneously rather than waiting for one task to finish before beginning the other, and finally, chip designers are happy because multi-tasking makes better use of the capabilities of their chips. We will talk more about multi-tasking later in this chapter.

1.1.4 Multi-User Operating Systems
Multi-User Operating Systems are designed so that many users can use the system’s resources at the same time. Such OSes are called “Server” or “Mainframe” operating systems. In addition to managing different tasks, multi-user OSes need to ensure that each user is getting the most out of the machine, and that problems with one user do not affect other users.

This was usually the scenario in older corporate environments where all resources would be present on one central computer, and all users would connect to it from their terminals—basically a keyboard and a monitor—to access their programs.

1.1.5 Multi-Processing Operating Systems
To do their job better, many OSes support the use of more than one processor. This way, tasks can be carried out in parallel, speeding up the system. This was especially useful for servers, which need to perform a large number of operations as quickly as possible.

There are two ways for an operating system to work in a multi-processor setup. The first, called Asymmetric Multi-processing, gives one processor to the OS to use exclusively for its own tasks. Tasks
for other applications are then distributed among the remaining processors. In the second approach, Symmetric Multi-processing, all tasks, including those of the OS, are distributed evenly among all the processors.

1.2 The Heart, The Soul, The Kernel

Between applications and the hardware stands the kernel. It is the part of the operating system that performs the most basic and most critical functions that an OS is supposed to support. Its functions are:

- To make sure that all running applications (and the OS itself) get adequate CPU time to perform their operations.
- To manage the system memory and ensure that applications are getting what they need.
- To provide a Hardware Abstraction Layer (HAL), which hides the details of the hardware from applications, providing them instead with a set of instructions they can use to access the devices. This way, the application does not depend on which manufacturer the devices come from.
- To help applications talk to each other—this is called InterProcess Communication (IPC).
- To manage files stored on the system’s hard disk.
1.2.1 Where It Fits In

The operating system’s kernel sits in the system memory in a protected space all to itself, called the *Kernel Mode*. It is this memory space that is used for the many functions it performs. The remaining space is called the *user mode*, and this is used by the various applications that you run on your OS. None of these applications are allowed in the kernel’s private space; this prevents them from corrupting the kernel’s data and crashing the system.

When your system starts up, the kernel is loaded into the memory, and remains there till the system shuts down.

Designing a good, robust kernel has always been a challenge, and OS developers use different approaches to get what they want.

1.2.2 The Lone Ranger—The Monolithic Kernel

The monolithic kernel is the one-stop solution for all the features of the OS. All these features run in the kernel mode. The features are written in *modules*, which are logical divisions of the different functions of the OS. So your OS would have a Memory Management Module, a Disk Management Module, and so on. Software talks directly to the kernel, which talks directly to the hardware. The monolithic approach is quick and efficient because of the tight integration between all its different modules; it makes optimum use of the resources at its disposal.

However, there are dangers to this approach. It is very difficult to write kernel modules that gel well with each other, and even then, the tiniest mistake in even the most insignificant module is capable of taking the whole system down. Another problem with the monolithic kernel is that it can be quite a waste, because it
loads all the kernel modules even if many of them are not need—for example, loading LAN and network management modules on a home computer that isn’t connected to a network.

The UNIX and Linux kernels are classic examples of monolithic kernels. The Linux and BSD (Berkley Software Distribution)—a variant of UNIX—kernels can even load new modules while it is running in the system’s memory to extend their capabilities when needed.

1.2.3 The Team Captain —The Microkernel

The microkernel is a bare-bones kernel that only takes care of very critical functions such as basic hardware abstraction, managing processes, and handling communication between processes. All other functions are carried out by separate applications called servers, which are run in the user mode.

The advantage of this design was supposed to be efficiency—servers would be loaded into the system’s memory only when needed, as opposed to the monolithic approach which loaded even unnecessary modules into memory. Moreover, a badly-written server would only cause itself to crash without crashing the entire system. However, the kernel has to manage servers like regular processes—switching between them to give each of them access to resource—and the time consumed in this activity caused it to slow down. By the mid-90s, researchers had all but given up on try-

**Microkernel vs. Monolithic**

“Asking the system for the time”
Time taken (Monolithic UNIX Kernel): 20 Microseconds
Time taken (Mach 3 Microkernel): 114 Microseconds
ing to make a faster microkernel. Newer microkernels, though, have tackled the performance issue to a respectable degree.

Popular microkernel-based operating systems are Apple’s Mac OS X and the Symbian OS. Because crashing servers do not crash the OS itself, microkernels are very stable, and are thus used in applications where the OS cannot be allowed to fail. A notable example is the robotic arms of the Hubble Space Telescope.

1.2.4 The Middle Ground—The Hybrid Kernel

The hybrid kernel is designed to compromise between the monolithic and the microkernel. It still uses servers in the user mode, but it also integrates some of these servers in the kernel mode itself to improve performance. This way, researchers aimed at striking a balance between the speed of the monolithic kernel and the stability of the microkernel.

The hybrid kernel appeared on the scene before it was realised that even pure microkernels could be high performers. Windows 2000 and Windows XP use a hybrid kernel. The microkernel itself is called the kernel, and the servers together are called the NT Executive.

Off-beat

Unununium (please don’t ask us how this is pronounced) is an experimental OS that doesn’t use a kernel at all! Instead, it is composed of many components that are loaded into and unloaded from memory as and when needed. This way, no part of the OS is always present in memory, leaving more room for applications to play.
1.3 The Juggler—Multitasking

Before we move further, there is the small matter of Processes and Threads to be dealt with.

1.3.1 Processes And Threads

A **process** is the running version of a computer program. It is given its own private space in the system memory which it uses to store its code and data. The **context** of the process is the entire contents of this memory, and some more data about the system’s state. This way, when the context of a process is loaded into the memory, it can start executing from when it left off. Processes are sometimes called “virtual machines”, because each process is given the illusion that it is the only one running on the system. Thus, many virtual machines run on the same physical machine, all managed by the operating system.

A **thread** is a sub-process created by a “parent” process. It runs in the same memory area as the process that creates it, and shares data with other threads created by that process. One process may create many threads to do different things at the same time. For example, while one thread of Microsoft Word brings your input onto the screen, another thread checks your spelling as you type, and yet another is saving backups of your document—just in case.

1.3.2 From Multiprogramming To Multithreading

Multitasking, simply put, is the ability of an operating system to do many different things at the same time. It sounds simple enough, but how do you do many different things at the same time when all you have at your disposal is a processor that can only process one instruction at a time?

**Seeing how many threads are created by a Process**

In Windows XP, hit [Ctrl] + [Shift] + [Esc] to bring up the Task Manager. Under the Performance tab, you will see “Threads” and “Processes” in the box labelled “Totals”. Now go to your Start Menu and select a program (let’s say Microsoft Word). You will notice that while only one process has been added, the number of threads has increased by four or five.
The first answer was multiprogramming. Many programs would be loaded into memory, and one would run first. Now, if this program was waiting for a device (like a drive) to process its data, valuable CPU time would be wasted. Instead, the context (see §1.3.1, Processes and Threads) of the program would be stored in a temporary location, and a different program would be allowed to use the CPU. This way, more work could get done, and faster.

The multiprogramming approach soon gave way to a ‘time-share’ approach. The idea was that each program should ‘give back’ resources to the OS every so often, so that these resources could now be given to different programs. This was called Co-operative Multitasking. Developers would write programs that would save their context after running for a fixed time and hand control over to other programs. While this sped things along quite well, there were a couple of very serious flaws. If the programmer had made a mistake, the program might well end up hogging all the system’s resources. At best, it would end up being the only useful program; at worst, it could crash and bring the whole system down with it.

Today’s OSes use Multithreading—they prefer to switch between threads rather than whole processes. Context-switching for threads is faster because they don’t have their own memory context—they run in the context of the process that created them. Rather than leaving it up to processes to multitask among themselves, the OS kernel takes charge and assigns them ‘timeslots’, within which they can use the system’s resources. After their time has expired, the OS saves their context, loads the context of another process, and resumes execution from there. This is called Preemptive Multitasking.
There are many ways for an OS to schedule the time that threads enjoy the use of system resources. The simplest of the lot is the *round robin* method. Each thread is loaded turn by turn, and once the OS has reached the last thread, it returns to the first and starts all over again. Most OSes use *priority-based scheduling*, where higher priority threads are given bigger chunks of time. The priority of the thread is sometimes coded in by the programmer, but the operating system is the ultimate authority in this matter. It puts its own critical processes at a higher priority, and if it can give a thread the priority level it asks for, it does.

### 1.4 The Manager—Memory Management

The memory on your machine is divided into two categories. First, there is the system’s physical memory—RAM chips. These chips are built for exchanging data with the CPU at very high speeds. Unfortunately, high speeds come at high costs, and even the richest know that it isn’t wise to invest all one’s money in RAM. Instead, we load our systems with all the physical memory our budgets allow, and add to it a cheaper (and slower) storage medium like a hard disk drive. This hard drive is now used to provide us with *virtual memory*.

Let us look at an OS running multiple tasks. One option for it would be to divide the available physical memory among the tasks, and give each portion to one task. This may make sense for two, maybe three processes which will get all the memory they need, but any more and your system would be slower than a pregnant hippo. Rather than face this, a better option would be to let each process have the memory it needs, and should the physical memory fall short, to store the process’ data on a hard disk, and bring it into the physical memory when needed. This space that the operating system uses on the hard disk is called *virtual memory*. Using virtual memory, the OS ‘fools’ programs into believing that they have the system memory all to themselves.
1.4.1 “Where did my page go?”—How Virtual Memory Works

Consider the case of a process running on your system. It’s one that requires a large amount of memory, but your OS cannot spare that much. What it does instead is load only the most essential part of the process into the physical memory, putting the rest in the virtual memory. Soon enough, the process will raise a ‘page fault’, because it couldn’t find a page it wanted in the physical memory. This, of course, is because your OS put it on the hard drive. At this point, the OS suspends this process, and begins to look for the page in the virtual memory. If it cannot find the page, it tells you that the process cannot go on under these conditions, and kills it. If, however, it does find the required page, it begins to look for free space in the physical memory for it to store this page. If the memory is full, the OS will look for pages that haven’t been used in a long time; it will then take the oldest of these pages, put it into the virtual memory, and use the newly freed space to load the page it got from the virtual memory. It now wakes up the process and tells it that its page is ready.

1.5 Putting It All Away—Managing Storage

Your data is organized into files—collections of data that represent one single unit. All operating systems have a preferred method to organise these files on storage devices, to make them easy to find and use.

Before we look at how your operating system organises these files, let’s take a look at what it’s organising them on. Most storage media is in the form of a disk, organized into tracks, sectors and blocks. Sectors are like slices of a pizza—any disk is made up of a large number of sec-
tors. Tracks are concentric circles that start at the centre of the disk and move outward to the edge. Blocks are the areas that lie between sectors and tracks: it is the blocks where data is stored.

As users, we can’t really be expected to understand how to store our data in these sectors and blocks, so our operating system gives us a filesystem, which is its way of protecting us from having to understand storage devices—by showing us our data in a friendlier way. To be more specific, the OS shows us our data organised into directories, which contain our files. Directories may also contain sub-directories, which could contain more sub-directories and files, and so on. While nearly all OSes organise data into directories, the ways they finally write the data to the disk are different.

The simplest filesystem is the File Allocation Table (FAT), which is understood by most OSes today. Let’s look at it this way—the hard drive is a massive warehouse with many shelves (sectors), and each shelf with many boxes (blocks). The OS is the supervisor of this warehouse. Let’s say that the warehouse is empty right now. A new truckload of files has arrived, and the OS must now put them away into the shelves. It starts at the first shelf and begins putting the files in their boxes. If a file is too big for the box, it splits it up and starts filling new boxes till the entire file is stored. While it stores the files, it takes notes in its FAT, which is its handy guide to all the files in the warehouse. The FAT tells it which file is stored in which shelf, and this helps it locate it quickly if a program asks for that file.
The FAT16 filesystem, introduced for MSDOS, had a 16-bit FAT counter. This meant it could write 65,535 entries into the FAT. Each entry corresponded to one block, and each block could hold 32 kilobytes of data. This added up to a support for only 2 GB disks. Then came FAT32, which could theoretically support disks up to 2 terabytes in size, but there have been problems with this, and to be safe, the maximum disk size is limited to 32 GB.

The NTFS (New Technology File System), introduced by Microsoft for Windows NT, took file organisation one step further. For one thing, it added journaling—it writes changes to data in a “journal” before it actually makes the changes. This way, if the system crashes and the OS sees data that doesn’t make sense, it just runs through the journal and keeps making changes till everything is nice and consistent once again. NTFS also brought security and access control to file storage.

Another type of filesystem is the Log Structured File System. In this case, the journal is the filesystem itself, which allows for “time travel”—you could go back and look at older versions of the same data. If data gets corrupted, it becomes easy to just go back to when everything was running fine. Right now, though, there is no Log Structured File System that has commercial popularity.

1.6 Summing It Up
The OS, we have seen, enters the picture everywhere—whether it’s juggling the various windows you have open at any time, or fetching data from your hard disk, or assigning memory to a program. Unless there’s a programmer willing to write code just for your hardware configuration, your computer—without an OS—can’t do much except blink lights on and off.
The Evolution Of Windows

We love our time-machines here at Digit, and we take a ride once more—to witness the long, stormy history of the most popular OS today.
2.1 The History of the Operating System

The earliest computers were built for a particular purpose, and had their programming hard-wired into them. Data was given to the program through punch-cards, which could be altered easily. But to change the purpose of the machine, you needed to physically alter it, or buy a new one altogether.

**Von Neumann to the Rescue**

The Hungarian scientist John Louis von Neumann was the first to propose the idea of the “stored program”—where the code for the program was in the same memory area as the data. He figured (and correctly, too) that this wouldn’t be a problem, because the computer could tell the difference between data and code.

Putting data and code together meant that computers could be more flexible, and reprogramming them wouldn’t be such a headache anymore.

**Getting your work done**

This is how you would write and run your program in the good old days:

- First, figure out what it is you want to write.
- Punch out your program and data on a paper tape or punch-card.
- Wait in a queue of programmers outside the computer room.
- Enter your program into the computer.
- Wait for your program to finish running or crash.
- Repeat if desired.

This would become quite tedious, and soon it was proposed that some scheduling needed to be done. Programmers were given appointments in the day to come and run their programs. At the end of their appointment, they would give the machine to the next programmer. As the computers got more powerful, the time taken to finish a program grew lesser, and the computer would sit idle for longer. This was unacceptable—these were expensive machines, and people could not afford to let it just lie there, could they?
The first operating system
To ensure that the precious computers weren’t wasted, companies and educational institutions needed a system which ensured that programs are always running on it.

Believe it or not, the first operating system was human—full-time computer operators who were hired to make sure that the computer would never be idle. Programmers would come to them with their programs on a punch-card and tell them to execute it. The operator would run the program, record the output, and give it to the programmer who would return after a nice snack.

The first real operating systems
Soon enough, programs were written that would perform the tasks of the computer operator—they would run a program, free up the resources used by it, and move on to run the next program. These were the first computer operating systems.

Every programmer used to write his or her own code to generate an output for their program, and the makers of the OS wanted to relieve them of this as well. This led to the introduction of the device driver—programs that could already talk to hardware. So programmers now just needed to write code to talk to the driver, rather than write their own drivers. It was also decided to give programmers a set of library functions—basic functionality that nearly all programmers would use. The management capabilities, device drivers and library functions together made up the structure of the OS—a structure it has even today.
2.2 From DOS to Windows XP

In the beginning, there was darkness; and out of that darkness there came a light. “A:\”, it said, and the world was happy.

Grandpa—MSDOS

MSDOS (Microsoft Disk Operating System) was Microsoft’s first operating system for the PC. It dominated the scene through the ’80s, and carries on till today, albeit in a less important role. It was actually developed by Seattle Computer Products, who called it QDOS—the Quick and Dirty Operating System. Microsoft then bought the system from them for just $50,000 and changed it to MSDOS. DOS was a simple system—it only let one program to run at a time, and gave it full control of the machine. If a program crashed, there was no other option but to reboot.

DOS gave ‘drive letters’ to each disk drive on your system—‘A:’ and ‘B:’ were the floppy drives, and if you were lucky enough to have a hard drive, it would be called ‘C:’. DOS organized these disks into files and directories, and used the FAT (File Allocation Table) to keep tabs on them.

DOS filenames consisted of two parts—an eight-letter name, and a three-letter extension, both separated by a dot ‘.’—For example, “filename.ext”. The file’s extension told DOS what type of file it was, and which program to use to open it.

Users spoke to DOS using a Command Line Interface. Put simply,

The heart of MSDOS

- io.sys: This let DOS communicate with the hardware through the BIOS (The Basic Input/Output System)
- Msdos.sys: This was the DOS kernel
- Command.com: This is where all the DOS commands were stored and interpreted
- Config.sys: Hardware configuration information was stored here
- Autoexec.bat: All the programs that were supposed to run at startup were called here
DOS would ask for a command using the Command Prompt, and you would type in what you wanted it to do. If you had lots of commands which you needed to run over and over again, you would used the handy ‘batch’ file—just type in all your commands into the batch file, save it, and now all you needed to do was to tell DOS to run this batch file, and it would run all your commands without disturbing you.

DOS has always been part of its successors, and Microsoft only ceased further development on it in the year 2000.

The forgotten uncle—Windows 1.0
Somewhere in 1983, Microsoft offered to rescue its users from the drab and tedious interface of DOS by introducing the first GUI (Graphical User Interface). Instead of having to type in their commands, users would be able to use the nifty new ‘mouse’ to point and click on what they wanted to do. What’s more, they’d be doing this in a brand new environment with pretty colours and everything. They first called it the ‘Interface Manager’, but then changed it to the more appealing ‘Windows’. Windows 1.0 launched in November 1985.

Windows 1.0 gave users the ability to run more than one DOS application at the same time. However, it isn’t really regarded as a full-fledged operating system—rather, it was an extension to DOS that gave users a friendlier environment to run their applications, most of which were written for DOS. Many DOS applications still accessed hardware directly, rather than using the device drivers that Windows supplied. Files were managed using the MS-DOS Executive, which was a marginally better looking interface than the old DOS way.

The development of Windows’ GUI was tough for Microsoft—they faced possible legal battles...
with Apple (who had come out with their own Graphical OS—the Macintosh OS—in 1984) if they copied any of the features of the Mac OS. For example, Apple believed it held the rights to the concept of a “Trash Bin,” which stored files before they were permanently deleted. Further development on Windows was seriously threatened, and Microsoft averted it by signing a licensing agreement with Apple which let them use the same features that Apple offered, in all the current and future versions of Windows.

Windows 1.0 had little luck in the market. It was slow, and plagued by hardware and software compatibility issues. Applications for Windows were little more than toys, and there was no real reason for business users to use it. Its breath of life came when Aldus Pagemaker, a popular page-layout software for the Macintosh, came out with a version for Windows, finally giving Windows the status of a credible OS. Now that Microsoft saw a future in Windows, it was time to spruce it up.

**Cleaned up—Windows 2.0**

Microsoft released Windows 2.0 in 1987 to take advantage of the awesome processing power of the Intel 286 processor. It was released with the same, if not greater fanfare as Windows 1.0, and sported a much better look. It introduced the concept of maximising and minimising windows, and now that they had signed the agreement with Apple, Microsoft even introduced overlapping windows, which they couldn’t have before. They also made the [Alt] key bring up the main menu—something still present in all Windows programs.

Windows 2.0 also saw the introduction of the first versions of Microsoft Word and Excel. Other software developers were also sitting up and taking notice of this new OS and started developing applications for it. They didn’t pack up their DOS applications just yet, for Windows was still new on the scene and was used only by a minority.
Windows 2.0 evolved to Windows/386, which was the same, only it used the 386 Microprocessor’s Enhanced Mode, giving Windows the ability to run each application as a Virtual Machine with access to most of the system’s memory rather than dividing up memory across applications.

The better look, though, looked too much like the Mac OS, and before they could blink, Apple came after Microsoft with accusations of violating their licensing agreement. A four-year court battle ensued, at the end of which Microsoft won its case.

Third time lucky—Windows 3.0
After the first faltering steps, Windows gained huge popularity in its third version, released in May 1990. It came with a prettier 16-colour interface, and new technical bells and whistles that let it make better use of the memory management capabilities that Intel had put in its 286 and 386 processors. Even if you had a lesser processor than the 286, Windows 3.0 would still support it, albeit without added features such as virtual memory.

Windows 3.0 was faster than the previous versions, and finally asserted the PC as a worthy competitor to the Apple Macintosh. The biggest thing to happen to Windows was the support it received from other application developers. More and more programs were written for Windows, giving more users a reason to invest in it.
Up until Windows 2.0, users had to use the boring MS-DOS Executive to manage files and run their programs. In Windows 3.0, Microsoft introduced the Program Manager and File Manager, simplifying things a little. It also brought all your system configuration options under one roof—the Control Panel. Apart from the Control Panel that we know so well, Windows 3.0 also saw the birth of one of the most popular games of all time—Solitaire!

In 1991, Microsoft brought multimedia support for Windows 3.0, called Multimedia Extensions 1.0. It gave Windows support for CD ROM Drives and Sound Cards. It also contained a basic CD Player application for Windows.

Windows 3.0 was still buggy, and had little support for networks, leading Microsoft to its next step.

**The ongoing struggle—the Windows 3.1 family**

In 1992, Microsoft released Windows 3.1, which addressed many user and developer brickbats. For the developer, Microsoft gave a big, comprehensive API (Application Programming Interface), which simplified the task of creating user interfaces and let them focus more time on developing the core functionality of software.

On the visual front, Microsoft introduced the TrueType font system, which led it to be taken seriously for Desktop Publication. They also brought us another favourite—Minesweeper. It also integrated the multimedia support which had only been offered as a separate add-on to Windows 3.0.

In 1993, Windows for Workgroups 3.1 was released, which added support for networking and file and printer sharing. It also added Microsoft Mail—a pro-
gram to send and receive e-mail over the network, and Schedule+, which could be used to schedule people’s tasks over the network.

The entire series of Windows so far stood between the application and hardware for Windows applications, but they still allowed DOS programs to talk to the hardware directly. Also, because programs did not run in their own ‘protected’ memory, it often happened that programs would inadvertently change each other’s data, crashing either each other, or the OS itself. This wasn’t such a big deal for the home user, who didn’t run that many programs at once, but it did become a big concern for organisations, who couldn’t afford to have their OS crashing at random intervals.

**The Control Freak—Windows NT**

Since 1988, Microsoft had been developing Windows NT; the NT stands for ‘New Technology’. This was a whole new kernel, built for data and application security. Applications ran in their own secure memory, which couldn’t be touched by other applications. Even the OS kernel ran in its own private memory, so theoretically, nothing could crash the system. All this, and in the familiar look and feel of Windows 3.1.

Unlike the Windows versions before it, Windows NT did not run ‘on top’ of DOS—it did not need DOS to run—but existed as a separate entity altogether.
Windows NT no longer allowed applications to access hardware directly. To speak to hardware, they required explicit permission from the OS. Game developers had always written their games to access hardware directly, which meant that NT would not allow games to run any more.

In addition to all this, Microsoft also gave us the NTFS (New Technology File System) which organised data using a ‘journal’ or log to track changes that were made to data. The NTFS also allowed for data security, restricting users from accessing files they were not allowed to.

Even with all its new features, NT lacked decent support for new hardware, and this was its shortcoming. And because it was an operating system for enterprises, it came with very little support for sound and video devices.

All Grow’d up—Windows 95 and NT 4.0
If people had ever doubted that Windows would dominate the OS scene, Windows 95 removed that doubt. It came with better networking support, better device support, and it was better looking than any other version of Windows before it. But just like Windows 3.1 and before, it ran on MS-DOS.

The user interface for Windows 95 was its most ground-breaking aspect. The new ‘Start’ button gave users a one-stop solution to access programs.
Directories were represented as the familiar ‘folders’, which contained files. It added support for filenames that were 255 characters long, although it still generated 8 character filenames for compatibility with DOS. Windows 95 was also when Microsoft introduced the Registry—a consolidated database of all software and hardware settings.

Even in Windows 95, game developers still preferred to program for graphics devices directly, and Microsoft wanted to stop them worrying about hardware so that they could focus more attention on programming game logic. They decided to provide them with an API that gave them a simpler way to talk to the hardware. This API was called DirectX, and promised the same support that DOS gave them. It took a while, but as it improved, DirectX found itself being accepted by more and more game developers.

Around the same time, Microsoft introduced its latest version of Windows NT—NT 4.0 had the strong heart of its older version and the pretty face of Windows 95. It still controlled every aspect of communication with hardware for security. It also still lacked good multimedia support, and was hence regarded as more of an enterprise OS than a home OS.

**A Little bit More—Windows 98**

Windows 98 was just a version of Windows 95 brought up to speed with the newest technologies. It now supported USB devices, and could also use the new FAT32 filesystem, which let it access drives larger than 2 GB.
Internet Explorer, till now a separate feature of Windows, was now integrated into the Windows user interface—one of the more notable examples being the ‘Active Desktop’, which let you turn your desktop into a Web page.

**Coming together—Windows 2000**

In the beginning of 2000, Microsoft gave us Windows 2000, which blurred the line between Windows 98 and Windows NT. Initially called Windows NT 5.0, it was based on the rock-solid NT kernel, but promised to be as user-friendly as Windows 98. However, Windows 2000 was still not targeted towards the home user—Microsoft had other plans for them.

Earlier versions of Windows NT had come with support for platforms other than Intel’s x86 platform—like IBM’s PowerPC—but didn’t enjoy so much popularity on these platforms. With Windows 2000, Microsoft ditched support for these platforms, making Windows 2000 a purely x86 compatible OS. It supported the FAT32 filesystem along with the NTFS, making it easier for users to upgrade from Windows 98.

All said and done, the ‘hybrid kernel’ (see Chapter 1) architecture of Windows 2000 was quite robust, and it was undoubtedly the most stable version of Windows yet.

**That’s it, I’m done—Windows Me**

Later in 2000, Windows Millennium Edition was released for the home user. This was the last version of Windows to be based on Windows 95. One of the most notable things was that it didn’t support DOS in the same way—DOS programs could no longer access hardware directly.
Windows Me had always been regarded as Microsoft’s way of keeping users busy while they waited for Windows XP. It was often blasted by users as being very unstable and not really of that much use.

To its credit, though, Windows Me brought us the System Restore, which helped users take a snapshot of the best condition of their system, and restore it if things were to go wrong. It also had the largest hardware support for any Windows version.

**The Best of Both Worlds—The Windows eXPerience**

Windows XP brought together the robust kernel of Windows 2000 and all the friendliness and multimedia support of Windows Me, and painted on a new face for it.

Apart from the merger of Windows 2000 and Me, Windows XP also added new features to enhance its performance. The first of these was its ability to work even in low-memory conditions without crashing, using a technique called **Memory Throttling**. Usually, Windows likes to do many things at once, but when memory falls short, it will ‘throttle’ its memory access, doing fewer things at a time. This slows the system down considerably, but prevents it from crashing. With this support, XP can theoretically run on machines with as little as 64 MB of RAM!

A favourite among its users for its stability and user-friendliness, XP comes in many different flavours.
2.3 The many Faces of Windows XP

It started out in only two editions—Windows XP Home Edition and Windows XP Professional, but over time, newer versions of Windows XP were released, each tweaked for a new purpose.

**Windows XP Home and Professional**

The Home Edition of Windows XP, as the name suggests, was built for home users and lacked some of the features that came with the Professional Edition. It could not be part of a network controlled by a central Windows Server—a scenario more common in professional organisations. It did include the new ‘Remote Desktop Connection’ feature, which let it connect to and control other XP machines, but did not support other machines connecting to it.

The Professional Edition came with support for file encryption, which increased data security; this was not present in the Home edition. Also, while XP Professional supported two processors running in parallel, XP Home only supported one.

**Windows XP Starter Edition**

Worried about the rampant piracy of its best OS, Microsoft introduced a low-cost version of Windows XP Home in countries such as Thailand, Malaysia, India, and some Latin American countries. It also promised localised support (support for languages other than English). But the Starter Edition had some bizarre limitations. It didn’t allow users to run more than three programs at the same time, and didn’t allow programs to open more than three windows at the same time. The screen resolution could not be set to anything higher than 1024 x 768, and it was licensed to work with older processors like the Intel Celeron and AMD Duron.

The Starter Edition found little acceptance in these markets, and they preferred the cracked versions of Windows XP Home and Professional.
Windows XP Media Center Edition
A year after the launch of Windows XP, Microsoft released the Windows XP Media Center Edition, which aimed to turn the home computer into a full entertainment solution. It’s basically Windows XP Professional, with the addition of new software—Media Center. Media Center turned your computer into a remote-controlled TV, DVD Player and music system. It also lets you record video from the TV to your hard disk. Now, you can ‘pause’ live TV by recording it to your hard drive when you need to make that important trip to the kitchen but don’t want to miss any part of the news.

Media Center can only offer all these capabilities on a mean machine, and so Microsoft decided it wasn’t wise to sell it as a separate retail version, should someone try to run it on a lower-end PC. They only distribute it to computer builders, and to own Media Center you need to buy a PC that comes loaded with it.

Media Center 2005, released in October 2004, requires at least a 1.6 GHz processor, DirectX 9-compatible video hardware such as ATi’s Radeon or nVidia’s GeForce, and 256 MB of RAM at a bare minimum.

Other Editions of Windows XP
With Intel releasing new 64-bit processors such as the Itanium, Microsoft decided to release a new edition of Windows XP, called Windows XP 64-bit Edition. It was designed to exploit the abilities of both Intel’s and AMD’s newest processors. It started out with little support for multimedia applications, but this was addressed in its later versions.
XP also came in Tablet PC edition, which was compatible with touch-screens and supported handwriting notes on-screen.

For use in applications ATMs, industrial robots and TV set-top boxes, there was Windows XP Embedded, also called XPe. It’s the same OS, but re-engineered a little to run on low-end hardware like 200 MHz processors and 32 MB of system RAM. Tempting though it might be, the license for XPe doesn’t allow you to install it on a regular PC.

There’s something for everyone here, and enough to keep us happy till Microsoft finally launches Windows Vista later this year.
A chapter on installing Windows XP is warranted because it’s not as simple as popping in the CD and waiting for Setup to complete its job—there are some decisions you need to make. Apart from installing XP, we also tell you, in this chapter, what you need to do post-installation, such as installing device drivers and essential third-party software.
3.1 Windows XP: Step-By-Step Installation

3.1.1 Planning The Installation
Before you start installing Windows XP, you need to make sure your computer meets XP’s minimum system requirements: a 233 MHz Intel or AMD processor, 64 MB of RAM, 1.5 GB of free hard disk space, a Super VGA (800 x 600) or higher resolution video adapter and monitor, a CD-ROM or DVD-ROM drive, and a compatible mouse and keyboard. These are the bare minimum system requirements, and XP will work better if you have a more powerful system.

Here’s a checklist of what you need to do before starting the installation:

- Check the system requirements
- Check compatibility of your hardware with XP. Also, if you’re planning to install a particular piece of software, check if it is compatible. For the hardware check, you can view the HCL (Hardware Compatibility List) on Microsoft’s Web site; the Windows XP CD, too, has a text file that tells you what hardware is compatible. As for software, you’ll need to check the packaging or the manufacturer’s Web site for XP compatibility.
- Determine the hard disk partitioning options—keep at least 1.5 GB for the Windows XP partition, though we recommend some more
- Choose the appropriate file system: FAT, FAT32, or and NTFS (FAT is usually selected if you have a hard disk smaller than 2 GB.)

3.1.2 Beginning the installation
You can install Windows XP in many different ways, depending on your needs and limitations. Installation can be manual or unattended. You can do a manual installation in several ways:
- Boot from CD—here, no existing hard disk partition is required.
- Boot from the six setup boot disks, and then insert the CD (if booting from CD is not possible)—here, too, no existing partition is required.
If booting from CD is not possible, you can boot from an MS-DOS startup floppy. To the command prompt, create a 4 GB FAT32 partition using FDISK, and reboot. Then format the C partition you just created. Now switch to the CD drive (which contains the XP installation files), go to the ‘i386’ folder, and run the “Winnt32.exe” command.

From within an already installed OS, such as Windows NT 4.0 Server, go to the ‘i386’ folder in the XP installation CD and run the “Winnt32.exe” command.

To upgrade Windows 2000 to Windows XP Professional, you can follow the same procedure as above.

Then there are the methods of unattended installation using an installation script. We shall explain the installation using a bootable Windows XP CD. The first step before installation is to check if the computer boots to CD. If it does not, set it to do so via the BIOS. Then follows the text-based part of the installation process.

### 3.1.3 The Text-Based Portion Of The Installation

When you boot using the bootable XP CD, you are prompted with “Press any key to boot from the CD”. Here begins the first part of the setup, characterised by a DOS-like screen with a blue background.

Press [F6] at this point if you wish to install additional drivers for SCSI, SATA or other mass storage adapters via a floppy disk. Then press [F2] to run the ASR (Automatic System Recovery) sequence using an ASR floppy disk or a backup created on the hard drive. (This will be required if you already have XP installed and have a problem booting.)
After Setup has loaded the necessary drivers, you’ll be instructed to press [Enter] to set up XP, [R] to repair a previous installation of XP using the recovery console, or [F3] to exit setup. Since we’re installing a fresh copy of XP, we’ll only talk about the first case.

Now, you’ll need to read the license agreement, and press [F8] to accept it.

The next step comes about when you already have a version of Windows installed. Setup searches for an earlier version of Windows, and if it finds one, you’ll be prompted to either repair it or install a fresh copy of Windows.

If you choose to install a fresh copy of Windows, you will be provided with the existing hard disk partition configuration. If the hard disk is unpartitioned, you can create and size the partition on which you will install Windows XP Professional. If the disk is partitioned but still has unpartitioned space, an additional partition can be created and Windows XP Professional can be installed on it. If the partition that Setup chooses by default has an existing operating system, you will be overwriting it if you accept the default installation path. However, files other than the operating system files, such as program files and data files, will not be overwritten, and a dual-boot system will result.
If the hard disk has an existing partition, you can delete it to create unpartitioned raw space for a new partition. (Bear in mind that deleting an existing partition erases all data on that partition.)

Next, you are presented with the option to choose the type of filesystem for the partition on which you wish to install Windows. You may choose between the NTFS and FAT file systems. You can also choose between Quick Format and Normal Format. Normal Format is the default, and is the more reliable option, because it securely deletes all data on the partition and checks it thoroughly for errors.

Setup then begins to format the drive. After formatting, the copying of the XP setup files to the hard drive begins. When the copying is done, the computer restarts, and you must remove the floppy (if there is one) from the floppy drive. The text-based portion of the installation ends here.

3.1.4 The GUI-Based Portion Of The Installation
In this part of the Windows installation, the graphical interface is installed and activated, and the mouse, too, functions at this point. The various hardware components of the computer are detected, and the appropriate drivers are loaded (if they're available in the Windows driver database). This takes place in the background.

The ‘Regional and Language Options’ box now appears. You can customise the ‘Standards and Formats’ settings if you wish to. You can also change the keyboard language, though you’re best off leaving it at the default (US English). Click ‘Next’ to proceed.
Enter your name and, optionally, your organisation name to personalise your copy of Windows XP. Click ‘Next’.

Enter the 25-character product key that came with your copy of Windows XP and click ‘Next’.

You need to enter a computer name and administrator password in the next dialog. The computer name cannot contain spaces or special characters such as underscores and question marks. Although not compulsory, a password can be assigned. Click ‘Next’.

In the ‘Date and Time Settings’ dialog box that pops up, set the date and time, as well as your time zone. Click ‘Next’.

Next appears the ‘Networking Settings’ dialog box, where you can install network software that allows you to connect to other computers and networks, and to the Internet. Choose ‘Typical Settings’ to create network connections using Client for Microsoft Networks, File and Printer Sharing, and TCP/IP Protocol with automatic addressing.

Choose ‘Custom’ if you wish to manually configure the networking components. Keep ‘TCP/IP’, ‘Client for Microsoft Networks’ and ‘File and Printer Sharing’ selected. Then, highlight the ‘TCP/IP’ selection and press ‘Properties’. In the ‘General’ tab, enter the required information. You must specify the IP address of the computer, and if you don’t know what the ‘Subnet Mask’ entry is, simply place your mouse pointer over the empty area in the ‘Subnet Mask’ box and click it. XP will automatically select the value it thinks is best for the IP address you provided.
If you don’t know what these values mean, or if you don’t know what to fill in, press ‘Cancel’ and select the ‘Typical Settings’ option. You can easily change these values later.

You must specify either the Workgroup or the Domain name. (This step will be skipped if your network card does not feature in XP’s hardware compatibility list, that is, if the drivers for your card are unavailable from within Windows XP.)

Installation then proceeds until the Setup reboots the computer to proceed to the final part of the installation.

3.1.5 Booting Into XP For The First Time
It is in the final part of the installation that you actually boot into XP. You are prompted to click ‘OK’ in a dialog box, and doing so will set the optimal resolution supported by both your monitor and display adapter. If satisfied, click ‘OK’ to proceed.

A welcome screen comes up as you start your first XP session. Click ‘Next’.

In the next screen, you are provided with the option to enable or disable “Automatic Updates,” which help keep Windows updated with the latest security and critical updates, bug fixes and service packs from Microsoft. Of course, you’ll need an Internet connection for this.

Windows then checks if your computer is connected to the Internet, and proceeds to update your version of Windows using Automatic Update.
Next, you are given the option of either registering your copy of Windows with Microsoft right then or at a later date. Registration is optional. If you’re registered, you’ll be notified about new products, updates, events, promotions and special offers from Microsoft. If you do not have an Internet connection, select ‘No’ and click ‘Next’.

In the screen that follows, you will be asked to enter the names of the users who will use the computer. Separate user accounts with these names are created—these can be later personalised. You need to enter your name in order to proceed to the next screen and complete the XP setup.

3.2 Installing Device Drivers

After you are done installing Windows XP, there remain some things that need to be done before you can start using it. The first step is installing the latest service pack (Service Pack 2, or SP2). SP2 addresses many issues—it fixes security loopholes, known bugs, and so on. It also includes several enhancements and features such as the Security Center, which monitors the status of your anti-virus program and your firewall, and manages automatic updates—besides checking if your virus definitions are updated. Then there is Windows Media Player 9 and DirectX 9.0c as also an updated version of Internet Explorer 6. Another important feature of SP2 is the inclusion of a better and more robust Windows Firewall, and Data Execution Prevention (DEP) which helps protect against viruses and other security threats.
The next important step is installing the chipset drivers for your motherboard. This is important because XP might not recognise the motherboard chipset, in which case the full potential of the system will not be realised. All motherboard manufacturers post chipset drivers for their motherboards, and you can download the latest ones from their Web sites. You can also download them from the chipset manufacturers’ Web sites.

Once this is done, install the latest version of DirectX, which is a 3D API used by the latest games. DirectX is also necessary for smooth playback of video and audio using the DirectShow and Direct Sound components. (These are video and sound hardware accelerators respectively.) You can find the latest version of DirectX at www.microsoft.com/directx.

In a similar way, you might need to install device drivers for your display card, sound card, network card, TV-Tuner and so on, which, again, should be available at the respective manufacturers’ Web sites. This completes the installation of XP.

Running Automatic Update will also provide you with the latest Microsoft-tested drivers for your hardware along with the latest security updates, bug fixes and service packs.

3.3 Creating User Accounts

Windows XP allows multiple users on a single computer, where each user can have his own settings. To create a user account, go to the Control Panel and click ‘User Accounts’. In the window that opens, the names of all the current users are listed. New user
accounts can be created here, besides altering the existing user account settings such as account type, name, password and picture.

To create a user account, click 'Create a new account'. Type in a user name and click 'Next'. You're now provided with the option to pick the type of account that is to be assigned to each new user—you can choose between Computer Administrator and Limited Account. A Computer Administrator enjoys full control over resources. Users with such an account type can create, change and delete accounts, make system-wide changes, and install programs and access all files. Users with a Limited account have limited rights that include changing or removing his own password, changing his own picture, themes and other desktop settings, and viewing files in the 'Shared Documents' folder. Such a user might not be able to install some programs. Another limitation of such an account is that programs written for Windows versions prior to XP or 2000 might not work properly.

It's now time to personalise the new account(s). When you click 'Change the name', you can change the user name by entering a new name and clicking on 'Change name'. You can assign a password to the user account by clicking 'Create a password'. You're then prompted to enter a password and confirm it. Optionally, you can enter a phrase as a password hint.

By clicking 'Change my Picture', you can assign a new picture to the account either from the ones that
Windows has inbuilt, or from other images on your hard disk. When you click ‘Change the account type’, you can change the account type from Administrator to Limited (this requires you to be logged in as an Administrator).

### 3.4 Creating an Internet connection

All types of network connections, including dial-up, LAN, and VPN (virtual private networking), can be created and maintained within the Networking Connections window. The New Connection Wizard in that window guides you step by step through the process of creating any type of connection.

The Network Connections window lists all your connections—for example, your dial-up modem and your LAN card—and provides a wizard for creating them. You can access the Network Connections Wizard by going to Start > All Programs > Accessories > Communications > Network Connections. Click ‘New Connection Wizard’. Now, to create an Internet connection, click ‘Next’. Click ‘Connect to the Internet’, and then click ‘Next’. The Wizard guides you through the process from this point.

- If you don’t yet have an Internet account, you’re given the following option: ‘Choose from a list of Internet service providers (ISPs)’ and click ‘Next’. That this facility is not currently available in India, and you’ll have to contact an ISP and go to one of the following two steps.
- If you already have an account with an ISP, click ‘Set up my connection manually’ and click ‘Next’.
- If your ISP provided you with a CD, click ‘Use the CD I got from an ISP’ and then click ‘Next’.

Depending on what you chose, do one of the following:

**A. Set up the connection manually**

Click ‘Connect using a dial-up modem’ if you are connecting to your ISP using a 56 Kbps or ISDN modem. Click ‘Next’, and follow the
instructions in the wizard. Click ‘Connect using a broadband connection that requires a user name and password’ if your DSL or cable modem ISP connection requires a user name and password, then click ‘Next’, and follow the instructions in the wizard.

Click ‘Connect using a broadband connection that is always on’ if your DSL or cable modem connection is always on and does not require you to type a username and password. Click ‘Next’, and then ‘Finish’.

**B. Use the CD provided by your ISP**
Click ‘Next’, and then click ‘Finish’. Insert the CD your ISP provided, and follow the instructions.

**C. Choose from a list of ISPs**
This is not yet an option in India.

**Note:** If you have an “always on” connection via DSL or cable, and your ISP does not require a user name and password, you do not need to run the New Connection Wizard. No additional configuration is required for a broadband connection.

Before creating an Internet connection, check with your ISP to verify the connection settings. A connection to your ISP may require one or more of the following settings:

- A specific IP address.
- DNS addresses and domain names.
- POP3 settings for incoming e-mail.
- SMTP settings for outgoing e-mail.
3.5 Post-Install Stuff To Add

1. Anti-virus Software
Before you start surfing the Internet or sharing your files on a network, you must install anti-virus software, otherwise your computer could get infected in a matter of seconds. There are quite a few anti-virus software available, such as Norton AntiVirus 2006 (www.symantec.com), McAfee ViruScan (www.mcafee.com/us), PCCillin from Trend Micro (www.trendmicro.com), Panda anti-virus (www.pandasoftware.com), Kaspersky anti-virus (www.kaspersky.com), AVG Anti-Virus (www.grisoft.com), and more. Most of these anti-virus software are paid, but some such as Avast! from www.avast.com and BitDefender from www.bitdefender.com are free. Note that paid anti-virus does not necessarily mean better protection against viruses.

Remember to always keep your anti-virus software updated with the latest virus definitions from the software publisher’s Web site, or by using the update facility in the software.

2. PDF Readers
Many e-books, help files and documents are currently available only in PDF (portable document format). The advantage of this format is that PDF files look the same no matter what platform or OS you view it on. This is possible because besides the pictures and formatting, fonts, too, are embedded in the file. In order to view files of this type, you need to install an appropriate viewer. The most popular amongst these is Adobe Reader 7. There are also a few other PDF viewers such as Foxit Reader and eXPert PDF Reader, the installers of which are smaller than that of Adobe Reader, and which also consume less system resources. All these are freeware.

3. Compression Utilities
Windows XP has its own compression utility that can compress files using the ZIP compression technique. All you need to do is right-click on a file or folder, mouse-over ‘Send to’, and click ‘Compressed (Zipped) folder’—and a Zip file is created. But this
does not let you control the compression settings, and you cannot create self-extracting archives. In order to achieve this, you need to install compression utilities such as WinZip from www.winzip.com, WinRAR from www.rarsoft.com, WinACE from www.winace.com, and PowerArchiver from www.powerarchiver.com. These software not only let you compress files and folders with a great degree of control over the compression ratio, some also let you choose the compression format, and let you create encrypted archives.

4. Image Viewing Software
Windows has image viewing and management software—namely, Windows Picture and Fax Viewer and MS Paint. But these only provide basic functionality, and you can choose from several other such software—most notably IrfanView (www.irfanview.com), ACDSee (www.acdsystems.com) and XnView (www.xnview.com). Many of these also have image management and editing capabilities.

5. Browsers
Internet Explorer 6 comes preinstalled with Windows XP, but there are other browsers such as Opera, Mozilla, and Firefox, which have features absent in IE—such as an RSS reader, tabbed browsing, and the ability to customise the browser by installing various plugins.

6. E-mail Clients
Windows XP comes with Outlook Express 6 inbuilt. Though OE is pretty OK, you might want to try out other e-mail clients such as Eudora (www.eudora.com), IncrediMail (www.incredimail.com) and Thunderbird (www.mozilla.com/thunderbird), which provide some additional features.
Using Windows XP

Now that you’ve installed XP, it’s time to have some fun playing around with it and getting used to it. This isn’t too difficult if you’re a Windows 98 user, but there are a few things that might confuse you at first. In addition, XP introduces several new features, and by the time you’re through with this chapter, you should have a hang of what XP has to offer.
4.1 Getting Around In Windows XP

In order to help users be at ease with the new look and interface, Windows XP offers a tour that tells you about the operating system in general. This tour starts by default upon completion of the installation. You can also run the tour at any time by clicking Start > All Programs > Accessories > Tour Windows XP. Here, we take you on a slightly different tour of the OS, with the idea being the same—getting you familiar with XP.

4.1.1 The Taskbar And Start Menu

The default XP desktop scheme is a bright blue with a landscape wallpaper. At the bottom of your screen is the Taskbar with the Start button (as in Windows 98). All the programs and installed applications are accessible from the Start button, while the Taskbar holds buttons corresponding to running applications. The right-hand corner of the Taskbar is known as the System Tray. It displays the clock (Date/Time settings) and volume/sound controls by default, and any application that has been enabled to start with Windows XP will appear in the System Tray. The System Tray also displays network connectivity if this is enabled in Network Connections. In short, the Taskbar and the Start Menu gives you quick access to various applications and system utilities.

Assume you have many Internet Explorer windows open at the same time. These sessions (or open browsers) are grouped within a single taskbar button. Clicking the button will list all the open windows. This happens because the option to ‘Group similar taskbar buttons’ is enabled by default. This behaviour of the Taskbar can be controlled and altered by changing its properties. To modify the properties of the Taskbar, right-click on an empty space on it and choose ‘Properties’. The window that opens allows you to view and change the properties of both the Taskbar and the Start Menu.

Here’s a screenshot of the pop-up window called ‘Taskbar and Start Menu Properties’. There are two tabs under this menu—one for the Taskbar and one for the Start Menu. The Taskbar tab is divided
into two sections—Appearance and Notification Area, with a few "enable/disable" options. You can lock, hide or keep the taskbar over other applications by checking their respective options. Choosing ‘Show Quick Launch’ will add a Quick Launch panel in the taskbar just next to the Start button. This is used to start the most frequently-used applications, such as Winamp, without having to go through the list of applications in the Start Menu. You can also choose to disable the clock.

XP displays icons for active and urgent notifications in the System Tray. For instance, there will be a Messenger icon in the System Tray as long as it is actively running. Now if many such applications are running, then the System Tray would occupy a fourth of the taskbar! To prevent this, XP has a “hide” button to hide all inactive icons. This way, you see only those applications that are currently active.

You can customise the Start Menu settings if you think the current settings don’t suit you. The Start Menu tab gives you two options to work with—‘Start Menu’ and ‘Classic Start Menu’. The latter is a style that is common to earlier versions of Windows such as Windows 2000 and 98. Once you have chosen between these two, you can click on the ‘Customise’ button to make finer changes such as the size of the icons and the list of programs.

Another useful option in the Taskbar is to add Toolbars. A Toolbar is something similar to Quick Launch—it gives faster access to items. (The first option in the pop-up that comes on right clicking the taskbar is for adding Toolbars.) You can choose to add toolbars for Links, Desktop (to access icons on the desktop), and more. You can also create your own toolbar. Let’s say you want to create a toolbar for the ‘My Documents’ folder. Choose ‘New toolbar...’ and the select ‘My Documents’ from the list that comes up.
4.1.2 Migrating From 98 To XP?

If you’re using Windows 98, you’d want to know what’s different in XP. But before we move on to the differences between the two operating systems, we should tell you that Microsoft withdrew support for Windows 98 a long time ago! It’s true that there were initial hardware and software compatibility issues when XP was first released on October 25th 2001—that’s why people took time to switch to XP. But with time, all games and software are now programmed to run better on XP. And with the arrival of Service Pack 2 (Windows XP SP2), the stability of the OS as well as hardware support has improved considerably.

So here are the main differences between 98 and XP.

- Windows XP needs to emulate the MS-DOS environment, whereas a user can log in to MS-DOS mode from Windows 98.
- Windows XP supports the NTFS file system in addition to FAT 16 and 32 (refer §3.3).
- System Restore in XP allows you to restore the OS to a previous state. There is no such feature in Windows 98.
- By using Hibernate, Windows XP users can resume using their machine from the point they last turned it off. This is not available in Windows 98.
- Windows XP is a better multimedia-based OS than Windows 98 is. It has photo sharing and printing, native CD writing, and a better Windows Media Player.
- Since DirectX is built in to Windows XP, it becomes an ideal choice for gaming.
- Fast switching between users is possible in Windows XP; a user can lock his screen and allow another user to log in right then.
- The power management feature of Windows XP is superior to that of Windows 98. That’s why most retail laptops come with XP loaded.
- Remote Desktop in XP allows a user to log in to his machine using another machine over the same network or via the Internet.
4.2 Managing Files, Folders, And Documents

Windows XP creates many folders such as ‘My Pictures’, and such folders are by default used by applications to store their files—unless the user decides to save it elsewhere. Novice users may love the idea, but it is not entirely safe to use such ‘friendly’ folders; we tell you why in §4.2.3. Before that, let’s get down to understanding the basic filesystem of Windows XP.

Windows XP installs itself on a primary partition, and if it is the only OS on your hard disk, then it is most likely called the C: drive. Let’s assume C: is your primary drive, for the sake of convenience.

4.2.1 The Default File System

Here, we try and explain what type of file is stored under what folder, rather than going into the details of each file.

The ‘C:\Windows’ folder stores files that are of critical importance for proper functioning of the OS. This folder contains the all-important ‘System32’ folder that not only stores .dll (dynamic link library) files responsible for the functioning of many process and services, but also contains the kernel (krnl386) for Windows XP and its dll. Now you know why files in ‘System32’ are more prone to virus attacks!

The Windows theme also finds a place in C:\Windows\Resources\Themes. Other folders such as AppPatch, Fonts and System also contain files that are closely associated with the functioning of the operating system. Basically, you don’t want to mess with the files in the ‘C:\Windows’ folder!

The ‘Program Files’ folder located under the root of the C: drive is assigned as the parent folder for installation of different software. Every software, by default, installs into ‘C:\Program Files\Software Name’; however, this default method of installation can be altered if the software allows the user to customise the installation procedure and choose a different path.
Few Windows users are aware of the swap file (or virtual memory) settings. The swap file is a reserved portion on the drive (the default is the C: drive) that serves as virtual RAM, and it is used if there’s no RAM left for running a particular program (refer §1.4.1). You can tweak the virtual memory settings to make your system work a little faster (Refer Chapter 8 for more details on this). This virtual memory can be seen on its target drive as a hidden file called ‘Pagefile.sys’.

The ‘My Documents’ folder has sub-folders by default: ‘My Pictures’, ‘My Music’ and ‘My Received Files’. Images and music are usually stored in the first two folders respectively, while ‘My Received Files’ is used by MSN messenger to store files that are transferred to you by your friends via the Internet.

Assuming that your computer is connected to a LAN through which you are connected to the Internet, ‘My Network Places’ shows up folders shared by other computers on your network or domain. The shared folders are visible if and only if your Internet Service Provider (ISP) does not implement a Firewall to prevent its users from interacting.

### 4.2.2 Folder Views

The manner in which files and sub-folders are arranged under a parent folder depends on the Folder View options. The default viewing option is ‘Icons’; there are five other options—Filmstrip, Thumbnails, Tiles, List and Details.

‘Filmstrip’ is applicable only for image viewing; it displays images as a strip of film with a larger preview above the strip. ‘Thumbnails’ shows a preview of the contents of a folder. ‘Icons’ and ‘Tiles’ are arrangement of files and folder into rows and columns. The display and font size for the ‘Tiles’ view is slightly larger than in the ‘Icons’ view. ‘List’ and ‘Details’ both display the content of a folder one below the other; the text and icon size under this view are the smallest. ‘Details’, as the name suggests, shows more information about a file such as the size, date/time of creation and modification, and more.
You may opt to apply one of the above styles and force Windows to display all files, folders and even drives in your preferred viewing style. To do this, open a folder, say ‘My Documents’. Click ‘View’ and choose your preferred viewing style, then go to Tools > Folder Options… Select the ‘View’ tab and click the ‘Apply to All Folders’ button.

### 4.2.3 Good Practices

We’ve mentioned earlier that using the ‘friendly folders’ Windows creates isn’t a good habit. Every OS has a decay period—after some time, a few services fail to start, resulting in a sluggish system. If a crucial system service fails, Windows may crash. Re-installing the OS will delete all the data on the C: drive. Remember that ‘My Documents’, a friendly folder, is located under the C: drive—which means you’ll lose all your documents if you format your drive and reinstall XP.

Good practice dictates that you maintain the C: drive for Windows, Program Files and other application-related files and folders. Limit the size of the C: drive to 10 GB and create separate partitions for storing personal data. Let’s assume that you and
your dad use the computer, and you do not want to create a separate user called “Dad.” You can create a separate partition, and also build a directory structure such as 'Documents' for text and office-based files, 'Pictures' for images, 'Songs' for music files, and so on.

You can also maintain a separate partition to store your song and video collection. The idea behind creating and maintaining separate partitions for your personal and important data is to safeguard them from the consequences of an OS crash.

Many people use Outlook Express or Microsoft Outlook as their e-mail client. The mails thus received are stored somewhere on the C: drive by default; use the account setting options in Outlook (or Outlook Express) to change the ‘Personal Folders’ path to somewhere other than the C: drive. Suppose you change the ‘Personal Folders’ path from ‘C:\Outlook\Personal Folders’ to ‘E:\My Mails\’. A few months down the line, if your system crashes and you reinstall Windows, you can simply reset Outlook’s mail folder path to ‘E:\My Mail’, and you’ll see all your mails intact.

### 4.3 Searching For Files, Folders, And Documents

It is very easy to search for files and folders in Windows XP—you get a host of options that you can specify, thus speeding up your search.

Press [Windows] + [F] to open the search window. Alternatively, you can open it by clicking Start > Search. Look to the left hand side: you will notice that the Companion offers to filter your search by choosing one of several options:

- Pictures, music or videos
- All files and folders
- Documents (formatted text, spreadsheets, etc.)
- Computers or people

An option to search the Internet is also provided; this uses the MSN search site. The last option you have on the main screen is that
of changing your preferences. Some changes in the preferences can be helpful. Proceed to the preferences screen by clicking ‘Change Preferences’. The first two options relate to the animated character, which you can change or disable. The most important option in the preferences is the Indexing Service. Turning this option On will enable file indexing when the system is idle. File indexing is a method by which an OS keeps a record—sort of a database—of all the files on your hard disk. When a search is initiated, it first scans this database file and verifies if the file still exists on the hard disk, thus saving time and system resources. System resources are used only when the search entry is not found in the database file, upon which it searches through the hard disk. This, naturally, consumes system memory and time, depending on the size of the partition being scanned.

Other options include changing the ‘Files and Folders search behaviour’ and ‘Internet search behaviour’. Both options deal with the method by which you can choose to search for files. For instance, you can opt for ‘Advanced Search’ in ‘Files and Folders behaviour’ or change ‘Internet search behaviour’ to use Google.com instead of MSN.com. Apart from these options, you can choose to enable or disable balloon tips and auto complete.

To begin searching, choose any of the options (from Pictures, Documents, etc.) on the main page. Let’s take ‘All files and folders’: all you need to do is type in the file name (see search tips below) and/or enter a keyword that the file may contain.

**Search Tips:**

- If you do not remember the file name but you know what the file extension is, you can use special characters. Say you’re looking for an executable (.exe) file, and you remember that the filename begins with, say, “G”, then you can enter the search word as “G*.exe”. This will search for files that have the .exe extension and also begin with the letter G. You
can also use the asterisk (*) for the file extension part. A few examples are "oo\*.jpg", cod.*, spider*.j*

The additional assistance feature: ‘Date of modification’, ‘Size’, and ‘Advanced Options’ can be used to force the search engine to look for files created or modified within a particular period, or search for files by specifying a size range. Use Advanced options to look for system files or hidden files.

4.4 Printing

A printer can be connected to your PC via the LPT port (using a Parallel cable) or through USB (using a USB cable). If you are connecting the printer for the first time, Windows XP will auto-detect the new hardware. If it has recognised the device and has the drivers for it, it will do what’s required all by itself. This is normally the case with a local printer.

Before you install a printer, you need to decide whether it’s a Local printer or a Network printer you’re installing. You also need to be aware of the type of printer, as in Dot-matrix/Inkjet/Laser, and the manufacturer name. Once you have this information, go to the Control Panel, select ‘Printers and Faxes’, and choose ‘Add Printer’ from ‘Pick a task’.

4.4.1 Adding A Local Printer

On clicking ‘Add a new printer’, an installation wizard begins, and guides you through the installation process. It first tries to detect if a printer is directly connected to your PC, and then loads the necessary drivers and default settings for it. If Windows fails to detect a printer attached to your PC, you will need to guide the wizard by
specifying the type of port, manufacturer name and model number—as and when it asks for these details. Finally, print a test page to confirm that everything is fine.

You may need to install the printer driver if the wizard asks for it. The CD-ROM that comes with the printer will have the necessary driver files.

4.4.2 Adding A Network Printer

Installing a network printer is very simple provided you know the “path” of the printer. Say your computer is on a Windows network, and a local printer is connected to a PC called “PCname”, and the name of the printer is “PrinterName”. This local printer will serve as a network printer for your PC.

Start the printer Wizard as mentioned earlier. Choose ‘Network Printer’ and click ‘Next’. Now you can either browse for a printer, which is rather tedious task, or you can just enter the path in the ‘Connect to Printer’ option. In our example, the path would be \PCname\PrinterName. A message saying “You are about to connect to a printer on PCname, which will automatically install a printer driver...” will appear when the network printer is located successfully. You will be prompted to print a test page.

If you face problems during installation, make sure the path you specified is correct—contact your network administrator for details. Problems could also arise if the PC that the network printer is connected to is turned off, or if a Firewall is disallowing connections from your machine. These problems can be addressed by a network administrator or the person handling the network printer.
4.4.3 Configuring A Printer
The added printer will be accessible from the Control Panel as mentioned earlier. Right-click on the printer and choose 'Properties'. There’s a ‘Printing Preferences…’ button under the ‘General’ tab. Open it to configure the manner in which you want the printer to work. First off, change the paper size to whatever you want (usually A4); the default is ‘Letter’. If you also want to conserve ink, change the ‘Print Quality’ to ‘Draft’.

To share your printer on the network, just right-click on the printer icon and choose ‘Sharing…’ Then choose the ‘Share this printer’ option and give it a share name.

4.4.4 Printing Documents And Pictures
For printing a simple document or HTML Web page, just click on File > Print in the application window. This will open a ‘Print’ dialog box. Use the dialog box to specify the page number you want to print and the number of copies. You can also edit the printing preferences—you can specify Normal or Draft mode, and so on. Once you have set your choices, hit ‘OK’ to start printing.

Photo printing requires a photo printer, which is an inkjet printer with better colour reproduction. For better output, use high-quality glossy paper specifically designed for photo printing. Windows XP has a wonderful photo printing wizard that can help you through the entire process of resizing and printing images.

Select the images you want to print, right-click and choose ‘Print’. The Photo Print Wizard starts automatically, displaying a preview of all the images you selected. You can choose to de-select images now before proceeding with the next step. The Wizard displays a list of lay-
outs—the layout offers you a number of different arrangements:
- Full Page Print (single image spread on full page)
- Contact Sheet Print (35 images on a single sheet)
- 8 x 10 inches (one image per sheet)
- 5 x 7 inches (one image per sheet)
- 4 x 6 inches (three images per sheet)
- 3.5 x 5 inches (four images per sheet)
- Wallet Prints (nine images on a single sheet)

A preview of each of the above options is displayed alongside to give you an idea of what will be printed.

4.5 Using Optical Media

Optical Device Drives (ODD), commonly called CD/DVD drives, are well backed by Windows XP’s driver database. You shouldn’t find any difficulty in installing a drive. If you do encounter some sort of problem, you’ve either done something wrong or the device is faulty.

Hard disks and ODDs both have jumper settings for “Master,” “Slave,” and “Cable Select.” If you have your hard disk and CD/DVD drive on the same IDE cable and if both are set to Master, then you may have only one of the device functioning at a time—in most cases, the hard disk will function and the CD/DVD will go undetected. It is good practice to maintain ODD devices on the secondary cable (there are two IDE ports, Primary and Secondary). If you have a CD/DVD-Writer, it is advisable to set it as the Secondary Master.

Windows XP comes with a CD-Writing Wizard. Although unimpressive, it can be useful to write data to CD when you do not have software to perform the task. Follow these steps to use the CD-Writing Wizard:

- Insert a blank CD into the drive. In the window that appears, select ‘Open writeable CD folder’ and click ‘OK’. Alternatively, just double-click the CD/DVD icon in My Computer.
Copy the files you want to write into this folder; you will see that the folder has a heading “Files Ready to Be Written to the CD”. While adding files to this folder, make sure that you do not shoot over the capacity of the disk (700 MB). To add files to this folder, select the files (hold down [Ctrl] and use mouse clicks to select multiple files) you want to write to the CD and use [Ctrl] + [C] after selection to copy the selection. Come back to the CD folder and use [Ctrl] + [V] to paste the copied files/folders. This information is stored as a temporary list by Windows XP, and it uses the list to fetch the files while burning the CD.

Once you’re done copying files and folders to the CD folder, click on the item labelled ‘Write these files to the CD’ to initiate the Wizard. Type in a CD name and click ‘Next’. A progress window will open, showing the CD burning operation. Upon completion of the burn process, just click ‘Finish’ to close the wizard.

4.6 The Control Panel

The Control Panel has always been the most interesting place to go on a Windows machine. In Windows XP, it has undergone some cosmetic changes, but all the options that Windows users are familiar with are still there. If you are not comfortable with the Category View as they call it, switch to Classic View.

We have covered some of the options in the Control Panel earlier in this chapter. We’ve discussed the display (in §4.1.2), Folder Options (in §4.2.2), Printers and Faxes (in §4.4) and Taskbar & Start Menu (in §4.1.1). We shall see the other important options in the Control Panel in this section. The following explanation is based on the Classic View.

4.6.1 Accessibility Options

‘Accessibility Options’ configures Windows to work for special vision, hearing, or mobility needs. Microsoft’s accessibility options are many and varied—screen magnifiers, keyboard adjustments, mouse modifications, and more!
StickyKeys allows you to press one key at a time for a combination of keys. There’s ToggleKeys, which allows you to hear tones when you press certain keys such as [Caps Lock] and [Num Lock]. Screen visibility can be improved by using a variety of colours and high-contrast colour combinations. Microsoft has implemented a good text-to-speech program called Narrator, which can help people with less-than-perfect vision. It can read text and even the letters as you type them.

Complete descriptions of the above are in the Accessibility Options window.

4.6.2 Add Hardware
Windows has improved a lot with respect to hardware detection. Almost all hardware can be detected by Windows XP, and it can even install the basic drivers. The Add Hardware Wizard has therefore lost much of its importance. However, easy hardware detection only happens with plug-and-play devices, so Add Hardware will be required when dealing with non plug-and-play devices.

If you have installed a piece of hardware that Windows does not recognise, double-click the Add Hardware icon in the Control Panel. Windows starts the Add Hardware Wizard, which helps you with the installation process.
You can let the Add Hardware Wizard search for the new hardware, and if the wizard does not recognise the hardware, you can select it from the list of devices that Windows offers. Of course, newer hardware will not be listed.

Read the installation manual that comes with a hardware device before you proceed with the Add Hardware wizard. The pack may contain drivers that install fixes and thus install the hardware without a glitch!

4.6.3 Add Or Remove Programs
All third-party software installations have setup files based on installation Wizards that guide you through the installation, so 'Add or Remove Programs’ doesn’t feature while installing a software. However, 'Add or Remove Programs’ is often used for removing installed software, and it is considered the right method, too. It is also used to add Windows components. To install Windows components, open ‘Add or Remove Programs’ and click on ‘Add/Remove Windows Components’. A Wizard begins and guides you through adding or removing Windows components. “Windows Components” refers to such programs as Windows Messenger, MS Paint, and so on.

To uninstall a particular software, choose the software from the program list in 'Add or Remove Programs’, and click 'Remove'.

4.6.4 Administrative Tools
Most options available here are designed for power users—those who know to work with such things as services and event loggers. But Computer Management is a very useful tool that anyone can make use of. We’ve covered Computer Management in the January issue of Digit (How To Use XP’s Computer Management Tool). We’ve also covered Computer Management in §9.2.

4.6.5 Automatic Updates
‘Automatic updates’ is a feature by which Microsoft tries to help genuine Windows users get patches, service packs and system updates. This helps you maintain a robust operating system.
You can set Automatic updates to any of the following four settings.

- Automatic Update (by specifying a period)
- Download updates for me but let me choose when to install them
- Notify me but do not download or install them
- Turn off Automatic updates

You need to have a genuine copy of Windows XP, and also a good Internet connection. Dial-up users be warned—the update process will take a lot of time the first time round.

4.6.6 Internet Options
Use ‘Internet Options’ to modify or set your Internet Explorer settings. You can specify the default Web page for the browser, delete temporary Internet files, and use Content Advisor to block access to objectionable material.

Double-click on ‘Internet Options’ listed in the Classic View of the Control Panel. A pop-up window with tabs opens; the tabs classify the settings under different categories—General, Connection, Content, Advanced, etc. Here’s a description of each of the tabs.

General
IE may most likely open the Microsoft page by default; you can change it to open a blank page or any page you’d like to see when you start up IE. Just enter the URL of the site under the ‘Home Page’ section. Temporary Internet Files and History both relate to your daily use of IE. Web pages you visit are cached, that is, saved temporarily to enable faster browsing. But some cleaning up of these files is occasionally required. You can change the folder size for temporary files and alter the cache settings for periodically checking changes to a Web page. In most cases, you’d want to leave the latter set at ‘Automatically’.

Connection
Use the features under this tab to set up an Internet connection by clicking the Setup button; you can also add VPN and dial-up net-
works. If your PC connects to the Internet through a proxy server, click on the LAN button to enter the settings for the proxy server. You can choose to bypass the proxy server for faster intranet browsing.

Programs
Under this tab, you’ll see a list of services such as HTML editor, e-mail, newsgroups, contacts, etc. and you can specify which program Windows should use by default to open these services.

Content
You can enable parental control by preventing certain sites (such as sites with adult content) from opening on IE. Click ‘Enable’, and then follow it up with the necessary settings. Details on how to use the content advisory is explained at www.microsoft.com/windows/ie/using/howto/security/contentadv/config.mspx

Privacy and Security
These tabs have very basic settings; for instance, you can enable or disable the pop-up blocker. Security allows you to set a security level for Internet browsing; this mainly deals with cookies.

4.6.7 The Network Setup Wizard
Use the Network Setup Wizard to register your computer on a network. Before you proceed with the Wizard, decide on a Workgroup name—it should be a name that describes your area, your housing society, or the department in which you work. Decide on a computer name as well. The Wizard now guides you through the process. The only point at which you may get confused is the type of connection. The Wizard gives a detailed description with illustrations to help you identify your connection. If you think your connection type is not listed, choose ‘Other’ and click ‘Next’. On the screen that follows, you will be able to identify your connection type. Towards the end, the Wizard will try to be friendly and offer you to set up network connections for other computers. Just click ‘Finish the settings and close the wizard’.
4.6.8 Phone And Modem Options
You may not need to run the Phone and Modem settings if your modem has been detected by Windows XP. If it hasn’t, then proceed by double-clicking the icon and enter your area code; leave the rest blank! Click ‘OK’; a new dialog box opens. Choose the ‘Modem’ tab and click ‘Add’ to install a modem. Be ready with the modem drivers.
To set up a dial-up connection, double-click on ‘Network Connections’ in the Classic View of the Control Panel and follow the instructions to successfully establish a dial-up connection.

4.6.9 Power Options
Several power-saving schemes are already configured by Windows. You can choose from Home/office, Portable/Laptop, Always On, Minimal Power Management, and Maximum Battery Life.

‘Enable Hibernation’ will allow Windows to turn off the system without affecting your current session; you can resume your PC on startup from where you had left off earlier. This option needs free space on the primary partition.

Use the UPS settings to control the battery usage and the power that your PC will derive from it. The ‘Advanced’ tab allows you to set options such as ‘Turn off the computer when I press the power button’; this will shut down the PC when you press the power button on the cabinet of your machine.

4.6.10 Scheduled Tasks
If you have an anti-virus program installed on your PC, it will make an entry in Scheduled Tasks to run a virus scan at a particular time, every day, week, or month. You can also add tasks such as creating a System Restore Point using the scheduling option. Office PCs may need to take periodic backups of data. Using Scheduled Tasks makes this simpler.

Let’s take the example of scheduling a System Restore Point. Double-click on the ‘Add Schedule Task’ icon. A wizard will pop up—click ‘Next’. On the following screen, you can either choose
a program for scheduling from the list it provides, or you can use the ‘Browse’ button to locate a program of your choice. ‘System Restore’ is present in the displayed list; select it and click ‘Next’. Enter a name for the schedule, say ‘Restore Point’, and choose the frequency at which you want to run the schedule from the ‘Perform this Task’ list: ‘Daily’, ‘Weekly’, ‘Monthly’, ‘One time only’, ‘When computer starts’ and ‘When I log on’.

Let’s choose ‘Weekly’ and proceeded with the wizard. Specify the time (10:00 AM in our example) and a day of the week (say Friday) in the following screen. Enter your username and password when asked for, and click ‘Next’ to finish adding the schedule. You may choose to open ‘Advanced Properties’ at the end of the Wizard, but this isn’t necessary unless the task demands advanced settings.

4.6.11 System
Managing your computer becomes easy from within the System Properties. Double-click on the ‘System’ icon to open System Properties. This dialog box contains seven tabs—General, Hardware, Advanced, Computer Name, System Restore, Automatic Updates and Remote. The tabs for Hardware and Advanced rank high in order of importance.

The ‘Hardware’ tab contains features such as the Device Manager, which lists all the devices in and attached to your computer, and also provides you with details about them—for example, whether they’re operational, or whether there are conflicts or driver issues. These can be easily identified—Device Manager indicates malfunctioning devices with an exclamation mark.

The ‘Advanced’ tab includes settings for Startup and Recovery, User Profiles, and Performance. Most users who know Windows XP well use the Performance settings to configure their systems for faster operation. The most common performance tuning is assigning a fixed range for virtual memory on a FAT32 partition. You’ll find more tips for tweaking using Advanced Options in Chapter 8.
4.7 Addressing Compatibility Issues

Compatibility has long been a major concern for Windows. Microsoft has played a balancing act between providing compatibility for a wide range of hardware and software on the one hand, and making the OS stable and efficient on the other. Many users expect to be able to run their ancient DOS or Windows programs and outdated peripherals on the latest version of Windows.

Microsoft’s attempt at building a system with a balance of compatibility and stability has been realised in Windows XP, which is built on the NT/2000 kernel. No matter how much work is done in achieving better compatibility, the problem of outdated hardware and software will always loom over the OS. It is therefore important to use new, supported hardware and software as far as possible. Microsoft has published a catalogue of hardware and software compatible with your OS at www.microsoft.com/whdc/hcl/default.mspx.

Windows XP’s Program Compatibility Mode is a tool designed to fool an application into thinking that it’s running under an older version of Windows. Using Compatibility Mode, you can select whether to run a program in Windows 95, 98/Me, NT 4 or 2000 mode. You can also set screen resolution and maximum colour display, and disable visual themes. The Program Compatibility Wizard lets you test each setting in turn to see if it works. The Program Compatibility Wizard is accessible from Start > All Programs > Accessories > Program Compatibility.
Windows XP provides a complete range of tools that help you get online. Of course, there are a whole lot of third-party software that you can install, but you can get started on the Internet with XP straight out of the box. This chapter gives an overview of various Internet software tools that come with Windows XP and how to get started with them.
5.1 Browsing

Viewing Web pages is termed browsing, and you require a software called a browser to do this. Windows XP comes with an inbuilt browser called Internet Explorer (IE). IE does what its name says—it lets you explore the Internet and acts as your window to the connected world. Currently in version 6, Internet Explorer includes new and enhanced features that simplify daily tasks while maintaining the privacy of your personal information on the Web.

Some of the key features offered by the latest version of Internet Explorer are:

**Image Toolbar:** When you move your mouse pointer over images on Web pages, the Image Toolbar appears giving instant access to various functions related to pictures. You can quickly save, e-mail, and print your pictures from a Web page, and also view all your saved pictures in the ‘My Pictures' folder.

**Media Bar:** Provides a user interface for locating and playing media within the browser window. You can play music, video, or mixed-media files without opening a separate window. You can also control the audio volume, choose which media files or tracks to play, and access different media on your computer.

**Auto Image Resize:** Resizes pictures that are too large to display in the browser window so they fit within the dimensions of the window.

**Favorites:** Put Web sites you visit often within easy reach. That way, you don’t have to remember or type anything. Just click your mouse twice, and there you are! As your list of favourite pages grows, you can organise them by moving them into subfolders.
**History List:** Makes it easy to find and return to Web sites and pages you’ve visited in the past. Whether it’s today or a few weeks ago, the History list can record pages you’ve visited, so it’s easy to go back later on.

**Auto Complete:** Saves you time by automatically remembering information you’ve recently typed, such as Web addresses, information in forms, and search queries.

**Customisable Browsing Layout:** Provides options so you can change your Web browsing layout to suit the way you work. Add and remove buttons on the toolbar, increase Web page viewing space, and create a custom toolbar layout.

**Search Companion:** Helps you track down information on the Web. Internet Explorer’s inbuilt search feature, the Search Companion, makes searching the Internet faster and simpler.

**Getting Started With Internet Explorer**

There are a number of ways to launch Internet Explorer. The easiest is to double-click the icon on your desktop. This icon looks like the letter “e” with a ring around it. If don’t have this icon on your desktop, you can launch Internet Explorer by going to Start > Programs, and then clicking on ‘Internet Explorer’ on the menu that pops up.

When the program starts, it will automatically go to the home page (provided you are connected to the Internet) that has been set in the options. To go to a Web page of your choice, you need to type its address or URL (Universal Resource Locator) into the address bar.
near the top and click ‘Go’ (or press [Enter] on your keyboard). The URL for each Web page is unique. For example, typing “www.thinkdigit.com” will take you to Digit Magazine’s Web site.

You can also choose from a list of URLs you’ve previously typed by pulling down the menu on the right of the Address field. Another way to visit a different page is to click on a hyperlink. A hyperlink contains the address (URL) of the page you want to see. By default, a blue link represents a page you haven’t viewed yet, and a purple link represents one that you have. Links appear as graphics or sometimes as underlined text.

To tell whether something is a link, move your mouse pointer over it. If the pointer changes into a “hand,” you’ve found a link. Click on it, and you’ll be taken to a different page. While a page is loading, the Windows flag icon in the upper right corner will be animated.

A set of buttons on the toolbar lets you navigate through Web pages. The ‘Back’ button takes you to the previous page you visited, the ‘Forward’ button takes you forward a page, the ‘Stop’ button stops the current page from loading, ‘Refresh’ reloads the current page, and the ‘Home’ button takes you to the home page you set.

Internet Explorer lets you quickly return to pages you’ve already seen during the current session and previous sessions. To see a history of pages that you’ve visited, click on the ‘History’ button in the toolbar. A window of previous pages (listed according to when you accessed them last) will appear on the left, which you can use to navigate your browsing history.

The status bar at the bottom displays the status of a page as it loads into Internet Explorer.
Bookmarks (Favorites)

Bookmarks provide a permanent and simple way to remember your favourite Web pages.

Creating a bookmark:
Navigate to the Web page you want to mark. Go to the ‘Favorites’ menu, and click ‘Add to Favorites’. Give the page a name or keep its original name, then click ‘OK’.

Viewing and using bookmarks: Click on the ‘Favorites’ menu to view the list of bookmarks you have created. From that list, click to select the bookmark of the page you want to see.

Organising your bookmarks: Internet Explorer lets you arrange your bookmarks in folders and change the order in which they appear. Open the ‘Organize Favorites’ window by clicking on the ‘Favorites’ menu, and then ‘Organize Favorites’. This window lets you create folders and place bookmarks in those folders by using the ‘Create Folder’ and ‘Move to Folder’ buttons. You can delete and rename existing bookmarks using the ‘Delete’ and ‘Rename’ buttons. Dragging bookmarks within the right-hand display window changes the order of their appearance. You may also move them into folders while within the Favorites menu.
Saving Pages And Images

Saving an image: To save an image on a Web page, place your mouse pointer over the picture you want to save, then right-click and choose ‘Save Picture As’ from the menu that appears. Browse to a location on your hard drive where you want to save the image, and click ‘Save’.

Saving a Web page and viewing it later: To save a Web page onto your hard drive, go to the Web page that you want to save. From the ‘File’ menu, choose ‘Save As’. You can type a new filename in the ‘File Name’ field, or you can just leave the name as is. In the ‘Save as type’ drop-down menu, you have several choices of how you can save the Web page. The default choice is ‘Web Page, complete’, to save the page along with all its images, and the next-most popular choice is to select ‘Web Page, HTML only’, which saves the page without the images. When you are done, click ‘Save’.

To open the page you saved, launch IE, and go to File > Open. Click ‘Browse’ to find and select the file you want to open. Click ‘Open’ and then click ‘OK’.

Basic Internet Options

Changing your home page: Go to Tools > Internet Options. In the ‘General’ tab, type in the URL of the desired Web page.
Alternatively, you can also choose and click on the three buttons below the address field that set the home page to the current page, default and blank respectively. Click ‘OK’ when you’re done. The chosen Web page will be loaded by default when you launch Internet Explorer. You can also go this page by clicking on the ‘Home’ button in the toolbar.

**History Options:** You can choose the number of days for which IE will store your history. To do this, go to Tools > Internet Options. Under ‘History’, type in the number of days to keep pages in history, or click on the up or down arrows to choose the desired number. If you wish to clear your history, click the ‘Clear History’ button.
5.2 E-Mail

Outlook Express is the e-mail client and news-group reader that comes by default with XP.

Many users are confused between Microsoft Outlook Express and Microsoft Outlook, believing them to be the same software. But these are two entirely different software. Both Outlook and Outlook Express handle the basics of e-mail, including an address book, message rules, user-created folders, and support for POP3, IMAP, and HTTP mail accounts. However, that’s where the similarity ends. Both programs were designed with different audiences in mind.

Outlook Express was developed as part of Internet Explorer with the home user in mind, while Outlook was developed as part of Microsoft Office with the corporate user in mind. Outlook Express is a basic e-mail client that is part of Internet Explorer and Windows. Outlook is a full-featured personal information manager (PIM) that is available as a part of Microsoft Office and also as a standalone program.

Outlook Express handles not only Internet mail but also Internet news, a feature that Outlook does not natively possess. But Outlook has a host of features that Outlook Express does not have, such as a calendar, a task list, a journal, and automatic back-up into archive files.

Outlook 2003 also has a very powerful “Junk Mail” feature and message rules for both incoming and outgoing mail, while Outlook Express can only filter incoming mail. Let’s learn how to get started with e-mail using Microsoft Outlook Express.
Getting Started With Outlook Express

To add an e-mail account, you will need your account name and password, and the names of an incoming and an outgoing mail server—which you can get from your Internet service provider (ISP) or local area network (LAN) administrator.

Setting up a new account

Step 1: Launch Outlook Express by double-clicking on the icon on your Desktop, or click on Start > Programs > Outlook Express. If you’ve launched the program for the first time, the Internet Connection Wizard will start. Select “Create a new Internet mail account” and click ‘Next’.

You can also create a new mail account by going to the ‘Tools’ menu, clicking on ‘Accounts’, then on ‘Add’, and then on ‘Mail’.

Step 2: Enter your full name, for example John Smith, and click ‘Next’.

Step 3: Enter your e-mail ID as provided to you by your ISP or LAN administrator. For example: john_smith@thinkdigit.com.

Step 4: In the next window, you will be required to choose the type of mail server (whether POP3, IMAP or HTTP) and enter the details of your incoming and outgoing mail servers.

Step 5: In the Internet Mail Logon window, enter your username for ‘Account Name’ and your password. If you wish, you can have Outlook Express remember your password by
checking 'Remember Password', but this is not recommended unless you are the only person using your computer. Click 'Next'. Click 'Finish' when you have entered all the information, and Outlook Express will create your account.

**Using Outlook Express**

Make sure your computer is connected to the Internet. When you open Outlook Express, your messages will download automatically, or click 'Send/Receive' on the toolbar to check for mail manually. You can read your messages either in a separate window or in the preview pane.

- To view the message in the preview pane, click the message in the message list.
- To view the message in a separate window, double-click the message in the message list.

**Replying To a Message**

- In the message list, click on the message you want to reply to. Then, click on the 'Reply' button on the toolbar. The e-mail address of the sender of the original message will be automatically filled in on the 'To' line. The original subject line prefixed with 'Re:' will be filled in on the subject line, and your original message will be included.
- At the blinking cursor, type in your message.
- Click 'Send' to send the message.
Sending a New Message
- Click on the ‘Create Mail’ button on the toolbar.
- Type the e-mail address of each recipient in the ‘To’ box. To send a message to multiple recipients, type each recipient’s e-mail address in the ‘To’ box, separating e-mail addresses with a comma or semicolon.
- If you want to add names from the Address Book, click on the book icon in the New Message window next to ‘To’, ‘Cc’, and ‘Bcc’. Select a name. To use the ‘Bcc’ box, click on the ‘View’ menu, and then select ‘All Headers’. Click on the ‘To’ box, ‘Cc’ box, or ‘Bcc’ box buttons to add the name to the appropriate line. Click ‘OK’. Recipients on the ‘To’ and ‘Cc’ lines will see all the e-mail addresses that the message was sent to. Recipients on the ‘Bcc’ line will not be seen by recipients on the ‘To’ and ‘Cc’ lines.
- Tab to the ‘Subject’ box and type in a message title.
- After you finish typing your message, click the ‘Send’ button on the New Message toolbar. If you are working offline, the message will be saved in the Outbox, and will be automatically sent when you go back online.

Forwarding Messages
- After selecting the message you want to forward, click ‘Forward’ on the Message menu.
- Type the e-mail name of each recipient in the ‘To’ box. To send a message to multiple recipients, type each recipient’s e-mail address in the ‘Cc’ box, separating names with a comma or semicolon.
- After you have typed your message, click the ‘Send’ button on the toolbar.
Deleting Messages
- Select the message in the message list and click the ‘Delete’ button on the toolbar.
- To remove all deleted items from your local hard drive, select the ‘Deleted Items’ folder, and on the ‘Edit’ menu, click ‘Empty Deleted Items Folder’.
- If you want to restore a deleted message, open the Deleted Items folder and drag the message back to the Inbox or other folder.
- For messages not to be saved in the Deleted Items folder when you quit Outlook Express, click Tools > Options. Click the ‘Maintenance’ tab, and select the “Empty messages from the ‘Deleted Items’ folder on exit” box.

Sending Attachments
- Click the ‘New Mail’ button on the toolbar.
- Go to Insert > File Attachment.
- Select the file you want to attach and click ‘Attach’. The file will be listed in the ‘Attach’ box in the message header.
- Compose your message as usual and click ‘Send’.

Viewing Attachments
- Double-click on the message with the attachment from the message list.
- Double-click the file attachment icon in the message header in the Attach box.
- If you have an application that can open the attachment, the application will be loaded with the attachment opened. For example, if the attached file has an .xls extension, when you double-click on the attachment in the ‘Attach’ box, Microsoft Excel loads automatically and opens the attachment.
- If the attachment’s file extension (e.g. abc.dat) is not associated
with any application on your system or if the file does not have an extension, you will be prompted to open the attachment or save it to disk. Select ‘Save to disk’ and click OK.

Using the Address Book
Contacts in your Outlook Express address book allow you to type in the name of your recipient on the ‘To’ or ‘Cc’ lines without having to type in the complete e-mail address. Outlook Express will insert the e-mail address when you send the message. To add a contact to your Outlook Express address book, click Tools > Address Book. Select the folder to which you want to add a contact. (You can create a new folder by clicking File > New Folder, then entering a name for the folder and clicking OK.) On the ‘Name’ tab, enter at least the first name, last name and e-mail address for the contact. Check “Send e-mail using plain text only.” You may add information on the other tabs if desired. Click ‘Add’ and ‘OK’.

You can create a group in the address book with multiple e-mail addresses. You can then use the group name instead of typing in individual e-mail addresses when sending a message. To add a group in the address book, click File > New Group. Enter the group name. In the ‘Name’ box, type in the name of the first contact in the group, then in the ‘E-mail’ box, type in the complete e-mail address of the first contact and then click ‘Add’. Repeat the procedure to add names and e-mail addresses for each person in the group until you are done.
Setting up multiple identities
If you have more than one person in your home who uses the same computer for e-mail, each one can have a separate mail box in Outlook Express. This means that each person can have separate messages, contacts, and personal settings. This is possible by creating multiple “identities.”

- To add a new identity, go to File > Identities, and then click ‘Add New Identity’. Then enter the name of the new user, and enter a password if you want to include one for this user.

- To delete an identity, go to File > Identities, and then click ‘Manage Identities’. Select a user and click ‘Remove’.

- To switch to a different identity, click File > Switch Identity. Then select the user you want to switch to.

- To change the current identity’s settings, go to File > Identities, and then click ‘Manage Identities’.

- To change your identity name or password, click Properties.

- To change the identity that Outlook Express opens on startup, select an identity from the ‘Start up using’ list box.
5.3 Instant Messaging

Instant messaging refers to electronic communication (using text, voice, and video) over the Internet between two or more users who are all online at the same time. Instant messaging is online communication in contrast to e-mail which is, in effect, a method of offline communication since the recipient of an e-mail does not need to be online to read it. Instant messaging has revolutionised the way we communicate with friends, family and co-workers.

Imagine wishing your daughter happy birthday in real-time when you are away on a business trip at a fraction of the cost of a telephone call. Or communicating simultaneously in real-time with your colleagues based in different cities to discuss the new project. Sure, this is possible with call conferencing as well, but nothing can match the convenience and affordability of instant messaging.

Windows XP comes with an instant messaging tool called Windows Messenger that lets you do the above, and more! The following are some of the key features offered by Windows Messenger apart from instant text messaging:

**Voice conversation:** Windows Messenger allows you to have clear voice conversations over the Internet with your contacts.

**Video conversation:** If you have a Web camera installed, you can have video conversations.

**File transfer:** You can transfer files such as documents and photos directly in real-time without leaving Windows Messenger.
Application sharing: With the application sharing capabilities of Windows Messenger, you can share control of an application with your contacts online. This is great for working together on a document with colleagues, for example.

Online status: You can let other users know if you are busy or on the phone, or have your status appear as offline in case you don’t want anyone to disturb you but still see who is online.

Remote assistance: With this feature, you can let a trusted friend or colleague control your computer over the Internet to troubleshoot problems or to teach you something new. If you are the expert, you can offer your help to your online buddies.

Block users: If there are people that you don’t want to communicate with in real-time over the Web, Windows Messenger lets you block their access to you altogether.

Getting Started With Windows Messenger

Start Windows Messenger by double-clicking the Windows Messenger icon near the clock in the lower right corner of your screen, or by going to Start > Programs > Windows Messenger.

The first time you start Windows Messenger, you will be asked to sign in to the .NET Messenger service. The .Net Messenger Service window will ask for an e-mail address and password. The easiest way is to sign up for a free Hotmail account. If you do not have one of these accounts, click Get a .NET Passport in the lower left corner. You can get a new .NET Passport account by using any of your e-mail IDs—you do not neces-
sarily require a Hotmail e-mail ID. Follow the instructions in the .NET Passport Wizard.

After you sign in, Windows Messenger will open, displaying your list of contacts and online status. If this is your first time using Windows Messenger, click ‘Add a contact’ to start building a contact list.

Adding Contacts
Click on ‘Add a contact’ in the lower part of the Messenger window. The next window asks you whether you want to add a new contact using his or her e-mail ID/sign-in name or by searching for a contact. Follow the instructions that follow in the wizard. The new contact will be added to your list.

If the person you have just added is online at that time, he or she will get a pop-up message informing that you have done so. They also have the option to allow you to see their online status or to deny access. They can also add you to their contact list at time. In case the other person is not signed in to Windows Messenger at that time, they will get the message whenever they sign in next. If they choose to allow you access, you can see their status online and send them instant messages using Windows Messenger.

Sending An Instant Message
You can start instant messaging in several ways:

- Double-click the name of a contact online
- Right-click on a contact’s name and then click ‘Send an Instant Message’
- Click on the ‘Actions’ menu, click ‘Send an Instant Message’, and then click a contact’s name
Click ‘Send an Instant Message’ near the bottom of the Messenger window, and then click a contact’s name.

Type your message in the lower part of the window. To start a new paragraph in your message, hold down [Shift] and press [Enter]. To add an emoticon to your message, click ‘Emoticons’ and choose the desired symbol from the list that pops up. Click ‘Send’ or press [Enter] to send your message. Your message will appear in the top window.

Your contact will receive a pop-up box in the lower right corner of his screen, and an audible alert indicates a message from you. Clicking on the pop-up box will open his Conversation window. In the status bar at the bottom of the Conversation window, you can see when your contact is typing, as well as the date and time of the last message you received.

Adding people to a Conversation
To add people to a conversation, click on ‘Invite Someone to this conversation’ from the pane on the right of the Conversation window, and then click a contact’s name.
File Transfer
After you’ve started a conversation, it’s easy to send or receive a file. Click ‘Send a File or Photo’ and choose the file or photo from the window that appears. Your contact sees a message asking whether he or she wants the file. If the intended recipient clicks ‘Yes’, the file is sent to his computer. If your friend declines to download the file, Windows Messenger informs you. When somebody sends you a file or photo, you’ll find it in the ‘My Received Files’ folder inside your ‘My Documents’ folder.

Changing your Display Name
To change your name as it is displayed to your contacts, click on the Tools menu on the Messenger window and then click on ‘Options’. On the ‘Personal’ tab, enter the desired name and click ‘OK’.

Changing Your Online Status
To change your online status, click on your display name on top of the Messenger window, and choose the desired status from the drop-down list. Your status is displayed in parentheses along with your display name in the contact list of your online buddies.

The above should be sufficient to get you started online with XP’s Internet tools. Remember, the above are just the basics, and there’s lots more you can do with the above software. Now that you have enough information to get online, search for more information so you can make the best use of these software!
Thus far, we've learnt the basics of Windows XP—the most popular operating system there is! It's time now to look at how we can make our Windows XP interfaces even more beautiful with the help of some third-party utilities, and of course, tweaking a few settings built into Windows XP.
6.1 The eXPerience

If you’re a performance freak and couldn’t care less how Windows looks, so long as it boots up in 20 seconds flat, and opens programs faster than ever before, we honestly suggest you move along to the chapter on tweaking tips. However, if you’re willing to sacrifice on a little performance, and want to customise your user interface and make a personal statement, this is the right chapter for you.

Windows XP was a huge step over Windows 98 and Windows 2000, and looks wasn’t the least of the reasons! As far as good-looking OSes go, before XP, Apple’s Mac OS ruled the roost—there just wasn’t any competition. Microsoft made sure with their XP launch that all dissenters were quietened. For the first time, users saw a fancy-looking Start Menu and Taskbar, with rounded corners and transparencies in application windows. At last, here was a Windows version that was not just enhanced for better performance and stability, but also in terms of aesthetics.

Though XP is great-looking all by itself, you can give it a makeover to better suit your style. Besides, almost everyone running Windows XP has the same looking Desktop, with only wallpapers differing.

The very first way to differentiate your desktop is to tweak a few settings.

6.2 Tweaking Visual Settings

The Start Menu

The first thing you notice about Windows XP is the changed Start Menu. The Start button itself is a vibrant green and the Taskbar is a beautiful blue. However, you don’t have to be content with what Windows provides you with by default, and changing settings is as simple as right-clicking on the Taskbar!
So, well, right-click on the Taskbar and go to ‘Toolbars’. Here you will see various options including the Desktop bar and the Quick Launch bar. The Quick Launch bar is the row of icons that appear next to the Start button to help you launch programs with a single-click, instead of having to navigate through the Start Menu to look for them. This is a very handy toolbar and should be added immediately after a fresh install of Windows XP!

Next, right-click on the Taskbar and select ‘Properties’ to open the ‘Taskbar and Start Menu Properties’ dialog box. Under the ‘Taskbar’ tab, you’ll see some basic options such as locking the taskbar to prevent inadvertent resizing or hiding. This is also the place where you can choose to auto-hide the Taskbar to get maximum real estate on your Desktop.

The next tab is the Start Menu tab, from where you can select whether to display the default applications for Internet and email! You can also set the number of recently-used programs that are temporarily stored in the Start Menu! Clicking on ‘Customise...’ brings up the ‘Customize Start Menu’ dialog box, from where you can further edit all the settings. Everything is pretty easy to understand, and you should have no trouble changing these settings to your taste.

**Icons**

On first installing XP, you will notice that your Desktop contains nothing but the Recycle Bin icon. Most users will miss the standard My Documents, My Computer and My Network Places icons immediately. It’s simple to get these back in place. Just right-click on your Desktop and select ‘Properties’. Now click on the ‘Desktop’
tab and click the 'Customize Desktop' button. Now under the header 'Desktop icons', you will see checkboxes for the following icons: My Documents, My Network Places, My Computer and Internet Explorer. Check the ones you want to see on your desktop and then click 'OK'.

Themes
If you want to try out different themes to give your desktop a different feel, right-click on the Desktop and select 'Properties' to get back to the 'Display Properties' dialog box. There is a tab called 'Themes' that contains two themes by default—Windows XP and Windows Classic. Windows XP is the default theme that is loaded when you install XP, but you can make your desktop look like Windows 98 or Windows 2000 by selecting the Windows Classic theme. This results in a more plain-looking Desktop that will probably not please too many people looking to enhance and customise their Desktops. However, it does improve performance, but more on this in the chapter on Tweaking Windows XP (Chapter 8).

If you install themes by third parties, you will find them here, and should be able to select them.

Wallpapers
Perhaps the easiest way to modify the look of your Desktop is to change the wallpaper. Most people never graduate from the default "Bliss" wallpaper of Windows XP, which results in many similar-
looking Desktops! You can fix this by changing the wallpaper, which is what takes up most of the real estate on your monitor. Just right-click on the Desktop and select ‘Properties’ to get to the ‘Display Properties’ dialog box. Click on the ‘Desktop’ tab and then select a wallpaper from the list of Backgrounds available. You can also choose to stretch a smaller picture to fit the screen, centre the image in the middle of the Desktop (at its original size), or tile the image so that it covers the entire Desktop. These options can be selected from the ‘Position’ drop-down box on the right.

If there’s an image of your own that you want to add to the list of available wallpapers, just click on the ‘Browse...’ button and select the image(s) of your choice.

Screen Savers
The next tab in the ‘Display Properties’ dialog box is ‘Screen Saver’, and though the original purpose of a screen saver (to protect older monitors from damage because of a static image being displayed for too long) is no longer valid due to enhancements in monitor technologies, they still serve an aesthetic purpose. Many people prefer to have a cool screen saver to show off with when their computer is idle.

You can select the screen saver you want from this tab, and even test it to see how it actually looks on your screen, instead of in the little preview window, by clicking ‘Preview’. Everything is pretty straightforward here—just select a screen saver, preview it, move your mouse to get back to the ‘Display Properties’ box, and click ‘Apply’ once you’ve decided on one.

Appearance
The Appearance tab is where you can choose the different colours for your style (if available), and also do a little advanced tweaking to get that unique-looking desktop.
The very first thing you need to do is see the different Color schemes available for the selected theme. For example, the default Windows XP theme comes with Blue (default), Green and Silver options. First try out these options before you go any further. The next thing to modify is the ‘Font size’ option. Here you can choose between ‘Normal’, ‘Large Fonts’ and ‘Extra Large Fonts’. To illustrate what this does, just select each one and look at the preview window to see the changes being reflected. You can always click ‘Apply’ to see the difference in your Windows GUI.

Now you should pay attention to the two buttons on the right, namely ‘Effects...’ and ‘Advanced’. The ‘Effects...’ button brings up a dialog box that will show you various options. These are pretty self explanatory. Experiment!

The ‘Advanced’ button opens up an ‘Advanced Appearance’ box, which will let you customise everything from the colour of the blank background on the Desktop to the font types and sizes used to name icons and windows. Just check the ‘Item’ drop-down box to select what you would like to change and then change the colours, fonts and formatting on the right. This can greatly help you make your own unique looking Desktop, but be careful—you may end up ruining everything and get this ugly-looking Desktop that you hate—with fonts that are too large, colour combinations that border on the gaudy, and so on. Thankfully, you can just go back to the Themes tab and select ‘Windows XP’ to start over!

The Settings Tab
The last tab in the ‘Display Properties’ window is the ‘Settings’ tab. This tab helps you select screen resolutions and colour depths. Of most significance is the ‘Advanced’ button on the right, which will bring up your display adapter properties box. From here you can select the best resolution and refresh rate that your monitor sup-
ports. Remember, to minimise eye strain and make colours look more vibrant, a refresh rate of 70 to 75 is considered the minimum. So even if your monitor supports a resolution of 1280 x 1024 @ 60 Hz, the lower-resolution option of 1024 x 768 @ 85 Hz could look a lot better! However, this varies from person to person—some people simply can’t make out the difference between 60 Hz and 85 Hz, while others can’t live with anything below 100 Hz!

6.3 Third-Party Software

Windows XP, by virtue of being the most popular operating system of all time, has millions of software designed with XP in mind. There are literally hundreds of software available that will accomplish even the most basic of tasks in XP, and it’s no surprise that desktop enhancement shares this competitiveness. Though there are probably hundreds of software that offer similar functionality, we will just focus on three software in this chapter: ObjectDock, WindowBlinds and StyleXP.

We chose these three because they are by far the most popular software, and even our Digit “My Desktop” competition gets hundreds of entries from people who use any one (or more) of these three software.

The reason for their popularity all boils down to the ease-of-use factor, and the amazingly aesthetic results, of course. Digit has provided all the three software mentioned here in the February 2006 CD for your convenience.

ObjectDock

This is one software that Mac OS fans will love! While Windows has merely prettied up the Start Menu and Windows Taskbar, not really changing the way it is displayed (ever since Windows 95 or
even 3.1), the Apple Mac OS desktops seem to exude vibrancy and panache. Yes, we may sound biased, but there’s just something about a Mac’s GUI that gets people hooked!

ObjectDock, a free software from StarDock, the makers of WindowBlinds (coming up), is an application that attempts to mimic Mac OS’ application dock, providing Windows users with a simple-to-use and great-looking Desktop. The dock is animated, meaning a much better look to your Desktop!

After you install the application, you can immediately start playing with the settings. You will see various settings, including the choice of animating the icons on your dock by enlarging them or making them swing about like paper thumb-tacked to a bulletin board. Then there are the options of what size you want to make your dock, where you want it to appear, the transparency level of the dock, and the ability to hide the Windows Start Menu altogether so that you only use your dock to start your favourite applications.
Though there’s no default installation of a Start Menu shortcut on the dock, you can still access it by pressing the [Windows] key on your keyboard. The Start Menu will pop up wherever it was placed before you hid it using ObjectDock.

We noticed a few bugs in the way it hides the Start Menu—ObjectDock seems to merely skin the start menu with your background, or overlay it with a strip that’s identical to your wallpaper, so any non-standard size start menu leaves traces of itself in the form of half-hidden pixels. Still, this is avoidable—just set your Start Menu to auto hide and this bug is taken care of!

**WindowBlinds**

This is another application by StarDock, and is one of the most popular Desktop Enhancement software—also known as shell replacement software!

After you install WindowBlinds, you will need to reboot your computer. As soon as the OS loads again you will be presented with
all the options available in WindowBlinds. These include the vari-
ous Skins (themes), which toolbars to skin / install, and even various
transparency levels for different menus. Since both ObjectDock and
WindowBlinds are StarDock products, there are no problems of
integration. Since we cannot do justice to the various cool-looking
themes that come with WindowBlinds, mainly due to the black and
white limitations of this book, we have provided the software for
you to download and make up your own mind.

StyleXP
This application was developed by TGT Soft, and is very similar to
WindowBlinds. Shown in the screenshots alongside are a few skins
from this program. Once you have made all the changes you need,
from within the StyleXP configuration menu, you can just click
‘Exit’ to leave the dialog box and also apply the changes. One great
thing about StyleXP is the fact that it has two components—a serv-
ice as well as regular setting. In the screenshots below you will see
a few different screens of Adobe Photoshop, highlighting the
embarrassment of theme options for StyleXP.

Examples
As you have seen in this chapter, Windows XP, along with various
third-party tools, gives you the flexibility to customise your desk-
top like no other Windows version has done before.

We mentioned Digit’s My Desktop competition, where using
such third-party tools to enhance your Desktop is considered
cheating, because it becomes too easy. However, since many of our
readers put in considerable effort into making their desktops look
as pretty as a picture, we decided that their efforts should be high-
lighted to show you the capabilities of such software.
Be it photos, music or movies, Windows XP makes it extremely simple to use and play around with digital media files. With added support for digital cameras and enhanced capabilities for media files, XP is loaded with all the software you need for entertainment. Here we get you started with these tools.
7.1 Playing with Pictures

If you own a digital camera, you can easily transfer them onto a PC for editing or sharing with friends by printing or e-mailing them. XP makes it extremely simple for you to view, organise, transfer, share, print and manipulate digital images from various sources such as a scanner, digital camera, optical media or the Internet. We take a look at these features in detail.

7.1.1 Transferring pictures from a digital camera

Step 1
To connect a digital camera to your PC, switch on the camera and connect the USB cable that came with the camera to a USB port on your computer. In most cases, Windows XP can copy pictures to your computer without the need for additional software. XP will detect the connection and ask you what you want to do with your pictures. Click 'Microsoft Scanner and Camera Wizard', then 'OK'. When the Scanner and Camera Wizard appears, click 'Next'.

Step 2
All the pictures stored on your camera will now be displayed on the “Choose Pictures to Copy” page. By default, all the pictures are selected for downloading. If there are pictures you don’t want to download, clear the checkbox at the top right corner of those pictures.

You can also rotate pictures you took holding your
camera vertically—to rotate a picture, click it and then click either the ‘Rotate Clockwise’ or ‘Rotate Counter-clockwise’ button on the lower-left corner of the page. Then, click ‘Next’.

**Step 3**

In the next window, type in a name for the group of pictures. This name (along with a number to differentiate between the pictures) will be applied to each of the pictures you download. For example, if you name the group “Goa,” the images will be named “Goa001,” “Goa002,” and so on. Click ‘Browse’ and select a folder in which to save your pictures.

If you want to erase the images from your camera’s memory (or memory card) to make space for new ones, select the “Delete pictures from my device after copying them” checkbox, and click ‘Next’. The pictures will be copied from your camera to the folder you specified, and will then be deleted from your camera’s memory or memory card.

**Step 4**

On the “Other Options” page, you can choose to publish your pictures to a Web site or order prints. If you’ve finished working with your pictures, click ‘Nothing’, and then ‘Next’. On the final page of the Wizard, click ‘Finish’. XP opens up an Explorer window showing the pictures you downloaded from your camera.
7.1.2 Viewing Images

XP saves images in your ‘My Pictures’ folder by default. This folder is in the ‘My Documents’ folder. Within ‘My Pictures’, you can view your pictures in the right pane. The images are automatically displayed either as thumbnails or as images on a filmstrip. Both these views let you preview the images within Windows Explorer.

In Filmstrip view, your pictures appear as a single row of thumbnails. You can scroll through your pictures using the left and right arrow keys. If you click a picture, it is displayed as a larger image above the other pictures. You can double-click a picture to edit, print, or save the image to another folder.

You can customise the view by clicking on the ‘View’ menu in Windows Explorer and then selecting the desired view option, or by clicking on the small arrow next to the ‘Views’ button in the toolbar and selecting the desired view from the drop-down menu.

To view your pictures as a slideshow, open the ‘My Pictures’ folder. Under ‘Picture Tasks’, click ‘View as a slideshow’. Use the slideshow toolbar buttons to play, pause, move to the previous or next slide, or to end the slide show. If the toolbar is not displayed, move your mouse pointer across the screen, and it will appear in the upper-right corner of the screen.

To preview a picture, double-click on an image. The image opens up in Windows Picture and Fax Viewer. This program lets
you view, rotate, and perform basic tasks on images without your having to use an image editing program. The table on the next page describes the buttons available on the Windows Picture and Fax Viewer, along with their respective keyboard shortcuts.

### 7.1.3 Organising Pictures

You can organise pictures as photo albums on your computer. To make a photo album:

1. Open the ‘My Pictures’ folder.
3. Type in the name of the folder and press [Enter].
4. Right-click on the new folder and click ‘Properties’.
5. On the ‘Customize’ tab, under ‘Use this folder type as a template’, select ‘Photo Album’. Copy the pictures you want to be a part of this album to this new folder.

### 7.1.4 Sharing Pictures

You can use the tasks in ‘My Pictures’ to send your pictures by e-mail or publish them to the Web. You can also print your pictures directly from the ‘My Pictures’ folder.

**To send a photo by e-mail**

1. Open My Pictures, then open the folder containing the photo you want to send.
2. Click the photo you want to send.
3. Under ‘File and Folder Tasks’, click ‘E-mail this file’.
4. In the ‘Send Pictures via E-mail’ dialog box, click ‘Make all my pictures smaller’.

---

Windows Picture and Fax Viewer
## Windows Picture And Fax Viewer

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous Image</td>
<td>Go to the previous image in this folder.</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>Next Image</td>
<td>Go to the next image in this folder.</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>Best Fit</td>
<td>Reduce or enlarge the image to fit into the window’s current size.</td>
<td>CTRL+B</td>
</tr>
<tr>
<td>Actual Size</td>
<td>Display the image without scaling.</td>
<td>CTRL+A</td>
</tr>
<tr>
<td>Start Slide</td>
<td>Displays each image in the folder in a slide show.</td>
<td>F11</td>
</tr>
<tr>
<td>Show</td>
<td>a slide show. Start, pause, navigate, or end the slide show using the slide show toolbar in the upper right-hand corner.</td>
<td></td>
</tr>
<tr>
<td>Zoom In</td>
<td>Enlarge the displayed image to twice its size.</td>
<td>Plus Sign (on the numeric keypad)</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Reduce the displayed image by half its size.</td>
<td>Minus Sign (on the numeric keypad)</td>
</tr>
<tr>
<td>Rotate clockwise</td>
<td>Rotate the image by 90 degrees clockwise.</td>
<td>CTRL+K</td>
</tr>
<tr>
<td>Rotate counter-clockwise</td>
<td>Rotate the image by 90 degrees counter-clockwise.</td>
<td>CTRL+L</td>
</tr>
<tr>
<td>Delete Image</td>
<td>Delete the image. Windows prompts you to confirm that you want to delete the image. If you click Yes, the image is deleted, and the next image in the folder is displayed. If there are no more images, the window is empty.</td>
<td>Delete</td>
</tr>
<tr>
<td>Print</td>
<td>Print the current image.</td>
<td>CTRL+P</td>
</tr>
<tr>
<td>Copy To</td>
<td>Copy the image file to another location.</td>
<td>CTRL+S</td>
</tr>
<tr>
<td>Help</td>
<td>Display the program help file.</td>
<td>F1</td>
</tr>
</tbody>
</table>
Windows makes a smaller photo file and attaches it to an e-mail message that displays a default subject and text message. To send the photo without reducing the size of the file, click ‘Keep the original sizes’. To change the settings for the size of the image, click ‘Show more options’.

5. In the ‘To’ box, type in the e-mail address of the recipient, change the subject and message text if you want, and then click ‘Send’.

To print pictures, Windows XP provides a useful little feature called the Photo Printing Wizard. To use it for printing your pictures:

1. Open My Pictures, then open the folder that contains the photo you want to print.
2. Right-click the photo you want to print, and click ‘Print’.
3. The Photo Printing Wizard starts. Click ‘Next’. The next window gives you a preview of all images in the current folder. You can now select the pictures you want to print. The image you right-clicked on is selected by default. You can click ‘Select All’ to select all images for printing, or select specific ones by checking the box on the top-right of each image. Click ‘Next’ when done.
4. Choose the printer to use from the drop-down list. Click ‘Printing Preferences’ to customise the print resolution, paper size, etc. Click ‘Next’ when you’re done.

5. The next screen lets you choose a layout for your prints. There are various layouts to choose from, and you get a print preview of the option you choose. You can also choose the number of times each image will be printed. Click ‘Next’ to print the pictures.

7.1.5 Great freeware

In some cases, the tools built in with XP may not offer a certain functionality you require. Don’t worry—there are some great free-ware programs available that will do whatever you need to. For image viewing and basic editing, we recommend IrfanView. IrfanView is a very fast and compact freeware (for non-commercial use) graphic viewer for Windows 9x/ME/NT/2000 /XP/2003. Apart from images, IrfanView supports many audio and video formats. Currently in version 3.98, it can be downloaded from www.irfanview.com. You can also install the latest version from the Digit CD.

Some of the key features offered by IrfanView include:
- Many supported file formats
- Multi-language support
- Thumbnail/preview option
- Slideshow (you can save a slideshow as an EXE or SCR file, or burn it to CD)
- Support for Adobe Photoshop Filters
- Fast directory view (moving through directory)
- Batch conversion (with image processing)
- Multi-page TIF editing
- E-mail option
- Multimedia player
- Print option
- Change colour depth
- Scan (batch scan) support
- Cut/crop
- Effects
- Capturing
- Extract icons from EXE/DLL/JCLs
- Lossless JPG rotation
7.2 Swing to the beat

With Windows XP, you can listen to tracks and also rip audio CDs, burn compilations to CD, create playlists, organise your music collection, and even listen to Internet radio. All this and more is possible with Windows Media Player.

The latest version of Windows Media Player (WMP) is version 10. If you have an older version installed, we recommend you upgrade to version 10, since it offers new features over the previous version. Some of the key new features include a streamlined design, smart jukebox features, and for the first time, synchronisation of music, video, and photos to the latest portable devices. To check the version you have, launch Windows Media Player by going to Start > Programs > Accessories > Entertainment > Windows Media Player. Click on the Help Menu, and then on About Windows Media Player.

WMP 10 can be downloaded from www.microsoft.com/windows/windowsmedia/default.mspx. After you’ve downloaded and installed WMP 10, you are set to enjoy the best the world of digital media has to offer.

7.2.1 Playing Music

1. To play digital music stored on your computer, go to File > Open. If the menu bar is not visible, you can click on the small arrow next to the minimise button at the top right of the player window, point to File, and then click ‘Open’. (To view the Menu bar, press [Ctrl] + [M].)
2. Browse and select the audio file you want to play, and then click ‘Open’.
3. Various buttons on the player win-

Playing music with Windows Media Player
dow let you control playback. You can play, pause, navigate between different tracks on your list, control volume, or use the slider to skip to a particular portion of a track.

4. To play tracks in a random order, press [Ctrl] + [H] or go to the ‘Play’ menu and select ‘Shuffle’. To repeat tracks, press [Ctrl] + [T] or go to the ‘Play’ Menu and select ‘Repeat’.

5. To customise the equaliser settings, click the small button with horizontal lines and a small arrow pointing downwards. This button is located on the Now Playing screen on the top left. Point to ‘Enhancements’ and then click on ‘Graphic Equalizer’. You can set the equaliser manually or choose between various presets.

### 7.2.2 Organising Music

To add content to your library:

1. In Windows Media Player, click ‘Library’.
2. Click ‘Add to Library’ and then click ‘By Searching Computer’, or just press [F3].
3. In the ‘Search on’ list, click the drive you want to search.
4. To search one folder on the drive rather than the entire drive, in the ‘Look in’ option, click ‘Browse’ to enter the folder.
5. Select your preferences for updating media information.
6. Click ‘Search’.

### Keeping the library up-to-date

The Player can monitor the music and video folders on your computer for changes and automatically update the library. This is particularly useful if you add or remove files regularly; you don’t need to remember to update the library.
To specify folders to monitor
1. In WMP, click ‘Library’.
2. Click ‘Add to Library’, and then click ‘By Monitoring Folders’.
3. Click Add or Remove to select the folders you want to monitor.

   Another option you have for keeping your library up-to-date is to have music files be automatically added to your library when you play them. To turn this option on, go to the Tools > Options. Select the ‘Add music files to library when played’ checkbox on the ‘Player’ tab.

Updating media information
If the Player cannot find media information for an item, or if the information is incorrect, you can edit the information yourself:
1. In WMP, click ‘Library’.
2. In the ‘Details’ pane, select the item you want to edit. To select multiple adjacent items, hold down [Shift] as you click each item. To select multiple, non-adjacent items, hold down [Ctrl] as you click each item.
3. Right-click the column you want to edit, and then click ‘Edit’.
4. Type in the media information and press [Enter].

   Playlists are collections of digital media that you can name, save, and play in WMP. You can build different playlists for listening to while you work, exercise, or relax. You can also create playlists of videos. To create a playlist:
1. Click Start > All Programs > Windows Media Player.
2. If necessary, click ‘Library’. You’ll now see an expandable view of all the media items in your library. If items appear in the ‘Now Playing’ list, clear those items from the list to start afresh.
3. Click the ‘Now Playing List’, and then click ‘Clear List’. The list is cleared, and you are ready to build a new playlist.
4. To add an album to the playlist, in the ‘Contents’ pane, click the plus sign next to ‘All Music’ to expand the list, and then click the plus sign next to ‘Album’ to expand the list of albums. WMP expands the category and shows all the albums in your library.
5. In the ‘Contents’ pane, select an album title in the list, and drag the title to the ‘List’ pane under the ‘Now Playing’ list. When you drag an album from the ‘Contents’ pane, all the songs in that album are added to the playlist.
6. To add selected songs from an album, in the ‘Contents’ pane, click the album. In the ‘Details’ pane, all the songs on the album are displayed.
7. In the ‘Details’ pane, hold down [Ctrl], and then click the songs you want added to the playlist.
8. Drag the selected songs to the ‘List’ pane.
9. The selected songs are added to the playlist. To remove an item from the playlist, right-click the item, and then click ‘Remove from List’.
10. To save your list, click the ‘Now Playing’ list, and then click ‘Save Playlist As’.
11. In the ‘Save As’ dialog box, type in a file name for your playlist, and click ‘Save’.
12. To listen to your new playlist, expand ‘My Playlists’, and then double-click the playlist you just created. WMP adds the songs from the playlist to the ‘List’ pane and plays the songs, starting with the first song in the list.

7.2.3 Ripping Music
You can rip songs from music CDs onto your computer with Windows Media Player 10. When you rip music, you are copying songs from your CD to your computer. When your songs are copied to your computer, you can use WMP to play and organise your
songs, create playlists, and sync your music to a portable device.

1. In WMP, click Tools > Options. Then click on the ‘Rip Music’ tab to set the ripping options. Here, you can change the default location of the folder where the ripped tracks are saved, and also choose how the files will be named. Under ‘Format’, you can specify the format in which the tracks will be ripped (such as Windows Media Audio or MP3), and also customise the quality of the ripped files using the slider at the bottom. Higher settings for quality will result in larger file sizes for the ripped tracks. Click ‘OK’ when you’re done.

2. Insert an audio CD in the CD drive, and then click ‘Rip’ to copy your music. All songs on the CD will be selected unless you’ve previously ripped them to your computer.

3. Clear the checkboxes next to any songs you don’t want to rip. You can use the checkbox at the top of the list to select or clear all check boxes at once.

4. When you’re satisfied with your selection, click ‘Rip Music’.

5. The first time you rip music, you will be prompted to choose between keeping the current format settings and changing them. You can change the format, sound quality, and download location of your ripped music files, or you can keep the default Windows Media format settings. You can always change these settings later. If you don’t want to make any changes at this point, select ‘Keep the current format settings’ and click ‘OK’.

### 7.2.4 Burning Music

To burn an audio CD:

1. In WMP, click Library. You’ll see an expandable view of all the media items in your library. If there are any items in the ‘Now Playing’ list, clear the existing list to start afresh.
2. Click ‘Now Playing List’, and then click ‘Clear List’. The list will be cleared, and you’re ready to build a playlist that you will burn to CD.
3. Click ‘Now Playing List’, then click ‘Burn List’. Next, add songs to the Burn List.
4. In the ‘Contents’ pane, expand the ‘All Music’ category by clicking the plus sign next to it, and then expand the ‘Album’ category. All albums in your library are displayed.
5. Select an item. In the ‘Details’ pane, press and hold [Ctrl], and click the songs you want to add to your list. Drag the selected songs to the Burn List.
6. Repeat step 5 until your Burn List is complete.
7. To change the order of the Burn List, drag songs up or down in the list.
8. Insert a blank CD-R disc in the CD drive.
9. To make sure the songs you’ve selected will fit on your CD, look at the Total Time at the bottom of your Burn List, and compare it with the total time the CD can hold. Most CDs can hold up to 80 minutes of music.
10. To remove a song from the Burn List, right-click the song title, and then click ‘Remove from List’.
11. Click the ‘Start Burn’ drop-down arrow at the bottom of the screen, and make sure that Audio CD is selected.
12. Click ‘Start Burn’ to burn your songs to the CD. When your computer finishes burning your songs, it ejects your CD. You now have your own custom music CD!

7.2.5 Winamp
One of the most popular multimedia players, Winamp is currently in version 5.12 and boasts of features such as a full-featured media library, integrated SHOUTcast radio and TV, skins, support for visualisations, and more. Download it from www.winamp.com.

7.3 Video
So you’ve seen how to play and organise music. What about video? Windows Media Player also plays common video formats and
allows you to watch your favourite video clips and movies in full-screen mode.

7.3.1 Playing video
The steps involved in playing video in WMP are essentially the same as those for audio. To play a video track:

1. Click File > Open. Browse and select the video file you want to play, and click ‘Open’.
2. Various buttons on the player window let you control playback. You can play, pause, navigate between different tracks on your list, control volume, or use the slider to skip to a particular portion of a track.
3. To set video settings, click on the button with the down arrow on the top left of the ‘Now Playing’ screen. Point to ‘Enhancements’ and then click on ‘Video Settings’. Here, you can set various options such as Hue, Saturation, Brightness and Contrast.
4. To view the video in full-screen mode, go to the View menu and click ‘Full Screen’. Alternatively, you can press [Alt] + [Enter], or double-click on the playing video.
5. To exit full-screen mode, click on the button next to the Close button on the top bar. If the top bar is not visible, just move your mouse pointer anywhere on the screen to display it. You can also press the [Esc] key, or press [Alt] + [Enter], or double-click on the full screen video.

7.3.2 Organising video
The steps involved in creating a video library and video playlists are also the same as those for audio. Refer §7.2.2.

7.3.3 VLC Media Player
VLC is a highly portable multimedia player for various audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, MP3, OGG, etc.) as well as DVDs, VCDs, and various streaming protocols. VLC supports a large number of multimedia formats without the need for additional codecs, and is available free for a variety of OSes. Find more information and download the software from www.videolan.org.
Most OSes are pre-configured to run stably on a variety of hardware. However, this doesn’t mean there’s no headroom for tweaking and customising the OS. “Tweaking” refers to altering the default behaviour of the OS to suit your needs.

This is one of the fun chapters in this book—how to tweak your XP-based computer to your heart’s content! Remember our disclaimer, though: if your computer breaks, don’t blame us!
8.1 First Things First

What follows are some general tips that should be implemented immediately after installing a fresh copy of Windows XP. The purpose of these tips is to boost XP's performance.

**8.1.1 Speeding Up The Bootup Process**

The common yardstick used to determine system performance is the boot speed. Though this isn’t really right, people tend to have a fascination with boot speeds. Let’s take a look at some of the common tricks used to speed up the booting process.

1. **Disable boot virus detection**

Some motherboards come with the capability to scan the boot sector for virus infection. Boot sector viruses were prevalent some years ago, and posed great danger to the hard drive partition table; however, the virus-writing community seems to have given up on this method of attack!

   And so, boot virus detection takes up precious boot time and slows down the bootup process. We would advise you to turn off this feature on your motherboard for faster boot speeds. To find out how you can do so, look in the “Advanced BIOS features” section of your BIOS.

2. **Change The Boot Sequence**

Since Windows XP is generally installed via a CD-ROM, the boot sequence is set to CD-ROM first, and then the hard drive. By realigning the boot sequence, a few seconds can be chopped off the bootup time. Keep your OS-loaded hard drive as the primary boot device; this is generally denoted as “Hard Disk0”. Similarly, if, like most people, you hardly use your floppy drive, turn it off from the BIOS. As far as floppy drives are concerned, there is an option to scan the drive on bootup. Turn this feature off to save a couple of more seconds.
3. Switch off unnecessary hardware in the BIOS
Since most motherboards today have integrated devices such as Ethernet controllers, FireWire devices, onboard sound and more, during the boot process, the BIOS assigns resources to these devices. In case you don’t plan on using these devices, it is advisable to switch them off from the BIOS. Also, there are hardly any devices that use legacy ports such as Parallel and Serial. Unless you do have, say, a serial mouse, it is advisable to switch off these ports too.

Motherboards these days come equipped with RAID solutions; if you’re not planning on using a RAID configuration, it is advisable to switch it off.

4. Disable the XP load screen
By disabling the load screen, you can boost the bootup time by a couple of seconds, if not more. To disable the load screen, open the “msconfig” utility: go to Start > Run, type in “msconfig” and press [Enter]. In the subsequent window, select the ‘boot.ini’ tab. Check the /NOGUIBOOT option and press ‘Apply’. Restart windows to see the effect.

5. Disabling unwanted startup programs
You’ll generally see that a fresh installation of Windows XP is fast and responsive, and that as time progresses, the system becomes slower—blame it on the tons of applications you install. Today, most applications leave some portion of themselves running in the background as services. These services are launched during bootup without your knowing it. The bootup time slows down as the number of these automatically-launched services increases. There are some applications such as Winamp, Winzip, display properties, etc. that can be switched off for faster bootup times.

The easiest way to remove these unwanted services at startup is by using the “msconfig” utility. The ‘Startup’ tab in msconfig lists all
the services that are launched at bootup. Each service has a check-box, by un-checking which, you can stop that particular service from being launched at startup. You should get a feel of which services are required and which are not by looking at the filename and target directory. For example, you might see “winampa” listed, and you can guess that this is the Winamp agent. You probably don’t need it to run. Similarly, “realsched” is the RealNetworks scheduler, which you probably don’t need. Un-check the ones that you feel are not required, and select ‘Apply’.

The ‘Start\Programs\Start’ directory in Windows XP is the place the OS uses to launch application shortcuts at bootup. Clearing this folder will cause the programs to not launch at boot-up. This folder also happens to be the target of most spyware and adware. Windows XP does not put any system-critical files in this folder, so even if you’re not sure of the application a particular shortcut refers to, just delete it.

6. Remove unwanted fonts
During bootup, Windows XP scans the ‘Fonts’ directory and loads them for the system to use. Windows XP by default installs fonts required for its operation as well as those for use in other applications such as Word, Notepad, IE, etc. Of these default fonts, most people hardly use more than 10. The remaining fonts simply sit there and occupy system resources, slowing down the bootup process as well. A simple way to address this situation is to move unused fonts to a separate directory.

Create a new folder, say ‘C:\Fonts_backup’. Go to Start > Control panel > Fonts. In the ‘Fonts’ folder that opens, select all
the fonts. Drag and drop them into the newly-created 'Fonts backup' folder. When you do so, the display will turn to gibberish—don’t worry. XP will install the basic fonts, the ones required for proper display, in the ‘Fonts’ folder.

Now that the system has the bare minimum fonts, hand-pick the fonts you always use, such as Times New Roman, Arial, Tahoma, Verdana, etc. from the backup folder and copy them to the ‘Fonts’ folder. If you removed a significant number of fonts, your system should boot faster.

Note: This tip is obviously not for graphics designers, as they generally use a large number of fonts!

7. Use the Bootvis utility
The “Bootvis” utility was designed by Microsoft to help system manufacturers optimise the boot characteristics of Windows XP. It’s a free tool, and is available at www.softpedia.com/get/Tweak/SystemTweak/BootVis.shtml. Run the utility, go to the ‘Trace’ menu and select ‘Next boot and driver delay’. Bootvis will prompt a reboot. Reboot and wait for Bootvis to start again.

Go to the ‘Trace’ menu and select ‘Optimise’. Reboot again and wait for Bootvis to complete its analysis. At the end of the analysis, your bootup time should be optimised.

8.1.2 Improving Response Times
Now that we’re done with improving bootup times, let’s have a look at some tips that help you improve overall system response times.
1. Adjust Visual effects
As compared to previous versions of Windows, XP comes loaded with lot of eye-candy. These visual effects put a lot of strain on your system resources and drag down the overall system performance. We suggest you follow this tip if you have 256 MB or less of RAM.

For adjusting the visual effects, you need to get to the System Properties page, which can be done by pressing [Windows] + [Pause/Break], or by right-clicking on ‘My Computer’ and selecting ‘Properties’.

Select the ‘Advanced’ tab and then click on ‘Settings’ under the ‘Performance’ box. In the box that opens, select the ‘Visual Effects’ tab. By default, the first option is always chosen. To improve performance, select the ‘Adjust for best performance’ radio button. Depending on your hardware configuration, Windows will automatically tone down the visual effects. To further tweak the system, select ‘Custom’, and start un-checking the effects that were not automatically shut down by XP in the first step. Play around with these settings until the interface reflects an optimum balance between speed and visual appeal.
2. Disable Error Reporting

The error reporting feature is a complete annoyance and a resource hog. It pops up when an application fails. As you’ve probably seen, the feature exists so problems can be reported to Microsoft. Simply switch off this service off without a second thought!

At the bottom of the ‘Advanced’ tab in ‘System Properties’ is a button called ‘Error Reporting’. Click the button to open the ‘Settings’ page, and then select ‘Disable Error reporting’. You can even choose to disable error notifying as well by un-selecting ‘But notify me when critical errors occur’. Apply the changes and press ‘OK’.

3. Disable Remote Assistance

This is another service you can disable to free up system resources. In ‘System Properties’, select the ‘Remote’ tab. Uncheck ‘Allow remote assistance’. If you have a standalone PC without a network connection, it’s a good idea to switch off the ‘Remote Desktop’ feature as well—just uncheck the ‘Allow users to connect remotely’ checkbox.
4. Turning Off System Restore

Windows XP comes with the System Restore feature, which allows you to roll the system back to a previously defined state. (Refer Chapter 9 for more on System Restore.) This feature comes in handy when a driver installation fails and the system crashes, in which case the system can be rolled back to the earlier state with a few clicks. By default, this service monitors almost all the partitions on your hard drives, and allocates a whopping 12 per cent of partition space for its activities.

If you’re a first-time user, we’d suggest you keep System Restore running on, at least on your primary (OS) partition, if not the entire hard disk(s). But if you’re an experienced user, there’s no need to keep this service running.

In the ‘System Properties’ page, select the ‘System Restore’ tab. By default, System Restore is turned on and monitors each drive. To turn it off, check the box ‘Turn off system restore on all drives’.

To selectively keep System Restore running on a particular drive, on the ‘System Restore’ page, select the appropriate drive and click the ‘Settings’ button. Drag the slider to set the space that System Restore will take up. 5 per cent to 7 per cent should be good enough for a home PC.

5. Turn Off The Indexing service

The Indexing Service creates a database of files on your hard drive. When you search for a file, XP searches for the file’s location in this database and reports its location. The database it constantly
updated as files are moved and created. This reduces system performance. Of course, it also speeds up searches, so you should turn it off or keep it on depending on how often you conduct local searches.

To turn off the Windows indexing service, open Windows Explorer, and right-click on each drive and choose ‘Properties’. In the ‘General’ tab, right at the bottom, uncheck the box ‘Allow Indexing service to index this …’. Alternatively, you can completely get rid the indexing service by going to Control Panel > Add or Remove Programs > Windows Components, and then un-checking ‘Indexing Service’.

6. Disable The Disk Performance Counter(s)
XP comes with many inbuilt performance monitoring applications that constantly examine various parts of the system. This information can be of real use to a system administrator for collecting performance statistics. However, for a home user, these statistics hold no value, and since the monitoring happens all the time, it consumes a good deal of system resources.

“Disk monitoring,” for example, happens in the background, and turning it off is advisable if you will not be using the performance monitoring applications. To turn it off, type in “diskperf -N” at a command prompt.

7. Moving The ‘My Documents’ Folder
The ‘My Documents’ folder invariably ends up as the default repos-
itory of files for most Windows applications. Over a period of time, this folder starts bloating, and this, to a certain extent, results in performance degradation. It might be a good idea to move the target location of the ‘My Documents’ folder to some other partition on the hard drive, or to a different drive.

To do so, right click on ‘My Documents’, and on the ‘Target’ tab, click on ‘Move’. In the subsequent dialog box, browse to the drive where you want to move the folder. Then click ‘Make New Folder’ to create a new folder, and name it appropriately. Click ‘Apply’ and then ‘Yes’.

8.2 The Page File

The page file, also called the virtual memory, is the part of the hard drive that the operating system uses as though it were main memory. The virtual memory comes into the picture when the physical memory cannot hold the data that the application requires it to. Since hard drives are much slower as compared to RAM, accessing data from virtual memory is slower, and there is naturally a significant effect on system performance. Moreover, Windows XP uses the virtual memory all the time, regardless of free physical memory, so optimisation of the page file is essential for a faster system.

There are two important aspects to the page file—its size and its location.
8.2.1 Page File Size
XP uses the page file dynamically, that is, the page file grows or shrinks according to need. The page file is often given a minimum value and a maximum value, where the minimum value defines the guaranteed space allocated to the page file and the maximum value defines the limit to which the page file can grow. With a maximum and minimum value set, XP has to resize the page file on the fly. Setting the maximum and minimum value to the same number results in more efficient handling of the page file, since XP won’t have to waste time resizing the page file.

Setting the size of the page file
Go to the ‘System Properties’ page. Here, go to the ‘Advanced’ tab and then select ‘Settings’. In the window that opens, go to the ‘Advanced’ tab; towards the bottom of the tab, you will find ‘Virtual memory settings’. Click ‘Change’.

In the next window that opens, you can select the drive on which you want the page file to reside; by default, the page file resides on the C: drive. You can also see the page file size. To change it, click on ‘Custom Size’ and then key in the initial and maximum sizes to be the same. Typically, 1 GB of page file is more than enough for most users, so key in “1024” as your initial and maximum page file size.

8.2.2 Page File Location
Setting the location of the page file
Keeping the page file on the same drive as the operating system is not advised, as the page file requires intermittent read and write cycles that can significantly affect the performance of the system. But most machines have one drive, and there is hardly an option other than placing it along with the OS.

Some people advocate partitioning your drive and placing the page file in a non-OS partition; we doubt if this will help. But if you have a second drive, we advise you place the page file on the non-OS drive for better performance.
Once in the virtual memory settings (see §8.2.1), you can see all your partitions listed in the box. Select the drive on which to enable the page file, then select ‘Custom size’, and key in an appropriate size for the page file as discussed in the previous section. You can also span the page file across several partitions by selecting each drive and repeating the process as discussed above. In fact, many believe that a small amount of page file should reside on the OS-loaded drive, and that the remaining should be spanned across the other drives to improve performance.

8.3 Services

Windows XP is perhaps the best operating system Microsoft has been able to deliver till date. Despite its complexity, XP poses no challenge to a beginner or seasoned pro when it comes to operating the system—the interface is slick, precise and intuitive. However, behind this slick interface lies a demon that hogs system resources like no other operating system does.

The reason for system resources vanishing is the barrage of services running in the background. All modern OSES constantly run processes that monitor the surrounding changes regardless of user or application inputs. These processes enable the OS to perform certain actions such as launching of applications, detection of plug-and-play devices, monitoring of network resources, file indexing, and so on. In XP terminology, these processes are called “Services,” and they run in the background without user intervention or knowledge.
The prime advantage of the concept of services is to automate system management, without the user having to launch applications or do something else. For example, in Windows 98, USB devices required installation of drivers. This was eliminated in XP due to the constant running of a service that automatically detects the presence of a USB device and installs a generic device driver for it.

8.3.1 Background Services
As mentioned earlier, services run in the background, where “background” refers to the fact that they’re hidden from the user. Windows XP comes bundled with an application that lets you view all running services.

Go to Start > Run, and type in “services.msc” and press [Enter]. This will bring up the Service Management Console. This console shows Windows XP services; apart from the name of the service, it also shows other useful information such as Description, Status, Startup Type and Log On As.

‘Description’ gives a brief idea of what the service does and what will happen when it is shut down.

‘Status’ indicates whether a service is running or not. If it is running, “Started” is displayed beside the name of the service.

‘Startup Type’ indicates the types of methods employed for starting the service. It can take three values: Automatic, Manual and Disable.

**Automatic:** This means the service was started by XP during the bootup process, and can be a critical service for the operation of the OS.
Manual: These services are started by applications dependent on the particular service. By default, manual services are Off, and once activated, they need to be shut down manually, or they will be switched off after reboot.

Disabled: Once ‘Disabled’ is assigned to a particular service, it won’t be activated until it is assigned Manual or Automatic status. For disabling a service, of course, one needs to assign the Disabled attribute to it.

‘Log On As’ indicates the user or the system account the service uses to operate—Network, Local, etc.

8.3.2 Getting Information On A Service
To obtain more information on any service, double-click the service in the Service Management Console. This will open up a window that lists complete information on the service.

There are four tabs in the ‘Properties’ page: ‘General’, ‘Log On’, ‘Recovery’, and ‘Dependencies’. The ‘General’ tab provides information relating to the service such as its true name, path to the executable, startup type, and the option to start or stop it. ‘Log On’ allows you to change the account the service uses to carry out its functions. The ‘Recovery’ tab gives control over what should happen if the service fails, etc. The ‘Dependencies’ tab lists various services a particular service depends on to function. Knowing the dependencies is useful when shutting down a service, so as to avoid an avalanche effect on other, dependent services.
8.3.3 The Difference Between Services And Processes

Now that you know the number of services running in the background, it is essential to understand why they are not represented under the ‘Processes’ tab in the Task Manager, which can be activated by pressing [Ctrl] + [Alt] + [Del].

Ideally, all services running in the background should be represented in the ‘Processes’ tab. Why they aren’t is because the ‘Processes’ tab only lists the .exe executable for each application currently running under Windows XP. Now applications are responsible for launching services, but they don’t represent a single service; that is, an application can have multiple service dependencies. Representing all of them in the ‘Processes’ tab doesn’t make sense.

8.3.4 Services To Stop To Gain Performance

1. Computer Browser
If you have a standalone computer, disable this service completely. If you are connected to a network, but do not use the network for browsing file shares, disabling this service won’t affect you.

In addition, disabling this service does not prevent you from accessing file shares on another computer. It’s the other user who won’t be able to browse your files if this service is turned off on your computer.

2. Messenger
The messenger service is not related to Windows messenger or MSN Messenger. This service allows users to communicate over the net-
work using the “netsend” command. If you are using Windows XP SP2, this service is probably already disabled. If it’s not, disable it.

3. Net Logon
This service also logs on to a Windows network domain. For a typical home network, this service is not required, so disable it. If at all it is required, you will be prompted to enable it.

4. Net Meeting Remote Desktop Share
As the name suggests, this allows sharing of Desktops in a NetMeeting session. If you don’t require this, disable it.

5. Performance Logs And Alerts
If you aren’t interested in measuring the performance of your system using the inbuilt performance monitoring tools, it is advisable to disable this service.

6. Network Provisioning Service
Microsoft’s description for this service is that it “manages XML configuration files on a domain basis for automatic network provisioning.” It is not critical for a home network.

7. Qos RSVP
This gives the quality of service parameter for a network. It is neither critical nor required for normal networking.

8. Remote Desktop Help
This refers to Remote Assistance, referred to in §9.11. If you’re not going to use Remote Assistance, disable this service.

9. Remote Registry
Messing around with the Registry is dangerous as it is; doing it remotely doesn’t make sense. Disable this service.

10. TCP/IP NETBios Helper Service
This is not required for a home network.
11. Uninterruptible Power Supply
Unless you have a UPS, this service is a resource hog.

12. Terminal Services
Unless you plan on using the Remote Desktop feature and other remote management tools, disable this service.

13. Wireless Zero Configuration
Unless you have a wireless device that needs auto-configuration (lame), you can disable this service.

14. Themes
This service gives Windows XP its slick user interface. Disabling it will make your system respond faster, but Windows won’t nearly look so good after you do that! Try disabling the service and see if you can live with the effect it has. You can re-enable it if you don’t like what you see.

15. Smart Card
This service does nothing but enable use of smart card authentication in Windows XP.

8.4 The Windows Registry

If you want to really tweak Windows, you’ll need to fiddle around with the registry. The registry is complex, and its health is crucial for the proper functioning of Windows. As we’ve said time and again, don’t mess with it without knowing what you’re doing! But since you’d like to know the basics of the Registry, we try and demystify it here, while mentioning some basic hacks.

8.4.1 What The Registry Is
As you know, the OS is a huge, complex piece of code that acts as a bridge between the user and the hardware. During its operations on various data, the OS requires lot of information (variables). For
example, if you’re working in, say, MS Word, the OS requires information such as what font to use, what each menu should contain, etc. This required data is stored in the registry. The registry is thus a warehouse for Windows’ configuration data and that of other applications as well.

Since variable data is stored in the Registry, you can set Windows XP’s behaviour to your preferences by tweaking it correctly. By default, XP allows customising certain variables via the Control Panel settings. However, for finer customisation, you’ll need to manually tweak the variables in the Registry.

8.4.2 The Registry Inside Out
Similar to the Service Management Console that allows tweaking of Windows XP services, XP comes with a Registry Editor. To invoke it, go to Start > Run, type in “regedit”, and press [Enter].

As you can see above, the registry has five main branches which separate the data stored in the registry into five different groups. The main branches have folders under them called ‘Keys’, which hold the values for the variables. It is important to understand the five main branches and their purpose.

HKEY_CLASSES_ROOT: As the name suggests, this holds the root data, that is, the data required for Windows XP’s internal functioning, such as the OLE (Object Liking and Embedding). It also acts as a database for file associations, which determines the application to be launched when a file is double-clicked. It is not advisable to do any tweaking in this branch, as it is very complex and offers zero margin for error.
HKEY_CURRENT_USER: This branch stores data related to the currently logged-in user. Any customisation you do to Windows or your applications is stored under this branch. This branch has a lot of customisation options, and they can be edited to suit your needs.

HKEY_LOCAL_MACHINE: This branch has information related to the computer and the applications installed on it. This also happens to be the most edited branch. An important thing to remember is that the changes made here are reflected globally—that is, they are independent of the user. The ‘SOFTWARE’ key under this branch offers customisation options for all installed applications, and for Windows too.

HKEY_USER: Pretty much like the ‘HKEY_CURRENT_USER’ branch, ‘HKEY_USER’ contains configuration data specific to the individual user. Users are identified by a Security Identifier (SID), a unique value assigned to a user on creation. As against ‘CURRENT_USER’, ‘HKEY_USER’ has information related to all the user accounts created on the machine.

HKEY_CURRENT_CONFIG: This key is connected to HKEY_LOCAL_MACHINE in much the same way as HKEY_USER is to HKEY_CURRENT_USER. This branch contains data specific to the hardware and software settings for all users of the machine.

As mentioned earlier, each of these branches are “keys”, denoted by a folder icon. The keys further have sub-keys and values that make up the Registry data. Apart from these five keys, there are other notations that you should be familiar with.

REG_DWORD: A REG_DWORD acts like a switch: it can have one of two values—“0” or “1”. DWORD is the most commonly tweaked or edited value while editing the Registry. You can create a new DWORD in the Registry Editor by going to Edit > New, and selecting ‘DWORD Value’. The value is usually denoted in the hexadecimal format with the decimal equivalent in brackets next to it.
REG_SZ: “REG_SZ” stands for “String Value”, and represents data as a string of characters. This string can be a word, a number, or the location of a file on the hard dive. REG_SZ is the second-most edited value while hacking the Registry.

8.4.3 Editing The Registry
Before you start editing the registry, it is always advisable to back up the current registry and save it to your hard drive. This is important because you might do something wrong and your computer could even stop functioning—in which case you’ll need to bring back the old Registry.

8.4.3.1 Creating A Registry Backup
Launch the Registry Editor, and select File > Export. In the subsequent dialog box, enter a name for the Registry file, say “Before_Editing”, and select a location to store the file, say ‘My Documents’. Before you press ‘OK’, select the ‘All’ option at the bottom of the page so that the entire registry is saved rather than the selected branch.

There are two types of registry files, a .REG file and a Hive file. If you save your current registry as a .REG file, then during restoration, it will simply add the information to the Registry without overwriting the new entries. But in the case of a Registry going bad due to installation of malware, it becomes necessary to overwrite the entire Registry, in which case the Hive file comes in handy. So when you’re taking a Registry backup, make sure you save it in both formats. This can be done by selecting the file type as “.REG” or “Hive” in the ‘Save As’ dialog box.

8.4.3.2 Restoring A Registry
Restoring a Registry gone bad is simple. Open REGEDIT and go to File > Import. In the box that opens, browse to the backup file; it could be a .REG file or a Hive file. Select the appropriate file and press ‘OK’. The system might ask you to provide your username and password.
8.4.3.3 Registry Hacks
For Novices
Here are some common and useful registry hacks for XP. All these hacks are done via Regedit.

1. Remove the “Shortcut To” text on shortcuts
Browse to HKEY_CURRENT_USER > Software > Microsoft > Windows > CurrentVersion > Explorer. Click on ‘Explorer’. On the right-hand pane you’ll see a list of values. In the list, look for the value “link”.

To modify it, double-click it, or right-click it and select ‘Modify’. In the subsequent window, delete the previous value and enter the new value as “00, 00, 00, 00”, and save the Registry.

2. Disable balloon tips
Browse to HKEY_CurrentUSER > Software > Microsoft > Windows > CurrentVersion > Explorer > Advanced. Click on ‘Advanced’, and in the right-hand pane, search for “EnableBalloonTips”. Double-click on it and modify the value to “00,00,00,00”, which is zero in binary and denotes “Off”.

3. Remove recent documents from the Start Menu
Browse to HKEY_CURRENT_USER > Software > Microsoft > Windows > CurrentVersion > Policies > Explorer. Look for “NoRecent DocsMenu” and modify the DWORD to “00,00,00,00”.

Creating a backup of the Registry

Restoring the Registry from a backup
There are innumerable registry hacks, and listing them here is not possible. If you want to have lots of fun with the Registry, we’d recommend *Windows XP Registry Guide* by Jerry Honeycut. The book is for advanced users, and is available from Microsoft press.

Finally, we should mention that for this chapter, we have occasionally referred to www.PCstats.com, www.tweakhound.com and www.tweakxp.com.
Here, we alert you to some things that need to be done to keep your computer in good running order—for example, the fact that you should defragment your disks often (which not many people do). We also tell you about how to use the Computer Management tool, about how to automatically have your computer shut down in the event of the processor overheating, and so forth.
9.1 Caring For Your Disk: Defragmentation

You can’t do anything about a hard disk crash—or can you? Yes and No. The fact is, hard disks have mechanical parts, and will ultimately crash—and you can’t predict when one will. You’ll sometimes find a decade-old hard disk running perfectly fine, and you’ll sometimes see a year-old hard disk that crashed for no reason at all. On the other hand, there are a few things you can do to prolong the life of your hard disk:

- Keep it running cool (which we’ll come to later in this chapter)
- Prevent thrashing: don’t make the hard disk access too many files at the same time. For example, don’t play a song while a movie is already running.
- Set the disk to turn itself off within a few minutes of inactivity. The downside is that you’ll have to wait a few seconds when you access a file after that time, but it’s worth it. It prevents overheating and reduces wear and tear.
- Don’t do anything that would shake up the mechanical parts—for example, frequently transporting it between two computers. Once in a while (if done with care) is OK, but don’t make it a habit.
- Defragment it often. This, too, reduces wear and tear.

Why defragmenting needs to be done is essentially so that the head doesn’t have to move “back and forth” too much.

Over a period of time, your files tend to get fragmented—one part of a file will be stored on one location on the disk, and the other part somewhere else. And it’s not limited to two locations: there could be hundreds of fragments of one file all over the disk! (For a visual representation of this, see How Disk Defragmentation Works, Digit, December 2005.) Accessing all the fragments in sequence means the head will need to shuttle between the locations at high speeds. The more of this it needs to do, the more susceptible it is to losing its alignment—which, of course, means a crash.
Defragmentation takes all the non-contiguous parts of a file and arranges them contiguously. It does this on a best-effort basis; if it can’t make one contiguous stretch of the file, it will at least try and reduce the number of fragments.

The process itself takes any amount of time ranging from a few minutes to several hours, depending, of course, on how fragmented the disk is—and also on how much RAM you have and how fast your processor is. If you bought your computer say, six months ago, and have never defragmented it, chances are it will take several hours, and even then, it won’t be able to do a perfect job. Make it a practice to defragment your disk(s) once a month or so. We recommend that you also defragment your disk after you’ve installed Windows and other essential software for the first time.

Apart from reducing wear and tear, there is another fundamental advantage to frequent defragmentation—performance. If your files are less fragmented, your hard disk will respond faster, leading to better performance.

**9.1.1 Defragging Your Disk**

There is more than one way to reach the disk defragmenter program from within Windows. The easiest is Start Menu > All Programs > Accessories > System Tools > Disk Defragmenter.

If you’ve used the defragmenter in Windows 98 or ME, you’ll see that there are some changes. First, you don’t get the option to “arrange files so that your programs start faster.” Windows XP does this by default. Second, the old defragmenter would arrange files in such a manner that it appeared as though every single cluster was in place. We won’t go into the internals of this, but XP does it differently—you’ll find files arranged with free space in between them, for example.

The main defrag window in Windows XP looks something like this. At the bottom, there are two strips: the first one tells you what
the disk looks like before
defragmentation, and
the second one tells you
what it'll look like after.

When you start the
defragger, first analyse
the drive(s) by right-click-
ing on each drive. After
analysing the drive,
you'll get an advice box
as shown below, which tells you whether you need to defrag the
drive or not.

In most cases, you
should accept Windows'
advice. You can start the
defragmenting process
by clicking the
'Defragment' button.
Remember that a drive
needs to have 15 per cent of free space for the defragging process
to continue normally—Windows uses this free space as a scratch-
pad. If there's less than 15 per cent of free space and you choose to
defragment the drive anyway, the defragmenting process will not
yield the best results.

You cannot defragment volumes the file system has marked as
"dirty", which indicates possible corruption. You must run the
chkdsk program (more on this later) on a dirty volume before you
can defragment it. You can determine if a volume is dirty by using
the "fsutil dirty query" command—for example, "fsutil dirty query
c:" will tell you if the c: drive is dirty.

Then there are the 'Pause', 'Stop' and 'Resume' buttons to be
talked about. You should use the 'Pause' and 'Resume' buttons
from time to time if the defragging process is taking too long, so
as to prevent hard disk overheating. You can also pause the process if you want to do something on your computer that makes use of files on the disk being defragmented. Also note that you can stop the defrag process at any time—again, you might want to do this if it’s taking too long. It’s not exactly the same, but when you choose to defrag the disk later, it pretty much picks up where it left off.

After having analysed a drive, you can choose to view the report by, of course, clicking on ‘View Report’. This gives you the details of what files on the drive are defragmented and to what degree. Of course, files defragmented into too many pieces are bad news. One trick you can apply here (if you have more than one partition and/or physical drive) is to move the heavily-fragmented file to another partition, defragment the current partition, and then bring the file back to the original drive. In most cases, when the file is copied back, it gets copied as a contiguous piece.

9.1.2 Using The Command Prompt

For those who like to use the command prompt, here is a list of the switches you can use with the ‘defrag’ command.

The syntax is “defrag volume [/a] [/v] [/f] [/?]”

**volume**
The drive letter or a mount point of the volume to be defragmented.

/a
Analyses the volume, displays a summary of the analysis report, and indicates whether you should defragment the volume.

/v
Displays the complete analysis and defragmentation reports. When used in combination with /a, displays only the analysis report. When used alone, displays both the analysis and defragmentation reports.
(By default, “defrag” displays a summary of both the analysis and defragmentation reports if you do not specify the /a or /v parameters.)

/f
Forces defragmentation of the volume when free space is low.

/?
Displays help at the command prompt.

9.1.3 Notes On Using The Command Prompt
You can send the reports to a text file by typing “> FileName.txt”, where “FileName.txt” is a file name you specify. For example:

defrag c:/v > report.txt

To interrupt the defragmentation process, press [Ctrl] + [C] at the command prompt.

Running the defrag command and Disk Defragmenter—the Windows tool we mentioned above—are mutually exclusive. If you are using Disk Defragmenter to defragment a volume and you run the defrag command at a command prompt, the defrag command fails. Conversely, if you run the defrag command and open Disk Defragmenter, the defragmentation options in Disk Defragmenter are unavailable.

Now here’s a hidden option: if you use “-b” at the command prompt, the defrag utility will optimise the boot files and applications—based on usage information that XP tracks—but it will leave most of the drive untouched. For instance, if you run

defrag c:-b

at the command prompt, the boot files and some application files will be defragged and possibly moved to a different location on the disk to enable them to be read from disk faster.
9.2 Using The Computer Management Tool

Computer Management is one of the powerful tools Windows provides. Access Computer Management by right-clicking 'My Computer' and selecting 'Manage'. You'll see three main sections in the window that opens: System Tools, Storage, and Services & Applications. We take a look at each of these. Here, above, is the Computer Management console in all its glory.

9.2.1 The System Tools Section

This has everything to do with monitoring your system, right from users and groups to shared folders and the device manager.

- 'Shared Folders' displays 'Shares', 'Sessions' and 'Open Files'. Selecting 'Shares' will display your shared network folders and also the Windows-created share folder for remote access by an Administrator. To disable sharing of any folder listed here, open
the folder location and right-click it, select ‘Sharing and Security’ and uncheck ‘Share this folder’.

- ‘Sessions’ displays the users connected to your machine if you’re on a network. It also displays information such as the type of user (whether guest or administrator), computer name, number of files opened, connected time and idle time. If you see an unexpected user or users connected to your computer, you can check under ‘Open Files’ to find out what folder and file is in use by the other user.

- In ‘Open Files’, you (as Administrator) can disconnect access to any files that are in use. Note that ‘Sessions’ allows you to disconnect the other user altogether.

- ‘Local Users and Groups’ displays system users and user groups on your machine. You can use this section to add users and groups, and control user accounts—you can disable an account, set/reset passwords, and also force a user to change his password at login. This tool is useful in the context of a machine that is used by more than one person.

9.2.2 The Storage Section

Under this section come ‘Removable Storage’, ‘Disk Defragmenter’ and ‘Disk Management’.

- Clicking ‘Disk Defragmenter’ opens up, of course, the Disk Defragmenter—which is the same as what opens up when you click Start > All Programs > Accessories > System Tools > Disk Defragmenter. Refer to section 9.1 for more on disk defragmentation.

- Clicking ‘Disk Management’ makes creating partitions and formatting them remarkably easy. It displays all the drives—even CD/DVD ROMs and writers along with the hard drives attached to the system. Disk Management helps you create a partition on a hard disk without having to run any commands or use a start-up disk. Since Windows XP is already installed, your hard disk would already have one partition. If all the space on the hard disk has been used as a single partition, you can’t do anything
using Disk Management—since you’re not permitted to split, delete or format a partition that contains Windows.

If you have used only a portion of the disk for the XP installation, you can use Disk Management to create more partitions (FAT32 or NTFS) on the drive, and assign them drive letters and volume labels. Note also that if you have multiple partitions, you can change their drive letters from here. Also, from the Disk Management window, you can see what partition is the System partition, what partitions are active, and what partitions contain a page file.

So what are Active and System partitions? When your computer is started, there are certain files needed to boot (start) the computer. These boot files reside on the System partition. Once the boot files have been accessed and performed their function, the system files (the files that comprise the XP OS) are accessed to complete the system start. The system files reside on the Boot partition.

So—and the following may seem to make no sense—the boot files reside on the System partition, and the system files reside on the Boot partition. “Active Partition” means the same as “Boot Partition.”

Now for the partitioning process: before you partition your disk(s), you need to know what the different types of partitions are.

1. A primary partition is one from which you can boot operating systems. There is a limitation, however: you can only have four primary partitions.

2. An extended partition is an extension of a primary partition that allows you to have up to 64 logical drives.

3. A logical “partition” is actually called a logical drive; these are not really partitions, but spaces allocated on the disk for addressing data differently. For all practical purposes, though, they look just like drives.
To create a partition, right-click on an unpartitioned area and select ‘New Partition’. Then choose the type of partition (primary, extended or logical) you want to create. In the following screen, give the size of the partition in MB, a Volume Label, and the type of file system (FAT32 or NTFS).

You can choose ‘Quick Format’ to save time. As opposed to ‘Format’, ‘Quick Format’ doesn’t scan the disk for bad sectors.

9.2.3 Services And Applications

Services are the process run by an operating system; some services are necessary for the functioning of a system, and some are optional. This section lists all the services and applications in Windows XP, and tells you the status of the service/process. The section also gives a description of each of the listed services.

A service can be stopped, started or restarted. For example, the Messenger service (which sends messages to a workgroup/computer/domain in a network) is normally in the ‘Stopped’ state; you can start this service to allow network users to send and receive messages. This can be done by right-clicking on the service name and then selecting the appropriate option out of ‘Stop’, ‘Start’, ‘Restart’, ‘Pause’ and ‘Resume’.

Refer §8.3 for more on what services run by default, which ones can be safely stopped, and so on.

9.2.4 Other Components Of Computer Management

The Indexing Service (under Services and Applications) indexes the files on your computer. It does this in the background, when your computer is idle. Strictly speaking, you don’t need a desktop search program: with the indexing service enabled, you can find whatever you need on your disks using the appropriate syntax (refer box Using XP’s Indexing Service). This can turn out to be a resource hog, in which case you can turn it off. If it is turned on, you can "Query the Catalog" right from the Computer Management console—‘Query the Catalog’ is the last item you’ll see in the console when you expand all the branches.
Removable Storage is under the Storage section. Use the Removable Storage tool to track your removable storage media and manage the libraries, or data-storage systems, that contain them.

Device Manager is under System Tools. This is the same as the Device Manager you get to when you go to Control Panel > System > Hardware > Device Manager.

‘Performance Logs and Alerts’ are meant for computer administrators, as is the ‘Event Viewer’, both under System Tools.

Using XP’s Indexing Service

To utilise the full power of the Indexing Service, don’t search by putting your criteria in the “All or part of the file name” box. Enter your criteria in the “A word or phrase in the file” as described below, even if you are looking for a file name.

To search for a file by name, your search criteria must begin with @filename or #filename followed by all or part of the filename you are looking for, and you must put it in the “A word or phrase in the file” input area. The wildcards “*” and/or “?” are allowed, as below.

- flower
- flow*
- *low*
- *fl?er*

To search for a file based upon a word or phrase in the file, your search criteria must start with an exclamation mark: !criteria

The exclamation mark forces use of the index. If the exclamation mark isn’t used, Search Companion will begin the regular (slow) file-by-file physical search.
9.3. The Device Manager

To access Device Manager, use any of the following methods:

- Start > Run and type in “devmgmt.msc”.
- Right-click My Computer, click ‘Manage’, and then click ‘Device Manager’.
- Right-click My Computer, click ‘Properties’, click the ‘Hardware’ tab, and then click ‘Device Manager’.
- Type in the following at a command prompt: “start devmgmt.msc”

Device Manager provides a graphical view of the hardware installed on the computer, as well as the device drivers and resources associated with that hardware. Using Device Manager provides a central point to change the way the hardware is configured and interacts with the processor.

The appearance of the Device Manager will, naturally, depend on what devices are connected to your computer, but typically, the Device Manager looks something like the image on the right:

![The Device Manager, expanded](image)

Typically, Device Manager is used to check the status of computer hardware and update device drivers on the computer. If you are an advanced user, and you have a thorough understanding of computer hardware, you can use Device Manager’s diagnostic features to resolve device conflicts, and change resource settings.

So, say you’ve installed a new piece of hardware, such as a hard disk. The BIOS apart, the hard disk will show up in Device Manager. Similarly, if you connect a USB drive, it should show up
immediately in Device Manager. If it doesn't, then you know you've done something wrong, or that the drive is faulty; if it shows up with an exclamation mark, the device has a problem, and double-clicking the item will give you an idea as to what the nature of the problem is.

Some devices may show up with red crosses; this means they've been disabled. You can manually disable certain devices if you're not using them.

Right-clicking a device brings up some or all of five options: Update Driver (shown on the next page), Disable, Uninstall, Scan for Hardware Changes, and Properties.

**Update Driver** is used, of course, for updating the driver for the device: it opens up a wizard that helps you update the device driver.

The first question you're asked is whether Windows can connect to the Internet to find an updated driver; make an appropriate choice here. Say you choose to connect. You're then asked whether you want to install the software “automatically” or whether you want to install it from a specific location. In the former case, Windows
will look on the Internet and on your hard disk to try and find a suitable driver; you’d choose the latter (“specific location”) if you have a CD-ROM, for example, with the updated drivers.

The wizard then asks you specific questions based on the outcome of the search in the former case, and in the latter case, you’re usually prompted to point Windows to the precise location of the driver files.

**Disable** is used to temporarily disable a device, if, for example, you never use the device and want to speed up startup times, or if you want to do advanced troubleshooting.

**Uninstall** removes the device from your system. This comes in handy if you want to re-install a device, for example.

**Scan for Hardware Changes** is used when, for example, you get a message like “The driver for this device might be corrupted, or your system may be running low on memory or other resources.” In such a case, you would uninstall the driver and scan for new hardware to install the driver again. (More on uninstalling drivers later.)

**Properties** is the most frequently used option. Since, in this limited space, we can’t tell you about the properties of every type of device, we’ll use examples.

### 9.3.1 Examples Of Device Properties

Say you select the properties of a hard disk. You’ll see a box with five tabs, as below:

Let’s look at the ‘Policies’ tab. Here, you have an option to “enable write caching” on the disk. If it is not already selected, enabling this can improve the disk’s performance by making the transferring of data between the drive and the memory more efficient. The only reasons not to enable this setting would be if the drive in question is in a hot-swappable drive rack, or if you expect
Now say you select the properties of your mouse. Depending on what model you’re using, you might see an ‘Advanced Settings’ tab, which could include three or more values, amongst them sample rate, wheel detection, input buffer length, and fast initialisation. Here’s a description of each.

**Sample Rate:** This setting changes how often XP determines the position of your mouse. Increasing the sample rate makes your mouse more sensitive to an input; this can improve responsiveness, although it may make finer movements seem awkward. Decreasing the value will have the opposite effect.

**Wheel Detection:** This setting can be used to change how XP deals with a mouse wheel. The ‘detection disabled’ setting will disable the auto-detection of a mouse wheel; you should select this option if your mouse doesn’t have a wheel or if you want the wheel disabled for some reason. ‘Look for wheel’ allows XP to detect if your mouse has a mouse wheel at all. If detected, the wheel will be enabled, if not, it will be disabled. (Not all mice support this feature, however; If your mouse features a wheel and it is not detected when you select this option, then set it to ‘Assume wheel is present’—which will automatically enable the mouse wheel.)

**Input Buffer Length:** This sets the amount of “packets” for the input buffer, which store data regarding mouse location. If you find your mouse behaving strangely, you should try increasing the
value. Otherwise you should ignore this setting, leaving it at the minimum value of 100.

**Fast Initialisation:** Checking this setting will enable fast initialisation, which will reduce the startup time for XP. If you encounter problems with your mouse when this is checked, try leaving it unchecked.

For your network controller, you have two “optimise for” options: throughput and CPU. This setting really makes no difference, and optimising for throughput could have an effect only if you’re on a LAN. Some people, though, encounter problems if the network controller is optimised for throughput.

As a final example, consider the COM ports, which allow communication devices such as modems, printers and mice to interact with the motherboard. You can set the bits per second, data bits, parity, stop bits, flow control, whether to use FIFO buffers, and how large the receive and transmit buffers should be. The defaults are usually sufficient, but you might need to change them in certain instances. For example, you might just find that the “bits per second” for your 56K modem is set to lower than 115000: set it to this value for the best speed. Also, you might find that “flow control” is set to ‘None’; set it to ‘Hardware’ for best results from your modem.

The above is intended to make you aware of the level of control possible through the Device Manager. It’s not a tweaking tool—if everything’s going fine, don’t mess with it! However, the Device Manager is the first place you should be looking if a device has problems.
9.4 Using The Task Manager

Task Manager provides information about programs and processes running on your computer. It also displays the most commonly used performance measures for processes. In earlier versions of Windows, pressing [Ctrl] + [Alt] + [Del] was the last resort if something went wrong. Windows XP doesn’t crash nearly as often, and pressing [Ctrl] + [Alt] + [Del] brings up the Task Manager. With the Task Manager, you can kill (terminate) offending processes, amongst other things.

You can use Task Manager to monitor key indicators of your computer’s performance. You can see the status of the programs that are running and end programs that have stopped responding.

You can also assess the activity of running processes using as many as fifteen parameters, and see graphs and data on CPU and memory usage. In addition, if you are connected to a network, you can view network status and see how your network is functioning. If you have more than one user connected to your computer, you can see who is connected, what they are working on, and you can send them a message.

The most common use for the Task Manager is to kill processes. The need for this arises in several situations: if a program is not responding, you might need to open the Task
Manager and end it. Or, if you just turned a program off and it still seems to be running in the background, you’ll need to use the Task Manager to terminate it. Also, if there are processes running in the background that you need to terminate because, say, you need more RAM, it’s the Task Manager you’ll be using.

In the Applications tab, you can view applications, that is, programs or windows you opened yourself. Some such applications may not show up in the Applications tab, and to view these, you’ll need to look at the Processes tab.

The Processes tab lists all the processes running on your computer. (Think of a process as a program in execution.) So why would you want to kill a process? There are two main reasons for doing so.

1. If a process is taking up too much memory (which is indicated under the memory column).

2. If a program is not responding, or is causing your computer to hang.
Another reason for using the Task Manager is to change the priority of processes. A process with a higher priority, as the name suggests, gets more CPU time. An instance where you might want to decrease the priority of a process is when you’re running a program such as Dr. DivX, which is doing some heavy CPU-intensive computation in the background—and you want to do something else at the same time, say use Microsoft Word. You’d then decrease the priority of Dr. DivX so that Word doesn’t respond too slowly. An instance where you might want to increase the priority of a process is when you’re running something like Winamp. You don’t want songs to skip while you access something else on the hard disk, so you increase the priority of Winamp.

Changing the priority of a process can make it run faster or slower, depending on whether you raise or lower the priority. Remember that increasing the priority of a process increases the chance of system instability.

The Performance and Networking tabs are for advanced system administration, which in all probability you will not use.

Under the Performance tab are listed the current CPU usage in percentage, a graph showing the CPU usage over time, the page file usage, and the page file usage history. Beneath the graphical view are several details including, for example, how many threads are running, and what percentage of the physical memory is occupied by the system cache.

The Networking tab has the most options. At the default settings, the tab shows you a graph of how much available bandwidth is being used by your network adapter. (This graph shows you the percentage of the total available bandwidth; so if you have a 100 Mbps adapter and your Internet connection is 256 Kbps, you’ll see the percentage of the former that is being used, not of the latter.) Beneath the graph are several columns that you can customise. Most of these have to do with bytes and unicasts—how many have been sent and received, and so on.
9.5 Scandisk And Chkdsk

Maintenance of your hard disk involves periodically checking it for errors. Errors include file system errors and bad sectors. A file system error leads to strange system behaviour. It can be caused by, for example, a power outage when a file is being written. A bad sector occurs when a "sector" (the basic unit of data storage on a hard disk) becomes unfit for writing to or reading from, and is marked as such.

9.5.1 Scandisk

Windows 98 shipped with a program called Scandisk; this is hidden in Windows XP. You get to it by opening Windows Explorer, right-clicking on a drive, clicking Properties, and selecting the Tools tab.

Once here, under ‘Error Checking’, clicking ‘Check Now’ brings up a little window with four options—‘Automatically fix file system errors’, ‘Scan and attempt recovery of bad sectors’, and, of course, ‘Start’ and ‘Cancel’.

File system errors are more common than bad sectors, and you will usually want Windows to automatically fix them—so you’ll usually want to check the first box. You’ll want to check the second box only if you want to do a thorough, physical scan of the hard disk, which is not often, but nevertheless important once in
a while. Disk defragmentation, for example, does not proceed if your disk has errors.

9.5.2 Chkdsk
Chkdsk is the more comprehensive, command-line version of Scandisk. It creates and displays a status report for a disk based on the file system. Chkdsk also lists and corrects errors on the disk. You run Chkdsk by opening a command prompt and typing in “chkdsk” with various switches. Used without switches, chkdsk displays the status of the disk in the current drive.

The syntax is as follows:

```
```

**volume:** Specifies the drive letter (followed by a colon), mount point, or volume name.

**[Path FileName]:** Specifies the location and name of a file or set of files that you want chkdsk to check for fragmentation. You can use wildcard characters—the asterisk and the question mark—to specify multiple files.

**/f:** Fixes errors on the disk. The disk must be locked. If chkdsk cannot lock the drive, a message appears that asks you if you want to check the drive the next time you restart the computer.

**/v:** Displays the name of each file in every directory as the disk is checked.

**/r:** Locates bad sectors and recovers readable information. The disk must be locked.

**/x:** (Used only with NTFS) Forces the volume to dismount first, if necessary. All open handles to the drive are invalidated. /x also includes the functionality of /f.
/i: (Used only with NTFS) Performs a less vigorous check of index entries, reducing the amount of time needed to run chkdsk.

/c: (Used only with NTFS) Skips the checking of cycles within the folder structure, reducing the amount of time needed to run chkdsk.

/l[size]: (Used only with NTFS) Changes the log file size to the size you type. If you omit the size parameter, /l displays the current size.

/?: Displays help at the command prompt.

9.5.3 Running Chkdsk

- To run chkdsk on a fixed disk, you must be an Administrator.
- If you want chkdsk to correct disk errors, you cannot have open files on the drive. If files are open, the following error message appears:

  “Chkdsk cannot run because the volume is in use by another process. Would you like to schedule this volume to be checked the next time the system restarts? (Y/N)”

  If you choose to check the drive the next time you restart the computer, chkdsk checks the drive and corrects errors automatically after you restart the computer. In addition, if the drive partition is a boot partition, chkdsk automatically restarts the computer after it checks the drive.

- Chkdsk examines disk space and disk use for the FAT and NTFS file systems. It provides information specific to each file system in a status report. This status report shows errors found in the file system.

- If you run chkdsk without the “/f” switch on an active partition, it might report spurious errors because it cannot lock the drive.
Chkdsk corrects disk errors only if you specify the “/f” command line option—it must be able to lock the drive to correct errors. Because repairs usually change a disk’s file allocation table and sometimes cause a loss of data, chkdsk sends a confirmation message similar to the following:

“10 lost allocation units found in 3 chains.
Convert lost chains to files?”

If you press ‘Y’, Windows saves each lost chain in the root directory as a file with a name in the format File.chk. When chkdsk finishes, you can check these files to see if they contain any data you need. If you press ‘N’, Windows fixes the disk, but it does not save the contents of the lost allocation units.

If you use “chkdsk /f” on a large disk (for example, 120 GB) or a disk with a very large number of files (for example, millions of files), chkdsk might take a long time (for example, over several days) to complete. The computer will not be available during this time because chkdsk does not relinquish control until it is finished.

Use the “/r” command line option to find physical disk errors in the file system.

The exit codes for Chkdsk are as follows.

0: No errors were found.
1: Errors were found and fixed.
2: Disk cleanup, such as garbage collection, was performed, or cleanup was not performed because “/f” was not specified.
3: Could not check the disk, errors could not be fixed, or errors were not fixed because “/f” was not specified.
System Restore is a useful feature in XP, which wasn’t available in earlier Windows versions. This essentially allows you to “roll back” your computer to an earlier, more stable point.

There are a variety of situations in which you might want to use System Restore. You might have made changes to the Registry, which are now causing some programs to not work properly. Or you might have installed a new program that interferes with another program’s functionality. You might have made certain system-wide changes via the Control Panel, and you can’t figure out how to get your old settings back. In all these situations, all you need to do is roll back your system to an earlier Restore Point.

What are Restore Points? Windows XP continually monitors what’s going on in the system, and whenever a major change is happening, Windows “records” the state of the system and stores that state as a “Restore Point” that you can get back to. Such Restore Points are continually being created, but you can create one whenever you like—for example, if you’re about to install a major program.

So why have more than one Restore Point? Imagine when you installed one program A, then installed another program B. Your computer is now malfunctioning. Do you restore it to before you installed B or to before you installed A? Basically, you might not know what has caused your system to malfunction—hence the availability of multiple Restore Points.
Creating a Restore Point is as simple as it gets: go to Start > All Programs > Accessories > System Tools > System Restore, and select ‘Create a Restore Point’. Give it a name, and click ‘OK’.

From the above, it follows that you’d want to use “Restore” your system if there’s something wrong with your computer. There are two scenarios: the first being that Windows doesn’t even start up, in which case you’ll have to run System Restore in Safe Mode. The second scenario is when Windows starts up, but with errors.

9.6.1 If Windows Doesn’t Start
1. Restart your computer, and press [F8] during startup to start your computer in Safe Mode with a command prompt.
2. Log on as an Administrator.
3. Type the following command at a command prompt (without the quotes), and then press [Enter]:
   “%systemroot%\system32\restore\rstrui.exe”
4. Follow the instructions that appear on the screen to restore your computer to an earlier state.

9.6.2 If Windows Does Start Up
1. Log on to Windows as Administrator.
2. Click Start > All Programs > Accessories > System Tools, and click System Restore. System Restore starts.
3. On the “Welcome to System Restore” page, click ‘Restore my computer to an earlier time’ (if it is not already selected), and then click ‘Next’.
4. On the “Select a Restore Point” page, click the most recent system checkpoint in the ‘On this list, click a restore point’ list, and click ‘Next’. There is a calendar next to the ‘On this list, click a restore point’ list; if there are no restore points for the current date, select an earlier date. A System Restore message may appear that lists configuration changes that System Restore will make. Click ‘OK’.
5. On the “Confirm Restore Point Selection” page, click ‘Next’. System Restore restores the previous Windows XP configuration, and restarts the computer.
6. Log on to the computer as an Administrator. The “System Restore Restoration Complete” page appears. Click ‘OK’.

9.6.3 System Restore Settings

Windows XP allows you to choose whether you want System Restore enabled, and on which drive(s). The reason you might not want System Restore on all drives (which is the default) is because it takes up disk space and system resources. So, for example, if you only have data on a drive, and you don’t expect that data to change, you might want to turn off System Restore on that drive.

To change System Restore settings, go to the Control Panel and select System, where you’ll find a tab called System Restore. Here, you can choose to turn off System Restore on all drives via a single checkbox. If that’s not what you want to do, you can select a drive from the list and click ‘Settings’. You’ll be presented with something like on the right. You can choose to turn off System Restore on the drive you selected, or you can decrease the amount of disk space allocated to System Restore on that drive. As the dialog box tells you, reducing the space means you’ll have fewer Restore Points to choose from when you’re “restoring” your system.
9.7 The Disk Cleanup Utility

When you right-click on a drive in Windows Explorer and select Properties, the first tab that greets you has a pie-chart that shows how much of the disk is full. Just next to the pie-chart is a button that says “Disk Cleanup.” This is a handy little tool that helps you reclaim space on the drive you selected.

Clicking ‘Disk Cleanup’ presents you with two tabs, with a total of six options. Here’s a brief description.

1. Checking the box next to ‘Recycle Bin’ and pressing ‘OK’ will, of course, empty the Recycle Bin. Clicking ‘View Files’ simply displays the contents of the Recycle Bin.

2. Choosing to ‘Compress old files’ will compress files that haven’t been accessed in a while. You will, naturally, gain disk space as a result. Note that compressed files aren’t encrypted or disabled in any way—you can still access them.

Clicking ‘Options’ with ‘Compress old files’ selected leads you to a dialog box that asks you when to compress old files, or, in
other words, to specify how long it will take for a file to be considered old. If you specify, for example, “60” in this box, files will be compressed if they haven’t been accessed in two months.

3. ‘Catalog files for the Content Indexer’ refers to files that were used—but are no longer being used—by the Indexing Service. (Refer to §9.2.4 for more on the Indexing Service.) These files, as the dialog box tells you, can be deleted.

4. Under the ‘More Options’ tab, you have three items, all of which you can “Clean Up.” The first is ‘Windows Components’. Choosing to clean up these means removing components that got installed along with Windows—for example, if you don’t use NetMeeting, you can remove it; if you installed the default games and never play them, you can remove them, and so on. Clicking ‘Clean Up’ will lead to a wizard that helps you remove the components you don’t want. This can free up some disk space.

5. Clicking ‘Clean Up’ under installed programs leads to, of course, the ‘Add or Remove Programs’ window. Here you can remove programs you no longer use, freeing up disk space.

6. Finally, the System Restore section allows you to clean up all but the most recent System Restore point, which is helpful if you’re running low on disk space. Note that you shouldn’t be removing all earlier Restore Points if you’ve been installing and uninstalling programs and such—you never know when a Restore Point could come in handy.
9.8 The Backup Utility

We have, in Digit, often stressed the importance of regular backups. Here we introduce you to the backup tool provided with Windows XP, in a step-by-step fashion.

9.8.1 Creating A Backup

1. Launch the backup utility by going to Start > All Programs > Accessories > System Tools > Backup. The ‘Backup or Restore Wizard’ will open by default. (To escape the Wizard, remove the checkmark from ‘Always Start in Wizard Mode’ and click ‘Advanced Mode’.)

2. Backup or Restore: Select what operation is intended.

3. What to Back Up:
   A number of different preset backup groupings are displayed, as well as the option to make custom backup selections. If ‘Custom’ is selected, the ‘Items to Back Up’ screen will open. Any of the other selections will take you to the Backup Type, Destination, and Name screen (step 5).

4. Items to Back Up:
   If you selected the ‘Let Me Choose What To Back Up’ selection in the ‘What To Back Up’ screen, this gives you the opportunity to
select the files to be included. The view is a slightly modified version of the standard Windows Explorer view, with selection boxes.

5. Backup Type, Destination, and Name:
This is where you enter a name and destination for the backup. The backup is a single file.

6. Completing the ‘Backup or Restore’ Wizard:
Now comes the screen where the actual backup process is imitated. However, this location also contains the ‘Advanced’ button, where important additional backup parameters may be specified. We discuss these at this point.

7. Type of Backup:
Specify the type of backup that will be performed. Choices include ‘Normal’, ‘Differential’, ‘Incremental’, ‘Copy’, and ‘Daily’. To put it briefly, a Normal and Copy backup are almost the same, except that a
Copy backup does not mark the files as having been backed up. Differential and Incremental backups take less time because they only back up files that have been changed since the last backup. And a Daily backup only backs up files that have changed on the day of the backup operation. Refer http://snipurl.com/b256 for more on the different types of backups.


9. Backup Options: Set specifications for overwriting data and who is allowed to access the backups.

10. When to Back Up: Set whether you want the backup to be done immediately or placed on a schedule.
11. Schedule Job—The Schedule Tab
Set the details for the backup schedule or multiple backup jobs that have been created.

12. Advanced Schedule Options:
Set more detailed options for a specifically scheduled backup.

13. Schedule Job—Settings Tab
This contains specific conditions that determine whether a scheduled backup will commence, that is, do not run if on battery power or if certain time frames have elapsed.

14. Completing the Backup or Restore Wizard
This is the final screen where the actual backup process is initiated when the ‘Advanced’ button was selected from this same screen previously. The ‘Advanced’ button is no longer available. At this point, you might be asked for your Windows XP password. Supply it, and the backup process will begin.

9.8.2 Restoring A Backup
Here’s the good news: regardless of all the fuss about what type of backup to choose and so forth, restoring a backup is very easy. All you need to do is to open the same wizard (the “Backup or Restore” wizard, accessible from Start > All Programs > Accessories > System Tools > Backup), and choose to restore a backup. You’ll be presented with a screen like the following:

On the right, you’ll see a description of the backup files that have been created thus far. And on the left, you simply select what items you want to restore, and click ‘OK’. You’re done!
9.9 Service Packs

About once a year, Microsoft releases an update to Windows XP. These updates contain all the fixes and enhancements which have been made available in the previous year. The updates (called Service Packs) provide convenient, all-in-one access to the most up-to-date drivers, tools, security updates, patches, and customer-requested product changes.

The latest Service Pack for Windows XP—Service Pack 2—is all about security, and it’s one of the most important service packs ever released. It provides better protection against viruses, hackers, and worms, and includes Windows Firewall, Pop-up Blocker for Internet Explorer, and the new Windows Security Center.

The official page for Windows XP SP2 (Service Pack 2) is www.microsoft.com/windowsxp/sp2/default.mspx
To download SP2 from Microsoft Update, point your browser to http://go.microsoft.com/?linkid=3646727

9.9.1 Why SP2?
Here are Microsoft’s top 10 reasons to install SP2.

1. Help protect your PC from harmful attachments.
   By alerting you to potentially unsafe attachments, SP2 helps guard your computer from viruses that can spread through Internet Explorer, Outlook Express, and Windows Messenger.

2. Improve your privacy when you’re on the Web.
   SP2 helps protect your private information by applying the security settings that guard your PC to the files and content downloaded using Internet Explorer.

3. Avoid potentially unsafe downloads.
   Internet Explorer download monitoring and the Internet Explorer Information Bar warn you about potentially harmful downloads and give you the option to block files that could be malicious.
4. Reduce annoying pop-ups.
Internet Explorer Pop-Up Blocker makes browsing the Internet more enjoyable by helping you reduce the unwanted ads and content that pop up when you’re browsing the Web.

5. Get firewall protection from startup to shutdown.
The inbuilt Windows Firewall is, in SP2, turned on by default. This helps protect XP against viruses and worms.

6. Take control of your security settings.
The new Windows Security Center allows you to easily view your security status and manage key security settings in one convenient place.

7. Get the latest updates easily.
Enhancements to XP’s Automatic Updates feature make it even easier to access Windows updates. Plus, new technology has been added to help dial-up customers download updates more efficiently.

8. Help protect your e-mail address.
Improvements to Outlook Express help reduce unwanted e-mail by limiting the possibility of your e-mail address being validated by potential spammers.

9. Take action against crashes caused by browser add-ons.
The new Add-On Manager in Internet Explorer lets you easily view and control add-ons to reduce the potential for crashes and enjoy a more trouble-free browsing experience.

SP2 improves wireless support and simplifies the process of discovering and connecting to wireless networks.

9.9.2 Service Packs 1 and 1a
You don’t need to bother about these, since installing SP2 installs whatever came with SP1 and SP1a. Note, however, that SP1 came with the JVM (Java Virtual Machine), whereas SP1a did not. In keep-
ing with this, SP2 does not install the JVM, and you’ll be left with no JVM if you’re upgrading from plain Windows XP to SP2. If you use Java applications, such as Java games on the Internet, you’ll need to download the JVM by visiting http://java.sun.com.

9.10 Monitoring Temperature

Even if you don’t do too much gaming, your computer could get too hot. The hard disk, motherboard, and processor—not to mention the graphics card—can all get hot and therefore unstable. If a hard disk gets too hot too often, its life is reduced. Fortunately, there are utilities available that can monitor temperatures and automatically perform actions (which you can specify) upon overheating. Here, we mention two such utilities—one for your hard disk and another for your motherboard and CPU.

9.10.1 HDD Thermometer

HDD Thermometer is a hard disk temperature monitoring tool. You can download this freeware utility from www.freedownloadcenter.com/Utilities/Disk_Maintenance_and_Repair_Utilities/HDD_Thermometer.html. It has all the features needed to prevent overheating. It uses S.M.A.R.T. technology to get access to the hard disk temperature, so your hard disk will need to support S.M.A.R.T.—but fortunately, most modern hard disks do.

HDD Thermometer can perform any of the following actions when the Warning or Critical temperatures are exceeded:
1. Show a notification
2. Play a sound
3. Execute an application
4. Shutdown or Hibernate

It shows hard disk temperature indicators in the System Tray, logs temperature changes, and there is the ability to set individual settings for each hard disk.
9.10.2 Motherboard Monitor v5.3.7

For a complete description of Motherboard Monitor, and also to download it, visit www.softpedia.com/get/System/System-Info/Motherboard-Monitor.shtml

This program reads temperature and fan rpm data collected by the BIOS, displays it in the Windows system tray, and alerts you when there’s trouble. You can use this application to manage your resources and alarms by doing things like setting an alarm to go off, or having an e-mail sent to another computer, when your motherboard starts to overheat. You could even have programs start and stop when your CPU reaches predetermined temperatures.
9.11 Miscellaneous Tips

Here are some additional things you can do to keep your computer running smoothly.

- Clean out your browser cache from time to time. This is a good thing to do if you notice your browser running slowly, as the allotted space for the cache may be full, and it takes time to clear out old images that haven’t been accessed in a long time to make room for the new images to be cached.

  Also, if you need to load a page with lots of images, such as a page of family picture, but you realise your browser stalls out before all the pictures have loaded, it’s time to do some cleaning. In Internet Explorer, point to Tools > Internet Options, and under Temporary Internet Files, click ‘Delete Files’. You can also use the ‘Settings’ button to, amongst other things, tweak how much of disk space to use for the cache.

- Run a thorough virus scan at least once a month. You’ll naturally be doing this if your computer seems a bit wonky, but it’s a good idea to do it on a regular basis.

  Most anti-virus programs have three scan modes—quick, standard, and thorough. You should choose the ‘thorough’ mode for scanning at least once a month or once in two months.

- If a program has installed a toolbar on your browser, don’t take it lying down! It may not be this easy, but one thing you can do is go to ‘Add or Remove Programs’ (in the Control Panel) and find a strange program, which will probably have the word “Toolbar” in the name. Remove it and restart your browser.

- Every now and then—say once in six months or so—use Device Manager to check for driver upgrades to your hardware. Simply double-click the device, go to the Driver tab, and select ‘Update Driver’, as explained in section 9.3. Also, for firmware upgrades, you’ll need to go to the manufacturer’s Web site and provide the model number of your device.
In this chapter, we tell you about the basic security measures you need to, or might want to, take with a Windows XP installation—from passwords to file encryption to Firewalls to automatic updates. Remember to apply everything you find here for a hassle-free computing experience!
Security is about restricting access, whether to a physical object, a location, information, an application, or a particular feature of an application. Talking about computers and networks, there is no fool-proof way of protecting a system till you disconnect your network card, switch off your system and make sure that no one has access to it. But, of course, this is not possible if you need to use the system!

A combination of protections is necessary to secure a system. At a minimum, we recommend the following protective measures be taken by all users who connect to the Internet.

1. Verifying identities using passwords
2. Determining what information a user has permission to see or what software a user has permission to use (that is, determining their access permissions)
3. Using anti-virus and anti-spyware software and Firewalls
4. Encrypting data

10.1 Restricting System Access

10.1.1 User Accounts
Securing Windows XP starts with limiting who can access your system. To set new usernames and passwords, you need to be logged in as an administrator, which is the default login after you’ve installed the OS.

Click Start > Control Panel > User Accounts. Select ‘Create a new account’. In the next screen, type in the new username you want to create and click ‘Next’. The resulting screen allows you to ‘Pick an account type’, which is either ‘Computer Administrator’ or ‘Limited’. Setting the new user to be a Computer Administrator allows him to make system-wide changes, which means giving complete control of the system to him. Setting the new user to ‘Limited’ restricts him to changing his password, viewing files he has created, and viewing files in the ‘Shared Documents’ folder.
After deciding upon the above, click ‘Create Account’. You’ll now be able to see the new account in User Accounts. To set a password for this user account, click on the new user account. In the following screen, click ‘Create a password’. Type in the password and re-type it to confirm it, and click ‘Create Password’. You’ll now see that the new account is password-protected.

To delete a user account, go to Start > Control Panel > User Accounts. Select the user whose account you want to delete. In the screen that comes up, clicking ‘Delete the account’ takes you to another screen that asks you if you want to delete all the files created by the user, or just delete the account while retaining the files.

One thing to remember before creating and deleting accounts is that your account (the Administrator account) should be password-protected; otherwise, the purpose is lost!

If your account is not password-protected, then in the User Accounts window, select your account and in the resulting window select ‘Create a password’. The next screen prompts you to type in a password. Do so and click ‘Create Password’.

There are two things to remember here: one is not to set easy passwords, such as your date of birth or your pet’s name. Second, you should keep the Guest account disabled if you don’t want a random person to access the system at all.

10.1.2 Preventing Users From Logging On
In XP, you can prevent, say, a family member from using the system at certain times. Say you want someone with username “digit” to be able to log in only between 5 AM and 8 PM, on Monday to Friday. At the command prompt, type in the following:

    net user digit /time:m-f,5am-8pm

You can change the days using m, t, w, th, f, s, su, and change the times as in the example above.
10.1.3 Restricting Access Over A Network

Whether we’re talking about a home or an office network, you might have information on your network that you don’t want to share, like files containing personal data or financial spreadsheets. Windows XP Professional gives you the ability to grant access to selected users while keeping others from accessing confidential files. Note that XP Home does not provide this feature.

The access control feature in XP Professional allows you to set a file or folder’s access permissions for a specific user, computer, or group of users. You can set permissions, and define the type, level of access granted to a user or group for a particular file or folder. For example, you can grant Read and Write permissions to the entire user group for a file called spreadsheet.xls. You can let one user read the contents of a file, let another user make changes to the file, and prevent all other users from accessing the file.

First, to change permissions on a file or folder, you must be the owner of that file (if you created the file or folder, then you are the owner of it) or folder, or you must have the permission (permission should be granted by the owner of that file) to make such changes. You can also set similar permissions on printers so that selected users can configure the printer and other users can only print using it.

To set, view, change or remove file and folder permissions, open Windows Explorer. Locate the file or folder you want to set permissions for. Now, right-click on the file or folder and click ‘Properties’. Click the ‘Security’ tab (if you don’t see the Security tab, then you are not part of a domain).

Next, choose the group or user name. If you need to add a group or user, click ‘Add’. Type in the name of the group or user...
for which you want to set permissions, and click ‘OK’. (When you add a new user or group, this user or group will have Read & Execute, List Folder Contents and Read permissions by default). To delete a group or user select the user and click ‘Remove’.

If the group or user is already listed, click the name of the group or user. You can now adjust their permissions. Select the permissions you want to set for the file or folder and click ‘OK’. To allow or deny a type of permission, select the ‘Allow’ or ‘Deny’ checkbox in the ‘Permission for User or Group’ dialog box.

### 10.2 Encrypting Files And Folders

One of the inbuilt features of XP is the encryption system, but one thing you should remember here is that it works only on NTFS. One of the most important advantages you gain when choosing the NTFS file system over older file systems such as FAT is that you have much greater control over who can perform what sorts of operations on various data within the filesystem. NTFS offers a secure environment and flexible control over what can be accessed by which users, to allow for many different users and groups of users to be networked together, with each able to access only the appropriate data.

Even after encrypting a file or folder, XP will not prompt you for a password to open the encrypted file, nor will it prompt you for a password while encrypting the file. The file is thus transparent to the user who encrypted it. However, if a different user tries to view or copy the encrypted file or folder, he’ll see an ‘Access Denied’ message.

You also have the option to encrypt a folder including its subfolders. If the owner of the encrypted file moves it to a FAT partition, the encryption will be lost. If you move an un-encrypted file into an encrypted folder, then the file that was moved also gets
encrypted. Encryption does not, however, stop deletion of the file or folder if the other user has the permission to do so.

So how do you encrypt a file? If you don’t want to convert any FAT32 partitions to NTFS, there are many third party software available. Some of the free software available are DeltaCrypt OneClick, which works on all Windows platforms and uses powerful 1024-bit RSA protection, digital signatures and unalterable public keys. Cryptainer LE encryption software uses the 128-bit Blowfish algorithm and a 256-bit implementation of AES. Cryptainer LE encrypts all the files that are dragged into the application window, which is also called a vault. P-Encryption Lite is also worth mentioning here, as it uses AES encryption.

If you have FAT32 partitions and want to use XP’s encryption feature, XP allows you change the filesystem without your losing any data. To convert a FAT32 disk or partition to NTFS, at the command prompt, type in

```
convert drive_letter: /fs:ntfs
```

Now that your filesystem is NTFS (if it wasn’t already), let’s get to the encryption. Open Windows Explorer. Select the file or folder you want to encrypt, right-click on it and go to ‘Properties’. Now click ‘Advanced’.

This will take you to another screen called ‘Advanced Attributes’. Select the last checkbox and click ‘OK’. If this is a parent folder, XP will ask if you also want to encrypt the sub-folders. Finally, click ‘Apply’. The file or folder is now encrypted.
10.3 Using XP’s Firewall

A firewall is a hardware or software solution to enforce security policies. To use a physical analogy, a firewall permits only authorised users—such as those with a key or access card—to enter. A firewall has inbuilt filters that can disallow potentially dangerous material from entering the system. It also logs attempted intrusions.

An important thing to note about a firewall is that it implements an access control policy. The firewall’s configuration imposes its policy on everything behind it.

In cases where a company’s policies dictate how data must be protected, a firewall turns out to be very important. Some firewalls permit only e-mail traffic through them, thereby protecting the network against any attacks other than attacks against the e-mail service. Other firewalls provide less strict protections, and block services that are known to be problems.

Generally, firewalls are configured to protect against unauthenticated logins from the outside world. More advanced firewalls block traffic from the outside to the inside, but permit users on the inside to communicate freely with the outside.

Windows XP includes an inbuilt Firewall. It protects a single computer connected to the Internet. In SP2, the Firewall is enabled by default. If you don’t have SP2 and want to enable the firewall, go to Control Panel > Windows Firewall (if you don’t find this in the Control Panel, switch to Classic View) and enable it from there.
The “Don’t allow exceptions” option allows no internal software to accept outside connections.

The next tab is “Exceptions”. It allows certain programs to accept connections from the Internet which would otherwise be blocked. You can choose ‘Add Program’ to add any application from a list of all that are installed on your PC to accept connections. For example, if you want to accept connections for Remote Assistance or Remote Desktop which is disabled by default, you can do so by clicking the ‘Exceptions’ tab and checking the box. You can follow the same procedure and have a greater control over programs such as P2P clients and IM software.

The ‘Advanced’ tab contains several options. The most important is the Services settings. You can access these by highlighting your Internet connection in the ‘Network Connection Settings’ window and clicking ‘Settings’.

The Services allow information to pass through certain ports, similar to the Exceptions. Ports are communication channels for software and are represented numerically. Different network communication protocols work on different ports. So if two computers, one the client and another the server, are connected, and the client wants to access a service on the server, the client connects to a standard port for that particular service on the server. For example, MSN messenger connects to Internet using port 1863, and Yahoo! Messenger uses port 5050. If you want other programs to accept connections from the Internet and the program is not in the list, but you know the port number, then you can type in the port number and “open” it. An example would be that of a P2P client; visiting the product’s forum page would inform you that a certain port needs to be unblocked for the software to function.

Other than protecting your system, Firewalls also help conserve bandwidth by preventing unwanted Internet access by certain programs.
There are many third-party software that protect your system better than does the Firewall that comes bundled with XP: third-party firewalls have good and easy-to-understand interfaces that allow you to configure your Firewall as though you were a pro. Some Firewalls come bundled with other utilities such as stoppers, anti-virus, and anti-spyware.

Let’s take Zone Alarm Pro (www.zonelabs.com) as an example: the software, after installation, takes you through a series of presentations telling how to configure the Firewall. It also allows you to configure it before it starts for the first time. When you are connected to the Internet and an application is trying to access the Net, Zone Alarm asks you if you want to allow the program to allow access. The Firewall also protects your system over a home network.

Other good Firewalls are Symantec Security Suite and Trend Micro PC-Cillin.

10.4 Updates And Patches

Updates are small changes to a program. They may be an update to any part of the system software, and the update is always regarded as better than the previous version. An update can either change the functionality of the original software in certain respects, or it may include additional features that were previously not present. An update may be denoted as a change in the last digit of a version number (such as version 3.0 to 3.1).

A patch is an update meant to fix problems. This can range from fixing bugs to replacing graphics to improving the usability or performance of a previous version. Though meant to fix problems, patches can sometimes introduce new problems too! The size of a patch file varies in size; some might be a few KB, and others might run into hundreds of MBs. Often, a collection of patches are bundled together and are called service packs.
Windows XP’s service packs usually contain a lot of security patches that plug security holes, updated drivers, and enhancements to the operating system. There are two ways to update your system. One is going to the Windows Update Web site: http://update.microsoft.com/windowsupdate/v6/default.aspx?ln=en-us

Here, you will be asked if you want to allow the site to scan your system to check what updates your system needs. If you allow it to, it presents you with a list of updates that are required. You can choose what updates you think you want, and download only those.

Second, you can configure your OS to automatically check for updates. In XP, updates are automated by default, and do not require manual intervention. But if you don’t want Windows to update itself, or if you want to schedule the update for a different time or change the notification settings you can do so. To access Windows Update, go to Start > Control Panel > Automatic Updates (if you don’t see ‘Automatic Updates’ in the Control Panel, switch to Classic View; if you find it here, go to Control Panel > System > Automatic Updates). Here, you’ll see ‘Notification Settings’.

You can select if you want to download the updates automatically and notify you when they’re ready to install, or notify you before downloading them, or turn off updating completely. You may want to turn off updates or notify you before downloading to save bandwidth. One thing you should note is that this will update only the Windows XP operating system and not Microsoft programs such as Office.

Once the system has downloaded the updates, it will show up as a small icon in the System Tray informing you that the updates
are ready to be installed on your system. Double-clicking the icon takes you to a page that prompts you to ‘Express Install’ or ‘Custom Install’ the update. If you select ‘Express Install’, then the program installs all the updates it has downloaded, and it doesn’t reboot your system. If you choose ‘Custom Install’, you have control over what updates to install. Note that your system would require one or several reboots depending on the updates you selected.

Windows XP Service Pack 1 was released on September 2002; it was a 133 MB download, and contained approximately 19 Critical Updates and around 15 Windows updates. There’s a little story about SP1 and the JVM: older copies of XP installed the JVM with Windows. If you updated to SP1, the JVM remained intact. And if you updated to SP1a, the JVM was removed; or, if your copy of XP was manufactured and shipped after SP1a was released, then the JVM was never present on your machine.

Service Pack 2, which was released in August 2004, had significant, crucial security updates as well as updates such as DirectX9 and Windows Media Player 9. Obviously, it doesn’t install the JVM on your machine. Refer §9.9.1 for 10 reasons to upgrade to SP2.

10.5 Viruses, Spyware, Adware, And Pop-ups

If you’ve been reading Digit, you’ll know how important it is to protect a system from viruses. In Chapter 3 of this book, we’ve mentioned that you should install anti-virus software even before you connect to the Internet for the first time. Windows XP doesn’t have an inbuilt anti-virus, and there are many third-party anti-virus software available. Some anti-virus software are free. Refer section §3.5 for more on these.

Spyware is malicious software designed to intercept or take partial control of a computer’s operation without the consent of the machine’s owner. The term is used to suggest software that secretly monitors the user, but it has now come to refer more
broadly software that alters the computer’s behaviour for the benefit of the person who planted the software.

Spyware differs from viruses and worms in that it does not usually self-replicate. But like many viruses, spyware can exploit infected computers for commercial gain. Typical tactics include delivery of unsolicited pop-up ads, theft of personal information, monitoring of Web browsing activity, and routing of HTTP requests to advertising sites.

The term “adware” refers to any software which displays advertisements, whether or not it does so with the user’s consent. Programs such as the Eudora mail client display advertisements as an alternative to registration fees. These classify as adware in the sense of “advertising-supported software,” but not as spyware.

The most direct and common route by which Spyware gets on a computer is by the user installing it. Many Spyware programs deceive the user, either by piggybacking on a piece of desirable software, or by tricking the user to do something that installs the software without his realising it. A “Trojan horse”, by definition, smuggles in something dangerous in the guise of something desirable. Some spyware programs spread in this manner. Spyware can also come bundled with shareware or other downloadable software, as well as music CDs. The user downloads a program—for instance, a music program—and installs it; the installer additionally installs the spyware. In some cases, spyware authors pay shareware authors to bundle spyware with their software.

Some of the more popular programs distributed with Spyware are BearShare, Download Accelerator Plus, ErrorGuard, FlashGet, and Kazaa Messenger Plus! (though this one lets the user choose during the installation whether to allow the adware to install or not).

Some of the popular anti-spyware software are Spybot Search & Destroy, and Lavasoft’s Ad-Aware. These third-party software are easy to install, and like anti-virus software, need to be updated.
often. The interfaces look like those of anti-virus software, and clicking the scan button will scan for any spyware on your system. After scanning, the software shows up the spyware and also tells you about the severity or the risk factor of each piece of spyware, and the action to be taken or the action that was taken. If no action has been taken, it is advisable to first quarantine the spyware, and see if there is a problem with the software it is associated with.

Here, “associated software” refers to the software that the spyware got installed with, for example, Download Accelerator Plus. You can figure what the associated software is by looking at the path of the spyware that shows up. If no problems are found with the associated software, it is recommended to delete the spyware.

Pop-up ads are a form of online advertising on the WWW intended to increase Web traffic or capture e-mail addresses. It works when certain Web sites open a new browser window to display ads. The pop-up window containing an ad is usually generated by JavaScript, but can be generated by other means as well. Another version of this is pop-under: this opens a new browser window behind the active window. Pop-unders are considered to interrupt the user less, but are not seen until the desired windows are closed, making it more difficult for the user to determine what Web site opened them.

Opera was the first major browser to incorporate a pop-up blocker. XP SP2 added pop-up blocking to Internet Explorer. Some users install non-Microsoft ad-blocking software instead. Some of the add-on programs that block pop-up ads are Google Toolbar, Yahoo! Toolbar, and MSN Toolbar. Nowadays, some Firewalls, too, bundle pop-up blockers, as in the Zone Alarm Security Suite.
About a decade ago, when Windows 95 first arrived on the scene, creating a home network was a fearsome task reserved for the knowledgeable or the courageous. That’s no longer the case! Windows XP makes setting up a network as easy as adding 2 and 2. The toughest part is physically installing the hardware; the software side is a minor operation.
11.1 Why Network?

Do you have more than one computer at home? If you do, how often have you moved from one system to another just to copy files or print documents? While copying files from one system to another, how many times have you cursed corrupt floppies or CDs? You probably have also found yourself waiting for the system that has the Internet connection to be vacated by the family member using it, just so you can check mail. It’s time you set up a home network, and because you’re running Windows XP, it’s going to be easier than ever to do so!

11.2 Required Hardware

Before you get your hands dirty (since you haven’t cleaned your system in a long time) you need to make sure you have all the necessary things needed to network your systems. There are two options available to connect your PCs: wired or wireless networks. A wired network is really cheap to set up, and gives you excellent data transfer rates. However, the positioning of your systems is pretty much fixed, and you’re going to have ugly white or grey wires running wild in your home. For those who want a better-looking setup, or those who have laptops as their personal computers, a wireless network is probably a much better idea. With a wireless network (using Wi-Fi) data is transmitted at the 2.4 GHz frequency.

Before you begin, make sure you have a LAN (Local Area Network) card. There are two types of LAN cards available in the market: the most common type, the internal LAN card, connects to a PCI slot on your motherboard, while the external option connects to a USB port on your system. The internal models are a lot cheaper though, so you would probably want to opt for these. Many newer motherboards come with an onboard LAN port, so there might be no need to buy a LAN card separately.

Once you’ve set up the LAN cards, or found the LAN slots on
your computers, the next step is to get the right cable. When net-
working just two computers, you can connect them directly using
an RJ-45 Crossover cable, which you can buy from any computer
dealer. If you have three or more PCs, you should consider invent-
ing in a switch that will allow you to easily connect all the PCs
using regular RJ-45 cables. A wireless network will need your com-
puters to be Wi-Fi-enabled, which is not a problem if you have Wi-
Fi capable laptops, but if you have desktop PCs, you will need to
buy wireless networking PCI cards. There are two ways in which
you can connect computers wirelessly: in Ad-Hoc mode or by using
an access point to assign fixed IP addresses. More on this later.

11.3 Setting Up The Network

Let’s first talk about IP addresses. What is an IP address? IP
addresses are nothing but names of computers represented in
numeric terms. In a TCP/IP network the names are represented in
32-bit numeric address written in four parts and each part is
divided by dots. Each number in this part can in the range of 0 to
255, for example, 192.192.0.1

In a home network you can assign IP address randomly as long as
each IP address is unique. If two IP addresses on a network are ident-
tical, they will clash and neither will work correctly. For example, if
a system has the IP 192.192.0.1, another system cannot use the same
IP and will have to be set as 192.192.0.2 or 192.192.0.3. The Internet
Assigned Numbers Authority has reserved the following three blocks
for private networks such as your LAN: 10.0.0.0 to 10.255.255.255,
172.16.0.0 to 172.31.255.255 and 192.168.0.0 to 192.168.255.255. So if
you are setting up a LAN that’s also connected to the Internet, you
can safely use these numbers within your network without causing
errors in DNS (Domain Name System) resolving.

When you type a Web page address such as www.thinkdigit.com
into your browser, the browser contacts a Domain Name System
(DNS) server and resolves the IP address of the computer it refers to.
You can find the IP address of your system by typing “ipconfig” at a command prompt.

Now go to Start > Control Panel > Network and Internet connection > Setup your home or small office network. You’ll now see the Network Setup Wizard dialog box.

Follow the instructions on each screen and press ‘Next’ to continue. You will see a screen ‘Other Internet connection methods…’. This lets you to choose the method of connecting to internet. If your computer is connecting to the internet then your system will be called the Internet Connection Sharing host. Click ‘Next’.

If you have assigned a computer name, you should be seeing this in the text box ‘Computer name’. If you want to change the computer name you can do so now. After you have finished, click ‘Next’. Now type in the name for which all the computers are going to be part of. By default, this is MSHOME; if you want to reassign you can do so.
Once done, click ‘Next’. You will now be taken to a window with the caption “You’re almost done...”. Here you have a set of options.

Select one of them if your network features operating systems other than Windows XP. If your other systems on the network have Windows XP, then choose the last option and click ‘Next’, and ‘Finish’ in the next window. The system will now ask for a reboot. The reboot allows the system to make the necessary changes. Run the Network Setup Wizard on all computers. If the other systems do not have Windows XP as the OS, run the Network Setup Wizard from the Windows XP CD-ROM. You can find the Wizard under ‘Perform Additional Tasks’, which you can see on the Welcome Menu. If the other system does not have a CD-ROM, then run the Network Setup Wizard from the floppy disk you created. To run the Network Setup Wizard, double-click on the executable file netsetup.exe. XP has now created a LAN using the workgroup name MSHOME.

If you were wondering what happened to those nasty IP addresses, it’s time you stopped worrying about it. Your Network Setup Wizard of Windows XP took care of it.

Now to view all the computers on your network, go to Start > My Network Places. If you don’t see other computers here, select View Workgroup Computers. You should now be able to see all the computers on the network.

My Network Places allows you to see all the computers on the workgroup which share the same workgroup name-such as the default MSHOME in Windows XP. You should be able to see all the shared folders and printers at this point. If you don’t see the shared folders and printers and the network is up, then this is just because that the folders and printers are not shared.
11.4 Sharing A Printer

Let’s now see how to share a printer over a network. The first step is to make the printer shareable on the system to which it is connected. To do this, click Start > Control Panel > Printers And Other Hardware > Printers And Faxes > View installed printers or fax printers. Now you should be seeing the printer that’s connected to your computer. Select the printer you want to share and right-click and select ‘Sharing…’. Now select ‘Share this printer’, and in the text box ‘Share name:’, give a name that you want others to see your printer’s name as and click OK.

Others computers on the network can access this printer by going to Start > Control Panel > Printers And Other Hardware > Add a printer. Now you should see the Add Printer Wizard. Click ‘Next’ to go the next screen, and here, select “A network printer, or a printer attached to another computer” and click Next. You will see a screen with the name “Specify a Printer”. Here you will have three options to choose from: Browse for a printer; Connect to this printer; Connect to a printer on the Internet or on a home or office network. If you don’t remember the name of the printer on the network you have shared, select ‘Browse for a printer’. If you know the URL of the printer on the network or on the Internet, then you can select the third option, and in the URL text box, type in the URL. Once done you should be able to see the printer. Now select the printer and continue with the Wizard, and you’re done.
Now let’s see how to share folders on the network. This will not only allow easy transfer of data, but also save disk space by not forcing you to have replicas of files across systems. Sharing of folders is far easier than sharing a printer. To share a folder, select the folder you want to share, right-click on it and select ‘Sharing and Security’. You’ll now see a ‘Sharing’ tab in the folder properties. Under ‘Network sharing and security’, select ‘Share this folder on the network’. Now, in the text box named ‘Share name’, type the name you want other people to see.

There are two ways you can allow the people to access your shared folder. If you want to allow other computers on the network to access the shared folder using Windows Explorer then just type in the name others want to see. But if you want only people who know the path of the folder to access the folder, add the “$” symbol at the end of the folder name you just gave. This adds more security to the shared folders. Windows XP does not allow more than 10 persons to simultaneously access the same folder. Dollar ($) shares are recommended because they prevent the spread of viruses on a network, and are especially important for folders that are shared with write-access.

To access a dollar-share folder called “shared$” on a computer called “Digit”, all you have to do is go to Start > Run, type in \digit\shared$, and press [Enter]. You can do this for regular shared folders as well.

### 11.6 Assigning A Drive Letter To A Shared Folder

Now, once you have shared folders, you can assign drives on the second computer to the shared folders on the first. What this does is prevent you from searching for, or typing in something like \digit\sharedfolder$ every time you want to access a shared fold-
er. Instead, you could access a shared folder right from My Computer or by going to Start > Run, and typing, say, “z:”.

To do this (also called Mapping a Network Folder or Drive), open Windows Explorer and follow the instructions below:

1. Go to Tools > Map Network Drive from My Computer window’s menu
2. Click the Drive drop-down list box. All the available drive letters appear in the list. Choose a drive letter.
3. Select Browse. The ‘Browse for Folder’ window appears.
4. Locate the shared folder you want to map the drive letter to. Click to select it, and click ‘OK’.
5. The address for the folder appears in the Folder text box.
6. Click ‘Finish’. The folder’s contents appear in a window. You will also notice the drive letter at the top of the window.

11.7 Sharing An Internet Connection

Now let’s see how you can share an Internet connection with other systems on your network. A computer that has a direct connection to the Internet is called the Internet Connection Sharing host (ICS). This allows sharing a single Internet connection with other systems on the network.

To do this, run the same Networking Wizard again. Make sure before you run the wizard that the ICS host is connected to the Internet. Click Start > Control Panel > Network and Internet connection > Setup your home or small office network.
Follow the instructions on each screen and press ‘Next’ to continue. You will see a screen, ‘Other Internet connection methods...’. This lets you to choose the method of connecting to the Internet. Select the first option, click ‘Next’, and click ‘Finish’ to exit the wizard. You can now access the Internet from other systems on the network.

You can also use third party software such as Proxy+, Proxy-Pro Professional GateKeeper, Squid, CCProxy, etc., to share an Internet connection. These proxies not only allow you to share your Net connection, they also help log the sites visited, the bandwidth used, and cache frequently-visited Web pages.

Logs are useful for monitoring Web pages, and will tell you who’s visiting what site. Though this sounds like snooping, you can never be too careful, especially when there are children in the family.

Caching is perhaps the most useful thing for those on limited usage Internet connections. Caching helps conserve bandwidth by not contacting the Internet for recently-visited Web pages, thus resulting in not just bandwidth savings but also an enhanced user experience—pages load faster! Usually, these proxies are easy to install, and have a good navigable interface.

11.8 Troubleshooting

Though networking in Windows XP is easy, there could be times when you face problems with your LAN. The basic problem, usually, is an improper physical connection. To check if there is a connectivity problem with your LAN, check the light on the LAN card (which can be located behind your cabinet). If the LEDs are glowing or blinking, there’s no physical connectivity problem with your LAN. If the LEDs are off, there is a connectivity problem—check for loose connections at joints and also check if the card is properly inserted into the PCI slot on the motherboard.
Once you’ve eliminated this problem, check if other computers on the network are using the TCP/IP protocol. TCP/IP might not have been installed if the operating system is not Windows XP (like in Windows 95).

To check if TCP/IP is installed, go to Start > Control Panel > Network Connections > Local Area Network. Right-click on Local Area Network and select properties. Here, you should see Internet Protocol (TCP/IP) under “This connection uses the following items”. If you don’t see this, the TCP/IP protocol is not installed on your system, and requires installation. If TCP/IP is installed and you still cannot access computers on the network check if there are other computers with the same IP address in the network. If there are two systems with the same IP address on the network, change the last digit on one computer to something else—this should solve the problem.